Bug 368993 - Kwin crash every time
Summary: Kwin crash every time
Status: RESOLVED DUPLICATE of bug 361236
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: 5.7.4
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-09-18 13:34 UTC by Damian
Modified: 2016-10-04 07:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Damian 2016-09-18 13:34:21 UTC
Application: kwin_x11 (5.7.4)

Qt Version: 5.6.1
Frameworks Version: 5.26.0
Operating System: Linux 4.7.3-1-default x86_64
Distribution: "openSUSE Tumbleweed"

-- Information about the crash:
- What I was doing when the application crashed: Start session, ktorrent and firefox. every time after few minutes crash notification appears

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f61a2b90940 (LWP 1595))]

Thread 6 (Thread 0x7f60e7fff700 (LWP 2289)):
#0  0x00007f61a2522281 in clock_gettime () from /lib64/libc.so.6
#1  0x00007f619fa0fd96 in qt_clock_gettime (ts=0x7f60e7ffeb10, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:105
#2  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:156
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:165
#4  0x00007f619fb8f639 in QTimerInfoList::updateCurrentTime (this=this@entry=0x7f60e00010f8) at kernel/qtimerinfo_unix.cpp:84
#5  0x00007f619fb8fbe5 in QTimerInfoList::timerWait (this=this@entry=0x7f60e00010f8, tm=...) at kernel/qtimerinfo_unix.cpp:381
#6  0x00007f619fb8f212 in QEventDispatcherUNIX::processEvents (this=0x7f60e007a6a0, flags=...) at kernel/qeventdispatcher_unix.cpp:594
#7  0x00007f619fb396fa in QEventLoop::exec (this=this@entry=0x7f60e7ffec60, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#8  0x00007f619f95f3c3 in QThread::exec (this=this@entry=0x2e5eb90) at thread/qthread.cpp:500
#9  0x00007f6199ba60a5 in QQmlThreadPrivate::run (this=0x2e5eb90) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/ftw/qqmlthread.cpp:141
#10 0x00007f619f9642e8 in QThreadPrivate::start (arg=0x2e5eb90) at thread/qthread_unix.cpp:341
#11 0x00007f619b074454 in start_thread () from /lib64/libpthread.so.0
#12 0x00007f61a25153ff in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f616ffff700 (LWP 1633)):
#0  0x00007f619b07a10f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f619eaee7f4 in ?? () from /usr/lib64/libQt5Script.so.5
#2  0x00007f619eaee839 in ?? () from /usr/lib64/libQt5Script.so.5
#3  0x00007f619b074454 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f61a25153ff in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f617bfff700 (LWP 1613)):
#0  0x00007f619f95c419 in std::__atomic_base<QMutexData*>::compare_exchange_strong (__m2=<optimized out>, __m1=std::memory_order_release, __p2=0x0, __p1=@0x7f617bffeaa8: 0x1, this=0x20d1928) at /usr/include/c++/6/bits/atomic_base.h:752
#1  std::atomic<QMutexData*>::compare_exchange_strong (__m=std::memory_order_release, __p2=0x0, __p1=@0x7f617bffeaa8: 0x1, this=0x20d1928) at /usr/include/c++/6/atomic:475
#2  QAtomicOps<QMutexData*>::testAndSetRelease<QMutexData*> (currentValue=<synthetic pointer>, newValue=0x0, expectedValue=0x1, _q_value=...) at ../../src/corelib/arch/qatomic_cxx11.h:167
#3  QBasicAtomicPointer<QMutexData>::testAndSetRelease (currentValue=<synthetic pointer>, newValue=0x0, expectedValue=<optimized out>, this=0x20d1928) at ../../src/corelib/thread/qbasicatomic.h:278
#4  QBasicMutex::fastTryUnlock (current=<synthetic pointer>, this=0x20d1928) at thread/qmutex.h:85
#5  QMutex::unlock (this=this@entry=0x20d1928) at thread/qmutex.cpp:271
#6  0x00007f619fb3d73b in QMutexLocker::unlock (this=<synthetic pointer>) at ../../src/corelib/thread/qmutex.h:138
#7  QMutexLocker::~QMutexLocker (this=<synthetic pointer>, __in_chrg=<optimized out>) at ../../src/corelib/thread/qmutex.h:132
#8  QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x20d1900) at kernel/qcoreapplication.cpp:1536
#9  0x00007f619fb8f152 in QEventDispatcherUNIX::processEvents (this=0x7f61700008c0, flags=...) at kernel/qeventdispatcher_unix.cpp:579
#10 0x00007f619fb396fa in QEventLoop::exec (this=this@entry=0x7f617bffec60, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#11 0x00007f619f95f3c3 in QThread::exec (this=this@entry=0x206d540) at thread/qthread.cpp:500
#12 0x00007f6199ba60a5 in QQmlThreadPrivate::run (this=0x206d540) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/ftw/qqmlthread.cpp:141
#13 0x00007f619f9642e8 in QThreadPrivate::start (arg=0x206d540) at thread/qthread_unix.cpp:341
#14 0x00007f619b074454 in start_thread () from /lib64/libpthread.so.0
#15 0x00007f61a25153ff in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f6182f1a700 (LWP 1601)):
#0  0x00007f619fb8f149 in QEventDispatcherUNIX::processEvents (this=0x7f617c0008c0, flags=...) at kernel/qeventdispatcher_unix.cpp:579
#1  0x00007f619fb396fa in QEventLoop::exec (this=this@entry=0x7f6182f19c50, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#2  0x00007f619f95f3c3 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:500
#3  0x00007f6198d7b985 in ?? () from /usr/lib64/libQt5DBus.so.5
#4  0x00007f619f9642e8 in QThreadPrivate::start (arg=0x7f6198feed20) at thread/qthread_unix.cpp:341
#5  0x00007f619b074454 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f61a25153ff in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f618901b700 (LWP 1600)):
#0  0x00007f61a250c6ed in poll () from /lib64/libc.so.6
#1  0x00007f61a169c3f0 in ?? () from /usr/lib64/libxcb.so.1
#2  0x00007f61a169e189 in xcb_wait_for_event () from /usr/lib64/libxcb.so.1
#3  0x00007f6189acb7a9 in QXcbEventReader::run (this=0x1ec5300) at qxcbconnection.cpp:1325
#4  0x00007f619f9642e8 in QThreadPrivate::start (arg=0x1ec5300) at thread/qthread_unix.cpp:341
#5  0x00007f619b074454 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f61a25153ff in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f61a2b90940 (LWP 1595)):
[KCrash Handler]
#6  QV4::Value::as<QV4::QQmlValueTypeWrapper const> (this=0x7f60ddf77320) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/jsruntime/qv4value_p.h:348
#7  QQmlBinding::write (this=this@entry=0x3c73b10, core=..., result=..., isUndefined=<optimized out>, flags=...) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/qqmlbinding.cpp:257
#8  0x00007f6199b922a7 in QQmlBinding::update (this=0x3c73b10, flags=...) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/qqmlbinding.cpp:191
#9  0x00007f6199b9bdc5 in QQmlObjectCreator::finalize (this=0x3e7d850, interrupt=...) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/qqmlobjectcreator.cpp:1193
#10 0x00007f6199b25c7e in QQmlComponentPrivate::complete (enginePriv=0x2d4cfe0, state=0x31748e0) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/qqmlcomponent.cpp:919
#11 0x00007f6199b25d47 in QQmlComponentPrivate::completeCreate (this=0x3174840) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/qqmlcomponent.cpp:955
#12 0x00007f6199b25bb0 in QQmlComponent::create (this=0x3174b90, context=0x3032a20) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/qqmlcomponent.cpp:781
#13 0x00007f61807cf587 in Aurorae::Decoration::init (this=0x3552230) at /usr/src/debug/kwin-5.7.4/plugins/kdecorations/aurorae/src/aurorae.cpp:316
#14 0x00007f61a213d459 in KWin::Decoration::DecorationBridge::createDecoration (this=0x1f8ede0, client=client@entry=0x3ec6890) at /usr/src/debug/kwin-5.7.4/decorations/decorationbridge.cpp:260
#15 0x00007f61a20247d9 in KWin::Client::createDecoration (this=this@entry=0x3ec6890, oldgeom=...) at /usr/src/debug/kwin-5.7.4/client.cpp:393
#16 0x00007f61a202519d in KWin::Client::updateDecoration (this=0x3ec6890, check_workspace_pos=<optimized out>, force=<optimized out>) at /usr/src/debug/kwin-5.7.4/client.cpp:380
#17 0x00007f61a20815df in KWin::Client::manage (this=this@entry=0x3ec6890, w=w@entry=41943177, isMapped=isMapped@entry=false) at /usr/src/debug/kwin-5.7.4/manage.cpp:385
#18 0x00007f61a200838f in KWin::Workspace::createClient (this=this@entry=0x1f87380, w=41943177, is_mapped=is_mapped@entry=false) at /usr/src/debug/kwin-5.7.4/workspace.cpp:498
#19 0x00007f61a206ebe7 in KWin::Workspace::workspaceEvent (this=0x1f87380, e=0x7f61840053b0) at /usr/src/debug/kwin-5.7.4/events.cpp:417
#20 0x00007f619fb3883f in QAbstractEventDispatcher::filterNativeEvent (this=<optimized out>, eventType=..., message=message@entry=0x7f61840053b0, result=result@entry=0x7ffd36597198) at kernel/qabstracteventdispatcher.cpp:460
#21 0x00007f6189acd185 in QXcbConnection::handleXcbEvent (this=this@entry=0x1eb9750, event=event@entry=0x7f61840053b0) at qxcbconnection.cpp:1091
#22 0x00007f6189ace11b in QXcbConnection::processXcbEvents (this=0x1eb9750) at qxcbconnection.cpp:1723
#23 0x00007f619fb69c99 in QObject::event (this=0x1eb9750, e=<optimized out>) at kernel/qobject.cpp:1256
#24 0x00007f61a0881acc in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x1eb9750, e=0x7f61840054c0) at kernel/qapplication.cpp:3804
#25 0x00007f61a0886f6f in QApplication::notify (this=0x7ffd365977e0, receiver=0x1eb9750, e=0x7f61840054c0) at kernel/qapplication.cpp:3561
#26 0x00007f619fb3b9b0 in QCoreApplication::notifyInternal2 (receiver=0x1eb9750, event=event@entry=0x7f61840054c0) at kernel/qcoreapplication.cpp:1015
#27 0x00007f619fb3d93c in QCoreApplication::sendEvent (event=0x7f61840054c0, receiver=<optimized out>) at kernel/qcoreapplication.h:225
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x1e9d740) at kernel/qcoreapplication.cpp:1650
#29 0x00007f619fb8f152 in QEventDispatcherUNIX::processEvents (this=0x1ee6870, flags=...) at kernel/qeventdispatcher_unix.cpp:579
#30 0x00007f6189b4020d in QUnixEventDispatcherQPA::processEvents (this=<optimized out>, flags=...) at eventdispatchers/qunixeventdispatcher.cpp:62
#31 0x00007f619fb396fa in QEventLoop::exec (this=this@entry=0x7ffd365976d0, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#32 0x00007f619fb41f0c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1285
#33 0x00007f61a008ab5c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1607
#34 0x00007f61a087eb05 in QApplication::exec () at kernel/qapplication.cpp:2979
#35 0x00007f61a27d4a56 in kdemain (argc=<optimized out>, argv=0x7ffd36597968) at /usr/src/debug/kwin-5.7.4/main_x11.cpp:466
#36 0x00007f61a244c291 in __libc_start_main () from /lib64/libc.so.6
#37 0x0000000000400719 in _start () at ../sysdeps/x86_64/start.S:118

Possible duplicates by query: bug 367951, bug 367862, bug 366240, bug 365593, bug 364842.

Reported using DrKonqi
Comment 1 Martin Flöser 2016-10-04 07:16:10 UTC
As a workaround use the breeze window decoration

*** This bug has been marked as a duplicate of bug 361236 ***