Bug 366240 - KWin crashed when opening Plasma digital clock settings
Summary: KWin crashed when opening Plasma digital clock settings
Status: RESOLVED DUPLICATE of bug 361236
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 5.7.0
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-07-29 12:36 UTC by Dennis Schridde
Modified: 2016-08-01 07:33 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2016-07-29 12:36:34 UTC
Application: kwin_x11 (5.7.0)

Qt Version: 5.6.1
Frameworks Version: 5.23.0
Operating System: Linux 4.6.0-1-amd64 x86_64
Distribution: Debian GNU/Linux testing (stretch)

-- Information about the crash:
- What I was doing when the application crashed:

I right clicked the Plasma digital clock and selected "Digital Clock Settings". The settings window opened and KWin crashed.

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f3029793940 (LWP 3598))]

Thread 5 (Thread 0x7f3019eaa700 (LWP 4433)):
#0  0x00007f3040df5f73 in select () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f303ec8ca1f in qt_safe_select (nfds=12, fdread=fdread@entry=0x7f300c000a58, fdwrite=fdwrite@entry=0x7f300c000ce8, fdexcept=fdexcept@entry=0x7f300c000f78, orig_timeout=orig_timeout@entry=0x0) at kernel/qcore_unix.cpp:75
#2  0x00007f303ec8e45e in QEventDispatcherUNIX::select (timeout=0x0, exceptfds=0x7f300c000f78, writefds=0x7f300c000ce8, readfds=0x7f300c000a58, nfds=<optimized out>, this=0x7f300c0923d0) at kernel/qeventdispatcher_unix.cpp:320
#3  QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f300c0008c0, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:196
#4  0x00007f303ec8e972 in QEventDispatcherUNIX::processEvents (this=0x7f300c0923d0, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#5  0x00007f303ec39e4a in QEventLoop::exec (this=this@entry=0x7f3019ea9c60, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f303ea629e4 in QThread::exec (this=this@entry=0x2c35490) at thread/qthread.cpp:500
#7  0x00007f3039510405 in QQmlThreadPrivate::run (this=0x2c35490) at qml/ftw/qqmlthread.cpp:141
#8  0x00007f303ea67808 in QThreadPrivate::start (arg=0x2c35490) at thread/qthread_unix.cpp:341
#9  0x00007f303a3ac464 in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#10 0x00007f3040dfd30d in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 4 (Thread 0x7f300a33c700 (LWP 3639)):
#0  0x00007f303a3b209f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x00007f303de02574 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f303dee9f00 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f303de025b9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f303a3ac464 in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#4  0x00007f3040dfd30d in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 3 (Thread 0x7f30192e7700 (LWP 3626)):
#0  0x00007f3040df5f73 in select () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f303ec8ca1f in qt_safe_select (nfds=13, fdread=fdread@entry=0x7f3010000a78, fdwrite=fdwrite@entry=0x7f3010000d08, fdexcept=fdexcept@entry=0x7f3010000f98, orig_timeout=orig_timeout@entry=0x0) at kernel/qcore_unix.cpp:75
#2  0x00007f303ec8e45e in QEventDispatcherUNIX::select (timeout=0x0, exceptfds=0x7f3010000f98, writefds=0x7f3010000d08, readfds=0x7f3010000a78, nfds=<optimized out>, this=0x7f30100008c0) at kernel/qeventdispatcher_unix.cpp:320
#3  QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f30100008e0, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:196
#4  0x00007f303ec8e972 in QEventDispatcherUNIX::processEvents (this=0x7f30100008c0, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#5  0x00007f303ec39e4a in QEventLoop::exec (this=this@entry=0x7f30192e6c60, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f303ea629e4 in QThread::exec (this=this@entry=0x20604e0) at thread/qthread.cpp:500
#7  0x00007f3039510405 in QQmlThreadPrivate::run (this=0x20604e0) at qml/ftw/qqmlthread.cpp:141
#8  0x00007f303ea67808 in QThreadPrivate::start (arg=0x20604e0) at thread/qthread_unix.cpp:341
#9  0x00007f303a3ac464 in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#10 0x00007f3040dfd30d in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 2 (Thread 0x7f301bb17700 (LWP 3615)):
#0  QEventDispatcherUNIXPrivate::initThreadWakeUp (this=this@entry=0x7f30140008e0) at kernel/qeventdispatcher_unix.cpp:268
#1  0x00007f303ec8e426 in QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f30140008e0, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:189
#2  0x00007f303ec8e972 in QEventDispatcherUNIX::processEvents (this=0x7f30140008c0, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#3  0x00007f303ec39e4a in QEventLoop::exec (this=this@entry=0x7f301bb16c50, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#4  0x00007f303ea629e4 in QThread::exec (this=this@entry=0x7f304146dd40 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread.cpp:500
#5  0x00007f30413fa515 in QDBusConnectionManager::run (this=0x7f304146dd40 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:189
#6  0x00007f303ea67808 in QThreadPrivate::start (arg=0x7f304146dd40 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:341
#7  0x00007f303a3ac464 in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#8  0x00007f3040dfd30d in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 1 (Thread 0x7f3029793940 (LWP 3598)):
[KCrash Handler]
#6  QV4::Value::as<QV4::QQmlValueTypeWrapper const> (this=0x7f2f8066b320) at ../../include/QtQml/5.6.1/QtQml/private/../../../../../src/qml/jsruntime/qv4value_p.h:354
#7  QQmlBinding::write (this=this@entry=0x2bd5df0, core=..., result=..., isUndefined=<optimized out>, flags=...) at qml/qqmlbinding.cpp:257
#8  0x00007f30394fd28a in QQmlBinding::update (this=0x2bd5df0, flags=...) at qml/qqmlbinding.cpp:191
#9  0x00007f303950659f in QQmlObjectCreator::finalize (this=0x2b4d130, interrupt=...) at qml/qqmlobjectcreator.cpp:1193
#10 0x00007f303949304e in QQmlComponentPrivate::complete (enginePriv=0x2c35070, state=0x2eaba40) at qml/qqmlcomponent.cpp:919
#11 0x00007f3039493117 in QQmlComponentPrivate::completeCreate (this=0x2eab9a0) at qml/qqmlcomponent.cpp:955
#12 0x00007f3039492f80 in QQmlComponent::create (this=0x2eab210, context=0x2f8e170) at qml/qqmlcomponent.cpp:781
#13 0x00007f30193070c7 in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/org.kde.kdecoration2/kwin5_aurorae.so
#14 0x00007f3040a24a01 in ?? () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#15 0x00007f304090c1d9 in KWin::Client::createDecoration(QRect const&) () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#16 0x00007f304090cb93 in KWin::Client::updateDecoration(bool, bool) () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#17 0x00007f30409691a6 in KWin::Client::manage(unsigned int, bool) () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#18 0x00007f30408ef6af in KWin::Workspace::createClient(unsigned int, bool) () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#19 0x00007f3040956881 in KWin::Workspace::workspaceEvent(xcb_generic_event_t*) () from /usr/lib/x86_64-linux-gnu/libkwin.so.5
#20 0x00007f303ec38fbf in QAbstractEventDispatcher::filterNativeEvent (this=<optimized out>, eventType=..., message=message@entry=0x7f301c002e00, result=result@entry=0x7fff5201d5d8) at kernel/qabstracteventdispatcher.cpp:460
#21 0x00007f30220fda05 in QXcbConnection::handleXcbEvent (this=this@entry=0x1f050e0, event=event@entry=0x7f301c002e00) at qxcbconnection.cpp:1091
#22 0x00007f30220fe966 in QXcbConnection::processXcbEvents (this=0x1f050e0) at qxcbconnection.cpp:1723
#23 0x00007f303ec69569 in QObject::event (this=0x1f050e0, e=<optimized out>) at kernel/qobject.cpp:1256
#24 0x00007f303f573afc in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x1f050e0, e=0x7f301c002750) at kernel/qapplication.cpp:3804
#25 0x00007f303f579036 in QApplication::notify (this=0x7fff5201dc10, receiver=0x1f050e0, e=0x7f301c002750) at kernel/qapplication.cpp:3561
#26 0x00007f303ec3c0f8 in QCoreApplication::notifyInternal2 (receiver=0x1f050e0, event=event@entry=0x7f301c002750) at kernel/qcoreapplication.cpp:1015
#27 0x00007f303ec3dfba in QCoreApplication::sendEvent (event=0x7f301c002750, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:225
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x1eeb5d0) at kernel/qcoreapplication.cpp:1650
#29 0x00007f303ec8e852 in QEventDispatcherUNIX::processEvents (this=0x1f384e0, flags=flags@entry=...) at kernel/qeventdispatcher_unix.cpp:579
#30 0x00007f302216d65d in QUnixEventDispatcherQPA::processEvents (this=<optimized out>, flags=...) at eventdispatchers/qunixeventdispatcher.cpp:62
#31 0x00007f303ec39e4a in QEventLoop::exec (this=this@entry=0x7fff5201db00, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#32 0x00007f303ec4250c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1285
#33 0x00007f30410c0226 in kdemain () from /usr/lib/x86_64-linux-gnu/libkdeinit5_kwin_x11.so
#34 0x00007f3040d36730 in __libc_start_main () from /lib/x86_64-linux-gnu/libc.so.6
#35 0x0000000000400769 in _start ()

Possible duplicates by query: bug 365593, bug 364842, bug 363221, bug 363196.

Reported using DrKonqi
Comment 1 Martin Flöser 2016-08-01 07:33:06 UTC
Please switch to Breeze window decoration as a workaround.

*** This bug has been marked as a duplicate of bug 361236 ***