Bug 367951 - KWin crashed when starting Firefox browser
Summary: KWin crashed when starting Firefox browser
Status: RESOLVED DUPLICATE of bug 361236
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 5.6.5
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-08-29 09:20 UTC by tux03
Modified: 2016-08-29 09:37 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tux03 2016-08-29 09:20:35 UTC
Application: kwin_x11 (5.6.5)
 (Compiled from sources)
Qt Version: 5.6.1
Frameworks Version: 5.23.0
Operating System: Linux 3.14.57-tuxonice i686
Distribution (Platform): Gentoo Packages

-- Information about the crash:
- What I was doing when the application crashed:

Pressing Firefox icon on taskbar.

xxxxxxxxxxxxxxxxxxxxx

The crash can be reproduced every time.

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb0064740 (LWP 1454))]

Thread 6 (Thread 0xafbcfb40 (LWP 1457)):
#0  0xb77aa428 in __kernel_vsyscall ()
#1  0xb769b7eb in poll () at ../sysdeps/unix/syscall-template.S:84
#2  0xb6271f40 in poll (__timeout=-1, __nfds=1, __fds=0xafbcf1bc) at /usr/include/bits/poll2.h:46
#3  _xcb_conn_wait (c=c@entry=0x807c428, cond=cond@entry=0x807c44c, vector=vector@entry=0x0, count=count@entry=0x0) at /data/tmp/portage/x11-libs/libxcb-1.11.1/work/libxcb-1.11.1/src/xcb_conn.c:459
#4  0xb627405b in xcb_wait_for_event (c=0x807c428) at /data/tmp/portage/x11-libs/libxcb-1.11.1/work/libxcb-1.11.1/src/xcb_in.c:693
#5  0xafc4572e in QXcbEventReader::run (this=0x80887b0) at qxcbconnection.cpp:1325
#6  0xb631aec5 in QThreadPrivate::start (arg=0x80887b0) at thread/qthread_unix.cpp:341
#7  0xb775f15d in start_thread (arg=0xafbcfb40) at pthread_create.c:334
#8  0xb76a5c3e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 5 (Thread 0xaeff0b40 (LWP 1459)):
#0  0xb77aa428 in __kernel_vsyscall ()
#1  0xb75d7216 in clock_gettime_syscall (id=1, tp=0xaeff00d4) at ../sysdeps/unix/sysv/linux/i386/init-first.c:32
#2  0xb76b2c21 in __GI___clock_gettime (clock_id=1, tp=0xaeff00d4) at ../sysdeps/unix/clock_gettime.c:115
#3  0xb63a3b76 in qt_clock_gettime (ts=0xaeff00d4, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:105
#4  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:156
#5  qt_gettime () at tools/qelapsedtimer_unix.cpp:165
#6  0xb6501008 in QTimerInfoList::updateCurrentTime (this=this@entry=0xae600af0) at kernel/qtimerinfo_unix.cpp:84
#7  0xb6501404 in QTimerInfoList::timerWait (this=this@entry=0xae600af0, tm=...) at kernel/qtimerinfo_unix.cpp:381
#8  0xb6500a11 in QEventDispatcherUNIX::processEvents (this=<optimized out>, flags=...) at kernel/qeventdispatcher_unix.cpp:594
#9  0xb64b27e9 in QEventLoop::processEvents (this=this@entry=0xaeff0254, flags=..., flags@entry=...) at kernel/qeventloop.cpp:128
#10 0xb64b2bce in QEventLoop::exec (this=this@entry=0xaeff0254, flags=flags@entry=...) at kernel/qeventloop.cpp:204
#11 0xb631609a in QThread::exec (this=this@entry=0xb4e41040 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread.cpp:500
#12 0xb4dcd2a6 in QDBusConnectionManager::run (this=0xb4e41040 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:189
#13 0xb631aec5 in QThreadPrivate::start (arg=0xb4e41040 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:341
#14 0xb775f15d in start_thread (arg=0xaeff0b40) at pthread_create.c:334
#15 0xb76a5c3e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 4 (Thread 0xab379b40 (LWP 1463)):
#0  0xb631317f in QMutex::lock (this=this@entry=0x81f022c) at thread/qmutex.cpp:217
#1  0xb64b644d in QMutexLocker::QMutexLocker (m=0x81f022c, this=<synthetic pointer>) at ../../include/QtCore/../../src/corelib/thread/qmutex.h:128
#2  QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x81f0210) at kernel/qcoreapplication.cpp:1527
#3  0xb6500900 in QEventDispatcherUNIX::processEvents (this=<optimized out>, flags=...) at kernel/qeventdispatcher_unix.cpp:579
#4  0xb64b27e9 in QEventLoop::processEvents (this=this@entry=0xab379274, flags=..., flags@entry=...) at kernel/qeventloop.cpp:128
#5  0xb64b2bce in QEventLoop::exec (this=this@entry=0xab379274, flags=flags@entry=...) at kernel/qeventloop.cpp:204
#6  0xb631609a in QThread::exec (this=this@entry=0x81f0108) at thread/qthread.cpp:500
#7  0xb524365b in QQmlThreadPrivate::run (this=0x81f0108) at qml/ftw/qqmlthread.cpp:141
#8  0xb631aec5 in QThreadPrivate::start (arg=0x81f0108) at thread/qthread_unix.cpp:341
#9  0xb775f15d in start_thread (arg=0xab379b40) at pthread_create.c:334
#10 0xb76a5c3e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 3 (Thread 0xa053cb40 (LWP 1467)):
#0  0xb77aa428 in __kernel_vsyscall ()
#1  0xb776461b in pthread_cond_wait () at ../sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:187
#2  0xb5efabc4 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=this@entry=0xb5fedb40 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#3  0xb5efabfd in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xb5fedb40 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#4  0xb775f15d in start_thread (arg=0xa053cb40) at pthread_create.c:334
#5  0xb76a5c3e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 2 (Thread 0xad077b40 (LWP 1782)):
#0  0xb77aa428 in __kernel_vsyscall ()
#1  0xb75d7216 in clock_gettime_syscall (id=1, tp=0xad0770f4) at ../sysdeps/unix/sysv/linux/i386/init-first.c:32
#2  0xb76b2c21 in __GI___clock_gettime (clock_id=1, tp=0xad0770f4) at ../sysdeps/unix/clock_gettime.c:115
#3  0xb63a3b76 in qt_clock_gettime (ts=0xad0770f4, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:105
#4  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:156
#5  qt_gettime () at tools/qelapsedtimer_unix.cpp:165
#6  0xb6501008 in QTimerInfoList::updateCurrentTime (this=this@entry=0xac700ae0) at kernel/qtimerinfo_unix.cpp:84
#7  0xb6501404 in QTimerInfoList::timerWait (this=this@entry=0xac700ae0, tm=...) at kernel/qtimerinfo_unix.cpp:381
#8  0xb6500a11 in QEventDispatcherUNIX::processEvents (this=<optimized out>, flags=...) at kernel/qeventdispatcher_unix.cpp:594
#9  0xb64b27e9 in QEventLoop::processEvents (this=this@entry=0xad077274, flags=..., flags@entry=...) at kernel/qeventloop.cpp:128
#10 0xb64b2bce in QEventLoop::exec (this=this@entry=0xad077274, flags=flags@entry=...) at kernel/qeventloop.cpp:204
#11 0xb631609a in QThread::exec (this=this@entry=0x80c9bb8) at thread/qthread.cpp:500
#12 0xb524365b in QQmlThreadPrivate::run (this=0x80c9bb8) at qml/ftw/qqmlthread.cpp:141
#13 0xb631aec5 in QThreadPrivate::start (arg=0x80c9bb8) at thread/qthread_unix.cpp:341
#14 0xb775f15d in start_thread (arg=0xad077b40) at pthread_create.c:334
#15 0xb76a5c3e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:122

Thread 1 (Thread 0xb0064740 (LWP 1454)):
[KCrash Handler]
#7  QV4::Value::as<QV4::QQmlValueTypeWrapper const> (this=0xabf01320) at ../../include/QtQml/5.6.1/QtQml/private/../../../../../src/qml/jsruntime/qv4value_p.h:348
#8  QQmlBinding::write (this=this@entry=0x8c90630, core=..., result=..., isUndefined=false, flags=...) at qml/qqmlbinding.cpp:257
#9  0xb522f53a in QQmlBinding::update (this=this@entry=0x8c90630, flags=flags@entry=...) at qml/qqmlbinding.cpp:191
#10 0xb522f743 in QQmlBinding::setEnabled (this=0x8c90630, e=true, flags=...) at qml/qqmlbinding.cpp:412
#11 0xb5238db7 in QQmlObjectCreator::finalize (this=0x86bc508, interrupt=...) at qml/qqmlobjectcreator.cpp:1193
#12 0xb51bd51f in QQmlComponentPrivate::complete (enginePriv=0x818fae8, state=0x81acb34) at qml/qqmlcomponent.cpp:919
#13 0xb51bd5c9 in QQmlComponentPrivate::completeCreate (this=0x81acad8) at qml/qqmlcomponent.cpp:955
#14 0xb51bfc1c in QQmlComponent::completeCreate (this=0x8188128) at qml/qqmlcomponent.cpp:948
#15 QQmlComponent::create (this=0x8188128, context=<optimized out>) at qml/qqmlcomponent.cpp:781
#16 0xadb73d28 in Aurorae::Decoration::init (this=0x86bb888) at /data/tmp/portage/kde-plasma/kwin-5.6.5-r1/work/kwin-5.6.5/clients/aurorae/src/aurorae.cpp:316
#17 0xb74c1fd9 in KWin::Decoration::DecorationBridge::createDecoration (this=0x80c98f8, client=client@entry=0x8761b88) at /data/tmp/portage/kde-plasma/kwin-5.6.5-r1/work/kwin-5.6.5/decorations/decorationbridge.cpp:254
#18 0xb7387438 in KWin::Client::createDecoration (this=this@entry=0x8761b88, oldgeom=...) at /data/tmp/portage/kde-plasma/kwin-5.6.5-r1/work/kwin-5.6.5/client.cpp:393
#19 0xb7388140 in KWin::Client::updateDecoration (this=0x8761b88, check_workspace_pos=false, force=false) at /data/tmp/portage/kde-plasma/kwin-5.6.5-r1/work/kwin-5.6.5/client.cpp:380
#20 0xb73ec1eb in KWin::Client::manage (this=this@entry=0x8761b88, w=w@entry=52429529, isMapped=isMapped@entry=false) at /data/tmp/portage/kde-plasma/kwin-5.6.5-r1/work/kwin-5.6.5/manage.cpp:385
#21 0xb736590d in KWin::Workspace::createClient (this=this@entry=0x80c5278, w=52429529, is_mapped=is_mapped@entry=false) at /data/tmp/portage/kde-plasma/kwin-5.6.5-r1/work/kwin-5.6.5/workspace.cpp:483
#22 0xb73cfc20 in KWin::Workspace::workspaceEvent (this=0x80c5278, e=e@entry=0xaf204a30) at /data/tmp/portage/kde-plasma/kwin-5.6.5-r1/work/kwin-5.6.5/events.cpp:417
#23 0xb73be762 in KWin::XcbEventFilter::nativeEventFilter (this=0x80b93f8, eventType=..., message=0xaf204a30, result=0xbfdd5b84) at /data/tmp/portage/kde-plasma/kwin-5.6.5-r1/work/kwin-5.6.5/main.cpp:511
#24 0xb64b1c83 in QAbstractEventDispatcher::filterNativeEvent (this=0x80a4cb0, eventType=..., message=message@entry=0xaf204a30, result=result@entry=0xbfdd5b84) at kernel/qabstracteventdispatcher.cpp:460
#25 0xafc43807 in QXcbConnection::handleXcbEvent (this=this@entry=0x807b7d8, event=event@entry=0xaf204a30) at qxcbconnection.cpp:1091
#26 0xafc459d6 in QXcbConnection::processXcbEvents (this=0x807b7d8) at qxcbconnection.cpp:1723
#27 0xafc78d40 in QXcbConnection::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at .moc/moc_qxcbconnection.cpp:188
#28 0xb64da53b in QMetaCallEvent::placeMetaCall (this=0xaf20b658, object=0x807b7d8) at kernel/qobject.cpp:495
#29 0xb64dd53e in QObject::event (this=this@entry=0x807b7d8, e=e@entry=0xaf20b658) at kernel/qobject.cpp:1256
#30 0xafc45e2e in QXcbConnection::event (this=0x807b7d8, e=0xaf20b658) at qxcbconnection.cpp:2339
#31 0xb6ce5f05 in QApplicationPrivate::notify_helper (this=0x8076b10, receiver=0x807b7d8, e=0xaf20b658) at kernel/qapplication.cpp:3804
#32 0xb6cea981 in QApplication::notify (this=this@entry=0xbfdd6208, receiver=receiver@entry=0x807b7d8, e=e@entry=0xaf20b658) at kernel/qapplication.cpp:3561
#33 0xb77784aa in KWin::ApplicationX11::notify (this=0xbfdd6208, o=o@entry=0x807b7d8, e=e@entry=0xaf20b658) at /data/tmp/portage/kde-plasma/kwin-5.6.5-r1/work/kwin-5.6.5/main_x11.cpp:199
#34 0xb64b4350 in QCoreApplication::notifyInternal2 (receiver=receiver@entry=0x807b7d8, event=event@entry=0xaf20b658) at kernel/qcoreapplication.cpp:1015
#35 0xb64b656f in QCoreApplication::sendEvent (event=0xaf20b658, receiver=0x807b7d8) at kernel/qcoreapplication.h:225
#36 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x806dde8) at kernel/qcoreapplication.cpp:1650
#37 0xb6500900 in QEventDispatcherUNIX::processEvents (this=<optimized out>, this@entry=0x80a4cb0, flags=flags@entry=...) at kernel/qeventdispatcher_unix.cpp:579
#38 0xafcb6aaf in QUnixEventDispatcherQPA::processEvents (this=0x80a4cb0, flags=...) at eventdispatchers/qunixeventdispatcher.cpp:62
#39 0xb64b27e9 in QEventLoop::processEvents (this=this@entry=0xbfdd6128, flags=..., flags@entry=...) at kernel/qeventloop.cpp:128
#40 0xb64b2bce in QEventLoop::exec (this=this@entry=0xbfdd6128, flags=flags@entry=...) at kernel/qeventloop.cpp:204
#41 0xb64bab53 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1285
#42 0xb67b4e9e in QGuiApplication::exec () at kernel/qguiapplication.cpp:1607
#43 0xb6ce2896 in QApplication::exec () at kernel/qapplication.cpp:2979
#44 0xb7778cad in kdemain (argc=3, argv=0xbfdd6314) at /data/tmp/portage/kde-plasma/kwin-5.6.5-r1/work/kwin-5.6.5/main_x11.cpp:327
#45 0x08048657 in main (argc=3, argv=0xbfdd6314) at /data/tmp/portage/kde-plasma/kwin-5.6.5-r1/work/kwin-5.6.5_build/kwin_x11_dummy.cpp:3

Possible duplicates by query: bug 367862, bug 366240, bug 365593, bug 364842, bug 363221.

Reported using DrKonqi
Comment 1 Martin Flöser 2016-08-29 09:37:30 UTC
As a workaround switch to the breeze window decoration

*** This bug has been marked as a duplicate of bug 361236 ***