Bug 364842 - Kwin crash during Kmail creating a new message
Summary: Kwin crash during Kmail creating a new message
Status: RESOLVED DUPLICATE of bug 361236
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 5.6.95
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-06-28 07:15 UTC by Ian
Modified: 2016-06-28 07:29 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ian 2016-06-28 07:15:57 UTC
Application: kwin_x11 (5.6.95)

Qt Version: 5.6.1
Frameworks Version: 5.23.0
Operating System: Linux 4.6.2-1-default x86_64
Distribution: "openSUSE Tumbleweed (20160625) (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I had kmail loaded, read most emails (except for one folder where kmail will not display contents) so i clicked on "New message to mailing list" and it gave the crash message as the new blank email was being displayed.

The crash can be reproduced sometimes.

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f1d3fe32940 (LWP 1387))]

Thread 6 (Thread 0x7f1d2612a700 (LWP 1392)):
#0  0x00007f1d3f593a1d in poll () from /lib64/libc.so.6
#1  0x00007f1d3e727410 in ?? () from /usr/lib64/libxcb.so.1
#2  0x00007f1d3e7291a9 in xcb_wait_for_event () from /usr/lib64/libxcb.so.1
#3  0x00007f1d26bd4579 in QXcbEventReader::run (this=0x16c2f80) at qxcbconnection.cpp:1325
#4  0x00007f1d3c9f02d8 in QThreadPrivate::start (arg=0x16c2f80) at thread/qthread_unix.cpp:341
#5  0x00007f1d3f85d474 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f1d3f59c3ed in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f1d1ffff700 (LWP 1395)):
#0  0x00007ffff7be7987 in ?? ()
#1  0x00007ffff7be7c8f in clock_gettime ()
#2  0x00007f1d3f5a90a6 in clock_gettime () from /lib64/libc.so.6
#3  0x00007f1d3ca9bd96 in qt_clock_gettime (ts=0x7f1d1fffeb00, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:105
#4  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:156
#5  qt_gettime () at tools/qelapsedtimer_unix.cpp:165
#6  0x00007f1d3cc1b699 in QTimerInfoList::updateCurrentTime (this=this@entry=0x7f1d18001118) at kernel/qtimerinfo_unix.cpp:84
#7  0x00007f1d3cc1bc45 in QTimerInfoList::timerWait (this=this@entry=0x7f1d18001118, tm=...) at kernel/qtimerinfo_unix.cpp:381
#8  0x00007f1d3cc1b272 in QEventDispatcherUNIX::processEvents (this=0x7f1d180008c0, flags=...) at kernel/qeventdispatcher_unix.cpp:594
#9  0x00007f1d3cbc576a in QEventLoop::exec (this=this@entry=0x7f1d1fffec50, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#10 0x00007f1d3c9eb3b3 in QThread::exec (this=this@entry=0x7f1d362acd20 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread.cpp:500
#11 0x00007f1d360399b5 in QDBusConnectionManager::run (this=0x7f1d362acd20 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:189
#12 0x00007f1d3c9f02d8 in QThreadPrivate::start (arg=0x7f1d362acd20 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:341
#13 0x00007f1d3f85d474 in start_thread () from /lib64/libpthread.so.0
#14 0x00007f1d3f59c3ed in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f1d1deb4700 (LWP 1408)):
#0  0x00007f1d3c9e802c in QMutex::lock (this=this@entry=0x1862b08) at thread/qmutex.cpp:225
#1  0x00007f1d3cc1b1cb in QMutexLocker::QMutexLocker (m=0x1862b08, this=<synthetic pointer>) at ../../src/corelib/thread/qmutex.h:128
#2  QThreadData::canWaitLocked (this=0x1862ae0) at ../../src/corelib/thread/qthread_p.h:246
#3  QEventDispatcherUNIX::processEvents (this=0x7f1d140008c0, flags=...) at kernel/qeventdispatcher_unix.cpp:582
#4  0x00007f1d3cbc576a in QEventLoop::exec (this=this@entry=0x7f1d1deb3c60, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#5  0x00007f1d3c9eb3b3 in QThread::exec (this=this@entry=0x188f480) at thread/qthread.cpp:500
#6  0x00007f1d36e621e5 in QQmlThreadPrivate::run (this=0x188f480) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/ftw/qqmlthread.cpp:141
#7  0x00007f1d3c9f02d8 in QThreadPrivate::start (arg=0x188f480) at thread/qthread_unix.cpp:341
#8  0x00007f1d3f85d474 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f1d3f59c3ed in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f1d1ce53700 (LWP 1427)):
#0  0x00007f1d3f86309f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f1d3bb7afc4 in ?? () from /usr/lib64/libQt5Script.so.5
#2  0x00007f1d3bb7b009 in ?? () from /usr/lib64/libQt5Script.so.5
#3  0x00007f1d3f85d474 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f1d3f59c3ed in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f1c8ff7d700 (LWP 3528)):
#0  0x00007ffff7be7989 in ?? ()
#1  0x00007ffff7be7c8f in clock_gettime ()
#2  0x00007f1d3f5a90a6 in clock_gettime () from /lib64/libc.so.6
#3  0x00007f1d3ca9bd96 in qt_clock_gettime (ts=0x7f1c8ff7cb10, clock=<optimized out>) at tools/qelapsedtimer_unix.cpp:105
#4  do_gettime (frac=<synthetic pointer>, sec=<synthetic pointer>) at tools/qelapsedtimer_unix.cpp:156
#5  qt_gettime () at tools/qelapsedtimer_unix.cpp:165
#6  0x00007f1d3cc1b699 in QTimerInfoList::updateCurrentTime (this=this@entry=0x7f1c880010f8) at kernel/qtimerinfo_unix.cpp:84
#7  0x00007f1d3cc1bc45 in QTimerInfoList::timerWait (this=this@entry=0x7f1c880010f8, tm=...) at kernel/qtimerinfo_unix.cpp:381
#8  0x00007f1d3cc1b272 in QEventDispatcherUNIX::processEvents (this=0x7f1c8806a040, flags=...) at kernel/qeventdispatcher_unix.cpp:594
#9  0x00007f1d3cbc576a in QEventLoop::exec (this=this@entry=0x7f1c8ff7cc60, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#10 0x00007f1d3c9eb3b3 in QThread::exec (this=this@entry=0x1946740) at thread/qthread.cpp:500
#11 0x00007f1d36e621e5 in QQmlThreadPrivate::run (this=0x1946740) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/ftw/qqmlthread.cpp:141
#12 0x00007f1d3c9f02d8 in QThreadPrivate::start (arg=0x1946740) at thread/qthread_unix.cpp:341
#13 0x00007f1d3f85d474 in start_thread () from /lib64/libpthread.so.0
#14 0x00007f1d3f59c3ed in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f1d3fe32940 (LWP 1387)):
[KCrash Handler]
#6  QV4::Value::as<QV4::QQmlValueTypeWrapper const> (this=0x7f1c8ef7e320) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/jsruntime/qv4value_p.h:348
#7  QQmlBinding::write (this=this@entry=0x22d2d70, core=..., result=..., isUndefined=<optimized out>, flags=...) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/qqmlbinding.cpp:257
#8  0x00007f1d36e4e3e7 in QQmlBinding::update (this=0x22d2d70, flags=...) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/qqmlbinding.cpp:191
#9  0x00007f1d36e57f05 in QQmlObjectCreator::finalize (this=0x213e9d0, interrupt=...) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/qqmlobjectcreator.cpp:1193
#10 0x00007f1d36de1dbe in QQmlComponentPrivate::complete (enginePriv=0x1b8dc10, state=0x18525d0) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/qqmlcomponent.cpp:919
#11 0x00007f1d36de1e87 in QQmlComponentPrivate::completeCreate (this=0x1852530) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/qqmlcomponent.cpp:955
#12 0x00007f1d36de1cf0 in QQmlComponent::create (this=0x18c2d90, context=0x187d170) at /usr/src/debug/qtdeclarative-opensource-src-5.6.1/src/qml/qml/qqmlcomponent.cpp:781
#13 0x00007f1d1e0f25a7 in Aurorae::Decoration::init (this=0x19185a0) at /usr/src/debug/kwin-5.6.95/plugins/kdecorations/aurorae/src/aurorae.cpp:316
#14 0x00007f1d3f1c6b59 in KWin::Decoration::DecorationBridge::createDecoration (this=0x179c660, client=client@entry=0x22edaf0) at /usr/src/debug/kwin-5.6.95/decorations/decorationbridge.cpp:260
#15 0x00007f1d3f0af6a9 in KWin::Client::createDecoration (this=this@entry=0x22edaf0, oldgeom=...) at /usr/src/debug/kwin-5.6.95/client.cpp:393
#16 0x00007f1d3f0b006d in KWin::Client::updateDecoration (this=0x22edaf0, check_workspace_pos=<optimized out>, force=<optimized out>) at /usr/src/debug/kwin-5.6.95/client.cpp:380
#17 0x00007f1d3f10ba7c in KWin::Client::manage (this=this@entry=0x22edaf0, w=w@entry=20971642, isMapped=isMapped@entry=false) at /usr/src/debug/kwin-5.6.95/manage.cpp:385
#18 0x00007f1d3f09329f in KWin::Workspace::createClient (this=this@entry=0x1794590, w=20971642, is_mapped=is_mapped@entry=false) at /usr/src/debug/kwin-5.6.95/workspace.cpp:498
#19 0x00007f1d3f0f9687 in KWin::Workspace::workspaceEvent (this=0x1794590, e=0x7f1d200024a0) at /usr/src/debug/kwin-5.6.95/events.cpp:417
#20 0x00007f1d3cbc48af in QAbstractEventDispatcher::filterNativeEvent (this=<optimized out>, eventType=..., message=message@entry=0x7f1d200024a0, result=result@entry=0x7ffff7baf8d8) at kernel/qabstracteventdispatcher.cpp:460
#21 0x00007f1d26bd5f55 in QXcbConnection::handleXcbEvent (this=this@entry=0x16ae790, event=event@entry=0x7f1d200024a0) at qxcbconnection.cpp:1091
#22 0x00007f1d26bd6eeb in QXcbConnection::processXcbEvents (this=0x16ae790) at qxcbconnection.cpp:1723
#23 0x00007f1d3cbf5cf9 in QObject::event (this=0x16ae790, e=<optimized out>) at kernel/qobject.cpp:1256
#24 0x00007f1d3d90daec in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x16ae790, e=0x7f1d20002d40) at kernel/qapplication.cpp:3804
#25 0x00007f1d3d912f8f in QApplication::notify (this=0x7ffff7baff20, receiver=0x16ae790, e=0x7f1d20002d40) at kernel/qapplication.cpp:3561
#26 0x00007f1d3cbc7a20 in QCoreApplication::notifyInternal2 (receiver=0x16ae790, event=event@entry=0x7f1d20002d40) at kernel/qcoreapplication.cpp:1015
#27 0x00007f1d3cbc999c in QCoreApplication::sendEvent (event=0x7f1d20002d40, receiver=<optimized out>) at kernel/qcoreapplication.h:225
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x16927a0) at kernel/qcoreapplication.cpp:1650
#29 0x00007f1d3cc1b1b2 in QEventDispatcherUNIX::processEvents (this=0x16fa820, flags=...) at kernel/qeventdispatcher_unix.cpp:579
#30 0x00007f1d26c48b9d in QUnixEventDispatcherQPA::processEvents (this=<optimized out>, flags=...) at eventdispatchers/qunixeventdispatcher.cpp:62
#31 0x00007f1d3cbc576a in QEventLoop::exec (this=this@entry=0x7ffff7bafe10, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#32 0x00007f1d3cbcdf6c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1285
#33 0x00007f1d3d116b6c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1607
#34 0x00007f1d3d90ab25 in QApplication::exec () at kernel/qapplication.cpp:2979
#35 0x00007f1d3fa7ca86 in kdemain (argc=<optimized out>, argv=0x7ffff7bb00a8) at /usr/src/debug/kwin-5.6.95/main_x11.cpp:466
#36 0x00007f1d3f4d4741 in __libc_start_main () from /lib64/libc.so.6
#37 0x0000000000400809 in _start () at ../sysdeps/x86_64/start.S:118

Possible duplicates by query: bug 363221, bug 363196.

Reported using DrKonqi
Comment 1 Martin Flöser 2016-06-28 07:29:27 UTC
As a workaround use the breeze window decoration.

*** This bug has been marked as a duplicate of bug 361236 ***