Bug 363221 - KWin crash sometimes when opening Dolphin
Summary: KWin crash sometimes when opening Dolphin
Status: RESOLVED DUPLICATE of bug 361236
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: 5.6.4
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2016-05-18 13:41 UTC by Benjamin Buch
Modified: 2016-05-18 18:24 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Buch 2016-05-18 13:41:52 UTC
Application: kwin_x11 (5.6.4)

Qt Version: 5.6.0
Frameworks Version: 5.22.0
Operating System: Linux 4.4.0-22-generic x86_64
Distribution: KDE neon Developer Edition

-- Information about the crash:
- What I was doing when the application crashed:

I just started Dolphin from the menu. The crash happens sometimes, when I start a new program. I am not sure, if it is only Dolphin.

I use the git stable branch of KDE neon.

The crash can be reproduced sometimes.

-- Backtrace:
Application: KWin (kwin_x11), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f607b347940 (LWP 1336))]

Thread 6 (Thread 0x7f6063573700 (LWP 1354)):
#0  0x00007f607ae3ee8d in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f607910fc62 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f60791118d7 in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f606401c1e9 in QXcbEventReader::run (this=0x1905f10) at qxcbconnection.cpp:1313
#4  0x00007f60793d4da8 in QThreadPrivate::start (arg=0x1905f10) at thread/qthread_unix.cpp:340
#5  0x00007f6074b2e6fa in start_thread (arg=0x7f6063573700) at pthread_create.c:333
#6  0x00007f607ae4ab5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7f60617be700 (LWP 1360)):
#0  0x00007f607ae40d13 in select () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f60795f8cff in qt_safe_select (nfds=8, fdread=fdread@entry=0x7f6054000a78, fdwrite=fdwrite@entry=0x7f6054000d08, fdexcept=fdexcept@entry=0x7f6054000f98, orig_timeout=orig_timeout@entry=0x0) at kernel/qcore_unix.cpp:75
#2  0x00007f60795fa73e in QEventDispatcherUNIX::select (timeout=0x0, exceptfds=0x7f6054000f98, writefds=0x7f6054000d08, readfds=0x7f6054000a78, nfds=<optimized out>, this=0x7f60540008c0) at kernel/qeventdispatcher_unix.cpp:320
#3  QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f60540008e0, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:196
#4  0x00007f60795fac52 in QEventDispatcherUNIX::processEvents (this=0x7f60540008c0, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#5  0x00007f60795a615a in QEventLoop::exec (this=this@entry=0x7f60617bdc50, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f60793cff94 in QThread::exec (this=this@entry=0x7f607b4ded40 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread.cpp:503
#7  0x00007f607b46b375 in QDBusConnectionManager::run (this=0x7f607b4ded40 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:181
#8  0x00007f60793d4da8 in QThreadPrivate::start (arg=0x7f607b4ded40 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:340
#9  0x00007f6074b2e6fa in start_thread (arg=0x7f60617be700) at pthread_create.c:333
#10 0x00007f607ae4ab5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f605b323700 (LWP 1385)):
#0  0x00007f607ae40d13 in select () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f60795f8cff in qt_safe_select (nfds=13, fdread=fdread@entry=0x7f6048000a78, fdwrite=fdwrite@entry=0x7f6048000d08, fdexcept=fdexcept@entry=0x7f6048000f98, orig_timeout=orig_timeout@entry=0x0) at kernel/qcore_unix.cpp:75
#2  0x00007f60795fa73e in QEventDispatcherUNIX::select (timeout=0x0, exceptfds=0x7f6048000f98, writefds=0x7f6048000d08, readfds=0x7f6048000a78, nfds=<optimized out>, this=0x7f60480008c0) at kernel/qeventdispatcher_unix.cpp:320
#3  QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f60480008e0, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:196
#4  0x00007f60795fac52 in QEventDispatcherUNIX::processEvents (this=0x7f60480008c0, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#5  0x00007f60795a615a in QEventLoop::exec (this=this@entry=0x7f605b322c60, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f60793cff94 in QThread::exec (this=this@entry=0x1abca10) at thread/qthread.cpp:503
#7  0x00007f6073a8ddc5 in QQmlThreadPrivate::run (this=0x1abca10) at qml/ftw/qqmlthread.cpp:141
#8  0x00007f60793d4da8 in QThreadPrivate::start (arg=0x1abca10) at thread/qthread_unix.cpp:340
#9  0x00007f6074b2e6fa in start_thread (arg=0x7f605b323700) at pthread_create.c:333
#10 0x00007f607ae4ab5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f6059a70700 (LWP 1403)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f607854d574 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Script.so.5
#2  0x00007f607854d5b9 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Script.so.5
#3  0x00007f6074b2e6fa in start_thread (arg=0x7f6059a70700) at pthread_create.c:333
#4  0x00007f607ae4ab5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f5fc5978700 (LWP 6912)):
#0  0x00007f607ae40d13 in select () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f60795f8cff in qt_safe_select (nfds=12, fdread=fdread@entry=0x7f5fc0000a58, fdwrite=fdwrite@entry=0x7f5fc0000ce8, fdexcept=fdexcept@entry=0x7f5fc0000f78, orig_timeout=orig_timeout@entry=0x0) at kernel/qcore_unix.cpp:75
#2  0x00007f60795fa73e in QEventDispatcherUNIX::select (timeout=0x0, exceptfds=0x7f5fc0000f78, writefds=0x7f5fc0000ce8, readfds=0x7f5fc0000a58, nfds=<optimized out>, this=0x7f5fc0086480) at kernel/qeventdispatcher_unix.cpp:320
#3  QEventDispatcherUNIXPrivate::doSelect (this=this@entry=0x7f5fc00008c0, flags=..., flags@entry=..., timeout=timeout@entry=0x0) at kernel/qeventdispatcher_unix.cpp:196
#4  0x00007f60795fac52 in QEventDispatcherUNIX::processEvents (this=0x7f5fc0086480, flags=...) at kernel/qeventdispatcher_unix.cpp:607
#5  0x00007f60795a615a in QEventLoop::exec (this=this@entry=0x7f5fc5977c60, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#6  0x00007f60793cff94 in QThread::exec (this=this@entry=0x3975e30) at thread/qthread.cpp:503
#7  0x00007f6073a8ddc5 in QQmlThreadPrivate::run (this=0x3975e30) at qml/ftw/qqmlthread.cpp:141
#8  0x00007f60793d4da8 in QThreadPrivate::start (arg=0x3975e30) at thread/qthread_unix.cpp:340
#9  0x00007f6074b2e6fa in start_thread (arg=0x7f5fc5978700) at pthread_create.c:333
#10 0x00007f607ae4ab5d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f607b347940 (LWP 1336)):
[KCrash Handler]
#6  QV4::Value::as<QV4::QQmlValueTypeWrapper const> (this=0x7f5fc4979320) at ../../include/QtQml/5.6.0/QtQml/private/../../../../../src/qml/jsruntime/qv4value_p.h:349
#7  QQmlBinding::write (this=this@entry=0x31d8420, core=..., result=..., isUndefined=<optimized out>, flags=...) at qml/qqmlbinding.cpp:257
#8  0x00007f6073a7b16a in QQmlBinding::update (this=0x31d8420, flags=...) at qml/qqmlbinding.cpp:191
#9  0x00007f6073a83f8f in QQmlObjectCreator::finalize (this=0x26da4e0, interrupt=...) at qml/qqmlobjectcreator.cpp:1191
#10 0x00007f6073a1130e in QQmlComponentPrivate::complete (enginePriv=0x29e8f30, state=0x29c16d0) at qml/qqmlcomponent.cpp:912
#11 0x00007f6073a113d7 in QQmlComponentPrivate::completeCreate (this=0x29c1630) at qml/qqmlcomponent.cpp:948
#12 0x00007f6073a11240 in QQmlComponent::create (this=0x2f54110, context=0x2e58e80) at qml/qqmlcomponent.cpp:774
#13 0x00007f605b36801a in Aurorae::Decoration::init (this=0x276fb30) at /var/lib/jenkins-slave/nci/workspace/xenial_stable_plasma_kwin_bin_amd64/build/clients/aurorae/src/aurorae.cpp:316
#14 0x00007f607aa4ff41 in KWin::Decoration::DecorationBridge::createDecoration (this=0x1a05a90, client=client@entry=0x372f740) at /var/lib/jenkins-slave/nci/workspace/xenial_stable_plasma_kwin_bin_amd64/build/decorations/decorationbridge.cpp:254
#15 0x00007f607a93dd19 in KWin::Client::createDecoration (this=this@entry=0x372f740, oldgeom=...) at /var/lib/jenkins-slave/nci/workspace/xenial_stable_plasma_kwin_bin_amd64/build/client.cpp:393
#16 0x00007f607a93e6d3 in KWin::Client::updateDecoration (this=0x372f740, check_workspace_pos=<optimized out>, force=<optimized out>) at /var/lib/jenkins-slave/nci/workspace/xenial_stable_plasma_kwin_bin_amd64/build/client.cpp:380
#17 0x00007f607a996e1a in KWin::Client::manage (this=this@entry=0x372f740, w=w@entry=62914564, isMapped=isMapped@entry=false) at /var/lib/jenkins-slave/nci/workspace/xenial_stable_plasma_kwin_bin_amd64/build/manage.cpp:385
#18 0x00007f607a92145f in KWin::Workspace::createClient (this=this@entry=0x19f78a0, w=62914564, is_mapped=is_mapped@entry=false) at /var/lib/jenkins-slave/nci/workspace/xenial_stable_plasma_kwin_bin_amd64/build/workspace.cpp:483
#19 0x00007f607a97e051 in KWin::Workspace::workspaceEvent (this=0x19f78a0, e=0x7f605c002510) at /var/lib/jenkins-slave/nci/workspace/xenial_stable_plasma_kwin_bin_amd64/build/events.cpp:417
#20 0x00007f60795a52cf in QAbstractEventDispatcher::filterNativeEvent (this=<optimized out>, eventType=..., message=message@entry=0x7f605c002510, result=result@entry=0x7fff9352e4d8) at kernel/qabstracteventdispatcher.cpp:460
#21 0x00007f6064020135 in QXcbConnection::handleXcbEvent (this=this@entry=0x18fa150, event=event@entry=0x7f605c002510) at qxcbconnection.cpp:1087
#22 0x00007f6064021066 in QXcbConnection::processXcbEvents (this=0x18fa150) at qxcbconnection.cpp:1701
#23 0x00007f60795d5839 in QObject::event (this=0x18fa150, e=<optimized out>) at kernel/qobject.cpp:1256
#24 0x00007f6079edb1dc in QApplicationPrivate::notify_helper (this=<optimized out>, receiver=0x18fa150, e=0x7f605c0038e0) at kernel/qapplication.cpp:3714
#25 0x00007f6079ee0446 in QApplication::notify (this=0x7fff9352eb20, receiver=0x18fa150, e=0x7f605c0038e0) at kernel/qapplication.cpp:3495
#26 0x00007f60795a83d8 in QCoreApplication::notifyInternal2 (receiver=0x18fa150, event=event@entry=0x7f605c0038e0) at kernel/qcoreapplication.cpp:1015
#27 0x00007f60795aa29a in QCoreApplication::sendEvent (event=0x7f605c0038e0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:227
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x18d65b0) at kernel/qcoreapplication.cpp:1650
#29 0x00007f60795fab32 in QEventDispatcherUNIX::processEvents (this=0x1933510, flags=flags@entry=...) at kernel/qeventdispatcher_unix.cpp:579
#30 0x00007f606408e33d in QUnixEventDispatcherQPA::processEvents (this=<optimized out>, flags=...) at eventdispatchers/qunixeventdispatcher.cpp:62
#31 0x00007f60795a615a in QEventLoop::exec (this=this@entry=0x7fff9352ea10, flags=..., flags@entry=...) at kernel/qeventloop.cpp:204
#32 0x00007f60795ae81c in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1285
#33 0x00007f60798eecbc in QGuiApplication::exec () at kernel/qguiapplication.cpp:1598
#34 0x00007f6079ed8215 in QApplication::exec () at kernel/qapplication.cpp:2973
#35 0x00007f607b112aee in kdemain (argc=1, argv=0x7fff9352eca8) at /var/lib/jenkins-slave/nci/workspace/xenial_stable_plasma_kwin_bin_amd64/build/main_x11.cpp:327
#36 0x00007f607ad64830 in __libc_start_main (main=0x4007c0 <main(int, char**)>, argc=3, argv=0x7fff9352eca8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff9352ec98) at ../csu/libc-start.c:291
#37 0x00000000004007f9 in _start ()

Possible duplicates by query: bug 363196.

Reported using DrKonqi
Comment 1 Thomas Lübking 2016-05-18 18:24:38 UTC
run "kcmshell5 kwindecoration", switch to breeze.
It's not dolphin.

*** This bug has been marked as a duplicate of bug 361236 ***