Bug 343189 - amarok crashes on exit - new install 4.14.3
Summary: amarok crashes on exit - new install 4.14.3
Status: RESOLVED NOT A BUG
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.8.0
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: 2.9
Assignee: Amarok Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-01-23 11:20 UTC by Landis
Modified: 2015-02-23 00:51 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (12.12 KB, text/plain)
2015-01-25 02:11 UTC, Landis
Details
New crash information added by DrKonqi (16.21 KB, text/plain)
2015-02-16 20:41 UTC, Landis
Details
New crash information added by DrKonqi (17.47 KB, text/plain)
2015-02-23 00:51 UTC, Landis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Landis 2015-01-23 11:20:19 UTC
Application: amarok (2.8.0)
KDE Platform Version: 4.14.3
Qt Version: 4.8.6
Operating System: Linux 3.16.7-7-desktop x86_64
Distribution: "openSUSE 13.2 (Harlequin) (x86_64)"

-- Information about the crash:
new installation. all updates.
amarok crashes on every exit.
quad core, 6 gb ram, 500 gb hdd
also, konqueror crashes on shutdown if open.
and gwenview crashes on every exit

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f2ac7d45800 (LWP 1530))]

Thread 14 (Thread 0x7f2a8e63f700 (LWP 1535)):
#0  0x00007f2ac2bf2408 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2a9df65e2a in ?? () from /usr/lib64/libmysqld.so.18
#2  0x00007f2a9df5e207 in ?? () from /usr/lib64/libmysqld.so.18
#3  0x00007f2ac2bee0a4 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f2ac4aaf7fd in clone () from /lib64/libc.so.6

Thread 13 (Thread 0x7f2a8de3e700 (LWP 1536)):
#0  0x00007f2ac2bf205f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2ac50fbc86 in wait (time=18446744073709551615, this=0x29116d0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x27d1d30, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f2ac1cec6fc in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f2ac1cef193 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f2ac1cedeaf in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f2ac50fb79f in QThreadPrivate::start (arg=0x27d02d0) at thread/qthread_unix.cpp:349
#7  0x00007f2ac2bee0a4 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f2ac4aaf7fd in clone () from /lib64/libc.so.6

Thread 12 (Thread 0x7f2a8d63d700 (LWP 1537)):
#0  0x00007f2ac4aa73cd in poll () from /lib64/libc.so.6
#1  0x00007f2abeeffbe4 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f2abeeffcec in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f2ac522a0de in QEventDispatcherGlib::processEvents (this=0x7f2a840008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:452
#4  0x00007f2ac51fbe6f in QEventLoop::processEvents (this=this@entry=0x7f2a8d63cda0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f2ac51fc165 in QEventLoop::exec (this=this@entry=0x7f2a8d63cda0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f2ac50f90bf in QThread::exec (this=this@entry=0x29142e0) at thread/qthread.cpp:538
#7  0x00007f2ac51dd783 in QInotifyFileSystemWatcherEngine::run (this=0x29142e0) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007f2ac50fb79f in QThreadPrivate::start (arg=0x29142e0) at thread/qthread_unix.cpp:349
#9  0x00007f2ac2bee0a4 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f2ac4aaf7fd in clone () from /lib64/libc.so.6

Thread 11 (Thread 0x7f2a7fdef700 (LWP 1538)):
#0  0x00007f2ac2bf205f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2ac50fbc86 in wait (time=18446744073709551615, this=0x29116d0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x27d1d30, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f2ac1cec6fc in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f2ac1cef193 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f2ac1cef1ac in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f2ac1cedeaf in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f2ac50fb79f in QThreadPrivate::start (arg=0x29a7670) at thread/qthread_unix.cpp:349
#8  0x00007f2ac2bee0a4 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f2ac4aaf7fd in clone () from /lib64/libc.so.6

Thread 10 (Thread 0x7f2a7f5ee700 (LWP 1539)):
#0  0x00007f2ac2bf205f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2ac50fbc86 in wait (time=18446744073709551615, this=0x29116d0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x27d1d30, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f2ac1cec6fc in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f2ac1cef193 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f2ac1cedeaf in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f2ac50fb79f in QThreadPrivate::start (arg=0x2abb020) at thread/qthread_unix.cpp:349
#7  0x00007f2ac2bee0a4 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f2ac4aaf7fd in clone () from /lib64/libc.so.6

Thread 9 (Thread 0x7f2a7eded700 (LWP 1540)):
#0  0x00007f2ac2bf205f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2ac50fbc86 in wait (time=18446744073709551615, this=0x29116d0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x27d1d30, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f2ac1cec6fc in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f2ac1cef193 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f2ac1cedeaf in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f2ac50fb79f in QThreadPrivate::start (arg=0x2ac01f0) at thread/qthread_unix.cpp:349
#7  0x00007f2ac2bee0a4 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f2ac4aaf7fd in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7f2a7dead700 (LWP 1541)):
#0  0x00007f2ac2bf205f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2ac50fbc86 in wait (time=18446744073709551615, this=0x29116d0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x27d1d30, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f2ac1cec6fc in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f2ac1cef193 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f2ac1cedeaf in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f2ac50fb79f in QThreadPrivate::start (arg=0x3187960) at thread/qthread_unix.cpp:349
#7  0x00007f2ac2bee0a4 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f2ac4aaf7fd in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7f2a7d6ac700 (LWP 1542)):
#0  0x00007f2ac2bf205f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2ac50fbc86 in wait (time=18446744073709551615, this=0x29116d0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x27d1d30, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f2ac1cec6fc in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f2ac1cef193 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f2ac1cedeaf in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f2ac50fb79f in QThreadPrivate::start (arg=0x31d7fe0) at thread/qthread_unix.cpp:349
#7  0x00007f2ac2bee0a4 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f2ac4aaf7fd in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f2a7ceab700 (LWP 1543)):
#0  0x00007f2ac2bf205f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2ac50fbc86 in wait (time=18446744073709551615, this=0x29116d0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x27d1d30, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f2ac1cec6fc in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f2ac1cef193 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f2ac1cedeaf in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f2ac50fb79f in QThreadPrivate::start (arg=0x31d8ea0) at thread/qthread_unix.cpp:349
#7  0x00007f2ac2bee0a4 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f2ac4aaf7fd in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f2a57fff700 (LWP 1544)):
#0  0x00007f2ac2bf205f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2abb094686 in WTF::TCMalloc_PageHeap::scavengerThread() () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f2abb0946b9 in WTF::TCMalloc_PageHeap::runScavengerThread(void*) () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f2ac2bee0a4 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f2ac4aaf7fd in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f2a170c1700 (LWP 1545)):
#0  0x00007f2ac2bf205f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2ac50fbc86 in wait (time=18446744073709551615, this=0x29116d0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x27d1d30, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f2ac1cec6fc in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f2ac1cef193 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f2ac1cedeaf in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f2ac50fb79f in QThreadPrivate::start (arg=0x3594d40) at thread/qthread_unix.cpp:349
#7  0x00007f2ac2bee0a4 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f2ac4aaf7fd in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f2a69907700 (LWP 1572)):
#0  0x00007f2ac4a816cd in nanosleep () from /lib64/libc.so.6
#1  0x00007f2ac4a81564 in sleep () from /lib64/libc.so.6
#2  0x00007f2ac0d3a882 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f2ac1038f00 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2363
#3  0x00007f2ac0d3a909 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#4  0x00007f2ac2bee0a4 in start_thread () from /lib64/libpthread.so.0
#5  0x00007f2ac4aaf7fd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f2a150a2700 (LWP 4985)):
#0  0x00007f2ac2bf205f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2abae06e7d in JSC::BlockAllocator::blockFreeingThreadMain() () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f2abb0bc1e6 in WTF::wtfThreadEntryPoint(void*) () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f2ac2bee0a4 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f2ac4aaf7fd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f2ac7d45800 (LWP 1530)):
[KCrash Handler]
#5  0x00007f2ac5930d29 in QRasterWindowSurface::~QRasterWindowSurface (this=0x315c600, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#6  0x00007f2ac5930da9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x315c600, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#7  0x00007f2ac594907c in QWidgetBackingStore::~QWidgetBackingStore (this=0x2feb890, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#8  0x00007f2ac5785709 in QWidgetBackingStoreTracker::destroy (this=0x2a94670) at kernel/qwidget.cpp:225
#9  0x00007f2ac57858a9 in QWidgetPrivate::deleteExtra (this=this@entry=0x31c3b40) at kernel/qwidget.cpp:1833
#10 0x00007f2ac5785abd in QWidgetPrivate::~QWidgetPrivate (this=0x31c3b40, __in_chrg=<optimized out>) at kernel/qwidget.cpp:365
#11 0x00007f2ac5785d49 in QWidgetPrivate::~QWidgetPrivate (this=0x31c3b40, __in_chrg=<optimized out>) at kernel/qwidget.cpp:370
#12 0x00007f2ac52160b5 in cleanup (pointer=<optimized out>) at ../../src/corelib/tools/qscopedpointer.h:62
#13 ~QScopedPointer (this=0x311fe28, __in_chrg=<optimized out>) at ../../src/corelib/tools/qscopedpointer.h:100
#14 QObject::~QObject (this=0x311fe20, __in_chrg=<optimized out>) at kernel/qobject.cpp:844
#15 0x00007f2ac578e4cc in QWidget::~QWidget (this=0x311fe20, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1554
#16 0x00007f2ac578e749 in QWidget::~QWidget (this=0x311fe20, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1703
#17 0x00007f2ac5cd9045 in QGlobalStaticDeleter<QWidget>::~QGlobalStaticDeleter (this=0x7f2ac6225080 <globalStyleInfoWidget()::cleanup>, __in_chrg=<optimized out>) at ../../src/corelib/global/qglobal.h:1959
#18 0x00007f2ac4a01bf9 in __run_exit_handlers () from /lib64/libc.so.6
#19 0x00007f2ac4a01c45 in exit () from /lib64/libc.so.6
#20 0x00007f2ac49ebb0c in __libc_start_main () from /lib64/libc.so.6
#21 0x00000000004080d2 in _start ()

Possible duplicates by query: bug 341443, bug 337115, bug 334146, bug 331437, bug 330038.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2015-01-23 11:28:03 UTC
Thank you for your report. This is a recurring problme with kdelibs, not an Amarok bug

*** This bug has been marked as a duplicate of bug 261539 ***
Comment 2 Christoph Feck 2015-01-23 12:50:46 UTC
Already reported as bug 343139.
Comment 3 Landis 2015-01-25 02:11:25 UTC
Created attachment 90636 [details]
New crash information added by DrKonqi

amarok (2.8.0) on KDE Platform 4.14.3 using Qt 4.8.6

amarok crashes on every exit of application.

-- Backtrace (Reduced):
#5  0x00007f99b2ac6d29 in QRasterWindowSurface::~QRasterWindowSurface (this=0x2cad680, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#6  0x00007f99b2ac6da9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x2cad680, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#7  0x00007f99b2adf07c in QWidgetBackingStore::~QWidgetBackingStore (this=0x2b29f10, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#8  0x00007f99b291b709 in QWidgetBackingStoreTracker::destroy (this=0x27266e0) at kernel/qwidget.cpp:225
#9  0x00007f99b291b8a9 in QWidgetPrivate::deleteExtra (this=this@entry=0x2cdd890) at kernel/qwidget.cpp:1833
Comment 4 Landis 2015-02-16 20:41:56 UTC
Created attachment 91113 [details]
New crash information added by DrKonqi

amarok (2.8.0) on KDE Platform 4.14.4 using Qt 4.8.5

Amarok proforms nicely, but crashes Every time i Quit application.
quad core, 6 gb ram, opensuse 13.1 KDE 14.4.x

-- Backtrace (Reduced):
#6  0x00007ff6c2558799 in QRasterWindowSurface::~QRasterWindowSurface (this=0x209f7d0, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#7  0x00007ff6c2558819 in QRasterWindowSurface::~QRasterWindowSurface (this=0x209f7d0, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#8  0x00007ff6c2570b2c in QWidgetBackingStore::~QWidgetBackingStore (this=0x20b2bb0, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#9  0x00007ff6c23ad8f9 in QWidgetBackingStoreTracker::destroy (this=0x1c6ebe0) at kernel/qwidget.cpp:225
#10 0x00007ff6c23ada99 in QWidgetPrivate::deleteExtra (this=this@entry=0x217d0c0) at kernel/qwidget.cpp:1833
Comment 5 Landis 2015-02-23 00:51:50 UTC
Created attachment 91229 [details]
New crash information added by DrKonqi

amarok (2.8.0) on KDE Platform 4.14.4 using Qt 4.8.5

On Quit, of App, Shutdown and Restart of system (if app is open), the following KDE Applications CRASH Every Time.

Kmix (only crashes if 'touched'. ie, any media is played or i adjust volume at any time during session)
Gwenview
Konqueror
Amarok
baloo

This is a Fresh Install from opneSuse ISO burnt to DVD (i've reinstalled w/ 3 different dls, 1 'Live CD')
Dell Latitude E6420 with Quad-core, 6 GB RAM and Clean HDD.
I've rolled back Konqueror from 4.14 to 4.11 and Still have this problem.
I've Removed baloo wich CRASHed All the time
I've Removed Aomuka??? something or other that CRASHED All the time.
I've Disabled 'Desktop Search'
I've Only changed the colors, theme and splashscreen, But these apps where crashing since the First Restart after installation.

Your apps generate the 'Crash Report'. I take the time to add info, and you Mark my reports 'Invalid'.
That sucks and is disheartening. Why?

-- Backtrace (Reduced):
#6  0x00007f003deaf799 in QRasterWindowSurface::~QRasterWindowSurface (this=0x14efd00, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#7  0x00007f003deaf819 in QRasterWindowSurface::~QRasterWindowSurface (this=0x14efd00, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#8  0x00007f003dec7b2c in QWidgetBackingStore::~QWidgetBackingStore (this=0x145f720, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#9  0x00007f003dd048f9 in QWidgetBackingStoreTracker::destroy (this=0x148c2e0) at kernel/qwidget.cpp:225
#10 0x00007f003dd04a99 in QWidgetPrivate::deleteExtra (this=this@entry=0x1534c50) at kernel/qwidget.cpp:1833