Bug 331437 - Amarok crashed during system shutdown
Summary: Amarok crashed during system shutdown
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.8.0
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: 2.9
Assignee: Amarok Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-02-23 17:38 UTC by Philip Tovstogan
Modified: 2014-02-23 18:05 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philip Tovstogan 2014-02-23 17:38:19 UTC
Application: amarok (2.8.0)
KDE Platform Version: 4.11.5
Qt Version: 4.8.5
Operating System: Linux 3.11.10-7-desktop x86_64
Distribution: "openSUSE 13.1 (Bottle) (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
This crash happens every time the system shuts down, even if Amarok window wasn't opened and it stayed in the tray.

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f9e13d73880 (LWP 12190))]

Thread 13 (Thread 0x7f9de2247700 (LWP 12247)):
#0  0x00007f9e0ebd3458 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9de8fb5576 in my_service_thread_sleep () from /usr/lib64/libmysqld.so.18
#2  0x00007f9de8d27d11 in ma_checkpoint_background () from /usr/lib64/libmysqld.so.18
#3  0x00007f9e0ebcf0db in start_thread () from /lib64/libpthread.so.0
#4  0x00007f9e10a9490d in clone () from /lib64/libc.so.6

Thread 12 (Thread 0x7f9dd450c700 (LWP 12296)):
#0  0x00007f9e0ebd30af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9e110e5b66 in wait (time=18446744073709551615, this=0x1b81b50) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1a7fb80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9e0dcc879c in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f9e0dccb233 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f9e0dcc9f4f in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f9e110e568f in QThreadPrivate::start (arg=0x14b01d0) at thread/qthread_unix.cpp:338
#7  0x00007f9e0ebcf0db in start_thread () from /lib64/libpthread.so.0
#8  0x00007f9e10a9490d in clone () from /lib64/libc.so.6

Thread 11 (Thread 0x7f9dd3d0b700 (LWP 12297)):
#0  0x00007f9e10a8bb3d in poll () from /lib64/libc.so.6
#1  0x00007f9e0acdb604 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f9e0acdb70c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f9e11211d76 in QEventDispatcherGlib::processEvents (this=0x7f9dc40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#4  0x00007f9e111e3d0f in QEventLoop::processEvents (this=this@entry=0x7f9dd3d0ad20, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9e111e4005 in QEventLoop::exec (this=this@entry=0x7f9dd3d0ad20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f9e110e2fef in QThread::exec (this=this@entry=0x1b84c10) at thread/qthread.cpp:536
#7  0x00007f9e111c5513 in QInotifyFileSystemWatcherEngine::run (this=0x1b84c10) at io/qfilesystemwatcher_inotify.cpp:256
#8  0x00007f9e110e568f in QThreadPrivate::start (arg=0x1b84c10) at thread/qthread_unix.cpp:338
#9  0x00007f9e0ebcf0db in start_thread () from /lib64/libpthread.so.0
#10 0x00007f9e10a9490d in clone () from /lib64/libc.so.6

Thread 10 (Thread 0x7f9dd2e8a700 (LWP 12299)):
#0  0x00007f9e0ebd30af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9e110e5b66 in wait (time=18446744073709551615, this=0x1b81b50) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1a7fb80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9e0dcc879c in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f9e0dccb233 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f9e0dccb24c in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f9e0dccb24c in ?? () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f9e0dcc9f4f in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#8  0x00007f9e110e568f in QThreadPrivate::start (arg=0x1c64400) at thread/qthread_unix.cpp:338
#9  0x00007f9e0ebcf0db in start_thread () from /lib64/libpthread.so.0
#10 0x00007f9e10a9490d in clone () from /lib64/libc.so.6

Thread 9 (Thread 0x7f9dd2689700 (LWP 12300)):
#0  0x00007f9e0ebd30af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9e110e5b66 in wait (time=18446744073709551615, this=0x1b81b50) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1a7fb80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9e0dcc879c in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f9e0dccb233 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f9e0dcc9f4f in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f9e110e568f in QThreadPrivate::start (arg=0x7f9dc801e010) at thread/qthread_unix.cpp:338
#7  0x00007f9e0ebcf0db in start_thread () from /lib64/libpthread.so.0
#8  0x00007f9e10a9490d in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7f9dd1e88700 (LWP 12301)):
#0  0x00007f9e0ebd30af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9e110e5b66 in wait (time=18446744073709551615, this=0x1b81b50) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1a7fb80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9e0dcc879c in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f9e0dccb233 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f9e0dccb24c in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f9e0dccb24c in ?? () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f9e0dccb24c in ?? () from /usr/lib64/libthreadweaver.so.4
#8  0x00007f9e0dcc9f4f in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#9  0x00007f9e110e568f in QThreadPrivate::start (arg=0x7f9dc8024630) at thread/qthread_unix.cpp:338
#10 0x00007f9e0ebcf0db in start_thread () from /lib64/libpthread.so.0
#11 0x00007f9e10a9490d in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7f9dd1687700 (LWP 12302)):
#0  0x00007f9e0ebd30af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9e110e5b66 in wait (time=18446744073709551615, this=0x1b81b50) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1a7fb80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9e0dcc879c in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f9e0dccb233 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f9e0dccb24c in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f9e0dcc9f4f in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f9e110e568f in QThreadPrivate::start (arg=0x7f9dc802bec0) at thread/qthread_unix.cpp:338
#8  0x00007f9e0ebcf0db in start_thread () from /lib64/libpthread.so.0
#9  0x00007f9e10a9490d in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f9dd0e86700 (LWP 12303)):
#0  0x00007f9e0ebd30af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9e110e5b66 in wait (time=18446744073709551615, this=0x1b81b50) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1a7fb80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9e0dcc879c in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f9e0dccb233 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f9e0dccb24c in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f9e0dccb24c in ?? () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f9e0dcc9f4f in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#8  0x00007f9e110e568f in QThreadPrivate::start (arg=0x7f9dc8033060) at thread/qthread_unix.cpp:338
#9  0x00007f9e0ebcf0db in start_thread () from /lib64/libpthread.so.0
#10 0x00007f9e10a9490d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f9dc3fff700 (LWP 12304)):
#0  0x00007f9e0ebd30af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9e110e5b66 in wait (time=18446744073709551615, this=0x1b81b50) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1a7fb80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9e0dcc879c in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f9e0dccb233 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f9e0dcc9f4f in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f9e110e568f in QThreadPrivate::start (arg=0x7f9dc80322b0) at thread/qthread_unix.cpp:338
#7  0x00007f9e0ebcf0db in start_thread () from /lib64/libpthread.so.0
#8  0x00007f9e10a9490d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f9dc37fe700 (LWP 12305)):
#0  0x00007f9e0ebd30af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9e110e5b66 in wait (time=18446744073709551615, this=0x1b81b50) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1a7fb80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9e0dcc879c in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f9e0dccb233 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f9e0dccb24c in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f9e0dccb24c in ?? () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f9e0dcc9f4f in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#8  0x00007f9e110e568f in QThreadPrivate::start (arg=0x7f9dc8007080) at thread/qthread_unix.cpp:338
#9  0x00007f9e0ebcf0db in start_thread () from /lib64/libpthread.so.0
#10 0x00007f9e10a9490d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f9dc2b67700 (LWP 12306)):
#0  0x00007f9e10a8bb3d in poll () from /lib64/libc.so.6
#1  0x00007f9e0acdb604 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f9e0acdb70c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f9e11211d76 in QEventDispatcherGlib::processEvents (this=0x7f9da00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#4  0x00007f9e111e3d0f in QEventLoop::processEvents (this=this@entry=0x7f9dc2b66d20, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9e111e4005 in QEventLoop::exec (this=this@entry=0x7f9dc2b66d20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f9e110e2fef in QThread::exec (this=this@entry=0x1fb90a0) at thread/qthread.cpp:536
#7  0x00007f9e111c5513 in QInotifyFileSystemWatcherEngine::run (this=0x1fb90a0) at io/qfilesystemwatcher_inotify.cpp:256
#8  0x00007f9e110e568f in QThreadPrivate::start (arg=0x1fb90a0) at thread/qthread_unix.cpp:338
#9  0x00007f9e0ebcf0db in start_thread () from /lib64/libpthread.so.0
#10 0x00007f9e10a9490d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f9dc121f700 (LWP 12333)):
#0  0x00007f9e0ebd30af in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9e0cd158cb in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f9e0d013f00 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f9e0cd15909 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f9e0ebcf0db in start_thread () from /lib64/libpthread.so.0
#4  0x00007f9e10a9490d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f9e13d73880 (LWP 12190)):
[KCrash Handler]
#5  0x00007f9e11917789 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1fd5050, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#6  0x00007f9e11917809 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1fd5050, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#7  0x00007f9e1192fb1c in QWidgetBackingStore::~QWidgetBackingStore (this=0x1fd7a60, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#8  0x00007f9e1176c8f9 in QWidgetBackingStoreTracker::destroy (this=0x1c30ec0) at kernel/qwidget.cpp:225
#9  0x00007f9e1176ca99 in QWidgetPrivate::deleteExtra (this=this@entry=0x2047d90) at kernel/qwidget.cpp:1833
#10 0x00007f9e1176ccad in QWidgetPrivate::~QWidgetPrivate (this=0x2047d90, __in_chrg=<optimized out>) at kernel/qwidget.cpp:365
#11 0x00007f9e1176cf39 in QWidgetPrivate::~QWidgetPrivate (this=0x2047d90, __in_chrg=<optimized out>) at kernel/qwidget.cpp:370
#12 0x00007f9e111fdc35 in cleanup (pointer=<optimized out>) at ../../src/corelib/tools/qscopedpointer.h:62
#13 ~QScopedPointer (this=0x2046f08, __in_chrg=<optimized out>) at ../../src/corelib/tools/qscopedpointer.h:100
#14 QObject::~QObject (this=0x2046f00, __in_chrg=<optimized out>) at kernel/qobject.cpp:816
#15 0x00007f9e117756ac in QWidget::~QWidget (this=0x2046f00, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1554
#16 0x00007f9e11775929 in QWidget::~QWidget (this=0x2046f00, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1703
#17 0x00007f9e11cc05e5 in QGlobalStaticDeleter<QWidget>::~QGlobalStaticDeleter (this=0x7f9e1220a080 <globalStyleInfoWidget()::cleanup>, __in_chrg=<optimized out>) at ../../src/corelib/global/qglobal.h:1951
#18 0x00007f9e109e53d9 in __run_exit_handlers () from /lib64/libc.so.6
#19 0x00007f9e109e5425 in exit () from /lib64/libc.so.6
#20 0x00007f9e109cebec in __libc_start_main () from /lib64/libc.so.6
#21 0x0000000000408615 in _start ()

Possible duplicates by query: bug 330038, bug 327798, bug 320766.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-02-23 18:05:11 UTC

*** This bug has been marked as a duplicate of bug 261539 ***