Bug 337115 - Application Crashed
Summary: Application Crashed
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.8.0
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: 2.9
Assignee: Amarok Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-07-05 12:54 UTC by Nuruddin Azmi
Modified: 2014-07-05 13:00 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nuruddin Azmi 2014-07-05 12:54:26 UTC
Application: amarok (2.8.0)
KDE Platform Version: 4.13.2
Qt Version: 4.8.5
Operating System: Linux 3.11.10-17-default i686
Distribution: "openSUSE 13.1 (Bottle) (i586)"

-- Information about the crash:
- What I was doing when the application crashed:
when I close some application like Amarok, Gwenview, etc. I got crash everytime.

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb089d7c0 (LWP 1412))]

Thread 7 (Thread 0xa7a76b40 (LWP 1528)):
#0  0xb76e4430 in __kernel_vsyscall ()
#1  0xb53ab31e in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb5879924 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xa8163546 in my_service_thread_sleep () from /usr/lib/libmysqld.so.18
#4  0xa7e19a9c in ma_checkpoint_background () from /usr/lib/libmysqld.so.18
#5  0xb53a707a in start_thread () from /lib/libpthread.so.0
#6  0xb586c80e in clone () from /lib/libc.so.6

Thread 6 (Thread 0xa5bc8b40 (LWP 1529)):
#0  0xb76e4430 in __kernel_vsyscall ()
#1  0xb53aaf3c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb58798cc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xb5a891d5 in wait (time=4294967295, this=0x8ffd2d8) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x8ffd250, mutex=0x8afc058, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0xb4f6d1b3 in ?? () from /usr/lib/libthreadweaver.so.4
#6  0xb4f7011b in ?? () from /usr/lib/libthreadweaver.so.4
#7  0xb4f6d10a in ?? () from /usr/lib/libthreadweaver.so.4
#8  0xb4f701f2 in ?? () from /usr/lib/libthreadweaver.so.4
#9  0xb4f6c062 in ?? () from /usr/lib/libthreadweaver.so.4
#10 0xb4f6eb73 in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#11 0xb5a88c5f in QThreadPrivate::start (arg=0x8f29f08) at thread/qthread_unix.cpp:338
#12 0xb53a707a in start_thread () from /lib/libpthread.so.0
#13 0xb586c80e in clone () from /lib/libc.so.6

Thread 5 (Thread 0x9940bb40 (LWP 1530)):
#0  0xb45a8fc3 in ?? () from /usr/lib/libglib-2.0.so.0
#1  0xb45d9c1f in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#2  0xb5bc860f in QEventDispatcherGlib::processEvents (this=0x98b00468, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#3  0xb5b97a03 in QEventLoop::processEvents (this=this@entry=0x9940b1d8, flags=...) at kernel/qeventloop.cpp:149
#4  0xb5b97d29 in QEventLoop::exec (this=this@entry=0x9940b1d8, flags=...) at kernel/qeventloop.cpp:204
#5  0xb5a8630d in QThread::exec (this=this@entry=0x8fff3e8) at thread/qthread.cpp:536
#6  0xb5b77e14 in QInotifyFileSystemWatcherEngine::run (this=0x8fff3e8) at io/qfilesystemwatcher_inotify.cpp:256
#7  0xb5a88c5f in QThreadPrivate::start (arg=0x8fff3e8) at thread/qthread_unix.cpp:338
#8  0xb53a707a in start_thread () from /lib/libpthread.so.0
#9  0xb586c80e in clone () from /lib/libc.so.6

Thread 4 (Thread 0x98affb40 (LWP 1544)):
#0  0xb76e4430 in __kernel_vsyscall ()
#1  0xb53aaf3c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb58798cc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xb5a891d5 in wait (time=4294967295, this=0x8ffd2d8) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x8ffd250, mutex=0x8afc058, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0xb4f6d1b3 in ?? () from /usr/lib/libthreadweaver.so.4
#6  0xb4f7011b in ?? () from /usr/lib/libthreadweaver.so.4
#7  0xb4f6d10a in ?? () from /usr/lib/libthreadweaver.so.4
#8  0xb4f701f2 in ?? () from /usr/lib/libthreadweaver.so.4
#9  0xb4f6c062 in ?? () from /usr/lib/libthreadweaver.so.4
#10 0xb4f6eb73 in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#11 0xb5a88c5f in QThreadPrivate::start (arg=0x90e2990) at thread/qthread_unix.cpp:338
#12 0xb53a707a in start_thread () from /lib/libpthread.so.0
#13 0xb586c80e in clone () from /lib/libc.so.6

Thread 3 (Thread 0x982feb40 (LWP 1545)):
#0  0xb76e4430 in __kernel_vsyscall ()
#1  0xb53aaf3c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb58798cc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xb5a891d5 in wait (time=4294967295, this=0x8ffd2d8) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x8ffd250, mutex=0x8afc058, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0xb4f6d1b3 in ?? () from /usr/lib/libthreadweaver.so.4
#6  0xb4f7011b in ?? () from /usr/lib/libthreadweaver.so.4
#7  0xb4f6d10a in ?? () from /usr/lib/libthreadweaver.so.4
#8  0xb4f701f2 in ?? () from /usr/lib/libthreadweaver.so.4
#9  0xb4f6c062 in ?? () from /usr/lib/libthreadweaver.so.4
#10 0xb4f6eb73 in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#11 0xb5a88c5f in QThreadPrivate::start (arg=0x98b2a7e8) at thread/qthread_unix.cpp:338
#12 0xb53a707a in start_thread () from /lib/libpthread.so.0
#13 0xb586c80e in clone () from /lib/libc.so.6

Thread 2 (Thread 0x97afdb40 (LWP 1546)):
#0  0xb76e4430 in __kernel_vsyscall ()
#1  0xb53aaf3c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb58798cc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xb5a891d5 in wait (time=4294967295, this=0x8ffd2d8) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x8ffd250, mutex=0x8afc058, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0xb4f6d1b3 in ?? () from /usr/lib/libthreadweaver.so.4
#6  0xb4f7011b in ?? () from /usr/lib/libthreadweaver.so.4
#7  0xb4f6d10a in ?? () from /usr/lib/libthreadweaver.so.4
#8  0xb4f701f2 in ?? () from /usr/lib/libthreadweaver.so.4
#9  0xb4f6c062 in ?? () from /usr/lib/libthreadweaver.so.4
#10 0xb4f6eb73 in ThreadWeaver::Thread::run() () from /usr/lib/libthreadweaver.so.4
#11 0xb5a88c5f in QThreadPrivate::start (arg=0x98b2a658) at thread/qthread_unix.cpp:338
#12 0xb53a707a in start_thread () from /lib/libpthread.so.0
#13 0xb586c80e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb089d7c0 (LWP 1412)):
[KCrash Handler]
#6  0xb6076622 in QRasterWindowSurface::~QRasterWindowSurface (this=0x915bf78, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#7  0xb60766ac in QRasterWindowSurface::~QRasterWindowSurface (this=0x915bf78, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#8  0xb6091764 in QWidgetBackingStore::~QWidgetBackingStore (this=<optimized out>, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#9  0xb5ea0973 in QWidgetBackingStoreTracker::destroy (this=0x9235528) at kernel/qwidget.cpp:225
#10 0xb5ea0b28 in QWidgetPrivate::deleteExtra (this=this@entry=0x923ebf8) at kernel/qwidget.cpp:1833
#11 0xb5ea0d2d in QWidgetPrivate::~QWidgetPrivate (this=0x923ebf8, __in_chrg=<optimized out>) at kernel/qwidget.cpp:365
#12 0xb5ea0fdc in QWidgetPrivate::~QWidgetPrivate (this=0x923ebf8, __in_chrg=<optimized out>) at kernel/qwidget.cpp:370
#13 0xb5bb2d86 in cleanup (pointer=<optimized out>) at ../../src/corelib/tools/qscopedpointer.h:62
#14 ~QScopedPointer (this=0x913bffc, __in_chrg=<optimized out>) at ../../src/corelib/tools/qscopedpointer.h:100
#15 QObject::~QObject (this=0x913bff8, __in_chrg=<optimized out>) at kernel/qobject.cpp:816
#16 0xb5eaa625 in QWidget::~QWidget (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1554
#17 0xb5eaa8dc in QWidget::~QWidget (this=0x913bff8, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1703
#18 0xb64929b8 in QGlobalStaticDeleter<QWidget>::~QGlobalStaticDeleter (this=0xb67ccf80 <globalStyleInfoWidget()::cleanup>, __in_chrg=<optimized out>) at ../../src/corelib/global/qglobal.h:1951
#19 0xb57af5a1 in __run_exit_handlers () from /lib/libc.so.6
#20 0xb57af5fd in exit () from /lib/libc.so.6
#21 0xb57979db in __libc_start_main () from /lib/libc.so.6
#22 0x0804f9cd in _start ()

Possible duplicates by query: bug 334146, bug 331437, bug 330038, bug 327798.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2014-07-05 13:00:56 UTC
the problem is in kdelibs

*** This bug has been marked as a duplicate of bug 261539 ***