Bug 343139 - konqueror, baloo, many other apps CRASH on exit
Summary: konqueror, baloo, many other apps CRASH on exit
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: 4.14.3
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-01-22 03:45 UTC by Landis
Modified: 2015-01-22 12:51 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (4.95 KB, text/plain)
2015-01-22 06:54 UTC, Landis
Details
New crash information added by DrKonqi (4.49 KB, text/plain)
2015-01-22 11:32 UTC, Landis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Landis 2015-01-22 03:45:56 UTC
Application: konqueror (4.14.3)
KDE Platform Version: 4.14.3
Qt Version: 4.8.6
Operating System: Linux 3.16.7-7-desktop x86_64
Distribution: "openSUSE 13.2 (Harlequin) (x86_64)"

-- Information about the crash:
01 - run most any application
02 - exit app or shutdown computer
03 - CRASH.
* konqueror is leaving 10 - 20 'zombie' konqueror instances open, as viewed by sysguard (system activity) and or TOP and or lsof | grep 'konqueror'... 

11 - baloo crashed Every time I exited KDE 4.14.3. Everytime.
12 - another program / service crashes with baloo, but I don't know what it is
13 - I've REMOVED most of baloo, ecept the parts Dictated by konqueror, dolphin, qwenview. 

I HATE your using these poorly coded appletes like namouka ?? baloo, search, catalog apps. They should NOT be 'need' to use a file manager or viewer!!! Poor coding.

-- Backtrace:
Application: Konqueror (konqueror), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f3093374780 (LWP 2370))]

Thread 4 (Thread 0x7f306dff7700 (LWP 2563)):
#0  0x00007f30909933cd in poll () from /lib64/libc.so.6
#1  0x00007f308daa5be4 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f308daa5cec in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f3091ff40de in QEventDispatcherGlib::processEvents (this=0x7f30600013e0, flags=...) at kernel/qeventdispatcher_glib.cpp:452
#4  0x00007f3091fc5e6f in QEventLoop::processEvents (this=this@entry=0x7f306dff6e20, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f3091fc6165 in QEventLoop::exec (this=this@entry=0x7f306dff6e20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f3091ec30bf in QThread::exec (this=this@entry=0x1b712c0) at thread/qthread.cpp:538
#7  0x00007f3091fa7783 in QInotifyFileSystemWatcherEngine::run (this=0x1b712c0) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007f3091ec579f in QThreadPrivate::start (arg=0x1b712c0) at thread/qthread_unix.cpp:349
#9  0x00007f3091c2f0a4 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f309099b7fd in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f3066617700 (LWP 2625)):
#0  0x00007f3091c3305f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f3086055686 in WTF::TCMalloc_PageHeap::scavengerThread() () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f30860556b9 in WTF::TCMalloc_PageHeap::runScavengerThread(void*) () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f3091c2f0a4 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f309099b7fd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f3074e1b700 (LWP 2626)):
#0  0x00007f3091c3305f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f3085dc7e7d in JSC::BlockAllocator::blockFreeingThreadMain() () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f308607d1e6 in WTF::wtfThreadEntryPoint(void*) () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f3091c2f0a4 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f309099b7fd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f3093374780 (LWP 2370)):
[KCrash Handler]
#5  0x00007f3091331d29 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1949c10, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#6  0x00007f3091331da9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1949c10, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#7  0x00007f309134a07c in QWidgetBackingStore::~QWidgetBackingStore (this=0x3065b00, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#8  0x00007f3091186709 in QWidgetBackingStoreTracker::destroy (this=0x246d830) at kernel/qwidget.cpp:225
#9  0x00007f30911868a9 in QWidgetPrivate::deleteExtra (this=this@entry=0x270a500) at kernel/qwidget.cpp:1833
#10 0x00007f3091186abd in QWidgetPrivate::~QWidgetPrivate (this=0x270a500, __in_chrg=<optimized out>) at kernel/qwidget.cpp:365
#11 0x00007f3091186d49 in QWidgetPrivate::~QWidgetPrivate (this=0x270a500, __in_chrg=<optimized out>) at kernel/qwidget.cpp:370
#12 0x00007f3091fe00b5 in cleanup (pointer=<optimized out>) at ../../src/corelib/tools/qscopedpointer.h:62
#13 ~QScopedPointer (this=0x3064998, __in_chrg=<optimized out>) at ../../src/corelib/tools/qscopedpointer.h:100
#14 QObject::~QObject (this=0x3064990, __in_chrg=<optimized out>) at kernel/qobject.cpp:844
#15 0x00007f309118f4cc in QWidget::~QWidget (this=0x3064990, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1554
#16 0x00007f309118f749 in QWidget::~QWidget (this=0x3064990, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1703
#17 0x00007f30916da045 in QGlobalStaticDeleter<QWidget>::~QGlobalStaticDeleter (this=0x7f3091c260e0 <_ZZL21globalStyleInfoWidgetvE7cleanup>, __in_chrg=<optimized out>) at ../../src/corelib/global/qglobal.h:1959
#18 0x00007f30908edbf9 in __run_exit_handlers () from /lib64/libc.so.6
#19 0x00007f30908edc45 in exit () from /lib64/libc.so.6
#20 0x000000000040881c in _start ()

Possible duplicates by query: bug 330038, bug 327798, bug 320766.

Reported using DrKonqi
Comment 1 Landis 2015-01-22 06:54:56 UTC
Created attachment 90574 [details]
New crash information added by DrKonqi

konqueror (4.14.3) on KDE Platform 4.14.3 using Qt 4.8.6

every Time I exit or restart system, Konqueror CRASHes.
one window, one tab or 4 tabs, doesn't mater. 
minimized or left open , it crashes.

Also, almost Every Time I close konqueror it CRASHes.
in sysgaurd (gui to top (processes) there are 10 to 20 instances of konqueror statuse = zombie... 

This is a FRESH install, only the color scheme and icons have been changed (customized), but the CRASHing was happening before these cosmetic changes.
baloo was CRASHing All the time, and it Sucked so I unistalled the 'framework'. Only the parts of baloo that are required for the equally yuck app dolphin to work so that konqueror will work have been kept. Now baloo doesn't CRASH on exit.

-- Backtrace (Reduced):
#5  0x00007f1e82e50d29 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1ec5830, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#6  0x00007f1e82e50da9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x1ec5830, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#7  0x00007f1e82e6907c in QWidgetBackingStore::~QWidgetBackingStore (this=0x2346090, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#8  0x00007f1e82ca5709 in QWidgetBackingStoreTracker::destroy (this=0x1ebfaa0) at kernel/qwidget.cpp:225
#9  0x00007f1e82ca58a9 in QWidgetPrivate::deleteExtra (this=this@entry=0x21ded40) at kernel/qwidget.cpp:1833
Comment 2 Landis 2015-01-22 11:32:41 UTC
Created attachment 90582 [details]
New crash information added by DrKonqi

konqueror (4.14.3) on KDE Platform 4.14.3 using Qt 4.8.6

Every Time I shut down or restart system, Konqueror CRASHes.
Also, KMix will CRASH.

* New Install on clean HDD. 4 gb ram, duo 2.6 ghz. opensuse 13.2 x86_64 from KDE Live CD

-- Backtrace (Reduced):
#5  0x00007f27483fbd29 in QRasterWindowSurface::~QRasterWindowSurface (this=0xf12c40, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#6  0x00007f27483fbda9 in QRasterWindowSurface::~QRasterWindowSurface (this=0xf12c40, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#7  0x00007f274841407c in QWidgetBackingStore::~QWidgetBackingStore (this=0x198f6f0, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#8  0x00007f2748250709 in QWidgetBackingStoreTracker::destroy (this=0x14cf390) at kernel/qwidget.cpp:225
#9  0x00007f27482508a9 in QWidgetPrivate::deleteExtra (this=this@entry=0x1e141d0) at kernel/qwidget.cpp:1833
Comment 3 Christoph Feck 2015-01-22 12:51:18 UTC
Are you using oxygen-transparent or Bespin widget style?

*** This bug has been marked as a duplicate of bug 261539 ***