Bug 341443 - Amarok crashed
Summary: Amarok crashed
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.8.0
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: 2.9
Assignee: Amarok Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-11-30 17:01 UTC by Dmitry
Modified: 2014-11-30 17:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry 2014-11-30 17:01:40 UTC
Application: amarok (2.8.0)
KDE Platform Version: 4.14.3
Qt Version: 4.8.6
Operating System: Linux 3.16.6-2-desktop x86_64
Distribution: "openSUSE 13.2 (Harlequin) (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
Install oxygen-transparent (http://software.opensuse.org/package/oxygen-transparent)
Start amarok
Quit amarok

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f2d0b9d7800 (LWP 6307))]

Thread 12 (Thread 0x7f2ccd7c3700 (LWP 6311)):
#0  0x00007f2d06887408 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2cd6de6e7a in ?? () from /usr/lib64/libmysqld.so.18
#2  0x00007f2cd6dedc27 in ?? () from /usr/lib64/libmysqld.so.18
#3  0x00007f2d068830a4 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f2d087447fd in clone () from /lib64/libc.so.6

Thread 11 (Thread 0x7f2cccfc2700 (LWP 6312)):
#0  0x00007f2d0688705f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2d08d90c86 in wait (time=18446744073709551615, this=0x1151d40) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1010ac0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f2d059816fc in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f2d05984193 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f2d05982eaf in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f2d08d9079f in QThreadPrivate::start (arg=0xcd9840) at thread/qthread_unix.cpp:349
#7  0x00007f2d068830a4 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f2d087447fd in clone () from /lib64/libc.so.6

Thread 10 (Thread 0x7f2cc7fff700 (LWP 6313)):
#0  0x00007f2d0873c3cd in poll () from /lib64/libc.so.6
#1  0x00007f2d011fcbe4 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f2d011fccec in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f2d08ebf0de in QEventDispatcherGlib::processEvents (this=0x7f2cbc0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:452
#4  0x00007f2d08e90e6f in QEventLoop::processEvents (this=this@entry=0x7f2cc7ffeda0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f2d08e91165 in QEventLoop::exec (this=this@entry=0x7f2cc7ffeda0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f2d08d8e0bf in QThread::exec (this=this@entry=0x1155010) at thread/qthread.cpp:538
#7  0x00007f2d08e72783 in QInotifyFileSystemWatcherEngine::run (this=0x1155010) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007f2d08d9079f in QThreadPrivate::start (arg=0x1155010) at thread/qthread_unix.cpp:349
#9  0x00007f2d068830a4 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f2d087447fd in clone () from /lib64/libc.so.6

Thread 9 (Thread 0x7f2cc77fe700 (LWP 6314)):
#0  0x00007f2d0688705f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2d08d90c86 in wait (time=18446744073709551615, this=0x1151d40) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1010ac0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f2d059816fc in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f2d05984193 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f2d059841ac in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f2d05982eaf in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f2d08d9079f in QThreadPrivate::start (arg=0x121f230) at thread/qthread_unix.cpp:349
#8  0x00007f2d068830a4 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f2d087447fd in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7f2cc6ffd700 (LWP 6315)):
#0  0x00007f2d0688705f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2d08d90c86 in wait (time=18446744073709551615, this=0x1151d40) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1010ac0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f2d059816fc in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f2d05984193 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f2d059841ac in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f2d059841ac in ?? () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f2d059841ac in ?? () from /usr/lib64/libthreadweaver.so.4
#8  0x00007f2d059841ac in ?? () from /usr/lib64/libthreadweaver.so.4
#9  0x00007f2d05982eaf in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#10 0x00007f2d08d9079f in QThreadPrivate::start (arg=0x7f2cb400d6d0) at thread/qthread_unix.cpp:349
#11 0x00007f2d068830a4 in start_thread () from /lib64/libpthread.so.0
#12 0x00007f2d087447fd in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7f2cc67fc700 (LWP 6316)):
#0  0x00007f2d0688705f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2d08d90c86 in wait (time=18446744073709551615, this=0x1151d40) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1010ac0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f2d059816fc in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f2d05984193 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f2d059841ac in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f2d05982eaf in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f2d08d9079f in QThreadPrivate::start (arg=0x7f2cb40095e0) at thread/qthread_unix.cpp:349
#8  0x00007f2d068830a4 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f2d087447fd in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f2cc5ffb700 (LWP 6317)):
#0  0x00007f2d0688705f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2d08d90c86 in wait (time=18446744073709551615, this=0x1151d40) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1010ac0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f2d059816fc in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f2d05984193 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f2d059841ac in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f2d059841ac in ?? () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f2d059841ac in ?? () from /usr/lib64/libthreadweaver.so.4
#8  0x00007f2d05982eaf in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#9  0x00007f2d08d9079f in QThreadPrivate::start (arg=0x7f2cb400aa00) at thread/qthread_unix.cpp:349
#10 0x00007f2d068830a4 in start_thread () from /lib64/libpthread.so.0
#11 0x00007f2d087447fd in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f2cc55ef700 (LWP 6318)):
#0  0x00007f2d0688705f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2d08d90c86 in wait (time=18446744073709551615, this=0x1151d40) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1010ac0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f2d059816fc in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f2d05984193 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f2d059841ac in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f2d059841ac in ?? () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f2d059841ac in ?? () from /usr/lib64/libthreadweaver.so.4
#8  0x00007f2d05982eaf in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#9  0x00007f2d08d9079f in QThreadPrivate::start (arg=0x16f72f0) at thread/qthread_unix.cpp:349
#10 0x00007f2d068830a4 in start_thread () from /lib64/libpthread.so.0
#11 0x00007f2d087447fd in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f2cc4dee700 (LWP 6319)):
#0  0x00007f2d0688705f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2d08d90c86 in wait (time=18446744073709551615, this=0x1151d40) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1010ac0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f2d059816fc in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f2d05984193 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f2d05982eaf in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f2d08d9079f in QThreadPrivate::start (arg=0x16f8130) at thread/qthread_unix.cpp:349
#7  0x00007f2d068830a4 in start_thread () from /lib64/libpthread.so.0
#8  0x00007f2d087447fd in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f2ca1f0d700 (LWP 6320)):
#0  0x00007f2d0688705f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2d08d90c86 in wait (time=18446744073709551615, this=0x1151d40) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1010ac0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f2d059816fc in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f2d05984193 in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f2d059841ac in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f2d059841ac in ?? () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f2d059841ac in ?? () from /usr/lib64/libthreadweaver.so.4
#8  0x00007f2d05982eaf in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#9  0x00007f2d08d9079f in QThreadPrivate::start (arg=0x16f8ff0) at thread/qthread_unix.cpp:349
#10 0x00007f2d068830a4 in start_thread () from /lib64/libpthread.so.0
#11 0x00007f2d087447fd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f2c93fff700 (LWP 6323)):
#0  0x00007f2d0688705f in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f2d049cf8cb in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f2d04ccdf00 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f2d049cf909 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f2d068830a4 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f2d087447fd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f2d0b9d7800 (LWP 6307)):
[KCrash Handler]
#5  0x00007f2d095c5d29 in QRasterWindowSurface::~QRasterWindowSurface (this=0x149d490, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#6  0x00007f2d095c5da9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x149d490, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#7  0x00007f2d095de07c in QWidgetBackingStore::~QWidgetBackingStore (this=0x15c8090, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#8  0x00007f2d0941a709 in QWidgetBackingStoreTracker::destroy (this=0x1180fe0) at kernel/qwidget.cpp:225
#9  0x00007f2d0941a8a9 in QWidgetPrivate::deleteExtra (this=this@entry=0x15f8e40) at kernel/qwidget.cpp:1833
#10 0x00007f2d0941aabd in QWidgetPrivate::~QWidgetPrivate (this=0x15f8e40, __in_chrg=<optimized out>) at kernel/qwidget.cpp:365
#11 0x00007f2d0941ad49 in QWidgetPrivate::~QWidgetPrivate (this=0x15f8e40, __in_chrg=<optimized out>) at kernel/qwidget.cpp:370
#12 0x00007f2d08eab0b5 in cleanup (pointer=<optimized out>) at ../../src/corelib/tools/qscopedpointer.h:62
#13 ~QScopedPointer (this=0x1584378, __in_chrg=<optimized out>) at ../../src/corelib/tools/qscopedpointer.h:100
#14 QObject::~QObject (this=0x1584370, __in_chrg=<optimized out>) at kernel/qobject.cpp:844
#15 0x00007f2d094234cc in QWidget::~QWidget (this=0x1584370, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1554
#16 0x00007f2d09423749 in QWidget::~QWidget (this=0x1584370, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1703
#17 0x00007f2d0996e045 in QGlobalStaticDeleter<QWidget>::~QGlobalStaticDeleter (this=0x7f2d09eba080 <globalStyleInfoWidget()::cleanup>, __in_chrg=<optimized out>) at ../../src/corelib/global/qglobal.h:1959
#18 0x00007f2d08696bf9 in __run_exit_handlers () from /lib64/libc.so.6
#19 0x00007f2d08696c45 in exit () from /lib64/libc.so.6
#20 0x00007f2d08680b0c in __libc_start_main () from /lib64/libc.so.6
#21 0x00000000004080d2 in _start () at ../sysdeps/x86_64/start.S:122

Possible duplicates by query: bug 337115, bug 334146, bug 331437, bug 330038, bug 327798.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2014-11-30 17:16:42 UTC
the crash is in kdelibs, please check with your distribution, something must have gone wrong

*** This bug has been marked as a duplicate of bug 261539 ***