Bug 341464 - Gwenview Error
Summary: Gwenview Error
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-12-01 14:34 UTC by Pavel Rudenkov
Modified: 2014-12-01 14:50 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Rudenkov 2014-12-01 14:34:23 UTC
Application: gwenview (4.14.0 pre)
KDE Platform Version: 4.14.3
Qt Version: 4.8.6
Operating System: Linux 3.17.4-300.fc21.x86_64 x86_64
Distribution: "Fedora release 21 (Twenty One)"

-- Information about the crash:
Gwenview Application Error after watching image (after closing program)

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa6cde2e940 (LWP 12371))]

Thread 2 (Thread 0x7fa6c18a4700 (LWP 12372)):
#0  0x00000033a2ef51dd in poll () at /lib64/libc.so.6
#1  0x00000033df049e24 in g_main_context_iterate.isra () at /lib64/libglib-2.0.so.0
#2  0x00000033df049f3c in g_main_context_iteration () at /lib64/libglib-2.0.so.0
#3  0x00000036b33b46be in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQtCore.so.4
#4  0x00000036b3383f91 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQtCore.so.4
#5  0x00000036b33842f5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /lib64/libQtCore.so.4
#6  0x00000036b3279b69 in QThread::exec() () at /lib64/libQtCore.so.4
#7  0x00000036b3364b53 in QInotifyFileSystemWatcherEngine::run() () at /lib64/libQtCore.so.4
#8  0x00000036b327c3cf in QThreadPrivate::start(void*) () at /lib64/libQtCore.so.4
#9  0x00000033a320752a in start_thread () at /lib64/libpthread.so.0
#10 0x00000033a2f0077d in clone () at /lib64/libc.so.6

Thread 1 (Thread 0x7fa6cde2e940 (LWP 12371)):
[KCrash Handler]
#5  0x00000036b4dca529 in QRasterWindowSurface::~QRasterWindowSurface() () at /lib64/libQtGui.so.4
#6  0x00000036b4dca599 in QRasterWindowSurface::~QRasterWindowSurface() () at /lib64/libQtGui.so.4
#7  0x00000036b4de360c in QWidgetBackingStore::~QWidgetBackingStore() () at /lib64/libQtGui.so.4
#8  0x00000036b4c0e469 in QWidgetBackingStoreTracker::destroy() () at /lib64/libQtGui.so.4
#9  0x00000036b4c0e619 in QWidgetPrivate::deleteExtra() () at /lib64/libQtGui.so.4
#10 0x00000036b4c0e82d in QWidgetPrivate::~QWidgetPrivate() () at /lib64/libQtGui.so.4
#11 0x00000036b4c0eab9 in QWidgetPrivate::~QWidgetPrivate() () at /lib64/libQtGui.so.4
#12 0x00000036b339f2a7 in QObject::~QObject() () at /lib64/libQtCore.so.4
#13 0x00000036b4c1aaa7 in QWidget::~QWidget() () at /lib64/libQtGui.so.4
#14 0x00000036b4c1ad29 in QWidget::~QWidget() () at /lib64/libQtGui.so.4
#15 0x00000036b519a5a8 in QGlobalStaticDeleter<QWidget>::~QGlobalStaticDeleter() () at /lib64/libQtGui.so.4
#16 0x00000033a2e39382 in __run_exit_handlers () at /lib64/libc.so.6
#17 0x00000033a2e393d5 in  () at /lib64/libc.so.6
#18 0x00000033a2e1ffe7 in __libc_start_main () at /lib64/libc.so.6
#19 0x0000000000427986 in _start ()

Possible duplicates by query: bug 331005, bug 330831, bug 330243, bug 330038, bug 328666.

Reported using DrKonqi
Comment 1 Arjun AK 2014-12-01 14:50:43 UTC

*** This bug has been marked as a duplicate of bug 261539 ***