Bug 335354 - imap email server crash upon wake-from-sleep
Summary: imap email server crash upon wake-from-sleep
Status: RESOLVED DUPLICATE of bug 319776
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.13
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christian Mollekopf
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-05-26 08:20 UTC by RJVB
Modified: 2014-05-27 00:42 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description RJVB 2014-05-26 08:20:21 UTC
Application: akonadi_imap_resource (4.13)
KDE Platform Version: 4.13.0
Qt Version: 4.8.6
Operating System: Linux 3.13.9-ck1-kubuntu-ck-amdf10-rjvb x86_64
Distribution: Ubuntu 14.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
Waking the computer from sleep ("suspend to ram", initiated by closing the laptop screen/cover).

- Unusual behaviour I noticed:
The computer is set to lock the screen before being suspended. When waking the system, I just had the time to notice some output to the console before the screenlocker kicked in and presented the password dialog. I cannot be certain, but I think the output was from the brcmsmac driver which I started using recently because the Broadcom STA driver (wl.ko) doesn't work well with my access points.

-- Backtrace:
Application: RJVB@MW of type IMAP E-Mail Server (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f58a78977c0 (LWP 2520))]

Thread 4 (Thread 0x7f58908fd700 (LWP 2746)):
#0  0x00007f58a2665569 in __GI___pthread_mutex_lock (mutex=0x7f5888007c10) at ../nptl/pthread_mutex_lock.c:125
#1  0x00007f58a1d7b991 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f58a1d39ed5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f58a1d3a0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f58a6c687be in QEventDispatcherGlib::processEvents (this=0x7f588801ed50, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#5  0x00007f58a6c3a0af in QEventLoop::processEvents (this=this@entry=0x7f58908fce20, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f58a6c3a3a5 in QEventLoop::exec (this=this@entry=0x7f58908fce20, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f58a6b36c5f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:537
#8  0x00007f58a6b3932f in QThreadPrivate::start (arg=0x18c7780) at thread/qthread_unix.cpp:349
#9  0x00007f58a2663182 in start_thread (arg=0x7f58908fd700) at pthread_create.c:312
#10 0x00007f58a324930d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 3 (Thread 0x7f5883fff700 (LWP 16967)):
#0  0x00007f58a1d7b639 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f58a1d7b989 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f58a1d391f8 in g_main_context_release () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f58a1d39f91 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f58a1d3a0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f58a6c687be in QEventDispatcherGlib::processEvents (this=0x7f587c02df60, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#6  0x00007f58a6c3a0af in QEventLoop::processEvents (this=this@entry=0x7f5883ffee20, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f58a6c3a3a5 in QEventLoop::exec (this=this@entry=0x7f5883ffee20, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f58a6b36c5f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:537
#9  0x00007f58a6b3932f in QThreadPrivate::start (arg=0x1937400) at thread/qthread_unix.cpp:349
#10 0x00007f58a2663182 in start_thread (arg=0x7f5883fff700) at pthread_create.c:312
#11 0x00007f58a324930d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7f5892afc700 (LWP 10383)):
#0  0x00007f58a1d7b62a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f58a1d7b989 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f58a1d390b0 in g_main_context_acquire () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f58a1d39ea5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f58a1d3a0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f58a6c687be in QEventDispatcherGlib::processEvents (this=0x7f588400c030, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#6  0x00007f58a6c3a0af in QEventLoop::processEvents (this=this@entry=0x7f5892afbe20, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f58a6c3a3a5 in QEventLoop::exec (this=this@entry=0x7f5892afbe20, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f58a6b36c5f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:537
#9  0x00007f58a6b3932f in QThreadPrivate::start (arg=0x19564b0) at thread/qthread_unix.cpp:349
#10 0x00007f58a2663182 in start_thread (arg=0x7f5892afc700) at pthread_create.c:312
#11 0x00007f58a324930d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f58a78977c0 (LWP 2520)):
[KCrash Handler]
#6  0x0000000001710990 in ?? ()
#7  0x00007f58a6c4e999 in QObject::disconnect (sender=0x19503d0, signal=0x1947189 "stateChanged(KIMAP::Session::State,KIMAP::Session::State)", signal@entry=0x472d48 "2stateChanged(KIMAP::Session::State,KIMAP::Session::State)", receiver=receiver@entry=0x18b1ed0, method=0x19373a9 "onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)", method@entry=0x472d00 "1onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)") at kernel/qobject.cpp:2883
#8  0x000000000045e915 in SessionPool::killSession (this=this@entry=0x18b1ed0, session=0x19503d0, termination=termination@entry=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:182
#9  0x000000000045ecb5 in SessionPool::disconnect (this=0x18b1ed0, termination=termination@entry=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:115
#10 0x0000000000418e6b in ImapResource::startConnect (this=0x18494a0) at ../../../resources/imap/imapresource.cpp:302
#11 0x000000000043c349 in ImapResource::qt_static_metacall (_o=0x19503d0, _o@entry=0x18494a0, _c=4123245392, _c@entry=QMetaObject::InvokeMetaMethod, _id=1, _id@entry=14, _a=0x0, _a@entry=0x7ffff5c3be40) at moc_imapresource.cpp:117
#12 0x00007f58a6c43908 in QMetaMethod::invoke (this=this@entry=0x7ffff5c3c030, object=object@entry=0x18494a0, connectionType=Qt::DirectConnection, connectionType@entry=Qt::AutoConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1664
#13 0x00007f58a6c45dc2 in QMetaObject::invokeMethod (obj=0x18494a0, member=<optimized out>, type=type@entry=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1179
#14 0x00007f58a739e4af in invokeMethod (val9=..., val8=..., val7=..., val6=..., val5=..., val4=..., val3=..., val2=..., val1=..., val0=..., member=<optimized out>, obj=<optimized out>) at /usr/include/qt4/QtCore/qobjectdefs.h:434
#15 Akonadi::ResourceScheduler::executeNext (this=0x18599b0) at ../../akonadi/resourcescheduler.cpp:348
#16 0x00007f58a739f03d in Akonadi::ResourceScheduler::qt_static_metacall (_o=0x19503d0, _c=4123245392, _id=1, _a=0x0) at ./moc_resourcescheduler_p.cpp:101
#17 0x00007f58a6c53c1e in QObject::event (this=0x18599b0, e=<optimized out>) at kernel/qobject.cpp:1194
#18 0x00007f58a5fd4e2c in QApplicationPrivate::notify_helper (this=this@entry=0x166f1c0, receiver=receiver@entry=0x18599b0, e=e@entry=0x18c7080) at kernel/qapplication.cpp:4567
#19 0x00007f58a5fdb4a0 in QApplication::notify (this=this@entry=0x7ffff5c3cbe0, receiver=receiver@entry=0x18599b0, e=e@entry=0x18c7080) at kernel/qapplication.cpp:4353
#20 0x00007f58a4110baa in KApplication::notify (this=0x7ffff5c3cbe0, receiver=0x18599b0, event=0x18c7080) at ../../kdeui/kernel/kapplication.cpp:311
#21 0x00007f58a6c3b4dd in QCoreApplication::notifyInternal (this=0x7ffff5c3cbe0, receiver=receiver@entry=0x18599b0, event=event@entry=0x18c7080) at kernel/qcoreapplication.cpp:953
#22 0x00007f58a6c3eb3d in sendEvent (event=0x18c7080, receiver=0x18599b0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#23 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x162f220) at kernel/qcoreapplication.cpp:1577
#24 0x00007f58a6c3efe3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1470
#25 0x00007f58a6c68f83 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#26 postEventSourceDispatch (s=0x165f930) at kernel/qeventdispatcher_glib.cpp:287
#27 0x00007f58a1d39e04 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f58a1d3a048 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f58a1d3a0ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f58a6c687a1 in QEventDispatcherGlib::processEvents (this=0x16604c0, flags=...) at kernel/qeventdispatcher_glib.cpp:434
#31 0x00007f58a6076bb6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#32 0x00007f58a6c3a0af in QEventLoop::processEvents (this=this@entry=0x7ffff5c3cb50, flags=...) at kernel/qeventloop.cpp:149
#33 0x00007f58a6c3a3a5 in QEventLoop::exec (this=this@entry=0x7ffff5c3cb50, flags=...) at kernel/qeventloop.cpp:204
#34 0x00007f58a6c3fb79 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#35 0x00007f58a5fd337c in QApplication::exec () at kernel/qapplication.cpp:3828
#36 0x00007f58a738edb3 in Akonadi::ResourceBase::init (r=r@entry=0x18494a0) at ../../akonadi/resourcebase.cpp:556
#37 0x0000000000421653 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:192
#38 0x00007f58a316fec5 in __libc_start_main (main=0x417910 <main(int, char**)>, argc=3, argv=0x7ffff5c3ccf8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffff5c3cce8) at libc-start.c:287
#39 0x0000000000417ac4 in _start ()

Possible duplicates by query: bug 325777, bug 325478, bug 324543, bug 324460, bug 322440.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-05-27 00:42:46 UTC

*** This bug has been marked as a duplicate of bug 319776 ***