Bug 325478 - Kontact crashed while sending queued message
Summary: Kontact crashed while sending queued message
Status: RESOLVED DUPLICATE of bug 319776
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.10
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-09-30 23:12 UTC by Ekkehard Blanz
Modified: 2013-10-01 09:23 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ekkehard Blanz 2013-09-30 23:12:59 UTC
Application: akonadi_imap_resource (4.10)
KDE Platform Version: 4.10.5
Qt Version: 4.8.4
Operating System: Linux 3.8.0-31-generic x86_64
Distribution: Ubuntu 13.04

-- Information about the crash:
I was trying to send a message queued in the outbox when Kontact suddenly crashed.  The WLAN connection was very flaky at the time - may have had something to do with it?

-- Backtrace:
Application: Google Mail (Ekkehard.Blanz) of type IMAP E-Mail Server (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f0abf1487c0 (LWP 2720))]

Thread 6 (Thread 0x7f0aab890700 (LWP 2763)):
#0  0x00007f0abab7cb0d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f0ab99086cf in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f0ab98c9d3c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f0ab98ca175 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f0ab98ca304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f0abe574036 in QEventDispatcherGlib::processEvents (this=0x7f0aa40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f0abe54438f in QEventLoop::processEvents (this=this@entry=0x7f0aab88fda0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f0abe544618 in QEventLoop::exec (this=this@entry=0x7f0aab88fda0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f0abe446410 in QThread::exec (this=this@entry=0xe8f570) at thread/qthread.cpp:542
#9  0x00007f0abd1a9b2a in KIMAP::SessionThread::run (this=0xe8f570) at ../../kimap/sessionthread.cpp:184
#10 0x00007f0abe448bec in QThreadPrivate::start (arg=0xe8f570) at thread/qthread_unix.cpp:338
#11 0x00007f0aba1e3f8e in start_thread (arg=0x7f0aab890700) at pthread_create.c:311
#12 0x00007f0abab8ae1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 5 (Thread 0x7f0aab08f700 (LWP 4417)):
#0  0x00007f0abab7e3cd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f0ab98ca1dc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f0ab98ca304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f0abe574036 in QEventDispatcherGlib::processEvents (this=0x7f0a9c002a20, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f0abe54438f in QEventLoop::processEvents (this=this@entry=0x7f0aab08eda0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f0abe544618 in QEventLoop::exec (this=this@entry=0x7f0aab08eda0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f0abe446410 in QThread::exec (this=this@entry=0xf33bd0) at thread/qthread.cpp:542
#7  0x00007f0abd1a9b2a in KIMAP::SessionThread::run (this=0xf33bd0) at ../../kimap/sessionthread.cpp:184
#8  0x00007f0abe448bec in QThreadPrivate::start (arg=0xf33bd0) at thread/qthread_unix.cpp:338
#9  0x00007f0aba1e3f8e in start_thread (arg=0x7f0aab08f700) at pthread_create.c:311
#10 0x00007f0abab8ae1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 4 (Thread 0x7f0aaa26a700 (LWP 4453)):
#0  0x00007f0ab99095d8 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f0ab98c9493 in g_main_context_release () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f0ab98ca188 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f0ab98ca304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f0abe574036 in QEventDispatcherGlib::processEvents (this=0x7f0aa000a030, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f0abe54438f in QEventLoop::processEvents (this=this@entry=0x7f0aaa269da0, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f0abe544618 in QEventLoop::exec (this=this@entry=0x7f0aaa269da0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f0abe446410 in QThread::exec (this=this@entry=0x101c300) at thread/qthread.cpp:542
#8  0x00007f0abd1a9b2a in KIMAP::SessionThread::run (this=0x101c300) at ../../kimap/sessionthread.cpp:184
#9  0x00007f0abe448bec in QThreadPrivate::start (arg=0x101c300) at thread/qthread_unix.cpp:338
#10 0x00007f0aba1e3f8e in start_thread (arg=0x7f0aaa26a700) at pthread_create.c:311
#11 0x00007f0abab8ae1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7f0aa9655700 (LWP 6242)):
#0  0x00007f0abab7e3cd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f0ab98ca1dc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f0ab98ca304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f0abe574036 in QEventDispatcherGlib::processEvents (this=0x7f0a94010290, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f0abe54438f in QEventLoop::processEvents (this=this@entry=0x7f0aa9654d90, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f0abe544618 in QEventLoop::exec (this=this@entry=0x7f0aa9654d90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f0abe446410 in QThread::exec (this=this@entry=0xf18d00) at thread/qthread.cpp:542
#7  0x00007f0abe525edf in QInotifyFileSystemWatcherEngine::run (this=0xf18d00) at io/qfilesystemwatcher_inotify.cpp:256
#8  0x00007f0abe448bec in QThreadPrivate::start (arg=0xf18d00) at thread/qthread_unix.cpp:338
#9  0x00007f0aba1e3f8e in start_thread (arg=0x7f0aa9655700) at pthread_create.c:311
#10 0x00007f0abab8ae1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f0aa8e54700 (LWP 6248)):
#0  0x00007f0ab9909359 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f0ab99095e9 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f0ab98ca30e in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f0abe574036 in QEventDispatcherGlib::processEvents (this=0x7f0a98002400, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f0abe54438f in QEventLoop::processEvents (this=this@entry=0x7f0aa8e53da0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f0abe544618 in QEventLoop::exec (this=this@entry=0x7f0aa8e53da0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f0abe446410 in QThread::exec (this=this@entry=0xed76b0) at thread/qthread.cpp:542
#7  0x00007f0abd1a9b2a in KIMAP::SessionThread::run (this=0xed76b0) at ../../kimap/sessionthread.cpp:184
#8  0x00007f0abe448bec in QThreadPrivate::start (arg=0xed76b0) at thread/qthread_unix.cpp:338
#9  0x00007f0aba1e3f8e in start_thread (arg=0x7f0aa8e54700) at pthread_create.c:311
#10 0x00007f0abab8ae1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f0abf1487c0 (LWP 2720)):
[KCrash Handler]
#6  0x00000000014879e0 in ?? ()
#7  0x00007f0abe55be51 in QObject::disconnect (sender=0x148b470, signal=0x102ad49 "stateChanged(KIMAP::Session::State,KIMAP::Session::State)", signal@entry=0x468bc8 "2stateChanged(KIMAP::Session::State,KIMAP::Session::State)", receiver=receiver@entry=0xe47920, method=0x130b1d9 "onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)", method@entry=0x468b80 "1onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)") at kernel/qobject.cpp:2887
#8  0x0000000000454fe5 in SessionPool::killSession (this=this@entry=0xe47920, session=0x148b470, termination=termination@entry=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:183
#9  0x0000000000455955 in SessionPool::disconnect (this=0xe47920, termination=termination@entry=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:117
#10 0x000000000041b093 in ImapResource::doSetOnline (this=0xe1e1d0, online=<optimized out>) at ../../../resources/imap/imapresource.cpp:495
#11 0x00007f0abeba2c59 in Akonadi::AgentBase::setOnlineInternal (this=this@entry=0xe1e1d0, state=state@entry=false) at ../../akonadi/agentbase.cpp:659
#12 0x00007f0abeba2d78 in Akonadi::AgentBase::setOnline (this=0xe1e1d0, state=false) at ../../akonadi/agentbase.cpp:646
#13 0x00007f0abece06cc in Akonadi__StatusAdaptor::qt_static_metacall (_o=0x148b470, _o@entry=0xe200f0, _c=1908366880, _c@entry=QMetaObject::InvokeMetaMethod, _id=1, _a=0x130b1d8, _a@entry=0x7fff71bf6210) at statusadaptor.moc:106
#14 0x00007f0abece086b in Akonadi__StatusAdaptor::qt_metacall (this=0xe200f0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff71bf6210) at statusadaptor.moc:149
#15 0x00007f0abe8c8063 in QDBusConnectionPrivate::deliverCall (this=this@entry=0xd26670, object=object@entry=0xe200f0, msg=..., metaTypes=..., slotIdx=12) at qdbusintegrator.cpp:951
#16 0x00007f0abe8c8955 in QDBusConnectionPrivate::activateCall (this=this@entry=0xd26670, object=0xe200f0, flags=flags@entry=273, msg=...) at qdbusintegrator.cpp:863
#17 0x00007f0abe8c92cf in QDBusConnectionPrivate::activateObject (this=0xd26670, node=..., msg=..., pathStartPos=<optimized out>) at qdbusintegrator.cpp:1427
#18 0x00007f0abe8c93ab in QDBusActivateObjectEvent::placeMetaCall (this=0x122a980) at qdbusintegrator.cpp:1541
#19 0x00007f0abe55f5be in QObject::event (this=0xe1e1d0, e=<optimized out>) at kernel/qobject.cpp:1194
#20 0x00007f0abd8eb8ec in QApplicationPrivate::notify_helper (this=this@entry=0xc9fc00, receiver=receiver@entry=0xe1e1d0, e=e@entry=0x122a980) at kernel/qapplication.cpp:4567
#21 0x00007f0abd8ee25b in QApplication::notify (this=this@entry=0x7fff71bf6df0, receiver=receiver@entry=0xe1e1d0, e=e@entry=0x122a980) at kernel/qapplication.cpp:4428
#22 0x00007f0abba5c1a6 in KApplication::notify (this=0x7fff71bf6df0, receiver=0xe1e1d0, event=0x122a980) at ../../kdeui/kernel/kapplication.cpp:311
#23 0x00007f0abe54563e in QCoreApplication::notifyInternal (this=0x7fff71bf6df0, receiver=receiver@entry=0xe1e1d0, event=event@entry=0x122a980) at kernel/qcoreapplication.cpp:946
#24 0x00007f0abe549171 in sendEvent (event=0x122a980, receiver=0xe1e1d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#25 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0xc6ff60) at kernel/qcoreapplication.cpp:1570
#26 0x00007f0abe5494a3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#27 0x00007f0abe573e83 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#28 postEventSourceDispatch (s=0xc9e870) at kernel/qeventdispatcher_glib.cpp:279
#29 0x00007f0ab98c9f05 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f0ab98ca248 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f0ab98ca304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f0abe574016 in QEventDispatcherGlib::processEvents (this=0xc71c20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#33 0x00007f0abd99113e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007f0abe54438f in QEventLoop::processEvents (this=this@entry=0x7fff71bf6d70, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007f0abe544618 in QEventLoop::exec (this=this@entry=0x7fff71bf6d70, flags=...) at kernel/qeventloop.cpp:204
#36 0x00007f0abe549cf6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#37 0x00007f0abd8e9ffc in QApplication::exec () at kernel/qapplication.cpp:3828
#38 0x00007f0abec69bb3 in Akonadi::ResourceBase::init (r=r@entry=0xe1e1d0) at ../../akonadi/resourcebase.cpp:451
#39 0x000000000041c7f3 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:189
#40 0x00007f0abaab2ea5 in __libc_start_main (main=0x4156c0 <main(int, char**)>, argc=3, ubp_av=0x7fff71bf6f08, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff71bf6ef8) at libc-start.c:260
#41 0x0000000000415845 in _start ()

Possible duplicates by query: bug 324543, bug 324460, bug 322440, bug 321253, bug 321055.

Reported using DrKonqi
Comment 1 Daniel Vrátil 2013-10-01 09:23:33 UTC

*** This bug has been marked as a duplicate of bug 319776 ***