Bug 322440 - akonadi_imap_resource under KDE 4.10.5 has crashed when using unreliable wireless connection
Summary: akonadi_imap_resource under KDE 4.10.5 has crashed when using unreliable wire...
Status: RESOLVED DUPLICATE of bug 319776
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.10
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-16 14:28 UTC by Thomas Dreibholz
Modified: 2013-10-01 09:22 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Dreibholz 2013-07-16 14:28:02 UTC
Application: akonadi_imap_resource (4.10)
KDE Platform Version: 4.10.5
Qt Version: 4.8.4
Operating System: Linux 3.8.0-26-generic x86_64
Distribution: Ubuntu 13.04

-- Information about the crash:
- What I was doing when the application crashed:

akonadi_imap_resource under KDE 4.10.5 has crashed when using unreliable wireless connection

-- Backtrace:
Application: Yahoo av type IMAP E-post-tjener (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f144adfb7c0 (LWP 23780))]

Thread 2 (Thread 0x7f1436b6a700 (LWP 26653)):
#0  0x00007f1445555d50 in pthread_mutex_unlock@plt () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f14455c45f1 in g_mutex_unlock (mutex=mutex@entry=0x7f1428002780) at /build/buildd/glib2.0-2.36.0/./glib/gthread-posix.c:229
#2  0x00007f14455848f3 in g_main_context_prepare (context=context@entry=0x7f1428002780, priority=priority@entry=0x7f1436b69c48) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3326
#3  0x00007f14455850fe in g_main_context_iterate (context=context@entry=0x7f1428002780, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3681
#4  0x00007f1445585304 in g_main_context_iteration (context=0x7f1428002780, may_block=1) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3762
#5  0x00007f144a22f036 in QEventDispatcherGlib::processEvents (this=0x7f142801a390, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f144a1ff38f in QEventLoop::processEvents (this=this@entry=0x7f1436b69da0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f144a1ff618 in QEventLoop::exec (this=this@entry=0x7f1436b69da0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f144a101410 in QThread::exec (this=this@entry=0x154abe0) at thread/qthread.cpp:542
#9  0x00007f1448e64b2a in KIMAP::SessionThread::run (this=0x154abe0) at ../../kimap/sessionthread.cpp:184
#10 0x00007f144a103bec in QThreadPrivate::start (arg=0x154abe0) at thread/qthread_unix.cpp:338
#11 0x00007f1445e9ef8e in start_thread (arg=0x7f1436b6a700) at pthread_create.c:311
#12 0x00007f1446845e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f144adfb7c0 (LWP 23780)):
[KCrash Handler]
#6  0x0000000001500000 in ?? ()
#7  0x00007f144a216e51 in QObject::disconnect (sender=0x12c6770, signal=0x154a409 "stateChanged(KIMAP::Session::State,KIMAP::Session::State)", signal@entry=0x468bc8 "2stateChanged(KIMAP::Session::State,KIMAP::Session::State)", receiver=receiver@entry=0x14bac10, method=0x1557c99 "onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)", method@entry=0x468b80 "1onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)") at kernel/qobject.cpp:2887
#8  0x0000000000454fe5 in SessionPool::killSession (this=this@entry=0x14bac10, session=0x12c6770, termination=termination@entry=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:183
#9  0x0000000000455955 in SessionPool::disconnect (this=0x14bac10, termination=termination@entry=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:117
#10 0x000000000041b093 in ImapResource::doSetOnline (this=0x14b1960, online=<optimized out>) at ../../../resources/imap/imapresource.cpp:495
#11 0x00007f144a85dc59 in Akonadi::AgentBase::setOnlineInternal (this=this@entry=0x14b1960, state=state@entry=false) at ../../akonadi/agentbase.cpp:659
#12 0x00007f144a85dd78 in Akonadi::AgentBase::setOnline (this=0x14b1960, state=false) at ../../akonadi/agentbase.cpp:646
#13 0x000000000041a987 in ImapResource::onConnectDone (this=0x14b1960, errorCode=805202928, errorString=...) at ../../../resources/imap/imapresource.cpp:285
#14 0x000000000041ae3f in ImapResource::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./imapresource.moc:121
#15 0x00007f144a2150ef in QMetaObject::activate (sender=sender@entry=0x14bac10, m=m@entry=0x469040 <SessionPool::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7fff2ffe6fe0) at kernel/qobject.cpp:3539
#16 0x0000000000454df4 in SessionPool::connectDone (this=this@entry=0x14bac10, _t1=_t1@entry=8, _t2=...) at ./sessionpool.moc:161
#17 0x0000000000455cbf in SessionPool::cancelSessionCreation (this=this@entry=0x14bac10, session=0x1509430, errorCode=errorCode@entry=8, errorMessage=...) at ../../../resources/imap/sessionpool.cpp:230
#18 0x0000000000456934 in SessionPool::onLoginDone (this=0x14bac10, job=0x150ef60) at ../../../resources/imap/sessionpool.cpp:373
#19 0x000000000045791c in SessionPool::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./sessionpool.moc:95
#20 0x00007f144a2150ef in QMetaObject::activate (sender=sender@entry=0x150ef60, m=m@entry=0x7f14474de4e0 <KJob::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7fff2ffe72f0) at kernel/qobject.cpp:3539
#21 0x00007f1447151a72 in KJob::result (this=this@entry=0x150ef60, _t1=_t1@entry=0x150ef60) at ./kjob.moc:208
#22 0x00007f1447151ab0 in KJob::emitResult (this=this@entry=0x150ef60) at ../../kdecore/jobs/kjob.cpp:318
#23 0x00007f1448e5474c in KIMAP::LoginJob::connectionLost (this=0x150ef60) at ../../kimap/loginjob.cpp:584
#24 0x00007f1448e60782 in KIMAP::SessionPrivate::clearJobQueue (this=0x154acd0) at ../../kimap/session.cpp:404
#25 0x00007f144a21a5be in QObject::event (this=0x1509430, e=<optimized out>) at kernel/qobject.cpp:1194
#26 0x00007f14495a68ec in QApplicationPrivate::notify_helper (this=this@entry=0x12cb7e0, receiver=receiver@entry=0x1509430, e=e@entry=0x7f1428012360) at kernel/qapplication.cpp:4567
#27 0x00007f14495a925b in QApplication::notify (this=this@entry=0x7fff2ffe7cf0, receiver=receiver@entry=0x1509430, e=e@entry=0x7f1428012360) at kernel/qapplication.cpp:4428
#28 0x00007f14477171a6 in KApplication::notify (this=0x7fff2ffe7cf0, receiver=0x1509430, event=0x7f1428012360) at ../../kdeui/kernel/kapplication.cpp:311
#29 0x00007f144a20063e in QCoreApplication::notifyInternal (this=0x7fff2ffe7cf0, receiver=receiver@entry=0x1509430, event=event@entry=0x7f1428012360) at kernel/qcoreapplication.cpp:946
#30 0x00007f144a204171 in sendEvent (event=0x7f1428012360, receiver=0x1509430) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x1297f60) at kernel/qcoreapplication.cpp:1570
#32 0x00007f144a2044a3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#33 0x00007f144a22ee83 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#34 postEventSourceDispatch (s=s@entry=0x12d6770) at kernel/qeventdispatcher_glib.cpp:279
#35 0x00007f1445584f05 in g_main_dispatch (context=0x12d66b0) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3054
#36 g_main_context_dispatch (context=context@entry=0x12d66b0) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3630
#37 0x00007f1445585248 in g_main_context_iterate (context=context@entry=0x12d66b0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3701
#38 0x00007f1445585304 in g_main_context_iteration (context=0x12d66b0, may_block=1) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3762
#39 0x00007f144a22f016 in QEventDispatcherGlib::processEvents (this=0x12ca950, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#40 0x00007f144964c1ae in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#41 0x00007f144a1ff38f in QEventLoop::processEvents (this=this@entry=0x7fff2ffe7c70, flags=...) at kernel/qeventloop.cpp:149
#42 0x00007f144a1ff618 in QEventLoop::exec (this=this@entry=0x7fff2ffe7c70, flags=...) at kernel/qeventloop.cpp:204
#43 0x00007f144a204cf6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#44 0x00007f14495a4ffc in QApplication::exec () at kernel/qapplication.cpp:3828
#45 0x00007f144a924bb3 in Akonadi::ResourceBase::init (r=r@entry=0x14b1960) at ../../akonadi/resourcebase.cpp:451
#46 0x000000000041c7f3 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:189
#47 0x00007f144676dea5 in __libc_start_main (main=0x4156c0 <main(int, char**)>, argc=3, ubp_av=0x7fff2ffe7e08, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff2ffe7df8) at libc-start.c:260
#48 0x0000000000415845 in _start ()

Possible duplicates by query: bug 321253, bug 321055, bug 319776, bug 315584, bug 312706.

Reported using DrKonqi
Comment 1 Daniel Vrátil 2013-10-01 09:22:23 UTC

*** This bug has been marked as a duplicate of bug 319776 ***