Bug 325777 - imap resource crash with flaky wifi connection
Summary: imap resource crash with flaky wifi connection
Status: RESOLVED DUPLICATE of bug 319776
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.11
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-10-08 14:27 UTC by Marc Schiffbauer
Modified: 2013-10-08 14:47 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Schiffbauer 2013-10-08 14:27:36 UTC
Application: akonadi_imap_resource (4.11)
KDE Platform Version: 4.11.2 (Compiled from sources)
Qt Version: 4.8.4
Operating System: Linux 3.9.11-gentoo-r1 x86_64
Distribution: "NAME=Gentoo"

-- Information about the crash:
- What I was doing when the application crashed:

This crash seems still not fixed, happened today with current 4.11 branch.

-- Backtrace:
Application: Privat vom Typ IMAP-E-Mail-Server (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8d3c03f780 (LWP 15875))]

Thread 5 (Thread 0x7f8d20e9b700 (LWP 16167)):
#0  0x00007f8d36852fc9 in g_mutex_lock () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f8d36814a6b in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f8d3681524e in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f8d36815454 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f8d3b435806 in QEventDispatcherGlib::processEvents (this=0x7f8d180008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f8d3b40635f in QEventLoop::processEvents (this=this@entry=0x7f8d20e9ae70, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f8d3b4065e8 in QEventLoop::exec (this=this@entry=0x7f8d20e9ae70, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f8d3b30a330 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#8  0x00007f8d3b30caac in QThreadPrivate::start (arg=0xf79b30) at thread/qthread_unix.cpp:338
#9  0x00007f8d37181f3b in start_thread () from /lib64/libpthread.so.0
#10 0x00007f8d378ed26d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f8d2920c700 (LWP 16340)):
#0  0x00007f8d36852d89 in ?? () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f8d36852ff9 in g_mutex_unlock () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f8d36814a53 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f8d3681524e in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f8d36815454 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007f8d3b435806 in QEventDispatcherGlib::processEvents (this=0x7f8d240197d0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f8d3b40635f in QEventLoop::processEvents (this=this@entry=0x7f8d2920be70, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f8d3b4065e8 in QEventLoop::exec (this=this@entry=0x7f8d2920be70, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f8d3b30a330 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#9  0x00007f8d3b30caac in QThreadPrivate::start (arg=0xfc8e30) at thread/qthread_unix.cpp:338
#10 0x00007f8d37181f3b in start_thread () from /lib64/libpthread.so.0
#11 0x00007f8d378ed26d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f8d28a0b700 (LWP 20652)):
#0  0x00007f8d36852d75 in ?? () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f8d36852fc9 in g_mutex_lock () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f8d36814f36 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f8d36815398 in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f8d36815454 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007f8d3b435806 in QEventDispatcherGlib::processEvents (this=0x7f8d1c052ad0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f8d3b40635f in QEventLoop::processEvents (this=this@entry=0x7f8d28a0ae70, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f8d3b4065e8 in QEventLoop::exec (this=this@entry=0x7f8d28a0ae70, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f8d3b30a330 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#9  0x00007f8d3b30caac in QThreadPrivate::start (arg=0xf1ec10) at thread/qthread_unix.cpp:338
#10 0x00007f8d37181f3b in start_thread () from /lib64/libpthread.so.0
#11 0x00007f8d378ed26d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f8d177fe700 (LWP 21584)):
#0  0x00007f8d37184085 in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00007f8d36852fd1 in g_mutex_lock () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f8d368144ae in g_main_context_acquire () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f8d36815204 in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f8d36815454 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007f8d3b435806 in QEventDispatcherGlib::processEvents (this=0x7f8d0800d150, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f8d3b40635f in QEventLoop::processEvents (this=this@entry=0x7f8d177fde70, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f8d3b4065e8 in QEventLoop::exec (this=this@entry=0x7f8d177fde70, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f8d3b30a330 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#9  0x00007f8d3b30caac in QThreadPrivate::start (arg=0x19d0e70) at thread/qthread_unix.cpp:338
#10 0x00007f8d37181f3b in start_thread () from /lib64/libpthread.so.0
#11 0x00007f8d378ed26d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f8d3c03f780 (LWP 15875)):
[KCrash Handler]
#6  0x00007f8d08019e30 in ?? ()
#7  0x00007f8d3b41d631 in QObject::disconnect (sender=0x19cb8e0, signal=0x10389a9 "stateChanged(KIMAP::Session::State,KIMAP::Session::State)", receiver=receiver@entry=0xf1b960, method=0x19c6749 "onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)", method@entry=0x47f610 "1onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)") at kernel/qobject.cpp:2887
#8  0x00000000004603ed in SessionPool::killSession (this=this@entry=0xf1b960, session=0x19cb8e0, termination=termination@entry=SessionPool::LogoutSession) at /var/tmp/portage/kde-base/kdepim-runtime-4.11.49.9999/work/kdepim-runtime-4.11.49.9999/resources/imap/sessionpool.cpp:183
#9  0x0000000000460f05 in SessionPool::disconnect (this=0xf1b960, termination=termination@entry=SessionPool::LogoutSession) at /var/tmp/portage/kde-base/kdepim-runtime-4.11.49.9999/work/kdepim-runtime-4.11.49.9999/resources/imap/sessionpool.cpp:117
#10 0x000000000041f15b in ImapResource::doSetOnline (this=0xeff950, online=false) at /var/tmp/portage/kde-base/kdepim-runtime-4.11.49.9999/work/kdepim-runtime-4.11.49.9999/resources/imap/imapresource.cpp:537
#11 0x00007f8d3ba77959 in Akonadi::AgentBase::setOnlineInternal (this=0xeff950, state=false) at /var/tmp/portage/kde-base/kdepimlibs-4.11.49.9999/work/kdepimlibs-4.11.49.9999/akonadi/agentbase.cpp:781
#12 0x00007f8d3ba77b8e in Akonadi::AgentBasePrivate::slotNetworkStatusChange (this=<optimized out>, stat=<optimized out>) at /var/tmp/portage/kde-base/kdepimlibs-4.11.49.9999/work/kdepimlibs-4.11.49.9999/akonadi/agentbase.cpp:636
#13 0x00007f8d3ba78103 in Akonadi::AgentBase::qt_static_metacall (_o=0xeff950, _c=<optimized out>, _id=18, _a=0x7fff29bb8b80) at /var/tmp/portage/kde-base/kdepimlibs-4.11.49.9999/work/kdepimlibs-4.11.49.9999_build/akonadi/moc_agentbase.cpp:102
#14 0x00007f8d3b41b8e4 in QMetaObject::activate (sender=0xd95320, m=m@entry=0x7f8d391bb240 <Solid::Networking::Notifier::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7fff29bb8b80) at kernel/qobject.cpp:3539
#15 0x00007f8d38f1281e in Solid::Networking::Notifier::statusChanged (this=<optimized out>, _t1=Solid::Networking::Unconnected) at /var/tmp/portage/kde-base/kdelibs-4.11.49.9999/work/kdelibs-4.11.49.9999_build/solid/solid/networking.moc:104
#16 0x00007f8d3b41b8e4 in QMetaObject::activate (sender=sender@entry=0xefb0b0, m=m@entry=0x7f8d391c89e0 <OrgKdeSolidNetworkingClientInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7fff29bb8cf0) at kernel/qobject.cpp:3539
#17 0x00007f8d38f7ca9e in OrgKdeSolidNetworkingClientInterface::statusChanged (this=this@entry=0xefb0b0, _t1=1) at /var/tmp/portage/kde-base/kdelibs-4.11.49.9999/work/kdelibs-4.11.49.9999_build/solid/solid/org_kde_solid_networking_client.moc:132
#18 0x00007f8d38f7cb4e in OrgKdeSolidNetworkingClientInterface::qt_static_metacall (_o=0xefb0b0, _c=<optimized out>, _id=0, _a=0x7fff29bb8ff0) at /var/tmp/portage/kde-base/kdelibs-4.11.49.9999/work/kdelibs-4.11.49.9999_build/solid/solid/org_kde_solid_networking_client.moc:58
#19 0x00007f8d38f7cf4f in OrgKdeSolidNetworkingClientInterface::qt_metacall (this=0xefb0b0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fff29bb8ff0) at /var/tmp/portage/kde-base/kdelibs-4.11.49.9999/work/kdelibs-4.11.49.9999_build/solid/solid/org_kde_solid_networking_client.moc:99
#20 0x00007f8d3b78ad33 in QDBusConnectionPrivate::deliverCall (this=0xdfd530, object=0xefb0b0, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:951
#21 0x00007f8d3b420e0e in QObject::event (this=0xefb0b0, e=<optimized out>) at kernel/qobject.cpp:1194
#22 0x00007f8d3a7d88ec in QApplicationPrivate::notify_helper (this=this@entry=0xd33650, receiver=receiver@entry=0xefb0b0, e=e@entry=0xff4350) at kernel/qapplication.cpp:4562
#23 0x00007f8d3a7db272 in QApplication::notify (this=this@entry=0x7fff29bb9a30, receiver=receiver@entry=0xefb0b0, e=e@entry=0xff4350) at kernel/qapplication.cpp:4423
#24 0x00007f8d3882b336 in KApplication::notify (this=0x7fff29bb9a30, receiver=0xefb0b0, event=0xff4350) at /var/tmp/portage/kde-base/kdelibs-4.11.49.9999/work/kdelibs-4.11.49.9999/kdeui/kernel/kapplication.cpp:311
#25 0x00007f8d3b40760e in QCoreApplication::notifyInternal (this=0x7fff29bb9a30, receiver=receiver@entry=0xefb0b0, event=event@entry=0xff4350) at kernel/qcoreapplication.cpp:946
#26 0x00007f8d3b40abd9 in sendEvent (event=0xff4350, receiver=0xefb0b0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#27 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0xd0a0e0) at kernel/qcoreapplication.cpp:1570
#28 0x00007f8d3b40aee3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#29 0x00007f8d3b435653 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#30 postEventSourceDispatch (s=0xd32a20) at kernel/qeventdispatcher_glib.cpp:279
#31 0x00007f8d36815055 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#32 0x00007f8d36815398 in ?? () from /usr/lib64/libglib-2.0.so.0
#33 0x00007f8d36815454 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#34 0x00007f8d3b4357e6 in QEventDispatcherGlib::processEvents (this=0xd0bda0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#35 0x00007f8d3a878fce in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#36 0x00007f8d3b40635f in QEventLoop::processEvents (this=this@entry=0x7fff29bb99b0, flags=...) at kernel/qeventloop.cpp:149
#37 0x00007f8d3b4065e8 in QEventLoop::exec (this=this@entry=0x7fff29bb99b0, flags=...) at kernel/qeventloop.cpp:204
#38 0x00007f8d3b40b7a8 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#39 0x00007f8d3a7d723c in QApplication::exec () at kernel/qapplication.cpp:3823
#40 0x00007f8d3bb4eb33 in Akonadi::ResourceBase::init (r=r@entry=0xeff950) at /var/tmp/portage/kde-base/kdepimlibs-4.11.49.9999/work/kdepimlibs-4.11.49.9999/akonadi/resourcebase.cpp:548
#41 0x0000000000420d73 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:192
#42 0x00007f8d37823bf5 in __libc_start_main () from /lib64/libc.so.6
#43 0x0000000000418c81 in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 319776.

Possible duplicates by query: bug 325478, bug 324543, bug 324460, bug 322440, bug 321253.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-10-08 14:47:53 UTC

*** This bug has been marked as a duplicate of bug 319776 ***