Bug 324460 - akonadi_imap_resource under KDE 4.11.0 has crashed when PC's IP address changed
Summary: akonadi_imap_resource under KDE 4.11.0 has crashed when PC's IP address changed
Status: RESOLVED DUPLICATE of bug 319776
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.11
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords: drkonqi
: 324543 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-09-03 15:52 UTC by Thomas Dreibholz
Modified: 2013-10-01 09:23 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Dreibholz 2013-09-03 15:52:21 UTC
Application: akonadi_imap_resource (4.11)
KDE Platform Version: 4.11.00
Qt Version: 4.8.4
Operating System: Linux 3.8.0-29-generic x86_64
Distribution: Ubuntu 13.04

-- Information about the crash:
- What I was doing when the application crashed:

akonadi_imap_resource under KDE 4.11.0 has crashed when the PC's IP address has changed. I guess it is still the old problem that I report from time to time when there is a new KDE version and akonadi_imap_resource crashes once again on unstable network connectivity. This problem probably persists since I started to work with KDE 4 in KDE 4.3 or KDE 4.4. It really needs some debugging, since I think that probably not so few people use KDE on a laptop that changes its address from time to time when continuing to work in a different network. Then, KDE's IMAP resource gets easily out of service or even crashes. While KDE 4 itself gets better with each new version, KDE PIM and particularly its IMAP resource implementation are a steady source of frustration.

-- Backtrace:
Application: Simula av type IMAP E-post-tjener (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f4a5979b7c0 (LWP 3553))]

Thread 3 (Thread 0x7f4a45da5700 (LWP 3795)):
#0  0x00007fffe69daaf7 in ?? ()
#1  0x0000000000fc5c10 in ?? ()
#2  0x00000002e69bcf10 in ?? ()
#3  0x00007f4a40002860 in ?? ()
#4  0x00007f4a45da4bb0 in ?? ()
#5  0x00007f4a45da4c68 in ?? ()
#6  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f4a3f5d8700 (LWP 4913)):
#0  g_mutex_get_impl (mutex=0x7f4a340009a0) at /build/buildd/glib2.0-2.36.0/./glib/gthread-posix.c:123
#1  0x00007f4a53f385b9 in g_mutex_lock (mutex=<optimized out>) at /build/buildd/glib2.0-2.36.0/./glib/gthread-posix.c:210
#2  0x00007f4a53ef90d5 in g_main_context_iterate (context=context@entry=0x7f4a340009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3668
#3  0x00007f4a53ef9304 in g_main_context_iteration (context=0x7f4a340009a0, may_block=1) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3762
#4  0x00007f4a58bc6036 in QEventDispatcherGlib::processEvents (this=0x7f4a340008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f4a58b9638f in QEventLoop::processEvents (this=this@entry=0x7f4a3f5d7dc0, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f4a58b96618 in QEventLoop::exec (this=this@entry=0x7f4a3f5d7dc0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f4a58a98410 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#8  0x00007f4a58a9abec in QThreadPrivate::start (arg=0xd51070) at thread/qthread_unix.cpp:338
#9  0x00007f4a54812f8e in start_thread (arg=0x7f4a3f5d8700) at pthread_create.c:311
#10 0x00007f4a551c5e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f4a5979b7c0 (LWP 3553)):
[KCrash Handler]
#6  0x00007f4a5916fb10 in vtable for QDBusConnectionPrivate () from /usr/lib/x86_64-linux-gnu/libQtDBus.so.4
#7  0x00007f4a58bade51 in QObject::disconnect (sender=0xdd2870, signal=0xe12589 "stateChanged(KIMAP::Session::State,KIMAP::Session::State)", signal@entry=0x46d5c8 "2stateChanged(KIMAP::Session::State,KIMAP::Session::State)", receiver=receiver@entry=0xede030, method=0xf362d9 "onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)", method@entry=0x46d580 "1onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)") at kernel/qobject.cpp:2887
#8  0x0000000000459295 in SessionPool::killSession (this=this@entry=0xede030, session=0xdd2870, termination=termination@entry=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:183
#9  0x0000000000459c05 in SessionPool::disconnect (this=0xede030, termination=termination@entry=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:117
#10 0x000000000041c313 in ImapResource::doSetOnline (this=0xf049d0, online=<optimized out>) at ../../../resources/imap/imapresource.cpp:531
#11 0x00007f4a591f76c9 in Akonadi::AgentBase::setOnlineInternal (this=0xf049d0, state=<optimized out>) at ../../akonadi/agentbase.cpp:781
#12 0x00007f4a591f78de in Akonadi::AgentBasePrivate::slotNetworkStatusChange (this=<optimized out>, stat=<optimized out>) at ../../akonadi/agentbase.cpp:636
#13 0x00007f4a591f7e1f in Akonadi::AgentBase::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./moc_agentbase.cpp:102
#14 0x00007f4a58bac0ef in QMetaObject::activate (sender=0xee2320, m=m@entry=0x7f4a569b2280 <Solid::Networking::Notifier::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7fffe69bc0c0) at kernel/qobject.cpp:3539
#15 0x00007f4a5671952e in Solid::Networking::Notifier::statusChanged (this=<optimized out>, _t1=Solid::Networking::Connecting) at ./networking.moc:104
#16 0x00007f4a58bac0ef in QMetaObject::activate (sender=0xf97850, m=m@entry=0x7f4a569bfa20 <OrgKdeSolidNetworkingClientInterface::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7fffe69bc210) at kernel/qobject.cpp:3539
#17 0x00007f4a5677d7fe in OrgKdeSolidNetworkingClientInterface::statusChanged (this=<optimized out>, _t1=3) at org_kde_solid_networking_client.moc:132
#18 0x00007f4a5677d88b in OrgKdeSolidNetworkingClientInterface::qt_static_metacall (_o=0xf97850, _c=<optimized out>, _id=<optimized out>, _a=0x7fffe69bc510) at org_kde_solid_networking_client.moc:58
#19 0x00007f4a5677dc6f in OrgKdeSolidNetworkingClientInterface::qt_metacall (this=0xf97850, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fffe69bc510) at org_kde_solid_networking_client.moc:99
#20 0x00007f4a58f1a063 in QDBusConnectionPrivate::deliverCall (this=0xddac90, object=0xf97850, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:951
#21 0x00007f4a58bb15be in QObject::event (this=0xf97850, e=<optimized out>) at kernel/qobject.cpp:1194
#22 0x00007f4a57f3d8ec in QApplicationPrivate::notify_helper (this=this@entry=0xd52520, receiver=receiver@entry=0xf97850, e=e@entry=0xf9bd10) at kernel/qapplication.cpp:4567
#23 0x00007f4a57f4025b in QApplication::notify (this=this@entry=0x7fffe69bcf10, receiver=receiver@entry=0xf97850, e=e@entry=0xf9bd10) at kernel/qapplication.cpp:4428
#24 0x00007f4a56095916 in KApplication::notify (this=0x7fffe69bcf10, receiver=0xf97850, event=0xf9bd10) at ../../kdeui/kernel/kapplication.cpp:311
#25 0x00007f4a58b9763e in QCoreApplication::notifyInternal (this=0x7fffe69bcf10, receiver=receiver@entry=0xf97850, event=event@entry=0xf9bd10) at kernel/qcoreapplication.cpp:946
#26 0x00007f4a58b9b171 in sendEvent (event=0xf9bd10, receiver=0xf97850) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#27 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0xd21f80) at kernel/qcoreapplication.cpp:1570
#28 0x00007f4a58b9b4a3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#29 0x00007f4a58bc5e83 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#30 postEventSourceDispatch (s=s@entry=0xd52e00) at kernel/qeventdispatcher_glib.cpp:279
#31 0x00007f4a53ef8f05 in g_main_dispatch (context=0xd55a60) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3054
#32 g_main_context_dispatch (context=context@entry=0xd55a60) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3630
#33 0x00007f4a53ef9248 in g_main_context_iterate (context=context@entry=0xd55a60, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3701
#34 0x00007f4a53ef9304 in g_main_context_iteration (context=0xd55a60, may_block=1) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3762
#35 0x00007f4a58bc6016 in QEventDispatcherGlib::processEvents (this=0xd54a30, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#36 0x00007f4a57fe313e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#37 0x00007f4a58b9638f in QEventLoop::processEvents (this=this@entry=0x7fffe69bce90, flags=...) at kernel/qeventloop.cpp:149
#38 0x00007f4a58b96618 in QEventLoop::exec (this=this@entry=0x7fffe69bce90, flags=...) at kernel/qeventloop.cpp:204
#39 0x00007f4a58b9bcf6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#40 0x00007f4a57f3bffc in QApplication::exec () at kernel/qapplication.cpp:3828
#41 0x00007f4a592c3163 in Akonadi::ResourceBase::init (r=r@entry=0xf049d0) at ../../akonadi/resourcebase.cpp:548
#42 0x000000000041ddc3 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:192
#43 0x00007f4a550edea5 in __libc_start_main (main=0x416210 <main(int, char**)>, argc=3, ubp_av=0x7fffe69bd028, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffe69bd018) at libc-start.c:260
#44 0x0000000000416395 in _start ()

Possible duplicates by query: bug 306040, bug 294401, bug 289052.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-09-05 11:41:55 UTC
*** Bug 324543 has been marked as a duplicate of this bug. ***
Comment 2 Daniel Vrátil 2013-10-01 09:23:10 UTC

*** This bug has been marked as a duplicate of bug 319776 ***