Bug 321253 - akonadi imap resource crash with spotty Wifi
Summary: akonadi imap resource crash with spotty Wifi
Status: RESOLVED DUPLICATE of bug 319776
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.10
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-17 08:22 UTC by Michael Hammond
Modified: 2013-06-17 09:03 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Hammond 2013-06-17 08:22:57 UTC
Application: akonadi_imap_resource (4.10)
KDE Platform Version: 4.10.3
Qt Version: 4.8.4
Operating System: Linux 3.8.0-25-generic x86_64
Distribution: Ubuntu 13.04

-- Information about the crash:
- What I was doing when the application crashed:
Accessing email over degraded Wifi link

- Custom settings of the application:
Kmail has request to create an IMAP folder stuck.  Repeatedly fails.

-- Backtrace:
Application: IMAP Account 5 of type IMAP E-Mail Server (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f7f69a7e7c0 (LWP 7663))]

Thread 2 (Thread 0x7f7f4ecd2700 (LWP 10531)):
#0  0x00007f7f642475b9 in g_mutex_lock (mutex=mutex@entry=0x7f7f3c0108f0) at /build/buildd/glib2.0-2.36.0/./glib/gthread-posix.c:210
#1  0x00007f7f64207abb in g_main_context_query (context=context@entry=0x7f7f3c0108f0, max_priority=2147483647, timeout=timeout@entry=0x7f7f4ecd1c4c, fds=fds@entry=0x7f7f3c0060a0, n_fds=n_fds@entry=1) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3426
#2  0x00007f7f6420814c in g_main_context_iterate (context=context@entry=0x7f7f3c0108f0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3683
#3  0x00007f7f64208304 in g_main_context_iteration (context=0x7f7f3c0108f0, may_block=1) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3762
#4  0x00007f7f68eb3036 in QEventDispatcherGlib::processEvents (this=0x7f7f3c010860, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f7f68e8338f in QEventLoop::processEvents (this=this@entry=0x7f7f4ecd1da0, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f7f68e83618 in QEventLoop::exec (this=this@entry=0x7f7f4ecd1da0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f7f68d85410 in QThread::exec (this=this@entry=0xfdeec0) at thread/qthread.cpp:542
#8  0x00007f7f67ae8b2a in KIMAP::SessionThread::run (this=0xfdeec0) at ../../kimap/sessionthread.cpp:184
#9  0x00007f7f68d87bec in QThreadPrivate::start (arg=0xfdeec0) at thread/qthread_unix.cpp:338
#10 0x00007f7f64b21f8e in start_thread (arg=0x7f7f4ecd2700) at pthread_create.c:311
#11 0x00007f7f654c8e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f7f69a7e7c0 (LWP 7663)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f7f68e9ae51 in QObject::disconnect (sender=0x106cf20, signal=0xfded59 "stateChanged(KIMAP::Session::State,KIMAP::Session::State)", signal@entry=0x468e28 "2stateChanged(KIMAP::Session::State,KIMAP::Session::State)", receiver=receiver@entry=0xfe0200, method=0x1096a79 "onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)", method@entry=0x468de0 "1onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)") at kernel/qobject.cpp:2887
#8  0x0000000000455015 in SessionPool::killSession (this=this@entry=0xfe0200, session=0x106cf20, termination=termination@entry=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:177
#9  0x0000000000455405 in SessionPool::disconnect (this=0xfe0200, termination=termination@entry=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:117
#10 0x000000000041b093 in ImapResource::doSetOnline (this=0x1063f50, online=<optimized out>) at ../../../resources/imap/imapresource.cpp:495
#11 0x00007f7f694e1c59 in Akonadi::AgentBase::setOnlineInternal (this=this@entry=0x1063f50, state=state@entry=false) at ../../akonadi/agentbase.cpp:659
#12 0x00007f7f694e1d78 in Akonadi::AgentBase::setOnline (this=0x1063f50, state=false) at ../../akonadi/agentbase.cpp:646
#13 0x000000000041a987 in ImapResource::onConnectDone (this=0x1063f50, errorCode=-1433706144, errorString=...) at ../../../resources/imap/imapresource.cpp:285
#14 0x000000000041ae3f in ImapResource::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./imapresource.moc:121
#15 0x00007f7f68e990ef in QMetaObject::activate (sender=sender@entry=0xfe0200, m=m@entry=0x4692a0 <SessionPool::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x7fffaa8b6550) at kernel/qobject.cpp:3539
#16 0x0000000000454e24 in SessionPool::connectDone (this=this@entry=0xfe0200, _t1=_t1@entry=8, _t2=...) at ./sessionpool.moc:161
#17 0x000000000045594f in SessionPool::cancelSessionCreation (this=this@entry=0xfe0200, session=0xfe4df0, errorCode=errorCode@entry=8, errorMessage=...) at ../../../resources/imap/sessionpool.cpp:224
#18 0x00000000004565c4 in SessionPool::onLoginDone (this=0xfe0200, job=0xfd3910) at ../../../resources/imap/sessionpool.cpp:367
#19 0x000000000045791c in SessionPool::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./sessionpool.moc:95
#20 0x00007f7f68e990ef in QMetaObject::activate (sender=sender@entry=0xfd3910, m=m@entry=0x7f7f661604e0 <KJob::staticMetaObject>, local_signal_index=local_signal_index@entry=3, argv=argv@entry=0x7fffaa8b6860) at kernel/qobject.cpp:3539
#21 0x00007f7f65dd4412 in KJob::result (this=this@entry=0xfd3910, _t1=_t1@entry=0xfd3910) at ./kjob.moc:208
#22 0x00007f7f65dd4450 in KJob::emitResult (this=this@entry=0xfd3910) at ../../kdecore/jobs/kjob.cpp:318
#23 0x00007f7f67ad874c in KIMAP::LoginJob::connectionLost (this=0xfd3910) at ../../kimap/loginjob.cpp:584
#24 0x00007f7f67ae4782 in KIMAP::SessionPrivate::clearJobQueue (this=0xfdefb0) at ../../kimap/session.cpp:404
#25 0x00007f7f68e9e5be in QObject::event (this=0xfe4df0, e=<optimized out>) at kernel/qobject.cpp:1194
#26 0x00007f7f6822a8ec in QApplicationPrivate::notify_helper (this=this@entry=0xeda2e0, receiver=receiver@entry=0xfe4df0, e=e@entry=0x7f7f3c006960) at kernel/qapplication.cpp:4567
#27 0x00007f7f6822d25b in QApplication::notify (this=this@entry=0x7fffaa8b7260, receiver=receiver@entry=0xfe4df0, e=e@entry=0x7f7f3c006960) at kernel/qapplication.cpp:4428
#28 0x00007f7f6639aaf6 in KApplication::notify (this=0x7fffaa8b7260, receiver=0xfe4df0, event=0x7f7f3c006960) at ../../kdeui/kernel/kapplication.cpp:311
#29 0x00007f7f68e8463e in QCoreApplication::notifyInternal (this=0x7fffaa8b7260, receiver=receiver@entry=0xfe4df0, event=event@entry=0x7f7f3c006960) at kernel/qcoreapplication.cpp:946
#30 0x00007f7f68e88171 in sendEvent (event=0x7f7f3c006960, receiver=0xfe4df0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#31 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0xeaff60) at kernel/qcoreapplication.cpp:1570
#32 0x00007f7f68e884a3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#33 0x00007f7f68eb2e83 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#34 postEventSourceDispatch (s=s@entry=0xedfd50) at kernel/qeventdispatcher_glib.cpp:279
#35 0x00007f7f64207f05 in g_main_dispatch (context=0xedfea0) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3054
#36 g_main_context_dispatch (context=context@entry=0xedfea0) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3630
#37 0x00007f7f64208248 in g_main_context_iterate (context=context@entry=0xedfea0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3701
#38 0x00007f7f64208304 in g_main_context_iteration (context=0xedfea0, may_block=1) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3762
#39 0x00007f7f68eb3016 in QEventDispatcherGlib::processEvents (this=0xeb1c20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#40 0x00007f7f682d01ae in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#41 0x00007f7f68e8338f in QEventLoop::processEvents (this=this@entry=0x7fffaa8b71e0, flags=...) at kernel/qeventloop.cpp:149
#42 0x00007f7f68e83618 in QEventLoop::exec (this=this@entry=0x7fffaa8b71e0, flags=...) at kernel/qeventloop.cpp:204
#43 0x00007f7f68e88cf6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#44 0x00007f7f68228ffc in QApplication::exec () at kernel/qapplication.cpp:3828
#45 0x00007f7f695a8b63 in Akonadi::ResourceBase::init (r=r@entry=0x1063f50) at ../../akonadi/resourcebase.cpp:451
#46 0x000000000041c7f3 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:188
#47 0x00007f7f653f0ea5 in __libc_start_main (main=0x4156c0 <main(int, char**)>, argc=3, ubp_av=0x7fffaa8b7378, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffaa8b7368) at libc-start.c:260
#48 0x0000000000415845 in _start ()

This bug may be a duplicate of or related to bug 319776.

Possible duplicates by query: bug 321055, bug 319776, bug 315584, bug 312706, bug 312057.

Reported using DrKonqi
Comment 1 Daniel Vrátil 2013-06-17 09:03:08 UTC

*** This bug has been marked as a duplicate of bug 319776 ***