Bug 325519 - dolphin(8643)/kdeui (kdelibs): Session bus not found
Summary: dolphin(8643)/kdeui (kdelibs): Session bus not found
Status: RESOLVED DUPLICATE of bug 282182
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 4.11.1
Platform: Ubuntu Linux
: NOR crash
Target Milestone: ---
Assignee: Dolphin Bug Assignee
Keywords: drkonqi
: 329852 342509 (view as bug list)
Depends on:
Reported: 2013-10-01 22:03 UTC by Sebastian
Modified: 2015-08-13 19:06 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:

New crash information added by DrKonqi (1.36 KB, text/plain)
2015-08-13 19:06 UTC, David

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian 2013-10-01 22:03:07 UTC
Application: dolphin (4.11.1)
KDE Platform Version: 4.11.2
Qt Version: 4.8.4
Operating System: Linux 3.12.0-031200rc3-generic x86_64
Distribution: Ubuntu Saucy Salamander (development branch)

-- Information about the crash:
I tried to launch Dolphin file manager from the terminal as root.

-- Backtrace:
Application: Dolphin (dolphin), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#6  0x00007f9b3f083f77 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#7  0x00007f9b3f0875e8 in __GI_abort () at abort.c:90
#8  0x00007f9b3aec6912 in qt_message_output (msgType=<optimized out>, buf=0xfdbe88 "dolphin(8643)/kdeui (kdelibs): Session bus not found \nTo circumvent this problem try the following command (with Linux and bash) \nexport $(dbus-launch) ") at global/qglobal.cpp:2347
#9  0x00007f9b3c5f4a89 in QDebug::~QDebug (this=0x7fffb8b5fe70, __in_chrg=<optimized out>) at /usr/include/qt4/QtCore/qdebug.h:85
#10 0x00007f9b3c6ccb48 in KApplicationPrivate::init (this=0xf1cd60, GUIenabled=GUIenabled@entry=true) at ../../kdeui/kernel/kapplication.cpp:516
#11 0x00007f9b3c6cd532 in KApplication::KApplication (this=0x7fffb8b600f0, GUIenabled=true) at ../../kdeui/kernel/kapplication.cpp:352
#12 0x00007f9b3f44ee6b in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_dolphin.so
#13 0x00007f9b3f4653de in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_dolphin.so
#14 0x00007f9b3f06ede5 in __libc_start_main (main=0x4006d0, argc=1, ubp_av=0x7fffb8b60228, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffb8b60218) at libc-start.c:260
#15 0x00000000004006fe in _start ()

Possible duplicates by query: bug 318467, bug 314342, bug 307311, bug 306037, bug 301897.

Reported using DrKonqi
Comment 1 Frank Reininghaus 2013-10-01 22:17:50 UTC
Thanks for the bug report, but please note that no KDE application will work without starting DBus first (Dolphin itself doesn't use DBus at all, but some parts of kdelibs do).

*** This bug has been marked as a duplicate of bug 282182 ***
Comment 2 Christoph Feck 2014-01-11 18:21:02 UTC
*** Bug 329852 has been marked as a duplicate of this bug. ***
Comment 3 Emmanuel Pescosta 2015-01-05 16:13:26 UTC
*** Bug 342509 has been marked as a duplicate of this bug. ***
Comment 4 David 2015-08-13 19:06:12 UTC
Created attachment 94020 [details]
New crash information added by DrKonqi

dolphin (4.14.3) on KDE Platform 4.14.5 using Qt 4.8.6

-In Konsole window tried to load dolphin with
sudo dolphin  (did not work) then tried 
su and then 
dolphin       but did not work

However AltF2 in KDE desktop
then           kdesu dolphin     did work??

-- Backtrace (Reduced):
#8  0x00007fd2d1e321a9 in QDebug::~QDebug() () from /lib64/libkdeui.so.5
#9  0x00007fd2d1e86278 in KApplicationPrivate::init(bool) () from /lib64/libkdeui.so.5
#10 0x00007fd2d1e86c3b in KApplication::KApplication(bool) () from /lib64/libkdeui.so.5
#11 0x00007fd2d4ab1d5b in DolphinApplication::DolphinApplication() () from /lib64/libkdeinit4_dolphin.so
#12 0x00007fd2d4ac6142 in kdemain () from /lib64/libkdeinit4_dolphin.so