Bug 321055 - akonadi_imap_resource (KDE 4.10.4, Kubuntu 13.04, 64 bit) has crashed.
Summary: akonadi_imap_resource (KDE 4.10.4, Kubuntu 13.04, 64 bit) has crashed.
Status: RESOLVED DUPLICATE of bug 319776
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.10
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-12 08:22 UTC by Thomas Dreibholz
Modified: 2013-06-12 14:03 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Dreibholz 2013-06-12 08:22:21 UTC
Application: akonadi_imap_resource (4.10)
KDE Platform Version: 4.10.4
Qt Version: 4.8.4
Operating System: Linux 3.8.0-23-generic x86_64
Distribution: Ubuntu 13.04

-- Information about the crash:
- What I was doing when the application crashed:
akonadi_imap_resource (KDE 4.10.4, Kubuntu 13.04, 64 bit) has crashed when switching to offline mode. akonadi_imap_resource did not synchronize after system resume. Therefore, I switched to offline mode in order to turn it back to online mode again, in the hope to get it working again without starting akonadiconsole.

-- Backtrace:
Application: Simula av type IMAP E-post-tjener (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fcb517b37c0 (LWP 15566))]

Thread 3 (Thread 0x7fcb37fff700 (LWP 15575)):
#0  0x00007fcb4bf7a359 in g_mutex_get_impl (mutex=0x7fcb2c0009a0) at /build/buildd/glib2.0-2.36.0/./glib/gthread-posix.c:121
#1  0x00007fcb4bf7a5e9 in g_mutex_unlock (mutex=mutex@entry=0x7fcb2c0009a0) at /build/buildd/glib2.0-2.36.0/./glib/gthread-posix.c:229
#2  0x00007fcb4bf3b0f1 in g_main_context_iterate (context=context@entry=0x7fcb2c0009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3679
#3  0x00007fcb4bf3b304 in g_main_context_iteration (context=0x7fcb2c0009a0, may_block=1) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3762
#4  0x00007fcb50be6036 in QEventDispatcherGlib::processEvents (this=0x7fcb2c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007fcb50bb638f in QEventLoop::processEvents (this=this@entry=0x7fcb37ffeda0, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fcb50bb6618 in QEventLoop::exec (this=this@entry=0x7fcb37ffeda0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007fcb50ab8410 in QThread::exec (this=this@entry=0x1a59780) at thread/qthread.cpp:542
#8  0x00007fcb4f81bb2a in KIMAP::SessionThread::run (this=0x1a59780) at ../../kimap/sessionthread.cpp:184
#9  0x00007fcb50ababec in QThreadPrivate::start (arg=0x1a59780) at thread/qthread_unix.cpp:338
#10 0x00007fcb4c854f8e in start_thread (arg=0x7fcb37fff700) at pthread_create.c:311
#11 0x00007fcb4d1fbe1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7fcb3d515700 (LWP 23064)):
#0  0x00007fcb4c857075 in __GI___pthread_mutex_lock (mutex=0x7fcb30008760) at pthread_mutex_lock.c:95
#1  0x00007fcb4bf7a5c1 in g_mutex_lock (mutex=<optimized out>) at /build/buildd/glib2.0-2.36.0/./glib/gthread-posix.c:210
#2  0x00007fcb4bf3b0d5 in g_main_context_iterate (context=context@entry=0x7fcb30002780, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3668
#3  0x00007fcb4bf3b304 in g_main_context_iteration (context=0x7fcb30002780, may_block=1) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3762
#4  0x00007fcb50be6036 in QEventDispatcherGlib::processEvents (this=0x7fcb3000e690, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007fcb50bb638f in QEventLoop::processEvents (this=this@entry=0x7fcb3d514da0, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fcb50bb6618 in QEventLoop::exec (this=this@entry=0x7fcb3d514da0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007fcb50ab8410 in QThread::exec (this=this@entry=0x1d566d0) at thread/qthread.cpp:542
#8  0x00007fcb4f81bb2a in KIMAP::SessionThread::run (this=0x1d566d0) at ../../kimap/sessionthread.cpp:184
#9  0x00007fcb50ababec in QThreadPrivate::start (arg=0x1d566d0) at thread/qthread_unix.cpp:338
#10 0x00007fcb4c854f8e in start_thread (arg=0x7fcb3d515700) at pthread_create.c:311
#11 0x00007fcb4d1fbe1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7fcb517b37c0 (LWP 15566)):
[KCrash Handler]
#6  0x0000000001ae8780 in ?? ()
#7  0x00007fcb50bcde51 in QObject::disconnect (sender=0x1d5b290, signal=0x1c6dfc9 "stateChanged(KIMAP::Session::State,KIMAP::Session::State)", signal@entry=0x468aa8 "2stateChanged(KIMAP::Session::State,KIMAP::Session::State)", receiver=receiver@entry=0x1c3e410, method=0x1dc7c29 "onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)", method@entry=0x468a60 "1onSessionStateChanged(KIMAP::Session::State,KIMAP::Session::State)") at kernel/qobject.cpp:2887
#8  0x0000000000454fd5 in SessionPool::killSession (this=this@entry=0x1c3e410, session=0x1d5b290, termination=termination@entry=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:177
#9  0x00000000004553c5 in SessionPool::disconnect (this=0x1c3e410, termination=termination@entry=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:117
#10 0x000000000041b093 in ImapResource::doSetOnline (this=0x1c0a500, online=<optimized out>) at ../../../resources/imap/imapresource.cpp:495
#11 0x00007fcb51214c59 in Akonadi::AgentBase::setOnlineInternal (this=this@entry=0x1c0a500, state=state@entry=false) at ../../akonadi/agentbase.cpp:659
#12 0x00007fcb51214d78 in Akonadi::AgentBase::setOnline (this=0x1c0a500, state=false) at ../../akonadi/agentbase.cpp:646
#13 0x00007fcb5135267c in Akonadi__StatusAdaptor::qt_static_metacall (_o=0x1d5b290, _o@entry=0x1c0ce50, _c=4146516992, _c@entry=QMetaObject::InvokeMetaMethod, _id=1, _a=0x1dc7c28, _a@entry=0x7ffff726d7f0) at statusadaptor.moc:106
#14 0x00007fcb5135281b in Akonadi__StatusAdaptor::qt_metacall (this=0x1c0ce50, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7ffff726d7f0) at statusadaptor.moc:149
#15 0x00007fcb50f3a063 in QDBusConnectionPrivate::deliverCall (this=this@entry=0x1ade030, object=object@entry=0x1c0ce50, msg=..., metaTypes=..., slotIdx=12) at qdbusintegrator.cpp:951
#16 0x00007fcb50f3a955 in QDBusConnectionPrivate::activateCall (this=this@entry=0x1ade030, object=0x1c0ce50, flags=flags@entry=273, msg=...) at qdbusintegrator.cpp:863
#17 0x00007fcb50f3b2cf in QDBusConnectionPrivate::activateObject (this=0x1ade030, node=..., msg=..., pathStartPos=<optimized out>) at qdbusintegrator.cpp:1427
#18 0x00007fcb50f3b3ab in QDBusActivateObjectEvent::placeMetaCall (this=0x1a56ce0) at qdbusintegrator.cpp:1541
#19 0x00007fcb50bd15be in QObject::event (this=0x1c0a500, e=<optimized out>) at kernel/qobject.cpp:1194
#20 0x00007fcb4ff5d8ec in QApplicationPrivate::notify_helper (this=this@entry=0x1a5b5a0, receiver=receiver@entry=0x1c0a500, e=e@entry=0x1a56ce0) at kernel/qapplication.cpp:4567
#21 0x00007fcb4ff6025b in QApplication::notify (this=this@entry=0x7ffff726e3d0, receiver=receiver@entry=0x1c0a500, e=e@entry=0x1a56ce0) at kernel/qapplication.cpp:4428
#22 0x00007fcb4e0cdaf6 in KApplication::notify (this=0x7ffff726e3d0, receiver=0x1c0a500, event=0x1a56ce0) at ../../kdeui/kernel/kapplication.cpp:311
#23 0x00007fcb50bb763e in QCoreApplication::notifyInternal (this=0x7ffff726e3d0, receiver=receiver@entry=0x1c0a500, event=event@entry=0x1a56ce0) at kernel/qcoreapplication.cpp:946
#24 0x00007fcb50bbb171 in sendEvent (event=0x1a56ce0, receiver=0x1c0a500) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#25 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x1a28f60) at kernel/qcoreapplication.cpp:1570
#26 0x00007fcb50bbb4a3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#27 0x00007fcb50be5e83 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#28 postEventSourceDispatch (s=s@entry=0x1a593c0) at kernel/qeventdispatcher_glib.cpp:279
#29 0x00007fcb4bf3af05 in g_main_dispatch (context=0x1a5c9e0) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3054
#30 g_main_context_dispatch (context=context@entry=0x1a5c9e0) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3630
#31 0x00007fcb4bf3b248 in g_main_context_iterate (context=context@entry=0x1a5c9e0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3701
#32 0x00007fcb4bf3b304 in g_main_context_iteration (context=0x1a5c9e0, may_block=1) at /build/buildd/glib2.0-2.36.0/./glib/gmain.c:3762
#33 0x00007fcb50be6016 in QEventDispatcherGlib::processEvents (this=0x1a2ac20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#34 0x00007fcb500031ae in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#35 0x00007fcb50bb638f in QEventLoop::processEvents (this=this@entry=0x7ffff726e350, flags=...) at kernel/qeventloop.cpp:149
#36 0x00007fcb50bb6618 in QEventLoop::exec (this=this@entry=0x7ffff726e350, flags=...) at kernel/qeventloop.cpp:204
#37 0x00007fcb50bbbcf6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#38 0x00007fcb4ff5bffc in QApplication::exec () at kernel/qapplication.cpp:3828
#39 0x00007fcb512dbb63 in Akonadi::ResourceBase::init (r=r@entry=0x1c0a500) at ../../akonadi/resourcebase.cpp:451
#40 0x000000000041c7f3 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:188
#41 0x00007fcb4d123ea5 in __libc_start_main (main=0x4156c0 <main(int, char**)>, argc=3, ubp_av=0x7ffff726e4e8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffff726e4d8) at libc-start.c:260
#42 0x0000000000415845 in _start ()

Possible duplicates by query: bug 319776, bug 315584, bug 312706, bug 312057, bug 308737.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-06-12 14:03:09 UTC

*** This bug has been marked as a duplicate of bug 319776 ***