Bug 324711 - Crash when scaning faces
Summary: Crash when scaning faces
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Faces-Engine (show other bugs)
Version: 3.5.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-09-09 18:47 UTC by tpotapov
Modified: 2019-12-23 06:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tpotapov 2013-09-09 18:47:32 UTC
Application: digikam (3.5.0)
KDE Platform Version: 4.11.1
Qt Version: 4.8.4
Operating System: Linux 3.8.0-30-generic i686
Distribution: Ubuntu 13.04

-- Information about the crash:
Digikam was crashed when I start 'scan and recognize faces'. I suppose that this problem occure when libkface database become grater than ~ 30Mb

The crash can be reproduced sometimes.

-- Backtrace:
Application: digiKam (digikam), signal: Aborted
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xa9c0d900 (LWP 3707))]

Thread 11 (Thread 0xa898ab40 (LWP 3717)):
#0  0xb7706424 in __kernel_vsyscall ()
#1  0xb45fa84b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb47ead7c in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb4acf0f0 in wait (time=4294967295, this=0x99627c0) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x9962734, mutex=0x9962730, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0x0820289a in Digikam::ScanController::run (this=0x9906280) at /home/timophey/digikam-software-compilation/core/digikam/database/scancontroller.cpp:725
#6  0xb4aceb18 in QThreadPrivate::start (arg=0x9906280) at thread/qthread_unix.cpp:338
#7  0xb45f6d78 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0xb47dd3de in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 10 (Thread 0xa7fffb40 (LWP 3718)):
#0  0xb2ac3a4a in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb2ac3d28 in g_mutex_lock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb2a80121 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2a80662 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2a80831 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb4c13c3f in QEventDispatcherGlib::processEvents (this=0xa7600468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb4be03ec in QEventLoop::processEvents (this=this@entry=0xa7fff068, flags=...) at kernel/qeventloop.cpp:149
#7  0xb4be06e1 in QEventLoop::exec (this=this@entry=0xa7fff068, flags=...) at kernel/qeventloop.cpp:204
#8  0xb4acbfec in QThread::exec (this=this@entry=0x9958498) at thread/qthread.cpp:542
#9  0xb4bbff2d in QInotifyFileSystemWatcherEngine::run (this=0x9958498) at io/qfilesystemwatcher_inotify.cpp:256
#10 0xb4aceb18 in QThreadPrivate::start (arg=0x9958498) at thread/qthread_unix.cpp:338
#11 0xb45f6d78 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb47dd3de in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 9 (Thread 0x98dfdb40 (LWP 4006)):
#0  0xb2a7d7b4 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb2a7fcad in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb2a805cf in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2a80831 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb4c13c3f in QEventDispatcherGlib::processEvents (this=0x879cd358, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0xb4be03ec in QEventLoop::processEvents (this=this@entry=0x98dfd078, flags=...) at kernel/qeventloop.cpp:149
#6  0xb4be06e1 in QEventLoop::exec (this=0x98dfd078, flags=...) at kernel/qeventloop.cpp:204
#7  0xb67c0618 in Digikam::WorkerObjectRunnable::run (this=0xd026e28) at /home/timophey/digikam-software-compilation/core/libs/threads/threadmanager.cpp:196
#8  0xb4ac1504 in QThreadPoolThread::run (this=0xb321020) at concurrent/qthreadpool.cpp:107
#9  0xb4aceb18 in QThreadPrivate::start (arg=0xb321020) at thread/qthread_unix.cpp:338
#10 0xb45f6d78 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0xb47dd3de in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 8 (Thread 0x88cb7b40 (LWP 4007)):
#0  0xb47eb120 in ?? () from /lib/i386-linux-gnu/libc.so.6
#1  0xb47cddb1 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb2a8f2db in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2a806d0 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2a80831 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb4c13c3f in QEventDispatcherGlib::processEvents (this=0x9cd55ce8, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb4be03ec in QEventLoop::processEvents (this=this@entry=0x88cb7078, flags=...) at kernel/qeventloop.cpp:149
#7  0xb4be06e1 in QEventLoop::exec (this=0x88cb7078, flags=...) at kernel/qeventloop.cpp:204
#8  0xb67c0618 in Digikam::WorkerObjectRunnable::run (this=0xcf64d40) at /home/timophey/digikam-software-compilation/core/libs/threads/threadmanager.cpp:196
#9  0xb4ac1504 in QThreadPoolThread::run (this=0xb4eb7e8) at concurrent/qthreadpool.cpp:107
#10 0xb4aceb18 in QThreadPrivate::start (arg=0xb4eb7e8) at thread/qthread_unix.cpp:338
#11 0xb45f6d78 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb47dd3de in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 7 (Thread 0x884b6b40 (LWP 4008)):
#0  0xb45f54a3 in __x86.get_pc_thunk.bx () from /lib/i386-linux-gnu/libpthread.so.0
#1  0xb45f8cdf in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb47eaf84 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#3  0xb2ac3d30 in g_mutex_lock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2a7fd2b in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb2a805cf in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb2a80831 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb4c13c3f in QEventDispatcherGlib::processEvents (this=0xa6c16000, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#8  0xb4be03ec in QEventLoop::processEvents (this=this@entry=0x884b6078, flags=...) at kernel/qeventloop.cpp:149
#9  0xb4be06e1 in QEventLoop::exec (this=0x884b6078, flags=...) at kernel/qeventloop.cpp:204
#10 0xb67c0618 in Digikam::WorkerObjectRunnable::run (this=0xcbebf08) at /home/timophey/digikam-software-compilation/core/libs/threads/threadmanager.cpp:196
#11 0xb4ac1504 in QThreadPoolThread::run (this=0xb4ec350) at concurrent/qthreadpool.cpp:107
#12 0xb4aceb18 in QThreadPrivate::start (arg=0xb4ec350) at thread/qthread_unix.cpp:338
#13 0xb45f6d78 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#14 0xb47dd3de in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 6 (Thread 0x894b8b40 (LWP 4009)):
[KCrash Handler]
#6  0xb7706424 in __kernel_vsyscall ()
#7  0xb471ab1f in raise () from /lib/i386-linux-gnu/libc.so.6
#8  0xb471e0b3 in abort () from /lib/i386-linux-gnu/libc.so.6
#9  0xb494c91d in __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/i386-linux-gnu/libstdc++.so.6
#10 0xb494a563 in ?? () from /usr/lib/i386-linux-gnu/libstdc++.so.6
#11 0xb494a59f in std::terminate() () from /usr/lib/i386-linux-gnu/libstdc++.so.6
#12 0xb494a885 in __cxa_rethrow () from /usr/lib/i386-linux-gnu/libstdc++.so.6
#13 0xb4ac16d2 in QThreadPoolThread::run (this=0xb4ebd20) at concurrent/qthreadpool.cpp:114
#14 0xb4aceb18 in QThreadPrivate::start (arg=0xb4ebd20) at thread/qthread_unix.cpp:338
#15 0xb45f6d78 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#16 0xb47dd3de in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 5 (Thread 0x9ccf6b40 (LWP 4010)):
#0  0xb7706424 in __kernel_vsyscall ()
#1  0xb47f08e2 in clock_gettime () from /lib/i386-linux-gnu/libc.so.6
#2  0xb4b2d0d5 in do_gettime (frac=0x9ccf5dc0, sec=0x9ccf5db8) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0xb4c1480e in QTimerInfoList::updateCurrentTime (this=this@entry=0x9cd3232c) at kernel/qeventdispatcher_unix.cpp:354
#5  0xb4c14b9a in QTimerInfoList::timerWait (this=0x9cd3232c, tm=...) at kernel/qeventdispatcher_unix.cpp:461
#6  0xb4c13373 in timerSourcePrepareHelper (src=<optimized out>, timeout=0x9ccf5eec) at kernel/qeventdispatcher_glib.cpp:136
#7  0xb4c1340d in timerSourcePrepare (source=0x9cd322f8, timeout=0x9ccf5eec) at kernel/qeventdispatcher_glib.cpp:169
#8  0xb2a7fd21 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb2a805cf in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb2a80831 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#11 0xb4c13c3f in QEventDispatcherGlib::processEvents (this=0x9cd2e418, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0xb4be03ec in QEventLoop::processEvents (this=this@entry=0x9ccf6078, flags=...) at kernel/qeventloop.cpp:149
#13 0xb4be06e1 in QEventLoop::exec (this=0x9ccf6078, flags=...) at kernel/qeventloop.cpp:204
#14 0xb67c0618 in Digikam::WorkerObjectRunnable::run (this=0xce9cc68) at /home/timophey/digikam-software-compilation/core/libs/threads/threadmanager.cpp:196
#15 0xb4ac1504 in QThreadPoolThread::run (this=0xb4ead30) at concurrent/qthreadpool.cpp:107
#16 0xb4aceb18 in QThreadPrivate::start (arg=0xb4ead30) at thread/qthread_unix.cpp:338
#17 0xb45f6d78 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#18 0xb47dd3de in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 4 (Thread 0x96d08b40 (LWP 4017)):
#0  0xb7706424 in __kernel_vsyscall ()
#1  0xb47d8377 in syscall () from /lib/i386-linux-gnu/libc.so.6
#2  0xb0730c06 in ?? () from /usr/lib/libtbb.so.2
#3  0xb0730c45 in ?? () from /usr/lib/libtbb.so.2
#4  0xb45f6d78 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#5  0xb47dd3de in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0x96b07b40 (LWP 4018)):
#0  0xb7706424 in __kernel_vsyscall ()
#1  0xb47d8377 in syscall () from /lib/i386-linux-gnu/libc.so.6
#2  0xb0730c06 in ?? () from /usr/lib/libtbb.so.2
#3  0xb0730c45 in ?? () from /usr/lib/libtbb.so.2
#4  0xb45f6d78 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#5  0xb47dd3de in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0x96906b40 (LWP 4019)):
#0  0xb7706424 in __kernel_vsyscall ()
#1  0xb47d8377 in syscall () from /lib/i386-linux-gnu/libc.so.6
#2  0xb0730c06 in ?? () from /usr/lib/libtbb.so.2
#3  0xb0730c45 in ?? () from /usr/lib/libtbb.so.2
#4  0xb45f6d78 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#5  0xb47dd3de in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xa9c0d900 (LWP 3707)):
#0  0xb7706424 in __kernel_vsyscall ()
#1  0xb45fa84b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb47ead7c in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb4acf0f0 in wait (time=4294967295, this=0x9b1e718) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=this@entry=0x99527f0, mutex=0x99527dc, time=time@entry=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0xb4ac0d33 in QThreadPoolPrivate::waitForDone (this=0x9952790, msecs=msecs@entry=-1) at concurrent/qthreadpool.cpp:298
#6  0xb4ac27cc in QThreadPool::~QThreadPool (this=0x9b44ae8, __in_chrg=<optimized out>) at concurrent/qthreadpool.cpp:440
#7  0xb4ac2832 in QThreadPool::~QThreadPool (this=0x9b44ae8, __in_chrg=<optimized out>) at concurrent/qthreadpool.cpp:442
#8  0xb4bf5b49 in QObjectPrivate::deleteChildren (this=this@entry=0x9c15538) at kernel/qobject.cpp:1907
#9  0xb4bfce1c in QObject::~QObject (this=0x994d7c8, __in_chrg=<optimized out>) at kernel/qobject.cpp:926
#10 0xb67c09f1 in Digikam::ThreadManager::~ThreadManager (this=0x994d7c8, __in_chrg=<optimized out>) at /home/timophey/digikam-software-compilation/core/libs/threads/threadmanager.cpp:257
#11 0xb67c12b7 in Digikam::ThreadManagerCreator::~ThreadManagerCreator (this=0x994d7c8, __in_chrg=<optimized out>) at /home/timophey/digikam-software-compilation/core/libs/threads/threadmanager.cpp:236
#12 0xb67c0890 in destroy () at /home/timophey/digikam-software-compilation/core/libs/threads/threadmanager.cpp:241
#13 0xb65c87e1 in KCleanUpGlobalStatic::~KCleanUpGlobalStatic (this=0xb6a85220 <_ZZN7Digikam5._157ptEvE13cleanUpObject>, __in_chrg=<optimized out>) at /usr/include/kglobal.h:62
#14 0xb471f7c1 in ?? () from /lib/i386-linux-gnu/libc.so.6
#15 0xb471f84d in exit () from /lib/i386-linux-gnu/libc.so.6
#16 0xb51ce3b8 in qt_xio_errhandler () at kernel/qapplication_x11.cpp:782
#17 0xb5ccc5b9 in KApplication::xioErrhandler(_XDisplay*) () from /usr/lib/libkdeui.so.5
#18 0xb5ccc5f4 in ?? () from /usr/lib/libkdeui.so.5
#19 0xb4491b44 in _XIOError () from /usr/lib/i386-linux-gnu/libX11.so.6
#20 0xb448f39f in _XEventsQueued () from /usr/lib/i386-linux-gnu/libX11.so.6
#21 0xb4480030 in XEventsQueued () from /usr/lib/i386-linux-gnu/libX11.so.6
#22 0xb520f35a in x11EventSourceCheck (s=0x9802198) at kernel/qguieventdispatcher_glib.cpp:85
#23 0xb2a80117 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#24 0xb2a80662 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#25 0xb2a80831 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#26 0xb4c13c21 in QEventDispatcherGlib::processEvents (this=this@entry=0x9794160, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#27 0xb520fa0a in QGuiEventDispatcherGlib::processEvents (this=0x9794160, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#28 0xb4be03ec in QEventLoop::processEvents (this=this@entry=0xbf970198, flags=...) at kernel/qeventloop.cpp:149
#29 0xb4be06e1 in QEventLoop::exec (this=this@entry=0xbf970198, flags=...) at kernel/qeventloop.cpp:204
#30 0xb4be63fa in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#31 0xb5156fc4 in QApplication::exec () at kernel/qapplication.cpp:3828
#32 0x082f3ea6 in main (argc=1, argv=0xbf9704d4) at /home/timophey/digikam-software-compilation/core/digikam/main/main.cpp:235

The reporter indicates this bug may be a duplicate of or related to bug 321295.

Possible duplicates by query: bug 324516, bug 324442, bug 324093, bug 323993, bug 323964.

Reported using DrKonqi
Comment 1 caulier.gilles 2013-09-09 20:25:53 UTC

*** This bug has been marked as a duplicate of bug 321295 ***
Comment 2 caulier.gilles 2019-12-23 06:22:11 UTC
Problem is fixed with new 7.0.0-beta1 through this long story from this bug

https://bugs.kde.org/show_bug.cgi?id=399923

You can test digiKam 7.0.0-beta1 with bundle available here:

https://download.kde.org/unstable/digikam/

Don't hesitate to give us a fresh feedback about his entry.

Thanks in advance

Gilles Caulier