Bug 323993 - Crash while naming multiple people at the same time in one picture
Summary: Crash while naming multiple people at the same time in one picture
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Faces-Engine (show other bugs)
Version: 3.3.0
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-08-25 05:41 UTC by Steven
Modified: 2017-07-26 16:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.7.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steven 2013-08-25 05:41:24 UTC
Application: digikam (3.3.0)
KDE Platform Version: 4.11.00
Qt Version: 4.8.5
Operating System: Linux 3.7.10-1.16-desktop x86_64
Distribution: "openSUSE 12.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I was adding face tags in picture preview mode.  It often (but not always) crashes after drawing a rectangle around a face then trying to name it without going back to thumbnail mode first.  This crash can most often be avoided by drawing your rectangle first, then going back to icon mode and then name the people in the photo from there.

-- Backtrace:
Application: digiKam (digikam), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f7c75120800 (LWP 2494))]

Thread 8 (Thread 0x7f7c52d61700 (LWP 2495)):
#0  0x00007f7c6c78d964 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f7c702b164b in wait (time=18446744073709551615, this=0x2306090) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2305f98, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00000000005db161 in Digikam::ScanController::run (this=0x2305d30) at /usr/src/debug/digikam-3.3.0/core/digikam/database/scancontroller.cpp:725
#4  0x00007f7c702b10ec in QThreadPrivate::start (arg=0x2305d30) at thread/qthread_unix.cpp:338
#5  0x00007f7c6c789e0f in start_thread () from /lib64/libpthread.so.0
#6  0x00007f7c6e81a7dd in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7f7c52560700 (LWP 2496)):
#0  0x00007f7c665fca90 in g_mutex_unlock () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f7c665bf392 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f7c665bf9cb in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f7c665bfbc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f7c703db5d6 in QEventDispatcherGlib::processEvents (this=0x7f7c440008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#5  0x00007f7c703abbef in QEventLoop::processEvents (this=this@entry=0x7f7c5255fd50, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f7c703abe78 in QEventLoop::exec (this=0x7f7c5255fd50, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f7c702ae110 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#8  0x00007f7c7038c3af in QInotifyFileSystemWatcherEngine::run (this=0x2308450) at io/qfilesystemwatcher_inotify.cpp:256
#9  0x00007f7c702b10ec in QThreadPrivate::start (arg=0x2308450) at thread/qthread_unix.cpp:338
#10 0x00007f7c6c789e0f in start_thread () from /lib64/libpthread.so.0
#11 0x00007f7c6e81a7dd in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f7c51d5f700 (LWP 2498)):
#0  0x00007f7c6c78d964 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f7c702b164b in wait (time=18446744073709551615, this=0x2514c00) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x284c438, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f7c726940b9 in Digikam::ParkingThread::run (this=0x284c420) at /usr/src/debug/digikam-3.3.0/core/libs/threads/threadmanager.cpp:119
#4  0x00007f7c702b10ec in QThreadPrivate::start (arg=0x284c420) at thread/qthread_unix.cpp:338
#5  0x00007f7c6c789e0f in start_thread () from /lib64/libpthread.so.0
#6  0x00007f7c6e81a7dd in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f7c42ee9700 (LWP 2499)):
#0  0x00007f7c6c78ce18 in __pthread_mutex_unlock_usercnt () from /lib64/libpthread.so.0
#1  0x00007f7c665fcaa1 in g_mutex_unlock () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f7c665bf32b in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f7c665bf9cb in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f7c665bfbc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007f7c703db5d6 in QEventDispatcherGlib::processEvents (this=0x7f7c3c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#6  0x00007f7c703abbef in QEventLoop::processEvents (this=this@entry=0x7f7c42ee8d50, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f7c703abe78 in QEventLoop::exec (this=0x7f7c42ee8d50, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f7c702ae110 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#9  0x00007f7c7038c3af in QInotifyFileSystemWatcherEngine::run (this=0x241b3e0) at io/qfilesystemwatcher_inotify.cpp:256
#10 0x00007f7c702b10ec in QThreadPrivate::start (arg=0x241b3e0) at thread/qthread_unix.cpp:338
#11 0x00007f7c6c789e0f in start_thread () from /lib64/libpthread.so.0
#12 0x00007f7c6e81a7dd in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f7c31a88700 (LWP 2513)):
#0  0x00007f7c665bd62c in ?? () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f7c665bf2b7 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f7c665bf9cb in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f7c665bfbc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f7c703db5d6 in QEventDispatcherGlib::processEvents (this=0x7f7c080008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#5  0x00007f7c703abbef in QEventLoop::processEvents (this=this@entry=0x7f7c31a87d20, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f7c703abe78 in QEventLoop::exec (this=0x7f7c31a87d20, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f7c7269371b in Digikam::WorkerObjectRunnable::run (this=0x7012c60) at /usr/src/debug/digikam-3.3.0/core/libs/threads/threadmanager.cpp:196
#8  0x00007f7c702a4c9d in QThreadPoolThread::run (this=0x47e9560) at concurrent/qthreadpool.cpp:107
#9  0x00007f7c702b10ec in QThreadPrivate::start (arg=0x47e9560) at thread/qthread_unix.cpp:338
#10 0x00007f7c6c789e0f in start_thread () from /lib64/libpthread.so.0
#11 0x00007f7c6e81a7dd in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f7bfffff700 (LWP 2516)):
#0  qcoreVariantHandler () at kernel/qvariant.cpp:1193
#1  0x00007f7c6f50ef90 in construct (x=x@entry=0x7f7bf0037510, copy=0x7f7bffffe880) at kernel/qguivariant.cpp:182
#2  0x00007f7c703cfc84 in QVariant::operator= (this=0x7f7bf0037510, variant=...) at kernel/qvariant.cpp:1815
#3  0x00007f7c74d42d04 in QSqlResult::bindValue(int, QVariant const&, QFlags<QSql::ParamTypeFlag>) () from /usr/lib64/libQtSql.so.4
#4  0x00007f7c74d3655c in QSqlQuery::bindValue(int, QVariant const&, QFlags<QSql::ParamTypeFlag>) () from /usr/lib64/libQtSql.so.4
#5  0x00007f7c7264f453 in Digikam::DatabaseCoreBackend::execQuery (this=this@entry=0x2335730, query=..., boundValue1=..., boundValue2=..., boundValue3=..., boundValue4=...) at /usr/src/debug/digikam-3.3.0/core/libs/database/core/databasecorebackend.cpp:1082
#6  0x00007f7c7264f50a in Digikam::DatabaseCoreBackend::execQuery (this=this@entry=0x2335730, sql=..., boundValue1=..., boundValue2=..., boundValue3=..., boundValue4=...) at /usr/src/debug/digikam-3.3.0/core/libs/database/core/databasecorebackend.cpp:1030
#7  0x00007f7c7264f565 in Digikam::DatabaseCoreBackend::execSql (this=0x2335730, sql=..., boundValue1=..., boundValue2=..., boundValue3=..., boundValue4=..., values=0x0, lastInsertId=0x7f7bffffe860) at /usr/src/debug/digikam-3.3.0/core/libs/database/core/databasecorebackend.cpp:928
#8  0x00007f7c7265aafd in Digikam::ThumbnailDB::insertThumbnail (this=0x233a150, info=..., lastInsertId=0x7f7bffffe9f0) at /usr/src/debug/digikam-3.3.0/core/libs/database/core/thumbnaildb.cpp:260
#9  0x00007f7c7267f014 in Digikam::ThumbnailCreator::storeInDatabase (this=this@entry=0x24191f0, info=..., image=...) at /usr/src/debug/digikam-3.3.0/core/libs/threadimageio/thumbnailcreator.cpp:755
#10 0x00007f7c72682429 in Digikam::ThumbnailCreator::load (this=0x24191f0, path=..., rect=..., pregenerate=pregenerate@entry=true) at /usr/src/debug/digikam-3.3.0/core/libs/threadimageio/thumbnailcreator.cpp:267
#11 0x00007f7c726832dc in Digikam::ThumbnailCreator::pregenerate (this=<optimized out>, path=...) at /usr/src/debug/digikam-3.3.0/core/libs/threadimageio/thumbnailcreator.cpp:183
#12 0x00007f7c7268fac0 in Digikam::ThumbnailLoadingTask::execute (this=0x7161fe0) at /usr/src/debug/digikam-3.3.0/core/libs/threadimageio/thumbnailtask.cpp:82
#13 0x00007f7c7266a0de in Digikam::LoadSaveThread::run (this=0x24ea110) at /usr/src/debug/digikam-3.3.0/core/libs/threadimageio/loadsavethread.cpp:136
#14 0x00007f7c7269586e in Digikam::DynamicThread::DynamicThreadPriv::run (this=0x25834e0) at /usr/src/debug/digikam-3.3.0/core/libs/threads/dynamicthread.cpp:186
#15 0x00007f7c702a4c9d in QThreadPoolThread::run (this=0x45fba30) at concurrent/qthreadpool.cpp:107
#16 0x00007f7c702b10ec in QThreadPrivate::start (arg=0x45fba30) at thread/qthread_unix.cpp:338
#17 0x00007f7c6c789e0f in start_thread () from /lib64/libpthread.so.0
#18 0x00007f7c6e81a7dd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f7beffff700 (LWP 2517)):
#0  0x00007f7c6c78be14 in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00007f7c665fca71 in g_mutex_lock () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f7c665bfbb0 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f7c703db5d6 in QEventDispatcherGlib::processEvents (this=0x7f7bf40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#4  0x00007f7c703abbef in QEventLoop::processEvents (this=this@entry=0x7f7befffed20, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f7c703abe78 in QEventLoop::exec (this=0x7f7befffed20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f7c7269371b in Digikam::WorkerObjectRunnable::run (this=0x4600230) at /usr/src/debug/digikam-3.3.0/core/libs/threads/threadmanager.cpp:196
#7  0x00007f7c702a4c9d in QThreadPoolThread::run (this=0x45fbe20) at concurrent/qthreadpool.cpp:107
#8  0x00007f7c702b10ec in QThreadPrivate::start (arg=0x45fbe20) at thread/qthread_unix.cpp:338
#9  0x00007f7c6c789e0f in start_thread () from /lib64/libpthread.so.0
#10 0x00007f7c6e81a7dd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f7c75120800 (LWP 2494)):
[KCrash Handler]
#6  0x00007f7c6e7673d5 in raise () from /lib64/libc.so.6
#7  0x00007f7c6e768858 in abort () from /lib64/libc.so.6
#8  0x00007f7c6e7a707b in __libc_message () from /lib64/libc.so.6
#9  0x00007f7c6e7acbf6 in malloc_printerr () from /lib64/libc.so.6
#10 0x00007f7c6e7ad973 in _int_free () from /lib64/libc.so.6
#11 0x00007f7c720e8d69 in node_destruct (n=0x6e1a7b8, this=<optimized out>) at /usr/include/QtCore/qlist.h:388
#12 erase (alast=..., afirst=..., this=0x262ca78) at /usr/include/QtCore/qlist.h:811
#13 Digikam::ImageModel::removeRowPairs (this=this@entry=0x2610920, toRemove=...) at /usr/src/debug/digikam-3.3.0/core/libs/models/imagemodel.cpp:1025
#14 0x00007f7c720eac8d in Digikam::ImageModel::finishIncrementalRefresh (this=0x2610920) at /usr/src/debug/digikam-3.3.0/core/libs/models/imagemodel.cpp:844
#15 0x000000000057a165 in Digikam::ImageAlbumModel::slotResult (this=0x2610920, job=<optimized out>) at /usr/src/debug/digikam-3.3.0/core/libs/models/imagealbummodel.cpp:307
#16 0x00007f7c703c244f in QMetaObject::activate (sender=0x70a4590, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff1a9e43a0) at kernel/qobject.cpp:3556
#17 0x00007f7c7083b8d2 in KJob::result (this=this@entry=0x70a4590, _t1=_t1@entry=0x70a4590) at /usr/src/debug/kdelibs-4.11.0/build/kdecore/kjob.moc:207
#18 0x00007f7c7083b910 in KJob::emitResult (this=0x70a4590) at /usr/src/debug/kdelibs-4.11.0/kdecore/jobs/kjob.cpp:318
#19 0x00007f7c715656d2 in KIO::SimpleJob::slotFinished (this=this@entry=0x70a4590) at /usr/src/debug/kdelibs-4.11.0/kio/kio/job.cpp:496
#20 0x00007f7c7156cdc2 in KIO::TransferJob::slotFinished (this=0x70a4590) at /usr/src/debug/kdelibs-4.11.0/kio/kio/job.cpp:1099
#21 0x00007f7c703c244f in QMetaObject::activate (sender=0x3939940, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3556
#22 0x00007f7c71609101 in KIO::SlaveInterface::dispatch (this=0x3939940, _cmd=104, rawdata=...) at /usr/src/debug/kdelibs-4.11.0/kio/kio/slaveinterface.cpp:176
#23 0x00007f7c716069da in KIO::SlaveInterface::dispatch (this=0x3939940) at /usr/src/debug/kdelibs-4.11.0/kio/kio/slaveinterface.cpp:92
#24 0x00007f7c715faf3e in KIO::Slave::gotInput (this=0x3939940) at /usr/src/debug/kdelibs-4.11.0/kio/kio/slave.cpp:344
#25 0x00007f7c703c244f in QMetaObject::activate (sender=0x63d5e80, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3556
#26 0x00007f7c7153a332 in dequeue (this=<optimized out>) at /usr/src/debug/kdelibs-4.11.0/kio/kio/connection.cpp:82
#27 KIO::ConnectionPrivate::dequeue (this=0x6bbb040) at /usr/src/debug/kdelibs-4.11.0/kio/kio/connection.cpp:71
#28 0x00007f7c703c192e in QObject::event (this=0x63d5e80, e=<optimized out>) at kernel/qobject.cpp:1203
#29 0x00007f7c6f4d892c in QApplicationPrivate::notify_helper (this=this@entry=0x2119f90, receiver=receiver@entry=0x63d5e80, e=e@entry=0x7129300) at kernel/qapplication.cpp:4562
#30 0x00007f7c6f4dcdab in QApplication::notify (this=0x7fff1a9e5a20, receiver=0x63d5e80, e=0x7129300) at kernel/qapplication.cpp:4423
#31 0x00007f7c70e10f76 in KApplication::notify (this=0x7fff1a9e5a20, receiver=0x63d5e80, event=0x7129300) at /usr/src/debug/kdelibs-4.11.0/kdeui/kernel/kapplication.cpp:311
#32 0x00007f7c703acf3e in QCoreApplication::notifyInternal (this=0x7fff1a9e5a20, receiver=receiver@entry=0x63d5e80, event=event@entry=0x7129300) at kernel/qcoreapplication.cpp:949
#33 0x00007f7c703b08a1 in sendEvent (event=0x7129300, receiver=0x63d5e80) at kernel/qcoreapplication.h:231
#34 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x208e380) at kernel/qcoreapplication.cpp:1573
#35 0x00007f7c703db423 in sendPostedEvents () at kernel/qcoreapplication.h:236
#36 postEventSourceDispatch (s=0x2115c60) at kernel/qeventdispatcher_glib.cpp:280
#37 0x00007f7c665bf7d5 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#38 0x00007f7c665bfb08 in ?? () from /usr/lib64/libglib-2.0.so.0
#39 0x00007f7c665bfbc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#40 0x00007f7c703db5b6 in QEventDispatcherGlib::processEvents (this=0x20937e0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#41 0x00007f7c6f578e0e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00007f7c703abbef in QEventLoop::processEvents (this=this@entry=0x7fff1a9e5410, flags=...) at kernel/qeventloop.cpp:149
#43 0x00007f7c703abe78 in QEventLoop::exec (this=0x7fff1a9e5410, flags=...) at kernel/qeventloop.cpp:204
#44 0x00007f7c703b0bb8 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1221
#45 0x000000000049ba3b in main (argc=5, argv=0x7fff1a9e5c58) at /usr/src/debug/digikam-3.3.0/core/digikam/main/main.cpp:235

The reporter indicates this bug may be a duplicate of or related to bug 323654.

Possible duplicates by query: bug 323964, bug 323828, bug 323654, bug 323428, bug 322022.

Reported using DrKonqi
Comment 1 caulier.gilles 2013-08-25 05:54:17 UTC

*** This bug has been marked as a duplicate of bug 323964 ***
Comment 2 caulier.gilles 2017-07-16 22:00:36 UTC
This problem is not reproducible since 5.0.0 as all digiKam KIO-slaves was been
replaced by a multithreaded interface to play with database.