Bug 324442 - akonadi-imap-resource crashed after accepting certificate
Summary: akonadi-imap-resource crashed after accepting certificate
Status: RESOLVED DUPLICATE of bug 279113
Alias: None
Product: Akonadi
Classification: Unclassified
Component: IMAP resource (show other bugs)
Version: 4.10
Platform: Debian stable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-09-03 06:55 UTC by Valery Mamonov
Modified: 2013-09-03 08:10 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Valery Mamonov 2013-09-03 06:55:51 UTC
Application: akonadi_imap_resource (4.10)
KDE Platform Version: 4.10.5
Qt Version: 4.8.5
Operating System: Linux 3.10-10.dmz.1-liquorix-amd64 x86_64
Distribution: Debian GNU/Linux experimental (sid)

-- Information about the crash:
- What I was doing when the application crashed:

Logged in, launched kmail, it reported about expired certificate, for some time dialog window was unresponsive, i accepted certificate and ta-da! akonadi-imap-resource crashed.

The crash can be reproduced sometimes.

-- Backtrace:
Application: vmamonov-imap1 типа Почтовый сервер IMAP (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f41bc83d780 (LWP 27208))]

Thread 4 (Thread 0x7f41b73d2700 (LWP 28638)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:238
#1  0x0000003b1de7b424 in wait (time=30000, this=0x7f41b0012b90) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=mutex@entry=0x7f41b0014148, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x0000003b1de6e8a5 in QThreadPoolThread::run (this=0x7f41b0014300) at concurrent/qthreadpool.cpp:141
#4  0x0000003b1de7af6f in QThreadPrivate::start (arg=0x7f41b0014300) at thread/qthread_unix.cpp:338
#5  0x0000003ea6007e0e in start_thread (arg=0x7f41b73d2700) at pthread_create.c:311
#6  0x0000003ea58e893d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7f41b7bd3700 (LWP 28643)):
#0  0x0000003ea58dd19d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x0000003ea88485c4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x0000003ea88486cc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x0000003b1dfa7d06 in QEventDispatcherGlib::processEvents (this=0x7f41b003f4f0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#4  0x0000003b1df797bf in QEventLoop::processEvents (this=this@entry=0x7f41b7bd2dd0, flags=...) at kernel/qeventloop.cpp:149
#5  0x0000003b1df79ab5 in QEventLoop::exec (this=this@entry=0x7f41b7bd2dd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x0000003b1de788cf in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#7  0x0000003b32241eda in ?? () from /usr/lib/libkimap.so.4
#8  0x0000003b1de7af6f in QThreadPrivate::start (arg=0x12d1e10) at thread/qthread_unix.cpp:338
#9  0x0000003ea6007e0e in start_thread (arg=0x7f41b7bd3700) at pthread_create.c:311
#10 0x0000003ea58e893d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f41b668b700 (LWP 28673)):
#0  0x0000003ea58dd19d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x0000003ea88485c4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x0000003ea88486cc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x0000003b1dfa7d06 in QEventDispatcherGlib::processEvents (this=0x7f41ac023970, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#4  0x0000003b1df797bf in QEventLoop::processEvents (this=this@entry=0x7f41b668add0, flags=...) at kernel/qeventloop.cpp:149
#5  0x0000003b1df79ab5 in QEventLoop::exec (this=this@entry=0x7f41b668add0, flags=...) at kernel/qeventloop.cpp:204
#6  0x0000003b1de788cf in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#7  0x0000003b32241eda in ?? () from /usr/lib/libkimap.so.4
#8  0x0000003b1de7af6f in QThreadPrivate::start (arg=0x123fd30) at thread/qthread_unix.cpp:338
#9  0x0000003ea6007e0e in start_thread (arg=0x7f41b668b700) at pthread_create.c:311
#10 0x0000003ea58e893d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f41bc83d780 (LWP 27208)):
[KCrash Handler]
#5  0x0000003b1df85192 in QMetaObject::invokeMethod (obj=0x3b1e2e0940 <QVectorData::shared_null>, member=<optimized out>, type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1166
#6  0x0000003b3223ca27 in KIMAP::SessionPrivate::handleSslError(KSslErrorUiData const&) () from /usr/lib/libkimap.so.4
#7  0x0000003b1df930ae in QObject::event (this=0x123d490, e=<optimized out>) at kernel/qobject.cpp:1194
#8  0x0000003b23dc870c in QApplicationPrivate::notify_helper (this=this@entry=0xf90260, receiver=receiver@entry=0x123d490, e=e@entry=0x7f41b01fee20) at kernel/qapplication.cpp:4567
#9  0x0000003b23dced80 in QApplication::notify (this=0x7fff587ef0c0, receiver=0x123d490, e=0x7f41b01fee20) at kernel/qapplication.cpp:4353
#10 0x0000003b25c41cfa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#11 0x0000003b1df7ab5d in QCoreApplication::notifyInternal (this=0x7fff587ef0c0, receiver=receiver@entry=0x123d490, event=event@entry=0x7f41b01fee20) at kernel/qcoreapplication.cpp:949
#12 0x0000003b1df7e0bf in sendEvent (event=0x7f41b01fee20, receiver=0x123d490) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#13 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0xf4ef60) at kernel/qcoreapplication.cpp:1573
#14 0x0000003b1df7e563 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1466
#15 0x0000003b1dfa8423 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#16 postEventSourceDispatch (s=0xf7e4e0) at kernel/qeventdispatcher_glib.cpp:280
#17 0x0000003ea88482d6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#18 0x0000003ea8848628 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x0000003ea88486cc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x0000003b1dfa7d06 in QEventDispatcherGlib::processEvents (this=0xf54bc0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#21 0x0000003b23e66846 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#22 0x0000003b1df797bf in QEventLoop::processEvents (this=this@entry=0x7fff587ee250, flags=...) at kernel/qeventloop.cpp:149
#23 0x0000003b1df79ab5 in QEventLoop::exec (this=this@entry=0x7fff587ee250, flags=...) at kernel/qeventloop.cpp:204
#24 0x0000003b2426b8bc in QDialog::exec (this=0x107a420) at dialogs/qdialog.cpp:562
#25 0x0000003b25bb5202 in KMessageBox::createKMessageBox(KDialog*, QIcon const&, QString const&, QStringList const&, QString const&, bool*, QFlags<KMessageBox::Option>, QString const&, QMessageBox::Icon) () from /usr/lib/libkdeui.so.5
#26 0x0000003b25bb5441 in KMessageBox::createKMessageBox(KDialog*, QMessageBox::Icon, QString const&, QStringList const&, QString const&, bool*, QFlags<KMessageBox::Option>, QString const&) () from /usr/lib/libkdeui.so.5
#27 0x0000003b25bb8478 in KMessageBox::warningYesNoCancelListWId(unsigned long, QString const&, QStringList const&, QString const&, KGuiItem const&, KGuiItem const&, KGuiItem const&, QString const&, QFlags<KMessageBox::Option>) () from /usr/lib/libkdeui.so.5
#28 0x0000003b25bb86ba in KMessageBox::warningYesNoCancelList(QWidget*, QString const&, QStringList const&, QString const&, KGuiItem const&, KGuiItem const&, KGuiItem const&, QString const&, QFlags<KMessageBox::Option>) () from /usr/lib/libkdeui.so.5
#29 0x0000003b25bb8722 in KMessageBox::warningYesNoCancel(QWidget*, QString const&, QString const&, KGuiItem const&, KGuiItem const&, KGuiItem const&, QString const&, QFlags<KMessageBox::Option>) () from /usr/lib/libkdeui.so.5
#30 0x0000003b280153b8 in KIO::SslUi::askIgnoreSslErrors(KSslErrorUiData const&, KIO::SslUi::RulesStorage) () from /usr/lib/libkio.so.5
#31 0x0000003b3223c93a in KIMAP::SessionPrivate::handleSslError(KSslErrorUiData const&) () from /usr/lib/libkimap.so.4
#32 0x0000003b1df930ae in QObject::event (this=0x11f5630, e=<optimized out>) at kernel/qobject.cpp:1194
#33 0x0000003b23dc870c in QApplicationPrivate::notify_helper (this=this@entry=0xf90260, receiver=receiver@entry=0x11f5630, e=e@entry=0x7f41b00cfb50) at kernel/qapplication.cpp:4567
#34 0x0000003b23dced80 in QApplication::notify (this=0x7fff587ef0c0, receiver=0x11f5630, e=0x7f41b00cfb50) at kernel/qapplication.cpp:4353
#35 0x0000003b25c41cfa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#36 0x0000003b1df7ab5d in QCoreApplication::notifyInternal (this=0x7fff587ef0c0, receiver=receiver@entry=0x11f5630, event=event@entry=0x7f41b00cfb50) at kernel/qcoreapplication.cpp:949
#37 0x0000003b1df7e0bf in sendEvent (event=0x7f41b00cfb50, receiver=0x11f5630) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#38 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0xf4ef60) at kernel/qcoreapplication.cpp:1573
#39 0x0000003b1df7e563 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1466
#40 0x0000003b1dfa8423 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#41 postEventSourceDispatch (s=0xf7e4e0) at kernel/qeventdispatcher_glib.cpp:280
#42 0x0000003ea88482d6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#43 0x0000003ea8848628 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#44 0x0000003ea88486cc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#45 0x0000003b1dfa7ce5 in QEventDispatcherGlib::processEvents (this=0xf54bc0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#46 0x0000003b23e66846 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#47 0x0000003b1df797bf in QEventLoop::processEvents (this=this@entry=0x7fff587ef030, flags=...) at kernel/qeventloop.cpp:149
#48 0x0000003b1df79ab5 in QEventLoop::exec (this=this@entry=0x7fff587ef030, flags=...) at kernel/qeventloop.cpp:204
#49 0x0000003b1df7f0fb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1221
#50 0x0000003b36b52973 in Akonadi::ResourceBase::init(Akonadi::ResourceBase*) () from /usr/lib/libakonadi-kde.so.4
#51 0x000000000041c413 in _start ()

This bug may be a duplicate of or related to bug 279113.

Possible duplicates by query: bug 324233, bug 323805, bug 322181, bug 319033, bug 317386.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-09-03 08:10:45 UTC

*** This bug has been marked as a duplicate of bug 279113 ***