Bug 324516 - digiKam crashed after switching display mode from thumbnails to table
Summary: digiKam crashed after switching display mode from thumbnails to table
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Thumbs-Engine (show other bugs)
Version: 3.3.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-09-04 21:47 UTC by Alexander Servirog
Modified: 2019-08-15 15:22 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.3.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Servirog 2013-09-04 21:47:16 UTC
Application: digikam (3.3.0)
KDE Platform Version: 4.11.00
Qt Version: 4.8.4
Operating System: Linux 3.11.0-4-generic x86_64
Distribution: Ubuntu Saucy Salamander (development branch)

-- Information about the crash:
- What I was doing when the application crashed:
I started batch conversion of around 1k of photos, saving it to original album, than
switched to the main window (which was displaing the album that was being converted in the background) and
changed the display mode from thumbnails to table after that digikam crashes
I tried 3 times to reproduce this bug and all 3 times was successful.

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f98ac920a80 (LWP 2320))]

Thread 8 (Thread 0x7f9884762700 (LWP 2324)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f98a7183406 in wait (time=18446744073709551615, this=0x1ee32d0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x1ee31e0, mutex=mutex@entry=0x1ee31d8, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00000000005d363e in Digikam::ScanController::run (this=0x1ee2f70) at /build/buildd/digikam-3.3.0/core/digikam/database/scancontroller.cpp:725
#4  0x00007f98a7182f2f in QThreadPrivate::start (arg=0x1ee2f70) at thread/qthread_unix.cpp:338
#5  0x00007f98a16fcf6e in start_thread (arg=0x7f9884762700) at pthread_create.c:311
#6  0x00007f98a63a1e2d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 7 (Thread 0x7f9883f61700 (LWP 2325)):
#0  0x00007f98a170005f in __pthread_mutex_unlock_usercnt (mutex=0x7f9874000a60, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  0x00007f989ed0e551 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f989ecce571 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f989ecce6cc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f98a72afa76 in QEventDispatcherGlib::processEvents (this=0x7f98740008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f98a72815ef in QEventLoop::processEvents (this=this@entry=0x7f9883f60ab0, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f98a72818e5 in QEventLoop::exec (this=this@entry=0x7f9883f60ab0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f98a718088f in QThread::exec (this=this@entry=0x1ee5760) at thread/qthread.cpp:542
#8  0x00007f98a7262d13 in QInotifyFileSystemWatcherEngine::run (this=0x1ee5760) at io/qfilesystemwatcher_inotify.cpp:265
#9  0x00007f98a7182f2f in QThreadPrivate::start (arg=0x1ee5760) at thread/qthread_unix.cpp:338
#10 0x00007f98a16fcf6e in start_thread (arg=0x7f9883f61700) at pthread_create.c:311
#11 0x00007f98a63a1e2d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 6 (Thread 0x7f9883760700 (LWP 2327)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f98a7183406 in wait (time=18446744073709551615, this=0x2110040) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x2111620, mutex=mutex@entry=0x2111618, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f98aa20ec7a in Digikam::ParkingThread::run (this=0x2111600) at /build/buildd/digikam-3.3.0/core/libs/threads/threadmanager.cpp:119
#4  0x00007f98a7182f2f in QThreadPrivate::start (arg=0x2111600) at thread/qthread_unix.cpp:338
#5  0x00007f98a16fcf6e in start_thread (arg=0x7f9883760700) at pthread_create.c:311
#6  0x00007f98a63a1e2d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 5 (Thread 0x7f9867fff700 (LWP 2394)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f98a7183406 in wait (time=18446744073709551615, this=0x33f13f0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x33efc80, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f98aa65f591 in KDcrawIface::RActionThreadBase::run() () from /usr/lib/libkdcraw.so.22
#4  0x00007f98a7182f2f in QThreadPrivate::start (arg=0x33f1100) at thread/qthread_unix.cpp:338
#5  0x00007f98a16fcf6e in start_thread (arg=0x7f9867fff700) at pthread_create.c:311
#6  0x00007f98a63a1e2d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 4 (Thread 0x7f98667fc700 (LWP 2395)):
#0  0x00007f98aa660e70 in ?? () from /usr/lib/libkdcraw.so.22
#1  0x00007f98aa69c16f in ?? () from /usr/lib/libkdcraw.so.22
#2  0x00007f98aa668ceb in ?? () from /usr/lib/libkdcraw.so.22
#3  0x00007f98aa650070 in KDcrawIface::KDcraw::Private::loadFromLibraw(QString const&, QByteArray&, int&, int&, int&) () from /usr/lib/libkdcraw.so.22
#4  0x00007f98aa055d3e in Digikam::RAWLoader::load (this=this@entry=0x7f98667faf80, filePath=..., observer=observer@entry=0x7f98300e14c0) at /build/buildd/digikam-3.3.0/core/libs/dimg/loaders/rawloader.cpp:125
#5  0x00007f98aa02b450 in Digikam::DImg::load (this=0x7f9830194028, filePath=..., loadFlagsInt=loadFlagsInt@entry=63, observer=observer@entry=0x7f98300e14c0, rawDecodingSettings=...) at /build/buildd/digikam-3.3.0/core/libs/dimg/dimg.cpp:503
#6  0x00007f98aa02c2a0 in Digikam::DImg::load (this=<optimized out>, filePath=..., observer=observer@entry=0x7f98300e14c0, rawDecodingSettings=...) at /build/buildd/digikam-3.3.0/core/libs/dimg/dimg.cpp:375
#7  0x00000000007186cd in Digikam::BatchTool::loadToDImg (this=this@entry=0x7f983006ac70) at /build/buildd/digikam-3.3.0/core/utilities/queuemanager/manager/batchtool.cpp:364
#8  0x0000000000757c99 in Digikam::Convert2JPEG::toolOperations (this=0x7f983006ac70) at /build/buildd/digikam-3.3.0/core/utilities/queuemanager/basetools/convert/convert2jpeg.cpp:104
#9  0x0000000000717ffe in Digikam::BatchTool::apply (this=0x7f983006ac70) at /build/buildd/digikam-3.3.0/core/utilities/queuemanager/manager/batchtool.cpp:441
#10 0x0000000000714005 in Digikam::Task::run (this=0x5f78320) at /build/buildd/digikam-3.3.0/core/utilities/queuemanager/manager/task.cpp:162
#11 0x00007f98a9499cb2 in ThreadWeaver::JobRunHelper::runTheJob (this=this@entry=0x7f98667fba90, th=th@entry=0x7f9848014950, job=job@entry=0x5f78320) at ../../../threadweaver/Weaver/Job.cpp:106
#12 0x00007f98a9499e6e in ThreadWeaver::Job::execute (this=0x5f78320, th=0x7f9848014950) at ../../../threadweaver/Weaver/Job.cpp:135
#13 0x00007f98a949b90b in ThreadWeaver::JobCollectionJobRunner::execute (this=0x4d6a280, t=0x7f9848014950) at ../../../threadweaver/Weaver/JobCollection.cpp:82
#14 0x00007f98a94996bb in ThreadWeaver::Thread::run (this=0x7f9848014950) at ../../../threadweaver/Weaver/Thread.cpp:108
#15 0x00007f98a7182f2f in QThreadPrivate::start (arg=0x7f9848014950) at thread/qthread_unix.cpp:338
#16 0x00007f98a16fcf6e in start_thread (arg=0x7f98667fc700) at pthread_create.c:311
#17 0x00007f98a63a1e2d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7f9865ffb700 (LWP 2396)):
#0  0x00007f98a63953dd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f989ecce5c4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f989ecce6cc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f98a72afa76 in QEventDispatcherGlib::processEvents (this=0x7f983c048c10, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f98a72815ef in QEventLoop::processEvents (this=this@entry=0x7f9865ffaa80, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f98a72818e5 in QEventLoop::exec (this=this@entry=0x7f9865ffaa80, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f98aa20e323 in Digikam::WorkerObjectRunnable::run (this=0x7f9830001090) at /build/buildd/digikam-3.3.0/core/libs/threads/threadmanager.cpp:196
#7  0x00007f98a71767ae in QThreadPoolThread::run (this=0x34a3400) at concurrent/qthreadpool.cpp:107
#8  0x00007f98a7182f2f in QThreadPrivate::start (arg=0x34a3400) at thread/qthread_unix.cpp:338
#9  0x00007f98a16fcf6e in start_thread (arg=0x7f9865ffb700) at pthread_create.c:311
#10 0x00007f98a63a1e2d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f98677fe700 (LWP 2405)):
#0  0x00007f98a2567b42 in ?? () from /usr/lib/x86_64-linux-gnu/libgomp.so.1
#1  0x00007f98a25663ae in ?? () from /usr/lib/x86_64-linux-gnu/libgomp.so.1
#2  0x00007f98a16fcf6e in start_thread (arg=0x7f98677fe700) at pthread_create.c:311
#3  0x00007f98a63a1e2d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f98ac920a80 (LWP 2320)):
[KCrash Handler]
#6  Digikam::TableViewModel::slotDatabaseImageChanged (this=0x2901440, imageChangeset=...) at /build/buildd/digikam-3.3.0/core/digikam/views/tableview_model.cpp:614
#7  0x00007f98a729adce in QObject::event (this=0x2901440, e=<optimized out>) at kernel/qobject.cpp:1194
#8  0x00007f98a7c73dfc in QApplicationPrivate::notify_helper (this=this@entry=0x1c237f0, receiver=receiver@entry=0x2901440, e=e@entry=0x7f983c142e80) at kernel/qapplication.cpp:4567
#9  0x00007f98a7c7a470 in QApplication::notify (this=this@entry=0x7fff9f586010, receiver=receiver@entry=0x2901440, e=e@entry=0x7f983c142e80) at kernel/qapplication.cpp:4353
#10 0x00007f98a897d9aa in KApplication::notify (this=0x7fff9f586010, receiver=0x2901440, event=0x7f983c142e80) at ../../kdeui/kernel/kapplication.cpp:311
#11 0x00007f98a72828bd in QCoreApplication::notifyInternal (this=0x7fff9f586010, receiver=receiver@entry=0x2901440, event=event@entry=0x7f983c142e80) at kernel/qcoreapplication.cpp:946
#12 0x00007f98a7285e1f in sendEvent (event=0x7f983c142e80, receiver=0x2901440) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#13 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x1b94b60) at kernel/qcoreapplication.cpp:1570
#14 0x00007f98a72862c3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#15 0x00007f98a72b0073 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#16 postEventSourceDispatch (s=0x1c208a0) at kernel/qeventdispatcher_glib.cpp:279
#17 0x00007f989ecce2d6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#18 0x00007f989ecce628 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f989ecce6cc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f98a72afa55 in QEventDispatcherGlib::processEvents (this=0x1c22b90, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#21 0x00007f98a7d159d6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#22 0x00007f98a72815ef in QEventLoop::processEvents (this=this@entry=0x7fff9f585af0, flags=...) at kernel/qeventloop.cpp:149
#23 0x00007f98a72818e5 in QEventLoop::exec (this=this@entry=0x7fff9f585af0, flags=...) at kernel/qeventloop.cpp:204
#24 0x00007f98a7286e5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#25 0x00007f98a7c7234c in QApplication::exec () at kernel/qapplication.cpp:3828
#26 0x0000000000491ea3 in main (argc=<optimized out>, argv=<optimized out>) at /build/buildd/digikam-3.3.0/core/digikam/main/main.cpp:235

The reporter indicates this bug may be a duplicate of or related to bug 320249.

Possible duplicates by query: bug 320249.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-09-05 01:04:07 UTC

*** This bug has been marked as a duplicate of bug 320249 ***
Comment 2 caulier.gilles 2014-04-01 14:34:36 UTC
*** Bug 332903 has been marked as a duplicate of this bug. ***
Comment 3 caulier.gilles 2019-08-15 15:21:58 UTC
Fixed with bug #320249