Bug 321295 - crash after face recognition run
Summary: crash after face recognition run
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Faces-Recognition (show other bugs)
Version: 3.3.0
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-17 20:55 UTC by simon
Modified: 2017-07-26 18:06 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.1.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description simon 2013-06-17 20:55:30 UTC
Application: digikam (3.3.0-beta3)
KDE Platform Version: 4.10.60 (Compiled from sources)
Qt Version: 4.8.4
Operating System: Linux 3.2.1-gentoo-r1 x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
- What I was doing when the application crashed:

scanned all the albums for faces, tagged a few, selected one person tag and ran a recognition run, after it finished i clicked one or two times - bang

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Traceback (most recent call last):
  File "<string>", line 32, in <module>
ImportError: No module named os.path
[Current thread is 1 (Thread 0x7fc6bab21800 (LWP 23216))]

Thread 9 (Thread 0x7fc696e8a700 (LWP 23218)):
#0  0x00007fc6af23250c in pthread_cond_wait () from /lib64/libpthread.so.0
#1  0x00007fc6af4c3403 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/qt4/libQtCore.so.4
#2  0x0000000000603d65 in Digikam::ScanController::run (this=0xe7fa20) at /home/user/kde/src/digikam-sc/core/digikam/database/scancontroller.cpp:713
#3  0x00007fc6af4c249e in QThreadPrivate::start(void*) () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007fc6ad7392da in ?? () from /usr/lib64/libGL.so.1
#5  0x00007fc6af22dd8f in start_thread () from /lib64/libpthread.so.0
#6  0x00007fc6ae1e625d in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7fc696689700 (LWP 23219)):
#0  0x00007fff2ff6f8de in ?? ()
#1  0x00007fc6a97758bd in clock_gettime () from /lib64/librt.so.1
#2  0x00007fc6af519a82 in qt_gettime() () from /usr/lib64/qt4/libQtCore.so.4
#3  0x00007fc6af5f1ced in QTimerInfoList::updateCurrentTime() () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007fc6af5f2035 in QTimerInfoList::timerWait(timeval&) () from /usr/lib64/qt4/libQtCore.so.4
#5  0x00007fc6af5f0a6c in timerSourcePrepareHelper(GTimerSource*, int*) () from /usr/lib64/qt4/libQtCore.so.4
#6  0x00007fc6af5f0b0d in timerSourcePrepare(_GSource*, int*) () from /usr/lib64/qt4/libQtCore.so.4
#7  0x00007fc6a9e34461 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#8  0x00007fc6a9e34b63 in g_main_context_iterate.clone.6 () from /usr/lib64/libglib-2.0.so.0
#9  0x00007fc6a9e34d44 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#10 0x00007fc6af5f1286 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#11 0x00007fc6af5c1612 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#12 0x00007fc6af5c18c5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#13 0x00007fc6af4bfe45 in QThread::exec() () from /usr/lib64/qt4/libQtCore.so.4
#14 0x00007fc6af5a0738 in QInotifyFileSystemWatcherEngine::run() () from /usr/lib64/qt4/libQtCore.so.4
#15 0x00007fc6af4c249e in QThreadPrivate::start(void*) () from /usr/lib64/qt4/libQtCore.so.4
#16 0x00007fc6ad7392da in ?? () from /usr/lib64/libGL.so.1
#17 0x00007fc6af22dd8f in start_thread () from /lib64/libpthread.so.0
#18 0x00007fc6ae1e625d in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7fc695e88700 (LWP 23223)):
#0  0x00007fc6ae1e2d59 in syscall () from /lib64/libc.so.6
#1  0x00007fc6af4c18e3 in QMutexPrivate::wait(int) () from /usr/lib64/qt4/libQtCore.so.4
#2  0x00007fc6af4bdb9d in QMutex::lockInternal() () from /usr/lib64/qt4/libQtCore.so.4
#3  0x00007fc6af4c33bc in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007fc6b730e2a5 in Digikam::ParkingThread::run (this=0x1204d60) at /home/user/kde/src/digikam-sc/core/libs/threads/threadmanager.cpp:119
#5  0x00007fc6af4c249e in QThreadPrivate::start(void*) () from /usr/lib64/qt4/libQtCore.so.4
#6  0x00007fc6ad7392da in ?? () from /usr/lib64/libGL.so.1
#7  0x00007fc6af22dd8f in start_thread () from /lib64/libpthread.so.0
#8  0x00007fc6ae1e625d in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7fc686ad3700 (LWP 23225)):
#0  0x00007fc6af23250c in pthread_cond_wait () from /lib64/libpthread.so.0
#1  0x00007fc687623a89 in vlc_cond_wait (p_condvar=<value optimized out>, p_mutex=<value optimized out>) at posix/thread.c:431
#2  0x00007fc6875c0748 in LoopRequest (data=0x163c808) at playlist/thread.c:544
#3  Thread (data=0x163c808) at playlist/thread.c:592
#4  0x00007fc6ad7392da in ?? () from /usr/lib64/libGL.so.1
#5  0x00007fc6af22dd8f in start_thread () from /lib64/libpthread.so.0
#6  0x00007fc6ae1e625d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7fc643ff7700 (LWP 23253)):
#0  0x00007fc6a9e714b0 in g_mutex_unlock () from /usr/lib64/libglib-2.0.so.0
#1  0x00007fc6a9e34c2a in g_main_context_iterate.clone.6 () from /usr/lib64/libglib-2.0.so.0
#2  0x00007fc6a9e34d44 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007fc6af5f1286 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007fc6af5c1612 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#5  0x00007fc6af5c18c5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#6  0x00007fc6b730d7d6 in Digikam::WorkerObjectRunnable::run (this=0x7fc65414fa80) at /home/user/kde/src/digikam-sc/core/libs/threads/threadmanager.cpp:196
#7  0x00007fc6af4b6b9e in QThreadPoolThread::run() () from /usr/lib64/qt4/libQtCore.so.4
#8  0x00007fc6af4c249e in QThreadPrivate::start(void*) () from /usr/lib64/qt4/libQtCore.so.4
#9  0x00007fc6ad7392da in ?? () from /usr/lib64/libGL.so.1
#10 0x00007fc6af22dd8f in start_thread () from /lib64/libpthread.so.0
#11 0x00007fc6ae1e625d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7fc646ffd700 (LWP 24731)):
[KCrash Handler]
#6  0x00007fc6af5d3dc8 in QObject::thread() const () from /usr/lib64/qt4/libQtCore.so.4
#7  0x00007fc6b730e1ce in Digikam::ParkingThread::moveToCurrentThread (this=0x1204d60, parkedObject=0x8604ac0) at /home/user/kde/src/digikam-sc/core/libs/threads/threadmanager.cpp:98
#8  0x00007fc6b730d700 in Digikam::WorkerObjectRunnable::run (this=0x80be260) at /home/user/kde/src/digikam-sc/core/libs/threads/threadmanager.cpp:178
#9  0x00007fc6af4b6b9e in QThreadPoolThread::run() () from /usr/lib64/qt4/libQtCore.so.4
#10 0x00007fc6af4c249e in QThreadPrivate::start(void*) () from /usr/lib64/qt4/libQtCore.so.4
#11 0x00007fc6ad7392da in ?? () from /usr/lib64/libGL.so.1
#12 0x00007fc6af22dd8f in start_thread () from /lib64/libpthread.so.0
#13 0x00007fc6ae1e625d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fc67b7fd700 (LWP 24874)):
#0  0x00007fc6af23250c in pthread_cond_wait () from /lib64/libpthread.so.0
#1  0x00007fc6af4c3403 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/qt4/libQtCore.so.4
#2  0x00007fc6b730e1c2 in Digikam::ParkingThread::moveToCurrentThread (this=0x1204d60, parkedObject=0x124d5f0) at /home/user/kde/src/digikam-sc/core/libs/threads/threadmanager.cpp:100
#3  0x00007fc6b730d700 in Digikam::WorkerObjectRunnable::run (this=0x9fc4da0) at /home/user/kde/src/digikam-sc/core/libs/threads/threadmanager.cpp:178
#4  0x00007fc6af4b6b9e in QThreadPoolThread::run() () from /usr/lib64/qt4/libQtCore.so.4
#5  0x00007fc6af4c249e in QThreadPrivate::start(void*) () from /usr/lib64/qt4/libQtCore.so.4
#6  0x00007fc6ad7392da in ?? () from /usr/lib64/libGL.so.1
#7  0x00007fc6af22dd8f in start_thread () from /lib64/libpthread.so.0
#8  0x00007fc6ae1e625d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fc64cff9700 (LWP 24875)):
#0  0x00007fc6ae1e2d59 in syscall () from /lib64/libc.so.6
#1  0x00007fc6af4c18e3 in QMutexPrivate::wait(int) () from /usr/lib64/qt4/libQtCore.so.4
#2  0x00007fc6af4bdb9d in QMutex::lockInternal() () from /usr/lib64/qt4/libQtCore.so.4
#3  0x00007fc6b71603a2 in QMutex::lockInline (this=0x1204d78) at /usr/include/qt4/QtCore/qmutex.h:198
#4  0x00007fc6b71602d9 in QMutexLocker::QMutexLocker (this=0x7fc64cff8c00, m=0x1204d78) at /usr/include/qt4/QtCore/qmutex.h:109
#5  0x00007fc6b730e0fc in Digikam::ParkingThread::moveToCurrentThread (this=0x1204d60, parkedObject=0x124d3a0) at /home/user/kde/src/digikam-sc/core/libs/threads/threadmanager.cpp:84
#6  0x00007fc6b730d700 in Digikam::WorkerObjectRunnable::run (this=0x92a5ad0) at /home/user/kde/src/digikam-sc/core/libs/threads/threadmanager.cpp:178
#7  0x00007fc6af4b6b9e in QThreadPoolThread::run() () from /usr/lib64/qt4/libQtCore.so.4
#8  0x00007fc6af4c249e in QThreadPrivate::start(void*) () from /usr/lib64/qt4/libQtCore.so.4
#9  0x00007fc6ad7392da in ?? () from /usr/lib64/libGL.so.1
#10 0x00007fc6af22dd8f in start_thread () from /lib64/libpthread.so.0
#11 0x00007fc6ae1e625d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fc6bab21800 (LWP 23216)):
#0  0x00007fc6ae1dd1f3 in poll () from /lib64/libc.so.6
#1  0x00007fc6a4072b5a in _xcb_conn_wait () from /usr/lib64/libxcb.so.1
#2  0x00007fc6a40730aa in _xcb_out_send () from /usr/lib64/libxcb.so.1
#3  0x00007fc6a4073368 in xcb_writev () from /usr/lib64/libxcb.so.1
#4  0x00007fc6ac8bc1fc in _XSend () from /usr/lib64/libX11.so.6
#5  0x00007fc6ac8bc2e7 in _XReply () from /usr/lib64/libX11.so.6
#6  0x00007fc6ac8b973c in XTranslateCoordinates () from /usr/lib64/libX11.so.6
#7  0x00007fc6b02efb5e in QWidgetPrivate::mapFromGlobal(QPoint const&) const () from /usr/lib64/qt4/libQtGui.so.4
#8  0x00007fc6b02efbfd in QWidget::mapFromGlobal(QPoint const&) const () from /usr/lib64/qt4/libQtGui.so.4
#9  0x00007fc6b02634e6 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#10 0x00007fc6b0fa8816 in KApplication::notify (this=0x7fff2fe492f0, receiver=0x1b91c40, event=0x7fff2fe486a0) at /var/tmp/portage/kde-base/kdelibs-9999/work/kdelibs-9999/kdeui/kernel/kapplication.cpp:311
#11 0x00007fc6af5c2863 in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#12 0x00007fc6b025f166 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib64/qt4/libQtGui.so.4
#13 0x00007fc6b02dc1f7 in QETWidget::translateMouseEvent(_XEvent const*) () from /usr/lib64/qt4/libQtGui.so.4
#14 0x00007fc6b02da8b9 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#15 0x00007fc6b0301e9a in x11EventSourceDispatch(_GSource*, int (*)(void*), void*) () from /usr/lib64/qt4/libQtGui.so.4
#16 0x00007fc6a9e3495a in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#17 0x00007fc6a9e34c98 in g_main_context_iterate.clone.6 () from /usr/lib64/libglib-2.0.so.0
#18 0x00007fc6a9e34d44 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#19 0x00007fc6af5f122f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#20 0x00007fc6b0301b4e in QGuiEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtGui.so.4
#21 0x00007fc6af5c1612 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#22 0x00007fc6af5c18c5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#23 0x00007fc6af5c6223 in QCoreApplication::exec() () from /usr/lib64/qt4/libQtCore.so.4
#24 0x0000000000715d18 in main (argc=1, argv=0x7fff2fe49a08) at /home/user/kde/src/digikam-sc/core/digikam/main/main.cpp:235

Reported using DrKonqi
Comment 1 caulier.gilles 2013-09-09 20:25:53 UTC
*** Bug 324711 has been marked as a duplicate of this bug. ***
Comment 2 caulier.gilles 2013-12-09 07:22:34 UTC
*** Bug 328560 has been marked as a duplicate of this bug. ***
Comment 3 caulier.gilles 2014-05-16 07:29:43 UTC
digiKam 4.0.0 is out :

http://www.digikam.org/node/713

Please check if this entry still valid with this new version.

Thanks in advance

Gilles Caulier
Comment 4 simon 2014-05-19 10:21:34 UTC
worksforme now with 4.0
Comment 5 caulier.gilles 2014-05-19 13:57:19 UTC
This file is closed through 4.1.0 release...
Comment 6 Dean Jagels 2014-06-15 18:48:02 UTC
Working for  me now with digiKam 4.0