Bug 324279 - Amarok crashed while qutting from taskbar
Summary: Amarok crashed while qutting from taskbar
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-08-30 15:45 UTC by Miki Kocic
Modified: 2013-08-30 21:34 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Miki Kocic 2013-08-30 15:45:23 UTC
Application: plasma-desktop (4.10.5 "release 1")
KDE Platform Version: 4.10.5 "release 1"
Qt Version: 4.8.4
Operating System: Linux 3.7.10-1.16-desktop x86_64
Distribution: "openSUSE 12.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

Trying to right click Amarok icon in the taskbar to quit Amarok

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f431b243780 (LWP 2110))]

Thread 3 (Thread 0x7f42fe385700 (LWP 2112)):
#0  0x00007f4319afe964 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f430e364307 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f430e671660 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f430e364339 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f4319afae0f in start_thread () from /lib64/libpthread.so.0
#4  0x00007f43188717dd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f42f5279700 (LWP 2113)):
#0  0x00007f4319afce25 in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00007f43157f2a71 in g_mutex_lock () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f43157b5a8a in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f43157b5bc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f4319ebb2e6 in QEventDispatcherGlib::processEvents (this=0x7f42f00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f4319e8badf in QEventLoop::processEvents (this=this@entry=0x7f42f5278dd0, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f4319e8bd68 in QEventLoop::exec (this=0x7f42f5278dd0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f4319d8e0f0 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#8  0x00007f4319e6c29f in QInotifyFileSystemWatcherEngine::run (this=0x1a8e050) at io/qfilesystemwatcher_inotify.cpp:256
#9  0x00007f4319d910cc in QThreadPrivate::start (arg=0x1a8e050) at thread/qthread_unix.cpp:338
#10 0x00007f4319afae0f in start_thread () from /lib64/libpthread.so.0
#11 0x00007f43188717dd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f431b243780 (LWP 2110)):
[KCrash Handler]
#6  QCoreApplication::postEvent (receiver=0x3636580, event=0x362f170, priority=0) at kernel/qcoreapplication.cpp:1343
#7  0x00007f42fea28979 in StatusNotifierItemJob::contextMenuReady (this=0x3636580, menu=0x368d6c0) at /usr/src/debug/kde-workspace-4.10.5/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#8  0x00007f4319ea229f in QMetaObject::activate (sender=0x26da430, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff2eb70d10) at kernel/qobject.cpp:3548
#9  0x00007f42fea244ff in StatusNotifierItemSource::contextMenuReady (this=<optimized out>, _t1=0x368d6c0) at /usr/src/debug/kde-workspace-4.10.5/build/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.moc:123
#10 0x00007f42fea24529 in StatusNotifierItemSource::contextMenuReady (this=<optimized out>) at /usr/src/debug/kde-workspace-4.10.5/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:365
#11 0x00007f42fea2787d in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at /usr/src/debug/kde-workspace-4.10.5/build/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.moc:65
#12 StatusNotifierItemSource::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/kde-workspace-4.10.5/build/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.moc:58
#13 0x00007f4319ea229f in QMetaObject::activate (sender=0x3653e50, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3548
#14 0x00007f43176a8c5c in DBusMenuImporter::slotMenuAboutToShow (this=0x3653e50) at /usr/src/debug/libdbusmenu-qt-0.9.2/src/dbusmenuimporter.cpp:505
#15 0x00007f4319ea229f in QMetaObject::activate (sender=0x368d6c0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3548
#16 0x00007f4319e94ca7 in QMetaMethod::invoke (this=this@entry=0x7fff2eb713d0, object=object@entry=0x368d6c0, connectionType=Qt::DirectConnection, connectionType@entry=Qt::AutoConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1664
#17 0x00007f4319e9707c in QMetaObject::invokeMethod (obj=0x368d6c0, member=<optimized out>, type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1179
#18 0x00007f43176a82c9 in invokeMethod (val9=..., val8=..., val7=..., val6=..., val5=..., val4=..., val3=..., val2=..., val1=..., val0=..., member=0x7f43176b9fb4 "aboutToShow", obj=<optimized out>) at /usr/include/QtCore/qobjectdefs.h:434
#19 DBusMenuImporter::updateMenu (this=<optimized out>) at /usr/src/debug/libdbusmenu-qt-0.9.2/src/dbusmenuimporter.cpp:438
#20 0x00007f42fea24116 in StatusNotifierItemSource::contextMenu (this=0x26da430, x=<optimized out>, y=<optimized out>) at /usr/src/debug/kde-workspace-4.10.5/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:468
#21 0x00007f42fea29303 in StatusNotifierItemJob::start (this=0x35f6d40) at /usr/src/debug/kde-workspace-4.10.5/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#22 0x00007f4319ea177e in QObject::event (this=0x35f6d40, e=<optimized out>) at kernel/qobject.cpp:1203
#23 0x00007f431901a86c in QApplicationPrivate::notify_helper (this=this@entry=0x115e2e0, receiver=receiver@entry=0x35f6d40, e=e@entry=0x2df9670) at kernel/qapplication.cpp:4562
#24 0x00007f431901eceb in QApplication::notify (this=0x115ac40, receiver=0x35f6d40, e=0x2df9670) at kernel/qapplication.cpp:4423
#25 0x00007f431ac2e7f6 in KApplication::notify (this=0x115ac40, receiver=0x35f6d40, event=0x2df9670) at /usr/src/debug/kdelibs-4.10.5/kdeui/kernel/kapplication.cpp:311
#26 0x00007f4319e8cd8e in QCoreApplication::notifyInternal (this=0x115ac40, receiver=receiver@entry=0x35f6d40, event=event@entry=0x2df9670) at kernel/qcoreapplication.cpp:946
#27 0x00007f4319e906f1 in sendEvent (event=0x2df9670, receiver=0x35f6d40) at kernel/qcoreapplication.h:231
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x10802b0) at kernel/qcoreapplication.cpp:1570
#29 0x00007f4319ebb133 in sendPostedEvents () at kernel/qcoreapplication.h:236
#30 postEventSourceDispatch (s=0x115f4c0) at kernel/qeventdispatcher_glib.cpp:279
#31 0x00007f43157b57d5 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#32 0x00007f43157b5b08 in ?? () from /usr/lib64/libglib-2.0.so.0
#33 0x00007f43157b5bc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#34 0x00007f4319ebb2c6 in QEventDispatcherGlib::processEvents (this=0x1139ae0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#35 0x00007f43190bac1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#36 0x00007f4319e90b9f in QCoreApplication::processEvents (flags=...) at kernel/qcoreapplication.cpp:1133
#37 0x00007f43176a7df6 in waitForWatcher (_watcher=_watcher@entry=0x3677360, maxWait=maxWait@entry=3000) at /usr/src/debug/libdbusmenu-qt-0.9.2/src/dbusmenuimporter.cpp:447
#38 0x00007f43176a8787 in DBusMenuImporter::slotMenuAboutToShow (this=0x3653e50) at /usr/src/debug/libdbusmenu-qt-0.9.2/src/dbusmenuimporter.cpp:491
#39 0x00007f4319ea229f in QMetaObject::activate (sender=0x368d6c0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3548
#40 0x00007f4319451beb in QMenu::popup (this=0x368d6c0, p=..., atAction=0x0) at widgets/qmenu.cpp:1844
#41 0x00007f42fee5c19d in SystemTray::Applet::showMenu (this=0x15d1f30, menu_var=<optimized out>, x=1696, y=1045, item_var=<optimized out>) at /usr/src/debug/kde-workspace-4.10.5/plasma/generic/applets/systemtray/ui/applet.cpp:769
#42 0x00007f42fee5e5f7 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at /usr/src/debug/kde-workspace-4.10.5/build/plasma/generic/applets/systemtray/applet.moc:151
#43 SystemTray::Applet::qt_static_metacall (_o=0x3636580, _c=56815984, _id=0, _a=0x7fff2eb729d0) at /usr/src/debug/kde-workspace-4.10.5/build/plasma/generic/applets/systemtray/applet.moc:126
#44 0x00007f42fee5e7e7 in SystemTray::Applet::qt_metacall (this=0x15d1f30, _c=QMetaObject::InvokeMetaMethod, _id=17, _a=0x7fff2eb729d0) at /usr/src/debug/kde-workspace-4.10.5/build/plasma/generic/applets/systemtray/applet.moc:201
#45 0x00007f430dc4dd08 in QDeclarativeObjectMethodScriptClass::callMethod (this=this@entry=0x175db40, object=object@entry=0x15d1f30, index=81, returnType=<optimized out>, argCount=<optimized out>, argTypes=0x7fff2eb72c90, ctxt=ctxt@entry=0x7f42fc2d70b8) at qml/qdeclarativeobjectscriptclass.cpp:970
#46 0x00007f430dc4f976 in QDeclarativeObjectMethodScriptClass::callPrecise (this=0x175db40, object=0x15d1f30, data=..., ctxt=0x7f42fc2d70b8) at qml/qdeclarativeobjectscriptclass.cpp:944
#47 0x00007f430dc502ab in QDeclarativeObjectMethodScriptClass::call (this=<optimized out>, o=<optimized out>, ctxt=<optimized out>) at qml/qdeclarativeobjectscriptclass.cpp:917
#48 0x00007f430e3da593 in QScript::DeclarativeObjectDelegate::call (exec=<optimized out>, callee=0x7f42fc29b8c0, thisValue=..., args=...) at bridge/qscriptdeclarativeobject.cpp:154
#49 0x00007f430e2d6d70 in QTJSC::NativeFuncWrapper::operator() (this=0x7fff2eb72de0, exec=0x7f42fc2d70b8, jsobj=0x7f42fc29b8c0, thisValue=..., argList=...) at ../3rdparty/javascriptcore/JavaScriptCore/runtime/CallData.cpp:46
#50 0x00007f430e2b3fca in QTJSC::cti_op_call_NotJSFunction (args=0x7fff2eb72e30) at ../3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp:1780
#51 0x00007f42fd655527 in ?? ()
#52 0x000000000136a120 in ?? ()
#53 0x00007f42fc29b8c0 in ?? ()
#54 0x00007f420000000e in ?? ()
#55 0x00007f4200000005 in ?? ()
#56 0x0000000000000000 in ?? ()

Possible duplicates by query: bug 323166, bug 320592, bug 313616, bug 312573, bug 311993.

Reported using DrKonqi
Comment 1 Dominik Haumann 2013-08-30 21:34:33 UTC

*** This bug has been marked as a duplicate of bug 241562 ***