Bug 311993 - Plasma crashes after the killing of an unrelated application with a systray
Summary: Plasma crashes after the killing of an unrelated application with a systray
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-systemtray (show other bugs)
Version: 4.9.4
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 309908 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-20 16:21 UTC by rtdvrs
Modified: 2013-08-30 21:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rtdvrs 2012-12-20 16:21:56 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.9.4
Qt Version: 4.8.2
Operating System: Linux 3.2.0-35-generic x86_64
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:

All I did was killall -9 vlc, which resulted in Plasma immediately crashing afterwards.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f6f78ebe780 (LWP 4678))]

Thread 4 (Thread 0x7f6f56c92700 (LWP 4684)):
#0  0x00007f6f6ca2305d in __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x7f6f44000a60) at pthread_mutex_unlock.c:290
#2  0x00007f6f6c35e5d1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6f6c32302a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f6f6c323164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f6f753ec906 in QEventDispatcherGlib::processEvents (this=0x7f6f440008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f6f753bbe42 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f6f753bc097 in QEventLoop::exec (this=0x7f6f56c91dd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f6f752bb057 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f6f7539bb4f in QInotifyFileSystemWatcherEngine::run (this=0x23882c0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f6f752be07b in QThreadPrivate::start (arg=0x23882c0) at thread/qthread_unix.cpp:307
#11 0x00007f6f6ca1fe9a in start_thread (arg=0x7f6f56c92700) at pthread_create.c:308
#12 0x00007f6f787c1cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f6f561a5700 (LWP 4685)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f6f7219f222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f6f7219f259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f6f6ca1fe9a in start_thread (arg=0x7f6f561a5700) at pthread_create.c:308
#4  0x00007f6f787c1cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f6f4af86700 (LWP 4686)):
#0  0x00007f6f787b6303 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f6f6c323036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6f6c323164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6f753ec906 in QEventDispatcherGlib::processEvents (this=0x7f6f3c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f6f753bbe42 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f6f753bc097 in QEventLoop::exec (this=0x7f6f4af85dd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f6f752bb057 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f6f7539bb4f in QInotifyFileSystemWatcherEngine::run (this=0x1023330) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f6f752be07b in QThreadPrivate::start (arg=0x1023330) at thread/qthread_unix.cpp:307
#9  0x00007f6f6ca1fe9a in start_thread (arg=0x7f6f4af86700) at pthread_create.c:308
#10 0x00007f6f787c1cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f6f78ebe780 (LWP 4678)):
[KCrash Handler]
#6  QMutex::lock (this=0xcb0138) at thread/qmutex.cpp:153
#7  0x00007f6f753c0949 in QCoreApplication::postEvent (receiver=0xe18cc0, event=0x31d6b50, priority=0) at kernel/qcoreapplication.cpp:1320
#8  0x00007f6f5a49ddac in StatusNotifierItemJob::contextMenuReady (this=0xe18cc0, menu=0x3180130) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#9  0x00007f6f753d1761 in QMetaObject::activate (sender=0x2e5ea70, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff549ff530) at kernel/qobject.cpp:3547
#10 0x00007f6f5a499dbf in StatusNotifierItemSource::contextMenuReady (this=<optimized out>, _t1=0x3180130) at ./statusnotifieritemsource.moc:123
#11 0x00007f6f5a49cd15 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at ./statusnotifieritemsource.moc:65
#12 StatusNotifierItemSource::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./statusnotifieritemsource.moc:58
#13 0x00007f6f753d1761 in QMetaObject::activate (sender=0x3569960, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#14 0x00007f6f6d29679c in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/x86_64-linux-gnu/libdbusmenu-qt.so.2
#15 0x00007f6f753d1761 in QMetaObject::activate (sender=0x3180130, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#16 0x00007f6f753c53e1 in QMetaMethod::invoke (this=0x7fff549ffd30, object=0x3180130, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1664
#17 0x00007f6f753c76f0 in QMetaObject::invokeMethod (obj=0x3180130, member=<optimized out>, type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1179
#18 0x00007f6f6d2955a1 in DBusMenuImporter::updateMenu() () from /usr/lib/x86_64-linux-gnu/libdbusmenu-qt.so.2
#19 0x00007f6f5a4999bb in StatusNotifierItemSource::contextMenu (this=0x2e5ea70, x=21, y=733) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:466
#20 0x00007f6f5a49ef0f in StatusNotifierItemJob::start (this=0xe18cc0) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#21 0x00007f6f753d6926 in QObject::event (this=0xe18cc0, e=<optimized out>) at kernel/qobject.cpp:1195
#22 0x00007f6f7473e7b4 in notify_helper (e=0x17b6070, receiver=0xe18cc0, this=0xcabef0) at kernel/qapplication.cpp:4556
#23 QApplicationPrivate::notify_helper (this=0xcabef0, receiver=0xe18cc0, e=0x17b6070) at kernel/qapplication.cpp:4528
#24 0x00007f6f74743583 in QApplication::notify (this=0xccdbe0, receiver=0xe18cc0, e=0x17b6070) at kernel/qapplication.cpp:4417
#25 0x00007f6f760a1786 in KApplication::notify (this=0xccdbe0, receiver=0xe18cc0, event=0x17b6070) at ../../kdeui/kernel/kapplication.cpp:311
#26 0x00007f6f753bd30c in QCoreApplication::notifyInternal (this=0xccdbe0, receiver=0xe18cc0, event=0x17b6070) at kernel/qcoreapplication.cpp:915
#27 0x00007f6f753c10ea in sendEvent (event=0x17b6070, receiver=0xe18cc0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xc131f0) at kernel/qcoreapplication.cpp:1539
#29 0x00007f6f753ec473 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#30 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#31 0x00007f6f6c322d53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f6f6c3230a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#33 0x00007f6f6c323164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#34 0x00007f6f753ec89f in QEventDispatcherGlib::processEvents (this=0xc14ad0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#35 0x00007f6f747e6cde in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#36 0x00007f6f753bbe42 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#37 0x00007f6f753bc097 in QEventLoop::exec (this=0x7fff54a00e20, flags=...) at kernel/qeventloop.cpp:204
#38 0x00007f6f753c13e7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#39 0x00007f6f78ac8be3 in kdemain (argc=1, argv=0x7fff54a01208) at ../../../../plasma/desktop/shell/main.cpp:120
#40 0x00007f6f786ef76d in __libc_start_main (main=0x400640 <main(int, char**)>, argc=1, ubp_av=0x7fff54a01208, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff54a011f8) at libc-start.c:226
#41 0x0000000000400671 in _start ()

Possible duplicates by query: bug 311545, bug 307375, bug 306157, bug 305851, bug 305243.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-01-04 04:20:21 UTC
*** Bug 309908 has been marked as a duplicate of this bug. ***
Comment 2 Christoph Feck 2013-01-28 00:19:49 UTC
Probably a duplicate of bug 241562.
Comment 3 Dominik Haumann 2013-08-30 21:36:02 UTC

*** This bug has been marked as a duplicate of bug 241562 ***