Bug 312573 - KDE crashed after closing Amarok
Summary: KDE crashed after closing Amarok
Status: RESOLVED DUPLICATE of bug 311545
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-03 23:47 UTC by An00biS
Modified: 2013-01-04 04:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description An00biS 2013-01-03 23:47:59 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.9.4
Qt Version: 4.8.4
Operating System: Linux 3.6.10-2.fc17.i686 i686
Distribution: "Fedora release 17 (Beefy Miracle)"

-- Information about the crash:
- What I was doing when the application crashed:
I closed Amarok using system tray icon -> popup menu -> close option. Then, nothing hapenned for around 2 sec and finally the screen went black (except for a single tiny window with Pidgin tray icon in the top left corner of the screen)

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb76ce7c0 (LWP 1241))]

Thread 3 (Thread 0xb4d14b40 (LWP 1242)):
#0  0xb7710424 in __kernel_vsyscall ()
#1  0x45f1512c in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:172
#2  0x4eba25dd in QTWTF::TCMalloc_PageHeap::scavengerThread (this=this@entry=0x4ecb1280) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#3  0x4eba2610 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x4ecb1280) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#4  0x45f11adf in start_thread (arg=0xb4d14b40) at pthread_create.c:309
#5  0x45e4b42e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 2 (Thread 0xae7aeb40 (LWP 1243)):
#0  0xb7710424 in __kernel_vsyscall ()
#1  0x45e40f34 in __GI___poll (fds=fds@entry=0xade02278, nfds=nfds@entry=1, timeout=timeout@entry=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x46012f5c in g_poll (fds=0xade02278, nfds=1, timeout=-1) at gpoll.c:132
#3  0x460043e0 in g_main_context_poll (n_fds=1, fds=0xade02278, timeout=<optimized out>, context=0xade004e0, priority=<optimized out>) at gmain.c:3440
#4  g_main_context_iterate (context=context@entry=0xade004e0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3141
#5  0x46004542 in g_main_context_iteration (context=0xade004e0, may_block=1) at gmain.c:3207
#6  0x4c1a6a5f in QEventDispatcherGlib::processEvents (this=0xade00468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0x4c172aad in QEventLoop::processEvents (this=this@entry=0xae7ae1a8, flags=...) at kernel/qeventloop.cpp:149
#8  0x4c172da9 in QEventLoop::exec (this=0xae7ae1a8, flags=...) at kernel/qeventloop.cpp:204
#9  0x4c05b09c in QThread::exec (this=0x9735510) at thread/qthread.cpp:542
#10 0x4c150a4e in QInotifyFileSystemWatcherEngine::run (this=0x9735510) at io/qfilesystemwatcher_inotify.cpp:256
#11 0x4c05e52a in QThreadPrivate::start (arg=0x9735510) at thread/qthread_unix.cpp:338
#12 0x45f11adf in start_thread (arg=0xae7aeb40) at pthread_create.c:309
#13 0x45e4b42e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0xb76ce7c0 (LWP 1241)):
[KCrash Handler]
#7  QCoreApplication::postEvent (receiver=receiver@entry=0xaa5f1f0, event=event@entry=0xad682c8, priority=priority@entry=0) at kernel/qcoreapplication.cpp:1343
#8  0x4c177b6c in QCoreApplication::postEvent (receiver=0xaa5f1f0, event=0xad682c8) at kernel/qcoreapplication.cpp:1304
#9  0x4c187179 in QObject::deleteLater (this=0xaa5f1f0) at kernel/qobject.cpp:2083
#10 0x4c4c6bed in KJob::emitResult (this=0xaa5f1f0) at /usr/src/debug/kdelibs-4.9.4/kdecore/jobs/kjob.cpp:321
#11 0x4f702289 in Plasma::ServiceJob::setResult (this=0xaa5f1f0, result=...) at /usr/src/debug/kdelibs-4.9.4/plasma/servicejob.cpp:92
#12 0xb4eb7cf9 in StatusNotifierItemJob::contextMenuReady (this=0xaa5f1f0, menu=0xa244120) at /usr/src/debug/kde-workspace-4.9.4/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#13 0x4c18b1ce in QMetaObject::activate (sender=0xa225150, m=0xb4ec0838, local_signal_index=0, argv=0xbf814958) at kernel/qobject.cpp:3539
#14 0xb4eb3496 in StatusNotifierItemSource::contextMenuReady (this=this@entry=0xa225150, _t1=0xa244120) at /usr/src/debug/kde-workspace-4.9.4/i686-redhat-linux-gnu/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.moc:122
#15 0xb4eb34d2 in StatusNotifierItemSource::contextMenuReady (this=this@entry=0xa225150) at /usr/src/debug/kde-workspace-4.9.4/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:363
#16 0xb4eb6724 in qt_static_metacall (_a=0xbf814a3c, _id=1, _o=0xa225150, _c=<optimized out>) at /usr/src/debug/kde-workspace-4.9.4/i686-redhat-linux-gnu/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.moc:64
#17 StatusNotifierItemSource::qt_static_metacall (_o=0xa225150, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbf814a3c) at /usr/src/debug/kde-workspace-4.9.4/i686-redhat-linux-gnu/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.moc:57
#18 0x4c18b1ce in QMetaObject::activate (sender=0x92e6dd8, m=0x4c7ff060, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3539
#19 0x4c7e19e6 in DBusMenuImporter::menuUpdated (this=0x92e6dd8) at /usr/src/debug/libdbusmenu-qt-0.9.0/i686-redhat-linux-gnu/src/dbusmenuimporter.moc:131
#20 0x4c7e2184 in DBusMenuImporter::slotMenuAboutToShow (this=0x92e6dd8) at /usr/src/debug/libdbusmenu-qt-0.9.0/src/dbusmenuimporter.cpp:523
#21 0x4c7e9cb8 in qt_static_metacall (_a=0xbf814c6c, _id=6, _o=0x92e6dd8, _c=<optimized out>) at /usr/src/debug/libdbusmenu-qt-0.9.0/i686-redhat-linux-gnu/src/dbusmenuimporter.moc:78
#22 DBusMenuImporter::qt_static_metacall (_o=0x92e6dd8, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xbf814c6c) at /usr/src/debug/libdbusmenu-qt-0.9.0/i686-redhat-linux-gnu/src/dbusmenuimporter.moc:66
#23 0x4c18b1ce in QMetaObject::activate (sender=0xa244120, m=0x4d6722b4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3539
#24 0x4d19fa06 in QMenu::aboutToShow (this=this@entry=0xa244120) at .moc/release-shared/moc_qmenu.cpp:164
#25 0x4d1a66d8 in qt_static_metacall (_a=0xbf814dc4, _id=0, _o=0xa244120, _c=<optimized out>) at .moc/release-shared/moc_qmenu.cpp:73
#26 QMenu::qt_static_metacall (_o=0xa244120, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf814dc4) at .moc/release-shared/moc_qmenu.cpp:67
#27 0x4c17caff in QMetaMethod::invoke (this=0xbf814ef4, object=0xa244120, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1664
#28 0x4c17f1ca in QMetaObject::invokeMethod (obj=0xa244120, member=0x4c7f1d72 "aboutToShow", type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1179
#29 0x4c7e19a0 in invokeMethod (val9=..., val8=..., val7=..., val6=..., val5=..., val4=..., val3=..., val2=..., val1=..., val0=..., member=0x4c7f1d72 "aboutToShow", obj=<optimized out>) at /usr/include/QtCore/qobjectdefs.h:434
#30 DBusMenuImporter::updateMenu (this=0x92e6dd8) at /usr/src/debug/libdbusmenu-qt-0.9.0/src/dbusmenuimporter.cpp:456
#31 0xb4eb3054 in StatusNotifierItemSource::contextMenu (this=0xa225150, x=1631, y=1061) at /usr/src/debug/kde-workspace-4.9.4/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:466
#32 0xb4eb86c4 in StatusNotifierItemJob::start (this=0xaa5f1f0) at /usr/src/debug/kde-workspace-4.9.4/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#33 0x4f701e4a in autoStart (this=<optimized out>) at /usr/src/debug/kdelibs-4.9.4/plasma/servicejob.cpp:47
#34 qt_static_metacall (_o=0xaa5f1f0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/kdelibs-4.9.4/i686-redhat-linux-gnu/plasma/servicejob.moc:60
#35 Plasma::ServiceJob::qt_static_metacall (_o=0xaa5f1f0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xb138110) at /usr/src/debug/kdelibs-4.9.4/i686-redhat-linux-gnu/plasma/servicejob.moc:54
#36 0x4c18606b in QMetaCallEvent::placeMetaCall (this=0xa2e6cb0, object=0xaa5f1f0) at kernel/qobject.cpp:524
#37 0x4c18a6c3 in QObject::event (this=0xaa5f1f0, e=0xa2e6cb0) at kernel/qobject.cpp:1194
#38 0x4ccee05c in QApplicationPrivate::notify_helper (this=0x9223400, receiver=0xaa5f1f0, e=0xa2e6cb0) at kernel/qapplication.cpp:4562
#39 0x4ccf2b1f in QApplication::notify (this=0xa2e6cb0, receiver=0xaa5f1f0, e=0xa2e6cb0) at kernel/qapplication.cpp:3944
#40 0x4d892fe2 in KApplication::notify (this=0x920b328, receiver=0xaa5f1f0, event=0xa2e6cb0) at /usr/src/debug/kdelibs-4.9.4/kdeui/kernel/kapplication.cpp:311
#41 0x4c17400e in QCoreApplication::notifyInternal (this=0x920b328, receiver=0xaa5f1f0, event=0xa2e6cb0) at kernel/qcoreapplication.cpp:946
#42 0x4c177fb5 in sendEvent (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#43 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x91d3278) at kernel/qcoreapplication.cpp:1570
#44 0x4c17823d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1463
#45 0x4c1a68b5 in sendPostedEvents () at kernel/qcoreapplication.h:236
#46 postEventSourceDispatch (s=s@entry=0x92261f0) at kernel/qeventdispatcher_glib.cpp:279
#47 0x460040bb in g_main_dispatch (context=0x9227780, context@entry=0x92275b8) at gmain.c:2539
#48 g_main_context_dispatch (context=context@entry=0x9227780) at gmain.c:3075
#49 0x46004460 in g_main_context_iterate (context=context@entry=0x9227780, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3146
#50 0x46004542 in g_main_context_iteration (context=0x9227780, may_block=1) at gmain.c:3207
#51 0x4c1a6a42 in QEventDispatcherGlib::processEvents (this=0x91d3fd0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#52 0x4cda069b in QGuiEventDispatcherGlib::processEvents (this=0x91d3fd0, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#53 0x4c172aad in QEventLoop::processEvents (this=this@entry=0xbf815b28, flags=...) at kernel/qeventloop.cpp:149
#54 0x4c172da9 in QEventLoop::exec (this=0xbf815b28, flags=...) at kernel/qeventloop.cpp:204
#55 0x4c1782eb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#56 0x4ccebed5 in QApplication::exec () at kernel/qapplication.cpp:3823
#57 0x4e3e9656 in kdemain (argc=1, argv=0xbf815ce4) at /usr/src/debug/kde-workspace-4.9.4/plasma/desktop/shell/main.cpp:120
#58 0x0804879c in main (argc=1, argv=0xbf815ce4) at /usr/src/debug/kde-workspace-4.9.4/i686-redhat-linux-gnu/plasma/desktop/shell/plasma-desktop_dummy.cpp:3

This bug may be a duplicate of or related to bug 311545.

Possible duplicates by query: bug 311545, bug 309132, bug 296467.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-01-04 04:17:44 UTC

*** This bug has been marked as a duplicate of bug 311545 ***