Bug 320592 - Crash after hang with Clementine music player app
Summary: Crash after hang with Clementine music player app
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: 4.10.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-02 04:21 UTC by steirscheisse
Modified: 2013-06-06 10:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description steirscheisse 2013-06-02 04:21:50 UTC
Application: plasma-desktop (4.10.3)
KDE Platform Version: 4.10.3
Qt Version: 4.8.4
Operating System: Linux 3.8.0-23-generic x86_64
Distribution: Ubuntu 13.04

-- Information about the crash:
- What I was doing when the application crashed:

Trying to close Clementine after an application hang generated a plasma crash.

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f9d8ebda7c0 (LWP 2056))]

Thread 5 (Thread 0x7f9d6facc700 (LWP 2059)):
#0  0x00007f9d819395b0 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f9d818fa0d5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9d818fa304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9d8b09d036 in QEventDispatcherGlib::processEvents (this=0x7f9d680008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f9d8b06d38f in QEventLoop::processEvents (this=this@entry=0x7f9d6facbd90, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9d8b06d618 in QEventLoop::exec (this=this@entry=0x7f9d6facbd90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f9d8af6f410 in QThread::exec (this=this@entry=0x157e360) at thread/qthread.cpp:542
#7  0x00007f9d8b04eedf in QInotifyFileSystemWatcherEngine::run (this=0x157e360) at io/qfilesystemwatcher_inotify.cpp:256
#8  0x00007f9d8af71bec in QThreadPrivate::start (arg=0x157e360) at thread/qthread_unix.cpp:338
#9  0x00007f9d81ffcf8e in start_thread (arg=0x7f9d6facc700) at pthread_create.c:311
#10 0x00007f9d8e4bfe1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 4 (Thread 0x7f9d6f2cb700 (LWP 2060)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f9d87900e77 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f9d87900ea9 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f9d81ffcf8e in start_thread (arg=0x7f9d6f2cb700) at pthread_create.c:311
#4  0x00007f9d8e4bfe1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7f9d52eae700 (LWP 2082)):
#0  0x00007fffb7efaaf7 in ?? ()
#1  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f9d4783f700 (LWP 2083)):
#0  0x00007fffb7efaaf7 in ?? ()
#1  0x00007f9d8afc7a74 in do_gettime (frac=0x7f9d4783eac8, sec=0x7f9d4783eac0) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x00007f9d8afc7a19 in QElapsedTimer::isMonotonic () at tools/qelapsedtimer_unix.cpp:107
#4  0x00007f9d8b09dced in QTimerInfoList::repairTimersIfNeeded (this=0x1) at kernel/qeventdispatcher_unix.cpp:414
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9d8ebda7c0 (LWP 2056)):
[KCrash Handler]
#6  QMutex::lock (this=this@entry=0x475c728) at thread/qmutex.cpp:153
#7  0x00007f9d8b071b29 in QCoreApplication::postEvent (receiver=receiver@entry=0x5f89e50, event=0x5015e10, priority=priority@entry=0) at kernel/qcoreapplication.cpp:1351
#8  0x00007f9d8b071e07 in QCoreApplication::postEvent (receiver=receiver@entry=0x5f89e50, event=<optimized out>) at kernel/qcoreapplication.cpp:1304
#9  0x00007f9d8b080324 in QObject::deleteLater (this=this@entry=0x5f89e50) at kernel/qobject.cpp:2083
#10 0x00007f9d8b76c539 in KJob::emitResult (this=this@entry=0x5f89e50) at ../../kdecore/jobs/kjob.cpp:321
#11 0x00007f9d8e06940a in Plasma::ServiceJob::setResult (this=this@entry=0x5f89e50, result=...) at ../../plasma/servicejob.cpp:92
#12 0x00007f9d711ec149 in StatusNotifierItemJob::contextMenuReady (this=0x5f89e50, menu=0x3aa43c0) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#13 0x00007f9d8b0830ef in QMetaObject::activate (sender=0x5713970, m=m@entry=0x7f9d713f38c0 <StatusNotifierItemSource::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x7fffb7e6d200) at kernel/qobject.cpp:3539
#14 0x00007f9d711e7ccf in StatusNotifierItemSource::contextMenuReady (this=<optimized out>, _t1=0x3aa43c0) at ./statusnotifieritemsource.moc:123
#15 0x00007f9d711e7cf9 in StatusNotifierItemSource::contextMenuReady (this=<optimized out>) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:365
#16 0x00007f9d711eb04d in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at ./statusnotifieritemsource.moc:65
#17 StatusNotifierItemSource::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./statusnotifieritemsource.moc:58
#18 0x00007f9d8b0830ef in QMetaObject::activate (sender=0x64273a0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3539
#19 0x00007f9d82a7958c in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/x86_64-linux-gnu/libdbusmenu-qt.so.2
#20 0x00007f9d8b0830ef in QMetaObject::activate (sender=0x3aa43c0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3539
#21 0x00007f9d8b076ad7 in QMetaMethod::invoke (this=this@entry=0x7fffb7e6d9a0, object=object@entry=0x3aa43c0, connectionType=Qt::DirectConnection, connectionType@entry=Qt::AutoConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1664
#22 0x00007f9d8b078eac in QMetaObject::invokeMethod (obj=0x3aa43c0, member=<optimized out>, type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1179
#23 0x00007f9d82a76e29 in DBusMenuImporter::updateMenu() () from /usr/lib/x86_64-linux-gnu/libdbusmenu-qt.so.2
#24 0x00007f9d711e78e6 in StatusNotifierItemSource::contextMenu (this=0x5713970, x=<optimized out>, y=y@entry=872) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:468
#25 0x00007f9d711ecad3 in StatusNotifierItemJob::start (this=0x5f89e50) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#26 0x00007f9d8b0885be in QObject::event (this=0x5f89e50, e=<optimized out>) at kernel/qobject.cpp:1194
#27 0x00007f9d8a4148ec in QApplicationPrivate::notify_helper (this=this@entry=0x153e370, receiver=receiver@entry=0x5f89e50, e=e@entry=0x598f160) at kernel/qapplication.cpp:4567
#28 0x00007f9d8a41725b in QApplication::notify (this=this@entry=0x1528730, receiver=receiver@entry=0x5f89e50, e=e@entry=0x598f160) at kernel/qapplication.cpp:4428
#29 0x00007f9d8bd2fad6 in KApplication::notify (this=0x1528730, receiver=0x5f89e50, event=0x598f160) at ../../kdeui/kernel/kapplication.cpp:311
#30 0x00007f9d8b06e63e in QCoreApplication::notifyInternal (this=0x1528730, receiver=receiver@entry=0x5f89e50, event=event@entry=0x598f160) at kernel/qcoreapplication.cpp:946
#31 0x00007f9d8b072171 in sendEvent (event=0x598f160, receiver=0x5f89e50) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#32 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x14b21f0) at kernel/qcoreapplication.cpp:1570
#33 0x00007f9d8b0724a3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#34 0x00007f9d8b09ce83 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#35 postEventSourceDispatch (s=0x1545a70) at kernel/qeventdispatcher_glib.cpp:279
#36 0x00007f9d818f9f05 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#37 0x00007f9d818fa248 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#38 0x00007f9d818fa304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#39 0x00007f9d8b09d016 in QEventDispatcherGlib::processEvents (this=0x14b3ad0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#40 0x00007f9d8a4ba1ae in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#41 0x00007f9d8b06d38f in QEventLoop::processEvents (this=this@entry=0x7fffb7e6e9c0, flags=...) at kernel/qeventloop.cpp:149
#42 0x00007f9d8b06d618 in QEventLoop::exec (this=this@entry=0x7fffb7e6e9c0, flags=...) at kernel/qeventloop.cpp:204
#43 0x00007f9d8b072cf6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#44 0x00007f9d8a412ffc in QApplication::exec () at kernel/qapplication.cpp:3828
#45 0x00007f9d8e7cb461 in kdemain (argc=1, argv=0x7fffb7e6ecb8) at ../../../../plasma/desktop/shell/main.cpp:126
#46 0x00007f9d8e3e7ea5 in __libc_start_main (main=0x4006a0 <main(int, char**)>, argc=1, ubp_av=0x7fffb7e6ecb8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffb7e6eca8) at libc-start.c:260
#47 0x00000000004006d1 in _start ()

Possible duplicates by query: bug 314336, bug 313616, bug 311545, bug 310989, bug 309029.

Reported using DrKonqi
Comment 1 Martin Flöser 2013-06-06 10:12:54 UTC

*** This bug has been marked as a duplicate of bug 241562 ***