Bug 313616 - Amarok file import
Summary: Amarok file import
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-21 12:55 UTC by Tim Clevenger
Modified: 2013-01-28 00:20 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Clevenger 2013-01-21 12:55:54 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.9.4 (Compiled from sources)
Qt Version: 4.8.3
Operating System: Linux 3.5.0-17-generic i686
Distribution: Linux Mint 14 Nadia

-- Information about the crash:
- What I was doing when the application crashed: Importing music files to Amarok as the music player froze. I attempted shutdown.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb1d37740 (LWP 2455))]

Thread 5 (Thread 0xa98d1b40 (LWP 2459)):
#0  0xb77b3424 in __kernel_vsyscall ()
#1  0xb2b4c96b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb767764c in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb3b7d1cd in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#4  0xb3b7d1ff in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#5  0xb2b48d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0xb7669d3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 4 (Thread 0xa80ffb40 (LWP 2462)):
#0  0xb77b3424 in __kernel_vsyscall ()
#1  0xb76593eb in read () from /lib/i386-linux-gnu/libc.so.6
#2  0xb2a7d1ae in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2a3c83b in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2a3cc92 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb2a3ce61 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb612f99f in QEventDispatcherGlib::processEvents (this=0xa7700468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0xb60fc26c in QEventLoop::processEvents (this=this@entry=0xa80ff228, flags=...) at kernel/qeventloop.cpp:149
#8  0xb60fc561 in QEventLoop::exec (this=0xa80ff228, flags=...) at kernel/qeventloop.cpp:204
#9  0xb5fe766c in QThread::exec (this=0x8d33340) at thread/qthread.cpp:501
#10 0xb60da7bd in QInotifyFileSystemWatcherEngine::run (this=0x8d33340) at io/qfilesystemwatcher_inotify.cpp:248
#11 0xb5feaa58 in QThreadPrivate::start (arg=0x8d33340) at thread/qthread_unix.cpp:338
#12 0xb2b48d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#13 0xb7669d3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xa59acb40 (LWP 2465)):
#0  0xb2b4adc8 in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0xb7677864 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0xb2a7ded0 in g_mutex_lock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2a3c616 in g_main_context_query () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2a3cc5e in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb2a3d1db in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xa629fb7a in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#7  0xb2a62303 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb2b48d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#9  0xb7669d3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xa47d8b40 (LWP 2468)):
#0  0xb2b4aca3 in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0xb7677864 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0xb2a7ded0 in g_mutex_lock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2a3ce4a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb612f99f in QEventDispatcherGlib::processEvents (this=0xa77022d8, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0xb60fc26c in QEventLoop::processEvents (this=this@entry=0xa47d8248, flags=...) at kernel/qeventloop.cpp:149
#6  0xb60fc561 in QEventLoop::exec (this=0xa47d8248, flags=...) at kernel/qeventloop.cpp:204
#7  0xb5fe766c in QThread::exec (this=0x91c5d98) at thread/qthread.cpp:501
#8  0xa4c34c29 in KCupsConnection::run() () from /usr/lib/libkcupslib.so
#9  0xb5feaa58 in QThreadPrivate::start (arg=0x91c5d98) at thread/qthread_unix.cpp:338
#10 0xb2b48d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0xb7669d3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb1d37740 (LWP 2455)):
[KCrash Handler]
#7  QMutex::lock (this=0x8ab76e4) at thread/qmutex.cpp:153
#8  0xb610121b in QCoreApplication::postEvent (receiver=receiver@entry=0x8808bc0, event=event@entry=0x9ee9ec8, priority=priority@entry=0) at kernel/qcoreapplication.cpp:1320
#9  0xb610154b in QCoreApplication::postEvent (receiver=0x8808bc0, event=0x9ee9ec8) at kernel/qcoreapplication.cpp:1273
#10 0xb6110a58 in QObject::deleteLater (this=0x8808bc0) at kernel/qobject.cpp:2084
#11 0xb63efd9c in KJob::emitResult (this=0x8808bc0) at ../../kdecore/jobs/kjob.cpp:321
#12 0xb7404d88 in Plasma::ServiceJob::setResult (this=0x8808bc0, result=...) at ../../plasma/servicejob.cpp:92
#13 0xaeda9b66 in StatusNotifierItemJob::contextMenuReady (this=0x8808bc0, menu=0x981c0b8) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#14 0xb6115ed6 in QMetaObject::activate (sender=0x8976518, m=0xaedb2c58 <StatusNotifierItemSource::staticMetaObject>, local_signal_index=0, argv=0xbfe9df58) at kernel/qobject.cpp:3547
#15 0xaeda53a5 in StatusNotifierItemSource::contextMenuReady (this=this@entry=0x8976518, _t1=0x981c0b8) at ./statusnotifieritemsource.moc:123
#16 0xaeda53e1 in StatusNotifierItemSource::contextMenuReady (this=this@entry=0x8976518) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:363
#17 0xaeda85e4 in qt_static_metacall (_a=0xbfe9e03c, _id=1, _o=0x8976518, _c=<optimized out>) at ./statusnotifieritemsource.moc:65
#18 StatusNotifierItemSource::qt_static_metacall (_o=0x8976518, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbfe9e03c) at ./statusnotifieritemsource.moc:58
#19 0xb6115ed6 in QMetaObject::activate (sender=0x88f4300, m=0xb2be6e00 <DBusMenuImporter::staticMetaObject>, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3547
#20 0xb2bc9fa5 in DBusMenuImporter::menuUpdated() () from /usr/lib/i386-linux-gnu/libdbusmenu-qt.so.2
#21 0xb2bcabdc in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/i386-linux-gnu/libdbusmenu-qt.so.2
#22 0xb2bd2620 in ?? () from /usr/lib/i386-linux-gnu/libdbusmenu-qt.so.2
#23 0xb6115ed6 in QMetaObject::activate (sender=0x981c0b8, m=0xb5f68b34 <QMenu::staticMetaObject>, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3547
#24 0xb5a97ed5 in QMenu::aboutToShow (this=this@entry=0x981c0b8) at .moc/release-shared/moc_qmenu.cpp:165
#25 0xb5a9e9b8 in qt_static_metacall (_a=0xbfe9e454, _id=0, _o=0x981c0b8, _c=<optimized out>) at .moc/release-shared/moc_qmenu.cpp:74
#26 QMenu::qt_static_metacall (_o=0x981c0b8, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfe9e454) at .moc/release-shared/moc_qmenu.cpp:68
#27 0xb610660d in QMetaMethod::invoke (this=0xbfe9e584, object=0x981c0b8, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1664
#28 0xb6108c89 in QMetaObject::invokeMethod (obj=0x981c0b8, member=0xb2bda467 "aboutToShow", type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1179
#29 0xb2bc990f in DBusMenuImporter::updateMenu() () from /usr/lib/i386-linux-gnu/libdbusmenu-qt.so.2
#30 0xaeda4f63 in StatusNotifierItemSource::contextMenu (this=0x8976518, x=1311, y=17) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:466
#31 0xaedaa51a in StatusNotifierItemJob::start (this=0x8808bc0) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#32 0xb7404972 in autoStart (this=<optimized out>) at ../../plasma/servicejob.cpp:47
#33 qt_static_metacall (_o=0x8808bc0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./servicejob.moc:61
#34 Plasma::ServiceJob::qt_static_metacall (_o=0x8808bc0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x9ad96f8) at ./servicejob.moc:55
#35 0xb610f9aa in QMetaCallEvent::placeMetaCall (this=0x9316838, object=0x8808bc0) at kernel/qobject.cpp:525
#36 0xb6113eeb in QObject::event (this=0x8808bc0, e=0x9316838) at kernel/qobject.cpp:1195
#37 0xb55ed39c in QApplicationPrivate::notify_helper (this=0x86e0020, receiver=0x8808bc0, e=0x9316838) at kernel/qapplication.cpp:4562
#38 0xb55f1daf in QApplication::notify (this=0x9316838, receiver=0x8808bc0, e=0x9316838) at kernel/qapplication.cpp:3944
#39 0xb678ce91 in KApplication::notify (this=0x86a43f0, receiver=0x8808bc0, event=0x9316838) at ../../kdeui/kernel/kapplication.cpp:311
#40 0xb60fd78e in QCoreApplication::notifyInternal (this=0x86a43f0, receiver=0x8808bc0, event=0x9316838) at kernel/qcoreapplication.cpp:915
#41 0xb610197d in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#42 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8678130) at kernel/qcoreapplication.cpp:1539
#43 0xb6101c0c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1432
#44 0xb612f804 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#45 postEventSourceDispatch (s=0x86da220) at kernel/qeventdispatcher_glib.cpp:279
#46 0xb2a3c9e3 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#47 0xb2a3cd80 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#48 0xb2a3ce61 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#49 0xb612f981 in QEventDispatcherGlib::processEvents (this=0x8678eb8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#50 0xb56a39aa in QGuiEventDispatcherGlib::processEvents (this=0x8678eb8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#51 0xb60fc26c in QEventLoop::processEvents (this=this@entry=0xbfe9f1b8, flags=...) at kernel/qeventloop.cpp:149
#52 0xb60fc561 in QEventLoop::exec (this=0xbfe9f1b8, flags=...) at kernel/qeventloop.cpp:204
#53 0xb6101cba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#54 0xb55eafc4 in QApplication::exec () at kernel/qapplication.cpp:3823
#55 0xb7771063 in kdemain (argc=1, argv=0xbfe9f374) at ../../../../plasma/desktop/shell/main.cpp:120
#56 0x0804855b in main (argc=1, argv=0xbfe9f374) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 311545, bug 310989, bug 309029, bug 307897, bug 307488.

Reported using DrKonqi
Comment 1 Christoph Feck 2013-01-28 00:20:21 UTC

*** This bug has been marked as a duplicate of bug 241562 ***