Bug 315929 - Starting Kpatience
Summary: Starting Kpatience
Status: RESOLVED DUPLICATE of bug 309824
Alias: None
Product: kpat
Classification: Unclassified
Component: general (show other bugs)
Version: 3.6
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-28 23:35 UTC by andy75043
Modified: 2013-03-01 00:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andy75043 2013-02-28 23:35:02 UTC
Application: kpat (3.6)
KDE Platform Version: 4.9.5
Qt Version: 4.8.4
Operating System: Linux 3.7.9-205.fc18.x86_64 x86_64
Distribution: "Fedora release 18 (Spherical Cow)"

-- Information about the crash:
- What I was doing when the application crashed:

Opened Kpatience and selected Grandfather; it crashed immediately.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KPatience (kpat), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
81	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#6  0x0000003695231f9d in lock (this=0x2741f20) at /usr/src/debug/kdelibs-4.9.5/kdecore/util/kshareddatacache.cpp:1231
#7  KSharedDataCache::Private::CacheLocker::cautiousLock (this=0x7fff4cab2550) at /usr/src/debug/kdelibs-4.9.5/kdecore/util/kshareddatacache.cpp:1255
#8  0x00000036952325f0 in KSharedDataCache::Private::CacheLocker::CacheLocker (this=0x7fff4cab2550, _d=<optimized out>) at /usr/src/debug/kdelibs-4.9.5/kdecore/util/kshareddatacache.cpp:1278
#9  0x000000369522a61e in KSharedDataCache::find (this=0x2804700, key=..., destination=0x7fff4cab25c0) at /usr/src/debug/kdelibs-4.9.5/kdecore/util/kshareddatacache.cpp:1630
#10 0x00000036972a8382 in KImageCache::findPixmap (this=0x2804700, key=..., destination=0x28762f8) at /usr/src/debug/kdelibs-4.9.5/kdeui/util/kimagecache.cpp:150
#11 0x00000034438165fa in KAbstractCardDeckPrivate::requestPixmap (this=0x28aad40, id=<optimized out>, faceUp=<optimized out>) at /usr/src/debug/kdegames-4.9.5/kpat/libkcardgame/kabstractcarddeck.cpp:205
#12 0x0000003443816810 in KAbstractCardDeck::cardPixmap (this=<optimized out>, id=<optimized out>, faceUp=<optimized out>) at /usr/src/debug/kdegames-4.9.5/kpat/libkcardgame/kabstractcarddeck.cpp:506
#13 0x0000003443818e27 in KCard::paint (this=0x2875c80, painter=0x7fff4cab2de0, option=<optimized out>, widget=<optimized out>) at /usr/src/debug/kdegames-4.9.5/kpat/libkcardgame/kcard.cpp:319
#14 0x0000003695dbd9f5 in QGraphicsScenePrivate::draw (this=this@entry=0x28aae10, item=item@entry=0x2875c90, painter=painter@entry=0x7fff4cab2de0, viewTransform=viewTransform@entry=0x7fff4cab2f70, transformPtr=transformPtr@entry=0x7fff4cab2a80, exposedRegion=exposedRegion@entry=0x272fce8, widget=0x2745b20, opacity=opacity@entry=1, effectTransform=effectTransform@entry=0x0, wasDirtyParentSceneTransform=wasDirtyParentSceneTransform@entry=true, drawItem=true) at graphicsview/qgraphicsscene.cpp:4964
#15 0x0000003695dbe775 in QGraphicsScenePrivate::drawSubtreeRecursive (this=this@entry=0x28aae10, item=0x2875c90, painter=painter@entry=0x7fff4cab2de0, viewTransform=viewTransform@entry=0x7fff4cab2f70, exposedRegion=exposedRegion@entry=0x272fce8, widget=widget@entry=0x2745b20, parentOpacity=parentOpacity@entry=1, effectTransform=effectTransform@entry=0x0) at graphicsview/qgraphicsscene.cpp:4857
#16 0x0000003695dbf24e in QGraphicsScenePrivate::drawItems (this=0x28aae10, painter=0x7fff4cab2de0, viewTransform=0x7fff4cab2f70, exposedRegion=0x272fce8, widget=0x2745b20) at graphicsview/qgraphicsscene.cpp:4739
#17 0x0000003695ddb3e8 in QGraphicsView::paintEvent (this=0x272f800, event=<optimized out>) at graphicsview/qgraphicsview.cpp:3471
#18 0x0000003695819efe in QWidget::event (this=0x272f800, event=0x7fff4cab3a30) at kernel/qwidget.cpp:8532
#19 0x0000003695bc49f6 in QFrame::event (this=0x272f800, e=0x7fff4cab3a30) at widgets/qframe.cpp:557
#20 0x0000003695ddc51b in QGraphicsView::viewportEvent (this=0x272f800, event=0x7fff4cab3a30) at graphicsview/qgraphicsview.cpp:2866
#21 0x0000003693977c26 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x2745b20, event=0x7fff4cab3a30) at kernel/qcoreapplication.cpp:1056
#22 0x00000036957ca59c in QApplicationPrivate::notify_helper (this=0x2572000, receiver=0x2745b20, e=0x7fff4cab3a30) at kernel/qapplication.cpp:4558
#23 0x00000036957cea4a in QApplication::notify (this=0x7fff4cab5e10, receiver=0x2745b20, e=0x7fff4cab3a30) at kernel/qapplication.cpp:4423
#24 0x0000003697246916 in KApplication::notify (this=0x7fff4cab5e10, receiver=0x2745b20, event=0x7fff4cab3a30) at /usr/src/debug/kdelibs-4.9.5/kdeui/kernel/kapplication.cpp:311
#25 0x0000003693977abe in QCoreApplication::notifyInternal (this=0x7fff4cab5e10, receiver=0x2745b20, event=0x7fff4cab3a30) at kernel/qcoreapplication.cpp:946
#26 0x0000003695815ac4 in QWidgetPrivate::drawWidget (this=0x2745c30, pdev=0x28a0990, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x27ddf00) at ../../src/corelib/kernel/qcoreapplication.h:234
#27 0x00000036958165bf in QWidgetPrivate::paintSiblingsRecursive (this=0x272f860, pdev=0x28a0990, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x27ddf00) at kernel/qwidget.cpp:5807
#28 0x0000003695815655 in QWidgetPrivate::drawWidget (this=0x272f860, pdev=0x28a0990, rgn=..., offset=..., flags=<optimized out>, sharedPainter=0x0, backingStore=0x27ddf00) at kernel/qwidget.cpp:5651
#29 0x00000036958165bf in QWidgetPrivate::paintSiblingsRecursive (this=0x26fd570, pdev=0x28a0990, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x27ddf00) at kernel/qwidget.cpp:5807
#30 0x0000003695816404 in QWidgetPrivate::paintSiblingsRecursive (this=0x26fd570, pdev=0x28a0990, siblings=..., index=10, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x27ddf00) at kernel/qwidget.cpp:5794
#31 0x0000003695816404 in QWidgetPrivate::paintSiblingsRecursive (this=0x26fd570, pdev=0x28a0990, siblings=..., index=18, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x27ddf00) at kernel/qwidget.cpp:5794
#32 0x0000003695815655 in QWidgetPrivate::drawWidget (this=0x26fd570, pdev=0x28a0990, rgn=..., offset=..., flags=<optimized out>, sharedPainter=0x0, backingStore=0x27ddf00) at kernel/qwidget.cpp:5651
#33 0x00000036959dfde8 in QWidgetBackingStore::sync (this=0x27ddf00) at painting/qbackingstore.cpp:1373
#34 0x000000369580a5f0 in QWidgetPrivate::syncBackingStore (this=0x26fd570) at kernel/qwidget.cpp:1896
#35 0x000000369581a3a4 in QWidget::event (this=0x26fd420, event=0x2803760) at kernel/qwidget.cpp:8679
#36 0x0000003695bddf2b in QMainWindow::event (this=0x26fd420, event=0x2803760) at widgets/qmainwindow.cpp:1478
#37 0x0000003697338678 in KXmlGuiWindow::event (this=0x26fd420, ev=0x2803760) at /usr/src/debug/kdelibs-4.9.5/kdeui/xmlgui/kxmlguiwindow.cpp:126
#38 0x00000036957ca5cc in QApplicationPrivate::notify_helper (this=0x2572000, receiver=0x26fd420, e=0x2803760) at kernel/qapplication.cpp:4562
#39 0x00000036957cea4a in QApplication::notify (this=0x7fff4cab5e10, receiver=0x26fd420, e=0x2803760) at kernel/qapplication.cpp:4423
#40 0x0000003697246916 in KApplication::notify (this=0x7fff4cab5e10, receiver=0x26fd420, event=0x2803760) at /usr/src/debug/kdelibs-4.9.5/kdeui/kernel/kapplication.cpp:311
#41 0x0000003693977abe in QCoreApplication::notifyInternal (this=0x7fff4cab5e10, receiver=receiver@entry=0x26fd420, event=event@entry=0x2803760) at kernel/qcoreapplication.cpp:946
#42 0x000000369397b571 in sendEvent (event=0x2803760, receiver=0x26fd420) at kernel/qcoreapplication.h:231
#43 QCoreApplicationPrivate::sendPostedEvents (receiver=0x26fd420, event_type=77, data=0x25397c0) at kernel/qcoreapplication.cpp:1570
#44 0x0000003695dae6e2 in dispatchPendingUpdateRequests (this=0x272f860) at ../../src/gui/graphicsview/qgraphicsview_p.h:200
#45 QGraphicsScenePrivate::_q_emitUpdated (this=0x28aae10) at graphicsview/qgraphicsscene.cpp:390
#46 0x0000003695db84b9 in qt_static_metacall (_c=QMetaObject::InvokeMetaMethod, _a=<optimized out>, _id=<optimized out>, _o=<optimized out>) at .moc/release-shared/moc_qgraphicsscene.cpp:104
#47 QGraphicsScene::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qgraphicsscene.cpp:85
#48 0x000000369398c3ce in QObject::event (this=0x2bc0b60, e=<optimized out>) at kernel/qobject.cpp:1194
#49 0x0000003695dc2d54 in QGraphicsScene::event (this=0x2bc0b60, event=0x2ed0d60) at graphicsview/qgraphicsscene.cpp:3565
#50 0x00000036957ca5cc in QApplicationPrivate::notify_helper (this=0x2572000, receiver=0x2bc0b60, e=0x2ed0d60) at kernel/qapplication.cpp:4562
#51 0x00000036957cea4a in QApplication::notify (this=0x7fff4cab5e10, receiver=0x2bc0b60, e=0x2ed0d60) at kernel/qapplication.cpp:4423
#52 0x0000003697246916 in KApplication::notify (this=0x7fff4cab5e10, receiver=0x2bc0b60, event=0x2ed0d60) at /usr/src/debug/kdelibs-4.9.5/kdeui/kernel/kapplication.cpp:311
#53 0x0000003693977abe in QCoreApplication::notifyInternal (this=0x7fff4cab5e10, receiver=receiver@entry=0x2bc0b60, event=event@entry=0x2ed0d60) at kernel/qcoreapplication.cpp:946
#54 0x000000369397b571 in sendEvent (event=0x2ed0d60, receiver=0x2bc0b60) at kernel/qcoreapplication.h:231
#55 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x25397c0) at kernel/qcoreapplication.cpp:1570
#56 0x00000036939a5f73 in sendPostedEvents () at kernel/qcoreapplication.h:236
#57 postEventSourceDispatch (s=s@entry=0x2570850) at kernel/qeventdispatcher_glib.cpp:279
#58 0x00000039bd047a55 in g_main_dispatch (context=0x257a930) at gmain.c:2715
#59 g_main_context_dispatch (context=context@entry=0x257a930) at gmain.c:3219
#60 0x00000039bd047d88 in g_main_context_iterate (context=context@entry=0x257a930, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3290
#61 0x00000039bd047e44 in g_main_context_iteration (context=0x257a930, may_block=1) at gmain.c:3351
#62 0x00000036939a6106 in QEventDispatcherGlib::processEvents (this=0x253b0a0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#63 0x000000369586a73e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#64 0x000000369397680f in QEventLoop::processEvents (this=this@entry=0x7fff4cab5b80, flags=...) at kernel/qeventloop.cpp:149
#65 0x0000003693976a98 in QEventLoop::exec (this=0x7fff4cab5b80, flags=...) at kernel/qeventloop.cpp:204
#66 0x000000369397b888 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#67 0x000000000041838a in main (argc=3, argv=0x7fff4cab5fc8) at /usr/src/debug/kdegames-4.9.5/kpat/main.cpp:325

This bug may be a duplicate of or related to bug 309824.

Possible duplicates by query: bug 313924, bug 313545, bug 311966, bug 310421, bug 310111.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-03-01 00:32:01 UTC

*** This bug has been marked as a duplicate of bug 309824 ***