Bug 313924 - Game crash before it begun
Summary: Game crash before it begun
Status: RESOLVED DUPLICATE of bug 309824
Alias: None
Product: kpat
Classification: Unclassified
Component: general (show other bugs)
Version: 3.6
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-26 14:54 UTC by odila
Modified: 2013-02-10 03:13 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (9.89 KB, text/plain)
2013-02-10 03:13 UTC, odila
Details

Note You need to log in before you can comment on or make changes to this bug.
Description odila 2013-01-26 14:54:24 UTC
Application: kpat (3.6)
KDE Platform Version: 4.9.5
Qt Version: 4.8.4
Operating System: Linux 3.7.3-101.fc17.x86_64 x86_64
Distribution: "Fedora release 17 (Beefy Miracle)"

-- Information about the crash:
- What I was doing when the application crashed:
Starting application. No other app was running at that time.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KPatience (kpat), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[KCrash Handler]
#6  0x0000003826c31eed in lock (this=<optimized out>) at /usr/src/debug/kdelibs-4.9.5/kdecore/util/kshareddatacache.cpp:1231
#7  KSharedDataCache::Private::CacheLocker::cautiousLock (this=0x7fff0a593950) at /usr/src/debug/kdelibs-4.9.5/kdecore/util/kshareddatacache.cpp:1255
#8  0x0000003826c32540 in KSharedDataCache::Private::CacheLocker::CacheLocker (this=0x7fff0a593950, _d=<optimized out>) at /usr/src/debug/kdelibs-4.9.5/kdecore/util/kshareddatacache.cpp:1278
#9  0x0000003826c2aa7b in KSharedDataCache::insert (this=0x14b5430, key=..., data=...) at /usr/src/debug/kdelibs-4.9.5/kdecore/util/kshareddatacache.cpp:1471
#10 0x00000038284a7e2d in KImageCache::insertImage (this=0x14b5430, key=..., image=...) at /usr/src/debug/kdelibs-4.9.5/kdeui/util/kimagecache.cpp:103
#11 0x000000382c0166b0 in KAbstractCardDeckPrivate::requestPixmap (this=0x1590540, id=<optimized out>, faceUp=<optimized out>) at /usr/src/debug/kdegames-4.9.5/kpat/libkcardgame/kabstractcarddeck.cpp:211
#12 0x000000382c0167c0 in KAbstractCardDeck::cardPixmap (this=<optimized out>, id=<optimized out>, faceUp=<optimized out>) at /usr/src/debug/kdegames-4.9.5/kpat/libkcardgame/kabstractcarddeck.cpp:506
#13 0x000000382c018dd7 in KCard::paint (this=0x1fbfd30, painter=0x7fff0a594250, option=<optimized out>, widget=<optimized out>) at /usr/src/debug/kdegames-4.9.5/kpat/libkcardgame/kcard.cpp:319
#14 0x00000038277bd6b5 in QGraphicsScenePrivate::draw (this=this@entry=0x192d2f0, item=item@entry=0x1fbfd40, painter=painter@entry=0x7fff0a594250, viewTransform=viewTransform@entry=0x7fff0a5943e0, transformPtr=transformPtr@entry=0x7fff0a593ef0, exposedRegion=exposedRegion@entry=0x13f8e28, widget=0x1404620, opacity=opacity@entry=1, effectTransform=effectTransform@entry=0x0, wasDirtyParentSceneTransform=wasDirtyParentSceneTransform@entry=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4964
#15 0x00000038277be435 in QGraphicsScenePrivate::drawSubtreeRecursive (this=this@entry=0x192d2f0, item=0x1fbfd40, painter=painter@entry=0x7fff0a594250, viewTransform=viewTransform@entry=0x7fff0a5943e0, exposedRegion=exposedRegion@entry=0x13f8e28, widget=widget@entry=0x1404620, parentOpacity=parentOpacity@entry=1, effectTransform=effectTransform@entry=0x0) at graphicsview/qgraphicsscene.cpp:4857
#16 0x00000038277bef0e in QGraphicsScenePrivate::drawItems (this=0x192d2f0, painter=0x7fff0a594250, viewTransform=0x7fff0a5943e0, exposedRegion=0x13f8e28, widget=0x1404620) at graphicsview/qgraphicsscene.cpp:4739
#17 0x00000038277db088 in QGraphicsView::paintEvent (this=0x13f8940, event=<optimized out>) at graphicsview/qgraphicsview.cpp:3471
#18 0x0000003827219ede in QWidget::event (this=0x13f8940, event=0x7fff0a594ea0) at kernel/qwidget.cpp:8532
#19 0x00000038275c46e6 in QFrame::event (this=0x13f8940, e=0x7fff0a594ea0) at widgets/qframe.cpp:557
#20 0x00000038277dc1bb in QGraphicsView::viewportEvent (this=0x13f8940, event=0x7fff0a594ea0) at graphicsview/qgraphicsview.cpp:2866
#21 0x0000003825977b06 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x1404620, event=0x7fff0a594ea0) at kernel/qcoreapplication.cpp:1056
#22 0x00000038271ca57c in QApplicationPrivate::notify_helper (this=this@entry=0x1282790, receiver=receiver@entry=0x1404620, e=e@entry=0x7fff0a594ea0) at kernel/qapplication.cpp:4558
#23 0x00000038271cea2a in QApplication::notify (this=0x7fff0a597080, receiver=0x1404620, e=0x7fff0a594ea0) at kernel/qapplication.cpp:4423
#24 0x00000038284468c6 in KApplication::notify (this=0x7fff0a597080, receiver=0x1404620, event=0x7fff0a594ea0) at /usr/src/debug/kdelibs-4.9.5/kdeui/kernel/kapplication.cpp:311
#25 0x000000382597799e in QCoreApplication::notifyInternal (this=0x7fff0a597080, receiver=0x1404620, event=0x7fff0a594ea0) at kernel/qcoreapplication.cpp:946
#26 0x0000003827215aa4 in sendSpontaneousEvent (event=0x7fff0a594ea0, receiver=0x1404620) at ../../src/corelib/kernel/qcoreapplication.h:234
#27 QWidgetPrivate::drawWidget (this=this@entry=0x14049f0, pdev=pdev@entry=0x157de30, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=backingStore@entry=0x14b9240) at kernel/qwidget.cpp:5598
#28 0x000000382721659f in QWidgetPrivate::paintSiblingsRecursive (this=0x13f89a0, pdev=0x157de30, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x14b9240) at kernel/qwidget.cpp:5807
#29 0x0000003827215635 in QWidgetPrivate::drawWidget (this=this@entry=0x13f89a0, pdev=pdev@entry=0x157de30, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=backingStore@entry=0x14b9240) at kernel/qwidget.cpp:5651
#30 0x000000382721659f in QWidgetPrivate::paintSiblingsRecursive (this=this@entry=0x139f9c0, pdev=pdev@entry=0x157de30, siblings=..., index=<optimized out>, index@entry=18, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=backingStore@entry=0x14b9240) at kernel/qwidget.cpp:5807
#31 0x00000038272163e4 in QWidgetPrivate::paintSiblingsRecursive (this=0x139f9c0, pdev=0x157de30, siblings=..., index=18, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x14b9240) at kernel/qwidget.cpp:5794
#32 0x0000003827215635 in QWidgetPrivate::drawWidget (this=0x139f9c0, pdev=0x157de30, rgn=..., offset=..., flags=<optimized out>, sharedPainter=0x0, backingStore=0x14b9240) at kernel/qwidget.cpp:5651
#33 0x00000038273dfb38 in QWidgetBackingStore::sync (this=0x14b9240) at painting/qbackingstore.cpp:1373
#34 0x000000382720a5d0 in QWidgetPrivate::syncBackingStore (this=this@entry=0x139f9c0) at kernel/qwidget.cpp:1896
#35 0x000000382721a384 in QWidget::event (this=0x139f870, event=0x145cbb0) at kernel/qwidget.cpp:8679
#36 0x00000038275ddc0b in QMainWindow::event (this=0x139f870, event=0x145cbb0) at widgets/qmainwindow.cpp:1478
#37 0x0000003828538618 in KXmlGuiWindow::event (this=0x139f870, ev=0x145cbb0) at /usr/src/debug/kdelibs-4.9.5/kdeui/xmlgui/kxmlguiwindow.cpp:126
#38 0x00000038271ca5ac in QApplicationPrivate::notify_helper (this=this@entry=0x1282790, receiver=receiver@entry=0x139f870, e=e@entry=0x145cbb0) at kernel/qapplication.cpp:4562
#39 0x00000038271cea2a in QApplication::notify (this=0x7fff0a597080, receiver=0x139f870, e=0x145cbb0) at kernel/qapplication.cpp:4423
#40 0x00000038284468c6 in KApplication::notify (this=0x7fff0a597080, receiver=0x139f870, event=0x145cbb0) at /usr/src/debug/kdelibs-4.9.5/kdeui/kernel/kapplication.cpp:311
#41 0x000000382597799e in QCoreApplication::notifyInternal (this=0x7fff0a597080, receiver=receiver@entry=0x139f870, event=event@entry=0x145cbb0) at kernel/qcoreapplication.cpp:946
#42 0x000000382597b451 in sendEvent (event=0x145cbb0, receiver=0x139f870) at kernel/qcoreapplication.h:231
#43 QCoreApplicationPrivate::sendPostedEvents (receiver=0x139f870, event_type=77, data=0x12537c0) at kernel/qcoreapplication.cpp:1570
#44 0x00000038277b7e42 in dispatchPendingUpdateRequests (this=0x13f89a0) at ../../src/gui/graphicsview/qgraphicsview_p.h:200
#45 QGraphicsScenePrivate::_q_processDirtyItems (this=0x192d2f0) at graphicsview/qgraphicsscene.cpp:515
#46 0x00000038277b7ff9 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at .moc/release-shared/moc_qgraphicsscene.cpp:106
#47 QGraphicsScene::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qgraphicsscene.cpp:85
#48 0x000000382598c29e in QObject::event (this=0x1590350, e=<optimized out>) at kernel/qobject.cpp:1194
#49 0x00000038277c2a04 in QGraphicsScene::event (this=0x1590350, event=0x1fed640) at graphicsview/qgraphicsscene.cpp:3565
#50 0x00000038271ca5ac in QApplicationPrivate::notify_helper (this=this@entry=0x1282790, receiver=receiver@entry=0x1590350, e=e@entry=0x1fed640) at kernel/qapplication.cpp:4562
#51 0x00000038271cea2a in QApplication::notify (this=0x7fff0a597080, receiver=0x1590350, e=0x1fed640) at kernel/qapplication.cpp:4423
#52 0x00000038284468c6 in KApplication::notify (this=0x7fff0a597080, receiver=0x1590350, event=0x1fed640) at /usr/src/debug/kdelibs-4.9.5/kdeui/kernel/kapplication.cpp:311
#53 0x000000382597799e in QCoreApplication::notifyInternal (this=0x7fff0a597080, receiver=receiver@entry=0x1590350, event=event@entry=0x1fed640) at kernel/qcoreapplication.cpp:946
#54 0x000000382597b451 in sendEvent (event=0x1fed640, receiver=0x1590350) at kernel/qcoreapplication.h:231
#55 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x12537c0) at kernel/qcoreapplication.cpp:1570
#56 0x00000038259a5e33 in sendPostedEvents () at kernel/qcoreapplication.h:236
#57 postEventSourceDispatch (s=s@entry=0x129a580) at kernel/qeventdispatcher_glib.cpp:279
#58 0x00000030ce047825 in g_main_dispatch (context=0x1290740) at gmain.c:2539
#59 g_main_context_dispatch (context=context@entry=0x1290740) at gmain.c:3075
#60 0x00000030ce047b58 in g_main_context_iterate (context=context@entry=0x1290740, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3146
#61 0x00000030ce047c14 in g_main_context_iteration (context=0x1290740, may_block=1) at gmain.c:3207
#62 0x00000038259a5fc6 in QEventDispatcherGlib::processEvents (this=0x12550a0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#63 0x000000382726a5ee in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#64 0x00000038259766ef in QEventLoop::processEvents (this=this@entry=0x7fff0a596df0, flags=...) at kernel/qeventloop.cpp:149
#65 0x0000003825976978 in QEventLoop::exec (this=0x7fff0a596df0, flags=...) at kernel/qeventloop.cpp:204
#66 0x000000382597b768 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#67 0x000000000041831a in main (argc=3, argv=0x7fff0a597238) at /usr/src/debug/kdegames-4.9.5/kpat/main.cpp:325

Possible duplicates by query: bug 313545, bug 311966, bug 310421, bug 310111, bug 309824.

Reported using DrKonqi
Comment 1 Christoph Feck 2013-02-02 00:16:21 UTC

*** This bug has been marked as a duplicate of bug 309824 ***
Comment 2 odila 2013-02-10 03:13:17 UTC
Created attachment 77076 [details]
New crash information added by DrKonqi

kpat (3.6) on KDE Platform 4.9.5 using Qt 4.8.4

- What I was doing when the application crashed:
Startin Kpatience. Chrome and Virtualbox were running.

-- Backtrace (Reduced):
#6  0x0000003afae31f9d in lock (this=0x1c2e590) at /usr/src/debug/kdelibs-4.9.5/kdecore/util/kshareddatacache.cpp:1231
#7  KSharedDataCache::Private::CacheLocker::cautiousLock (this=0x7fff9ef61500) at /usr/src/debug/kdelibs-4.9.5/kdecore/util/kshareddatacache.cpp:1255
#8  0x0000003afae325f0 in KSharedDataCache::Private::CacheLocker::CacheLocker (this=0x7fff9ef61500, _d=<optimized out>) at /usr/src/debug/kdelibs-4.9.5/kdecore/util/kshareddatacache.cpp:1278
#9  0x0000003afae2a61e in KSharedDataCache::find (this=0x1b78de0, key=..., destination=0x7fff9ef61570) at /usr/src/debug/kdelibs-4.9.5/kdecore/util/kshareddatacache.cpp:1630
#10 0x0000003225aa8382 in KImageCache::findPixmap (this=0x1b78de0, key=..., destination=0x28c9498) at /usr/src/debug/kdelibs-4.9.5/kdeui/util/kimagecache.cpp:150