Bug 311545 - Plasma crashed after trying to open kmix
Summary: Plasma crashed after trying to open kmix
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-systemtray (show other bugs)
Version: 4.9.3
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 310158 312573 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-11 22:09 UTC by methodofmechanism
Modified: 2013-01-28 00:19 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description methodofmechanism 2012-12-11 22:09:30 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.9.3
Qt Version: 4.8.3
Operating System: Linux 3.6.9-2.fc17.i686 i686
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:
Opened and attempted to use the drum machine Hydrogen and kmix.

- Unusual behavior I noticed:
The kmix icon on the plasma panel began jittering, disappearing and reappearing rapidly. After attempting to open kmix manually, the desktop environment disappeared, with only Hydrogen still open and a black screen behind it. The jittering began when Hydrogen was opened.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb76f17c0 (LWP 1103))]

Thread 4 (Thread 0xae6c3b40 (LWP 1140)):
#0  0xb7734424 in __kernel_vsyscall ()
#1  0x483ce18b in read () at ../sysdeps/unix/syscall-template.S:82
#2  0x484ab766 in read (__nbytes=16, __buf=0xae6c2fdc, __fd=<optimized out>) at /usr/include/bits/unistd.h:45
#3  g_wakeup_acknowledge (wakeup=0xb46015d8) at gwakeup.c:212
#4  0x4846aef2 in g_main_context_check (context=context@entry=0xadd004e0, max_priority=2147483647, fds=fds@entry=0xadd02278, n_fds=n_fds@entry=1) at gmain.c:2980
#5  0x4846b372 in g_main_context_iterate (context=context@entry=0xadd004e0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3143
#6  0x4846b542 in g_main_context_iteration (context=0xadd004e0, may_block=1) at gmain.c:3207
#7  0x4924aa9f in QEventDispatcherGlib::processEvents (this=0xadd00468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#8  0x49216f7d in QEventLoop::processEvents (this=this@entry=0xae6c31a8, flags=...) at kernel/qeventloop.cpp:149
#9  0x49217279 in QEventLoop::exec (this=0xae6c31a8, flags=...) at kernel/qeventloop.cpp:204
#10 0x490fef4c in QThread::exec (this=0x9181718) at thread/qthread.cpp:501
#11 0x491f4f1e in QInotifyFileSystemWatcherEngine::run (this=0x9181718) at io/qfilesystemwatcher_inotify.cpp:248
#12 0x491023da in QThreadPrivate::start (arg=0x9181718) at thread/qthread_unix.cpp:338
#13 0x483c7adf in start_thread (arg=0xae6c3b40) at pthread_create.c:309
#14 0x482cd42e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 3 (Thread 0xadcffb40 (LWP 1146)):
#0  0xb7734424 in __kernel_vsyscall ()
#1  0x483cb12c in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:172
#2  0x4c7165dd in QTWTF::TCMalloc_PageHeap::scavengerThread (this=this@entry=0x4c825280) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#3  0x4c716610 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x4c825280) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#4  0x483c7adf in start_thread (arg=0xadcffb40) at pthread_create.c:309
#5  0x482cd42e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 2 (Thread 0xac6fab40 (LWP 1170)):
#0  g_mutex_unlock (mutex=mutex@entry=0xaca004e0) at gthread-posix.c:224
#1  0x4846ab65 in g_main_context_prepare (context=context@entry=0xaca004e0, priority=priority@entry=0xac6fa0a8) at gmain.c:2834
#2  0x4846b2df in g_main_context_iterate (context=context@entry=0xaca004e0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3126
#3  0x4846b542 in g_main_context_iteration (context=0xaca004e0, may_block=1) at gmain.c:3207
#4  0x4924aa9f in QEventDispatcherGlib::processEvents (this=0xaca00468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x49216f7d in QEventLoop::processEvents (this=this@entry=0xac6fa1d8, flags=...) at kernel/qeventloop.cpp:149
#6  0x49217279 in QEventLoop::exec (this=0xac6fa1d8, flags=...) at kernel/qeventloop.cpp:204
#7  0x490fef4c in QThread::exec (this=0x8d5db90) at thread/qthread.cpp:501
#8  0x415256ac in Plasma::StorageThread::run (this=0x8d5db90) at /usr/src/debug/kdelibs-4.9.3/plasma/private/storagethread.cpp:326
#9  0x491023da in QThreadPrivate::start (arg=0x8d5db90) at thread/qthread_unix.cpp:338
#10 0x483c7adf in start_thread (arg=0xac6fab40) at pthread_create.c:309
#11 0x482cd42e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0xb76f17c0 (LWP 1103)):
[KCrash Handler]
#7  QMutex::lock (this=0x4937da4c) at thread/qmutex.cpp:153
#8  0x4921bd0c in QCoreApplication::postEvent (receiver=receiver@entry=0x9d4e610, event=event@entry=0x98808a8, priority=priority@entry=0) at kernel/qcoreapplication.cpp:1320
#9  0x4921c03c in QCoreApplication::postEvent (receiver=0x9d4e610, event=0x98808a8) at kernel/qcoreapplication.cpp:1273
#10 0x4922b649 in QObject::deleteLater (this=0x9d4e610) at kernel/qobject.cpp:2084
#11 0x4fb51bed in KJob::emitResult (this=0x9d4e610) at /usr/src/debug/kdelibs-4.9.3/kdecore/jobs/kjob.cpp:321
#12 0x4155ac89 in Plasma::ServiceJob::setResult (this=0x9d4e610, result=...) at /usr/src/debug/kdelibs-4.9.3/plasma/servicejob.cpp:92
#13 0xb50f5cf9 in StatusNotifierItemJob::contextMenuReady (this=0x9d4e610, menu=0x94e2488) at /usr/src/debug/kde-workspace-4.9.3/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#14 0x49230bce in QMetaObject::activate (sender=0x9a3ac60, m=0xb50fe838, local_signal_index=0, argv=0xbfc128e8) at kernel/qobject.cpp:3547
#15 0xb50f1496 in StatusNotifierItemSource::contextMenuReady (this=this@entry=0x9a3ac60, _t1=0x94e2488) at /usr/src/debug/kde-workspace-4.9.3/i686-redhat-linux-gnu/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.moc:122
#16 0xb50f14d2 in StatusNotifierItemSource::contextMenuReady (this=this@entry=0x9a3ac60) at /usr/src/debug/kde-workspace-4.9.3/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:363
#17 0xb50f4724 in qt_static_metacall (_a=0xbfc129cc, _id=1, _o=0x9a3ac60, _c=<optimized out>) at /usr/src/debug/kde-workspace-4.9.3/i686-redhat-linux-gnu/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.moc:64
#18 StatusNotifierItemSource::qt_static_metacall (_o=0x9a3ac60, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbfc129cc) at /usr/src/debug/kde-workspace-4.9.3/i686-redhat-linux-gnu/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.moc:57
#19 0x49230bce in QMetaObject::activate (sender=0x9cde888, m=0x44c45060, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3547
#20 0x44c279e6 in DBusMenuImporter::menuUpdated (this=0x9cde888) at /usr/src/debug/libdbusmenu-qt-0.9.0/i686-redhat-linux-gnu/src/dbusmenuimporter.moc:131
#21 0x44c28184 in DBusMenuImporter::slotMenuAboutToShow (this=0x9cde888) at /usr/src/debug/libdbusmenu-qt-0.9.0/src/dbusmenuimporter.cpp:523
#22 0x44c2fcb8 in qt_static_metacall (_a=0xbfc12bfc, _id=6, _o=0x9cde888, _c=<optimized out>) at /usr/src/debug/libdbusmenu-qt-0.9.0/i686-redhat-linux-gnu/src/dbusmenuimporter.moc:78
#23 DBusMenuImporter::qt_static_metacall (_o=0x9cde888, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xbfc12bfc) at /usr/src/debug/libdbusmenu-qt-0.9.0/i686-redhat-linux-gnu/src/dbusmenuimporter.moc:66
#24 0x49230bce in QMetaObject::activate (sender=0x94e2488, m=0x44bf82b4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3547
#25 0x44725f36 in QMenu::aboutToShow (this=this@entry=0x94e2488) at .moc/release-shared/moc_qmenu.cpp:164
#26 0x4472cb18 in qt_static_metacall (_a=0xbfc12d54, _id=0, _o=0x94e2488, _c=<optimized out>) at .moc/release-shared/moc_qmenu.cpp:73
#27 QMenu::qt_static_metacall (_o=0x94e2488, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfc12d54) at .moc/release-shared/moc_qmenu.cpp:67
#28 0x49220fcf in QMetaMethod::invoke (this=0xbfc12e84, object=0x94e2488, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1664
#29 0x4922369a in QMetaObject::invokeMethod (obj=0x94e2488, member=0x44c37d72 "aboutToShow", type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1179
#30 0x44c279a0 in invokeMethod (val9=..., val8=..., val7=..., val6=..., val5=..., val4=..., val3=..., val2=..., val1=..., val0=..., member=0x44c37d72 "aboutToShow", obj=<optimized out>) at /usr/include/QtCore/qobjectdefs.h:434
#31 DBusMenuImporter::updateMenu (this=0x9cde888) at /usr/src/debug/libdbusmenu-qt-0.9.0/src/dbusmenuimporter.cpp:456
#32 0xb50f1054 in StatusNotifierItemSource::contextMenu (this=0x9a3ac60, x=18, y=578) at /usr/src/debug/kde-workspace-4.9.3/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:466
#33 0xb50f66c4 in StatusNotifierItemJob::start (this=0x9d4e610) at /usr/src/debug/kde-workspace-4.9.3/plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#34 0x4155a84a in autoStart (this=<optimized out>) at /usr/src/debug/kdelibs-4.9.3/plasma/servicejob.cpp:47
#35 qt_static_metacall (_o=0x9d4e610, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/kdelibs-4.9.3/i686-redhat-linux-gnu/plasma/servicejob.moc:60
#36 Plasma::ServiceJob::qt_static_metacall (_o=0x9d4e610, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x9bba168) at /usr/src/debug/kdelibs-4.9.3/i686-redhat-linux-gnu/plasma/servicejob.moc:54
#37 0x4922a53b in QMetaCallEvent::placeMetaCall (this=0x9b69680, object=0x9d4e610) at kernel/qobject.cpp:525
#38 0x4922eb93 in QObject::event (this=0x9d4e610, e=0x9b69680) at kernel/qobject.cpp:1195
#39 0x44274fac in QApplicationPrivate::notify_helper (this=0x8a4c6c8, receiver=0x9d4e610, e=0x9b69680) at kernel/qapplication.cpp:4557
#40 0x44279a6f in QApplication::notify (this=0x9b69680, receiver=0x9d4e610, e=0x9b69680) at kernel/qapplication.cpp:3939
#41 0x419defe2 in KApplication::notify (this=0x8a332e0, receiver=0x9d4e610, event=0x9b69680) at /usr/src/debug/kdelibs-4.9.3/kdeui/kernel/kapplication.cpp:311
#42 0x492184de in QCoreApplication::notifyInternal (this=0x8a332e0, receiver=0x9d4e610, event=0x9b69680) at kernel/qcoreapplication.cpp:915
#43 0x4921c485 in sendEvent (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#44 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x89fb290) at kernel/qcoreapplication.cpp:1539
#45 0x4921c70d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1432
#46 0x4924a8f5 in sendPostedEvents () at kernel/qcoreapplication.h:236
#47 postEventSourceDispatch (s=s@entry=0x8a4fd00) at kernel/qeventdispatcher_glib.cpp:279
#48 0x4846b0bb in g_main_dispatch (context=0x8a4c7a8, context@entry=0x8a4f138) at gmain.c:2539
#49 g_main_context_dispatch (context=context@entry=0x8a4c7a8) at gmain.c:3075
#50 0x4846b460 in g_main_context_iterate (context=context@entry=0x8a4c7a8, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3146
#51 0x4846b542 in g_main_context_iteration (context=0x8a4c7a8, may_block=1) at gmain.c:3207
#52 0x4924aa82 in QEventDispatcherGlib::processEvents (this=0x89fbfe8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#53 0x4432752b in QGuiEventDispatcherGlib::processEvents (this=0x89fbfe8, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#54 0x49216f7d in QEventLoop::processEvents (this=this@entry=0xbfc13ab8, flags=...) at kernel/qeventloop.cpp:149
#55 0x49217279 in QEventLoop::exec (this=0xbfc13ab8, flags=...) at kernel/qeventloop.cpp:204
#56 0x4921c7bb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#57 0x44272e25 in QApplication::exec () at kernel/qapplication.cpp:3818
#58 0x4f8e0656 in kdemain (argc=1, argv=0xbfc13c74) at /usr/src/debug/kde-workspace-4.9.3/plasma/desktop/shell/main.cpp:120
#59 0x0804879c in main (argc=1, argv=0xbfc13c74) at /usr/src/debug/kde-workspace-4.9.3/i686-redhat-linux-gnu/plasma/desktop/shell/plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 310989, bug 309029, bug 307897, bug 307488, bug 304742.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-01-04 04:17:32 UTC
*** Bug 310158 has been marked as a duplicate of this bug. ***
Comment 2 Jekyll Wu 2013-01-04 04:17:44 UTC
*** Bug 312573 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Feck 2013-01-28 00:19:01 UTC

*** This bug has been marked as a duplicate of bug 241562 ***