Bug 307488 - KDE plante quand ajout de composants graphiques
Summary: KDE plante quand ajout de composants graphiques
Status: RESOLVED DUPLICATE of bug 293877
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-27 16:42 UTC by Cory
Modified: 2012-09-27 17:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cory 2012-09-27 16:42:40 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.8.5 (4.8.5)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-23-generic i686
Distribution: Linux Mint 13 Maya

-- Information about the crash:
J'ai simplement essayé d'ajouter le composant graphique "Espaces de travail" (bureaux multiples) et ça a planté droit dérière.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb76e8740 (LWP 1790))]

Thread 5 (Thread 0xb058eb40 (LWP 1791)):
#0  0x03263dcd in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x010c6315 in do_gettime (frac=0xb058dfb0, sec=0xb058dfa8) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x011b0226 in QTimerInfoList::updateCurrentTime (this=0xafc02074) at kernel/qeventdispatcher_unix.cpp:343
#4  0x011b057a in QTimerInfoList::timerWait (this=0xafc02074, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#5  0x011aee23 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb058e0bc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x011aeebd in timerSourcePrepare (source=0xafc02040, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x01be3872 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0x01be3faf in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0x01be4201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0x011af8e7 in QEventDispatcherGlib::processEvents (this=0xafc00468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#11 0x0117b50d in QEventLoop::processEvents (this=0xb058e240, flags=...) at kernel/qeventloop.cpp:149
#12 0x0117b7a9 in QEventLoop::exec (this=0xb058e240, flags=...) at kernel/qeventloop.cpp:204
#13 0x0106494c in QThread::exec (this=0x90683f8) at thread/qthread.cpp:501
#14 0x01158b5d in QInotifyFileSystemWatcherEngine::run (this=0x90683f8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x01067de0 in QThreadPrivate::start (arg=0x90683f8) at thread/qthread_unix.cpp:298
#16 0x039f2d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0x00207ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 4 (Thread 0xafad2b40 (LWP 1792)):
#0  0x039f5c4d in __pthread_mutex_unlock_usercnt () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x00215634 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0x01c23410 in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x01be3865 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x01be3faf in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x01be4201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0x011af8e7 in QEventDispatcherGlib::processEvents (this=0xaf100468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0x0117b50d in QEventLoop::processEvents (this=0xafad2240, flags=...) at kernel/qeventloop.cpp:149
#8  0x0117b7a9 in QEventLoop::exec (this=0xafad2240, flags=...) at kernel/qeventloop.cpp:204
#9  0x0106494c in QThread::exec (this=0x8b54d08) at thread/qthread.cpp:501
#10 0x01158b5d in QInotifyFileSystemWatcherEngine::run (this=0x8b54d08) at io/qfilesystemwatcher_inotify.cpp:248
#11 0x01067de0 in QThreadPrivate::start (arg=0x8b54d08) at thread/qthread_unix.cpp:298
#12 0x039f2d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#13 0x00207ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xadfffb40 (LWP 1795)):
#0  0x00fff416 in __kernel_vsyscall ()
#1  0x039f696b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x002153dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x027e5029 in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#4  0x027e506f in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#5  0x039f2d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0x00207ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xacbedb40 (LWP 1800)):
#0  0x039f5c64 in __pthread_mutex_unlock_usercnt () from /lib/i386-linux-gnu/libpthread.so.0
#1  0x00215634 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0x01c23410 in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x01be3f50 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x01be456b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x0633c1ba in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#6  0x01c076b3 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0x039f2d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0x00207ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb76e8740 (LWP 1790)):
[KCrash Handler]
#7  QMutex::lock (this=0x2d) at thread/qmutex.cpp:150
#8  0x0118036b in QCoreApplication::postEvent (receiver=0x9b15000, event=0xae83ec0, priority=0) at kernel/qcoreapplication.cpp:1281
#9  0x011806fb in QCoreApplication::postEvent (receiver=0x9b15000, event=0xae83ec0) at kernel/qcoreapplication.cpp:1234
#10 0x01190024 in QObject::deleteLater (this=0x9b15000) at kernel/qobject.cpp:2084
#11 0x07613ba6 in QX11Data::xdndHandleFinished (this=0x8b28ee8, xe=0xbfefb24c, passive=false) at kernel/qdnd_x11.cpp:1256
#12 0x07604c3b in QApplication::x11ClientMessage (this=0x8b16030, w=0x9874958, event=0xbfefb24c, passive_only=false) at kernel/qapplication_x11.cpp:3242
#13 0x07602d0c in QApplication::x11ProcessEvent (this=0x8b16030, event=0xbfefb24c) at kernel/qapplication_x11.cpp:3871
#14 0x0762feac in x11EventSourceDispatch (s=0x8b285a8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#15 0x01be3d86 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#16 0x01be4125 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#17 0x01be4201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#18 0x011af887 in QEventDispatcherGlib::processEvents (this=0x8ad9eb8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#19 0x0762faaa in QGuiEventDispatcherGlib::processEvents (this=0x8ad9eb8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#20 0x0117b50d in QEventLoop::processEvents (this=0xbfefb544, flags=...) at kernel/qeventloop.cpp:149
#21 0x0117b7a9 in QEventLoop::exec (this=0xbfefb544, flags=...) at kernel/qeventloop.cpp:204
#22 0x01180eba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#23 0x07574a74 in QApplication::exec () at kernel/qapplication.cpp:3820
#24 0x00a0ea7b in kdemain (argc=1, argv=0xbfefb744) at ../../../../plasma/desktop/shell/main.cpp:120
#25 0x0804850b in main (argc=1, argv=0xbfefb744) at plasma-desktop_dummy.cpp:3

This bug may be a duplicate of or related to bug 292640.

Possible duplicates by query: bug 304742, bug 300754, bug 296467, bug 294645, bug 292640.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-09-27 17:16:26 UTC
Please, always use English to report bugs.

*** This bug has been marked as a duplicate of bug 293877 ***