Bug 310989 - Plasma crash
Summary: Plasma crash
Status: RESOLVED DUPLICATE of bug 182511
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: 4.8.5
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-01 15:54 UTC by BST
Modified: 2013-04-22 21:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (10.73 KB, text/plain)
2013-03-26 20:48 UTC, bqk345
Details

Note You need to log in before you can comment on or make changes to this bug.
Description BST 2012-12-01 15:54:02 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.8.5 (4.8.5) (Compiled from sources)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-34-generic-pae i686
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:
Tried to install the weather forecast  widged from default screen
That's all.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xafd0ba40 (LWP 1677))]

Thread 6 (Thread 0xa7b3fb40 (LWP 1678)):
#0  0xb771d424 in __kernel_vsyscall ()
#1  0xb75bc5f0 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb2b4ea7b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2b410ae in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2b41201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb63e48e7 in QEventDispatcherGlib::processEvents (this=0xa7200488, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb63b050d in QEventLoop::processEvents (this=0xa7b3f190, flags=...) at kernel/qeventloop.cpp:149
#7  0xb63b07a9 in QEventLoop::exec (this=0xa7b3f190, flags=...) at kernel/qeventloop.cpp:204
#8  0xb629994c in QThread::exec (this=0xa355510) at thread/qthread.cpp:501
#9  0xb638db5d in QInotifyFileSystemWatcherEngine::run (this=0xa355510) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb629cde0 in QThreadPrivate::start (arg=0xa355510) at thread/qthread_unix.cpp:298
#11 0xb22840d1 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#12 0x5c8b0824 in ?? ()
#13 0xbab80424 in ?? ()
#14 0x65000000 in ?? ()
#15 0x001015ff in ?? ()
#16 0xd3890000 in ?? ()
#17 0xfff0013d in ?? ()
#18 0xc30173ff in ?? ()
#19 0x0fc3a2e8 in ?? ()
#20 0xafc18100 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 5 (Thread 0xa6f9fb40 (LWP 1679)):
#0  0xb2b41046 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb2b41201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb63e48e7 in QEventDispatcherGlib::processEvents (this=0xa6600488, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#3  0xb63b050d in QEventLoop::processEvents (this=0xa6f9f190, flags=...) at kernel/qeventloop.cpp:149
#4  0xb63b07a9 in QEventLoop::exec (this=0xa6f9f190, flags=...) at kernel/qeventloop.cpp:204
#5  0xb629994c in QThread::exec (this=0xa3a3498) at thread/qthread.cpp:501
#6  0xb638db5d in QInotifyFileSystemWatcherEngine::run (this=0xa3a3498) at io/qfilesystemwatcher_inotify.cpp:248
#7  0xb629cde0 in QThreadPrivate::start (arg=0xa3a3498) at thread/qthread_unix.cpp:298
#8  0xb22840d1 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#9  0x5c8b0824 in ?? ()
#10 0xbab80424 in ?? ()
#11 0x65000000 in ?? ()
#12 0x001015ff in ?? ()
#13 0xd3890000 in ?? ()
#14 0xfff0013d in ?? ()
#15 0xc30173ff in ?? ()
#16 0x0fc3a2e8 in ?? ()
#17 0xafc18100 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 4 (Thread 0xa651bb40 (LWP 1680)):
#0  0xb771d424 in __kernel_vsyscall ()
#1  0xb2c5596b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb75d864c in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb3c12029 in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#4  0xb3c1206f in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#5  0xb22840d1 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#6  0x5c8b0824 in ?? ()
#7  0xbab80424 in ?? ()
#8  0x65000000 in ?? ()
#9  0x001015ff in ?? ()
#10 0xd3890000 in ?? ()
#11 0xfff0013d in ?? ()
#12 0xc30173ff in ?? ()
#13 0x0fc3a2e8 in ?? ()
#14 0xafc18100 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 3 (Thread 0xa4cffb40 (LWP 1682)):
#0  0xb771d424 in __kernel_vsyscall ()
#1  0xb75bc5f0 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb2b4ea7b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2b410ae in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2b4156b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xa57831ba in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#6  0xb2b646b3 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb22840d1 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#8  0x5c8b0824 in ?? ()
#9  0xbab80424 in ?? ()
#10 0x65000000 in ?? ()
#11 0x001015ff in ?? ()
#12 0xd3890000 in ?? ()
#13 0xfff0013d in ?? ()
#14 0xc30173ff in ?? ()
#15 0x0fc3a2e8 in ?? ()
#16 0xafc18100 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 2 (Thread 0xa5694b40 (LWP 4253)):
#0  0xb771d424 in __kernel_vsyscall ()
#1  0xb75bc5f0 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb2b4ea7b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2b410ae in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2b41201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb63e48e7 in QEventDispatcherGlib::processEvents (this=0xa4d083a8, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb63b050d in QEventLoop::processEvents (this=0xa5694190, flags=...) at kernel/qeventloop.cpp:149
#7  0xb63b07a9 in QEventLoop::exec (this=0xa5694190, flags=...) at kernel/qeventloop.cpp:204
#8  0xb629994c in QThread::exec (this=0x9bddfe0) at thread/qthread.cpp:501
#9  0xb638db5d in QInotifyFileSystemWatcherEngine::run (this=0x9bddfe0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb629cde0 in QThreadPrivate::start (arg=0x9bddfe0) at thread/qthread_unix.cpp:298
#11 0xb22840d1 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#12 0x5c8b0824 in ?? ()
#13 0xbab80424 in ?? ()
#14 0x65000000 in ?? ()
#15 0x001015ff in ?? ()
#16 0xd3890000 in ?? ()
#17 0xfff0013d in ?? ()
#18 0xc30173ff in ?? ()
#19 0x0fc3a2e8 in ?? ()
#20 0xafc18100 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 1 (Thread 0xafd0ba40 (LWP 1677)):
[KCrash Handler]
#7  QMutex::lock (this=0xb49f74e) at thread/qmutex.cpp:153
#8  0xb63b536b in QCoreApplication::postEvent (receiver=0xc35eac0, event=0xc22a238, priority=0) at kernel/qcoreapplication.cpp:1281
#9  0xb63b56fb in QCoreApplication::postEvent (receiver=0xc35eac0, event=0xc22a238) at kernel/qcoreapplication.cpp:1234
#10 0xb63c5024 in QObject::deleteLater (this=0xc35eac0) at kernel/qobject.cpp:2084
#11 0xb5939ba6 in QX11Data::xdndHandleFinished (this=0x9bb26b8, xe=0xbfc00d5c, passive=false) at kernel/qdnd_x11.cpp:1256
#12 0xb592ac3b in QApplication::x11ClientMessage (this=0x9b7d628, w=0xbaf71f8, event=0xbfc00d5c, passive_only=false) at kernel/qapplication_x11.cpp:3242
#13 0xb5928d0c in QApplication::x11ProcessEvent (this=0x9b7d628, event=0xbfc00d5c) at kernel/qapplication_x11.cpp:3871
#14 0xb5955eac in x11EventSourceDispatch (s=0x9bb2040, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#15 0xb2b40d86 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#16 0xb2b41125 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#17 0xb2b41201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#18 0xb63e4887 in QEventDispatcherGlib::processEvents (this=0x9af9eb8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#19 0xb5955aaa in QGuiEventDispatcherGlib::processEvents (this=0x9af9eb8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#20 0xb63b050d in QEventLoop::processEvents (this=0xbfc01054, flags=...) at kernel/qeventloop.cpp:149
#21 0xb63b07a9 in QEventLoop::exec (this=0xbfc01054, flags=...) at kernel/qeventloop.cpp:204
#22 0xb63b5eba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#23 0xb589aa74 in QApplication::exec () at kernel/qapplication.cpp:3820
#24 0xb76d1a7b in kdemain (argc=1, argv=0xbfc01254) at ../../../../plasma/desktop/shell/main.cpp:120
#25 0x0804850b in main (argc=1, argv=0xbfc01254) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 309029, bug 307897, bug 307488, bug 304742, bug 300754.

Reported using DrKonqi
Comment 1 bqk345 2013-03-26 20:48:19 UTC
Created attachment 78411 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.8.4 (4.8.4) using Qt 4.8.2

- What I was doing when the application crashed:

Trying to add the system monitor widget to panel

-- Backtrace (Reduced):
#6  QCoreApplication::postEvent (receiver=0x39b9600, event=0x2350cb0, priority=0) at kernel/qcoreapplication.cpp:1312
#7  0x00007ffc349383bd in QX11Data::xdndHandleFinished (this=<optimized out>, xe=0x7fff4051c950, passive=false) at kernel/qdnd_x11.cpp:1252
#8  0x00007ffc3492b9b3 in QApplication::x11ClientMessage (this=<optimized out>, w=0x3ab4620, event=<optimized out>, passive_only=<optimized out>) at kernel/qapplication_x11.cpp:3215
#9  0x00007ffc3492a2a2 in QApplication::x11ProcessEvent (this=0x22e5ff0, event=0x7fff4051c950) at kernel/qapplication_x11.cpp:3785
#10 0x00007ffc34950bc2 in x11EventSourceDispatch (s=0x22ef860, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
Comment 2 Christoph Feck 2013-04-22 21:58:15 UTC

*** This bug has been marked as a duplicate of bug 182511 ***