Bug 304742 - plasma desktop crash on switching applications on the taskbar
Summary: plasma desktop crash on switching applications on the taskbar
Status: RESOLVED DUPLICATE of bug 293877
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-07 17:30 UTC by martman1925
Modified: 2012-08-08 02:43 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description martman1925 2012-08-07 17:30:35 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-27-generic-pae i686
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

Switching to Google chome on the taskbar. Plasma desktop crashes.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xafdb4a40 (LWP 4774))]

Thread 7 (Thread 0xad5eab40 (LWP 4775)):
#0  0xb76f9424 in __kernel_vsyscall ()
#1  0xb2c2a96b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb75ad3dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb3be9029 in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#4  0xb3be906f in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#5  0xb225ba11 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#6  0x5c8b0824 in ?? ()
#7  0xbab80424 in ?? ()
#8  0x65000000 in ?? ()
#9  0x001015ff in ?? ()
#10 0xd3890000 in ?? ()
#11 0xfff0013d in ?? ()
#12 0xc30173ff in ?? ()
#13 0x0f8122e8 in ?? ()
#14 0x9fc18100 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 6 (Thread 0xa7689b40 (LWP 4776)):
#0  0xb76f9424 in __kernel_vsyscall ()
#1  0xb7591380 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb2b23a7b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2b160ae in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb2b16201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb63bb8e7 in QEventDispatcherGlib::processEvents (this=0xa6d00480, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb638750d in QEventLoop::processEvents (this=0xa7689190, flags=...) at kernel/qeventloop.cpp:149
#7  0xb63877a9 in QEventLoop::exec (this=0xa7689190, flags=...) at kernel/qeventloop.cpp:204
#8  0xb627094c in QThread::exec (this=0x8b45828) at thread/qthread.cpp:501
#9  0xb6364b5d in QInotifyFileSystemWatcherEngine::run (this=0x8b45828) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb6273de0 in QThreadPrivate::start (arg=0x8b45828) at thread/qthread_unix.cpp:298
#11 0xb225ba11 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#12 0x5c8b0824 in ?? ()
#13 0xbab80424 in ?? ()
#14 0x65000000 in ?? ()
#15 0x001015ff in ?? ()
#16 0xd3890000 in ?? ()
#17 0xfff0013d in ?? ()
#18 0xc30173ff in ?? ()
#19 0x0f8122e8 in ?? ()
#20 0x9fc18100 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 5 (Thread 0xa2987b40 (LWP 6221)):
#0  0xb76f9424 in __kernel_vsyscall ()
#1  0xb2c2a96b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb75ad3dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb6274350 in wait (time=4294967295, this=0x8bb9ef8) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x8ba7290, mutex=0x8ba92e0, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0xb34e3acc in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x8ba7278, th=0x97b2278) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0xb34e695b in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x8b87d08, th=0x97b2278) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0xb34e363a in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x8ba7278, th=0x97b2278) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0xb34e6a5c in ThreadWeaver::WorkingHardState::applyForWork (this=0x8b87d08, th=0x97b2278) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0xb34e3533 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8ba7278, th=0x97b2278, previous=0x9ebb978) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0xb34e54e4 in ThreadWeaver::ThreadRunHelper::run (this=0xa29871f4, parent=0x8ba7278, th=0x97b2278) at ../../../threadweaver/Weaver/Thread.cpp:87
#11 0xb34e559a in ThreadWeaver::Thread::run (this=0x97b2278) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0xb6273de0 in QThreadPrivate::start (arg=0x97b2278) at thread/qthread_unix.cpp:298
#13 0xb225ba11 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#14 0x5c8b0824 in ?? ()
#15 0xbab80424 in ?? ()
#16 0x65000000 in ?? ()
#17 0x001015ff in ?? ()
#18 0xd3890000 in ?? ()
#19 0xfff0013d in ?? ()
#20 0xc30173ff in ?? ()
#21 0x0f8122e8 in ?? ()
#22 0x9fc18100 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 4 (Thread 0xa4afdb40 (LWP 6222)):
#0  0xb76f9424 in __kernel_vsyscall ()
#1  0xb2c2a96b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb75ad3dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb6274350 in wait (time=4294967295, this=0x8bb9ef8) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x8ba7290, mutex=0x8ba92e0, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0xb34e3acc in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x8ba7278, th=0x8d1b960) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0xb34e695b in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x8b87d08, th=0x8d1b960) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0xb34e363a in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x8ba7278, th=0x8d1b960) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0xb34e6a5c in ThreadWeaver::WorkingHardState::applyForWork (this=0x8b87d08, th=0x8d1b960) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0xb34e3533 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8ba7278, th=0x8d1b960, previous=0x9bbb2a0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0xb34e54e4 in ThreadWeaver::ThreadRunHelper::run (this=0xa4afd1f4, parent=0x8ba7278, th=0x8d1b960) at ../../../threadweaver/Weaver/Thread.cpp:87
#11 0xb34e559a in ThreadWeaver::Thread::run (this=0x8d1b960) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0xb6273de0 in QThreadPrivate::start (arg=0x8d1b960) at thread/qthread_unix.cpp:298
#13 0xb225ba11 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#14 0x5c8b0824 in ?? ()
#15 0xbab80424 in ?? ()
#16 0x65000000 in ?? ()
#17 0x001015ff in ?? ()
#18 0xd3890000 in ?? ()
#19 0xfff0013d in ?? ()
#20 0xc30173ff in ?? ()
#21 0x0f8122e8 in ?? ()
#22 0x9fc18100 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 3 (Thread 0xa0d70b40 (LWP 6223)):
#0  0xb76f9424 in __kernel_vsyscall ()
#1  0xb2c2a96b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb75ad3dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb6274350 in wait (time=4294967295, this=0x8bb9ef8) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x8ba7290, mutex=0x8ba92e0, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0xb34e3acc in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x8ba7278, th=0x94ce338) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0xb34e695b in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x8b87d08, th=0x94ce338) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0xb34e363a in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x8ba7278, th=0x94ce338) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0xb34e6a5c in ThreadWeaver::WorkingHardState::applyForWork (this=0x8b87d08, th=0x94ce338) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0xb34e3533 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8ba7278, th=0x94ce338, previous=0x8bbee78) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0xb34e54e4 in ThreadWeaver::ThreadRunHelper::run (this=0xa0d701f4, parent=0x8ba7278, th=0x94ce338) at ../../../threadweaver/Weaver/Thread.cpp:87
#11 0xb34e559a in ThreadWeaver::Thread::run (this=0x94ce338) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0xb6273de0 in QThreadPrivate::start (arg=0x94ce338) at thread/qthread_unix.cpp:298
#13 0xb225ba11 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#14 0x5c8b0824 in ?? ()
#15 0xbab80424 in ?? ()
#16 0x65000000 in ?? ()
#17 0x001015ff in ?? ()
#18 0xd3890000 in ?? ()
#19 0xfff0013d in ?? ()
#20 0xc30173ff in ?? ()
#21 0x0f8122e8 in ?? ()
#22 0x9fc18100 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 2 (Thread 0xa056fb40 (LWP 6224)):
#0  0xb76f9424 in __kernel_vsyscall ()
#1  0xb2c2a96b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb75ad3dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb6274350 in wait (time=4294967295, this=0x8bb9ef8) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x8ba7290, mutex=0x8ba92e0, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0xb34e3acc in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x8ba7278, th=0x987ff90) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#6  0xb34e695b in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x8b87d08, th=0x987ff90) at ../../../threadweaver/Weaver/WorkingHardState.cpp:80
#7  0xb34e363a in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x8ba7278, th=0x987ff90) at ../../../threadweaver/Weaver/WeaverImpl.cpp:356
#8  0xb34e6a5c in ThreadWeaver::WorkingHardState::applyForWork (this=0x8b87d08, th=0x987ff90) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#9  0xb34e3533 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8ba7278, th=0x987ff90, previous=0x93df4f0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:351
#10 0xb34e54e4 in ThreadWeaver::ThreadRunHelper::run (this=0xa056f1f4, parent=0x8ba7278, th=0x987ff90) at ../../../threadweaver/Weaver/Thread.cpp:87
#11 0xb34e559a in ThreadWeaver::Thread::run (this=0x987ff90) at ../../../threadweaver/Weaver/Thread.cpp:142
#12 0xb6273de0 in QThreadPrivate::start (arg=0x987ff90) at thread/qthread_unix.cpp:298
#13 0xb225ba11 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#14 0x5c8b0824 in ?? ()
#15 0xbab80424 in ?? ()
#16 0x65000000 in ?? ()
#17 0x001015ff in ?? ()
#18 0xd3890000 in ?? ()
#19 0xfff0013d in ?? ()
#20 0xc30173ff in ?? ()
#21 0x0f8122e8 in ?? ()
#22 0x9fc18100 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 1 (Thread 0xafdb4a40 (LWP 4774)):
[KCrash Handler]
#7  QMutex::lock (this=0x6109fb) at thread/qmutex.cpp:150
#8  0xb638c36b in QCoreApplication::postEvent (receiver=0xa15ff38, event=0x8d049e8, priority=0) at kernel/qcoreapplication.cpp:1281
#9  0xb638c6fb in QCoreApplication::postEvent (receiver=0xa15ff38, event=0x8d049e8) at kernel/qcoreapplication.cpp:1234
#10 0xb639c024 in QObject::deleteLater (this=0xa15ff38) at kernel/qobject.cpp:2084
#11 0xb5910ba6 in QX11Data::xdndHandleFinished (this=0x88c1be0, xe=0xbff4deec, passive=false) at kernel/qdnd_x11.cpp:1256
#12 0xb5901c3b in QApplication::x11ClientMessage (this=0x88920f8, w=0x8a29a20, event=0xbff4deec, passive_only=false) at kernel/qapplication_x11.cpp:3242
#13 0xb58ffd0c in QApplication::x11ProcessEvent (this=0x88920f8, event=0xbff4deec) at kernel/qapplication_x11.cpp:3871
#14 0xb592ceac in x11EventSourceDispatch (s=0x88c0100, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#15 0xb2b15d86 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#16 0xb2b16125 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#17 0xb2b16201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#18 0xb63bb887 in QEventDispatcherGlib::processEvents (this=0x880eea0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#19 0xb592caaa in QGuiEventDispatcherGlib::processEvents (this=0x880eea0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#20 0xb638750d in QEventLoop::processEvents (this=0xbff4e1e4, flags=...) at kernel/qeventloop.cpp:149
#21 0xb63877a9 in QEventLoop::exec (this=0xbff4e1e4, flags=...) at kernel/qeventloop.cpp:204
#22 0xb638ceba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#23 0xb5871a74 in QApplication::exec () at kernel/qapplication.cpp:3820
#24 0xb76ada7b in kdemain (argc=1, argv=0xbff4e3e4) at ../../../../plasma/desktop/shell/main.cpp:120
#25 0x0804850b in main (argc=1, argv=0xbff4e3e4) at plasma-desktop_dummy.cpp:3

This bug may be a duplicate of or related to bug 293877.

Possible duplicates by query: bug 300754, bug 296467, bug 294645, bug 292640, bug 285614.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-08-08 02:43:10 UTC

*** This bug has been marked as a duplicate of bug 293877 ***