Bug 309692 - Patience crashes for me
Summary: Patience crashes for me
Status: RESOLVED DUPLICATE of bug 308099
Alias: None
Product: kpat
Classification: Unclassified
Component: general (show other bugs)
Version: 3.6
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-07 12:20 UTC by Stig-Åke Edborg
Modified: 2012-11-07 12:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stig-Åke Edborg 2012-11-07 12:20:09 UTC
Application: kpat (3.6)
KDE Platform Version: 4.9.2
Qt Version: 4.8.3
Operating System: Linux 3.5.0-18-generic x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:
- What I was doing when the application crashed: I chose a brand new game in the gaming console. And when I double-clicked the game "grandfather solitaire",the  solitaire program crashed immediately.

-- Backtrace:
Application: Patiens (kpat), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fde1826b780 (LWP 4191))]

Thread 2 (Thread 0x7fde1024f700 (LWP 4192)):
#0  0x00007fde1fea0303 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fde1bdf7d84 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fde1bdf7ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fde215d6c16 in QEventDispatcherGlib::processEvents (this=0x7fde080008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fde215a72bf in QEventLoop::processEvents (this=this@entry=0x7fde1024edd0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fde215a7548 in QEventLoop::exec (this=0x7fde1024edd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fde214a8b10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fde215879af in QInotifyFileSystemWatcherEngine::run (this=0xefe1d0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fde214abaec in QThreadPrivate::start (arg=0xefe1d0) at thread/qthread_unix.cpp:338
#9  0x00007fde1c6c7e9a in start_thread (arg=0x7fde1024f700) at pthread_create.c:308
#10 0x00007fde1feabcbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fde1826b780 (LWP 4191)):
[KCrash Handler]
#6  0x00007fde21b2aa3d in lock (this=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1231
#7  KSharedDataCache::Private::CacheLocker::cautiousLock (this=0x7fffd1883a60) at ../../kdecore/util/kshareddatacache.cpp:1255
#8  0x00007fde21b2b090 in KSharedDataCache::Private::CacheLocker::CacheLocker (this=0x7fffd1883a60, _d=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1278
#9  0x00007fde21b230ae in KSharedDataCache::find (this=0x2357360, key=..., destination=0x7fffd1883ad0) at ../../kdecore/util/kshareddatacache.cpp:1630
#10 0x00007fde220513d2 in KImageCache::findPixmap (this=0x2357360, key=..., destination=0x11a95a8) at ../../kdeui/util/kimagecache.cpp:150
#11 0x00007fde22d8549a in ?? () from /usr/lib/libkcardgame.so
#12 0x00007fde22d856b0 in KAbstractCardDeck::cardPixmap(unsigned int, bool) () from /usr/lib/libkcardgame.so
#13 0x00007fde22d87cc7 in KCard::paint(QPainter*, QStyleOptionGraphicsItem const*, QWidget*) () from /usr/lib/libkcardgame.so
#14 0x00007fde20f43c05 in QGraphicsScenePrivate::draw (this=this@entry=0x11b4010, item=item@entry=0x1cb77b0, painter=painter@entry=0x7fffd18842f0, viewTransform=viewTransform@entry=0x7fffd1884480, transformPtr=transformPtr@entry=0x7fffd1883f90, exposedRegion=exposedRegion@entry=0xd68f88, widget=0xd7e9a0, opacity=opacity@entry=1, effectTransform=effectTransform@entry=0x0, wasDirtyParentSceneTransform=wasDirtyParentSceneTransform@entry=true, drawItem=true) at graphicsview/qgraphicsscene.cpp:4964
#15 0x00007fde20f44985 in QGraphicsScenePrivate::drawSubtreeRecursive (this=this@entry=0x11b4010, item=0x1cb77b0, painter=painter@entry=0x7fffd18842f0, viewTransform=viewTransform@entry=0x7fffd1884480, exposedRegion=exposedRegion@entry=0xd68f88, widget=widget@entry=0xd7e9a0, parentOpacity=parentOpacity@entry=1, effectTransform=effectTransform@entry=0x0) at graphicsview/qgraphicsscene.cpp:4857
#16 0x00007fde20f4545e in QGraphicsScenePrivate::drawItems (this=0x11b4010, painter=0x7fffd18842f0, viewTransform=0x7fffd1884480, exposedRegion=0xd68f88, widget=0xd7e9a0) at graphicsview/qgraphicsscene.cpp:4739
#17 0x00007fde20f61828 in QGraphicsView::paintEvent (this=0xd68aa0, event=<optimized out>) at graphicsview/qgraphicsview.cpp:3471
#18 0x00007fde2099b802 in QWidget::event (this=0xd68aa0, event=0x7fffd1884f40) at kernel/qwidget.cpp:8517
#19 0x00007fde20d4ab66 in QFrame::event (this=0xd68aa0, e=0x7fffd1884f40) at widgets/qframe.cpp:557
#20 0x00007fde20f6295b in QGraphicsView::viewportEvent (this=0xd68aa0, event=0x7fffd1884f40) at graphicsview/qgraphicsview.cpp:2866
#21 0x00007fde215a86d6 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0xd7e9a0, event=0x7fffd1884f40) at kernel/qcoreapplication.cpp:1025
#22 0x00007fde2094be6c in QApplicationPrivate::notify_helper (this=this@entry=0xb9f9f0, receiver=receiver@entry=0xd7e9a0, e=e@entry=0x7fffd1884f40) at kernel/qapplication.cpp:4558
#23 0x00007fde2095030a in QApplication::notify (this=0x7fffd1887320, receiver=0xd7e9a0, e=0x7fffd1884f40) at kernel/qapplication.cpp:4423
#24 0x00007fde21ff01d6 in KApplication::notify (this=0x7fffd1887320, receiver=0xd7e9a0, event=0x7fffd1884f40) at ../../kdeui/kernel/kapplication.cpp:311
#25 0x00007fde215a856e in QCoreApplication::notifyInternal (this=0x7fffd1887320, receiver=0xd7e9a0, event=0x7fffd1884f40) at kernel/qcoreapplication.cpp:915
#26 0x00007fde20997524 in sendSpontaneousEvent (event=0x7fffd1884f40, receiver=0xd7e9a0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:234
#27 QWidgetPrivate::drawWidget (this=this@entry=0xd7e9d0, pdev=pdev@entry=0xf20a40, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=backingStore@entry=0xda1570) at kernel/qwidget.cpp:5594
#28 0x00007fde2099801f in QWidgetPrivate::paintSiblingsRecursive (this=0xd68b00, pdev=0xf20a40, siblings=..., index=<optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xda1570) at kernel/qwidget.cpp:5803
#29 0x00007fde209970b5 in QWidgetPrivate::drawWidget (this=this@entry=0xd68b00, pdev=pdev@entry=0xf20a40, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=backingStore@entry=0xda1570) at kernel/qwidget.cpp:5647
#30 0x00007fde2099801f in QWidgetPrivate::paintSiblingsRecursive (this=this@entry=0xd3b6a0, pdev=pdev@entry=0xf20a40, siblings=..., index=<optimized out>, index@entry=10, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=backingStore@entry=0xda1570) at kernel/qwidget.cpp:5803
#31 0x00007fde20997e64 in QWidgetPrivate::paintSiblingsRecursive (this=this@entry=0xd3b6a0, pdev=pdev@entry=0xf20a40, siblings=..., index=10, index@entry=18, rgn=..., offset=..., flags=flags@entry=4, sharedPainter=sharedPainter@entry=0x0, backingStore=backingStore@entry=0xda1570) at kernel/qwidget.cpp:5790
#32 0x00007fde20997e64 in QWidgetPrivate::paintSiblingsRecursive (this=0xd3b6a0, pdev=0xf20a40, siblings=..., index=18, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0xda1570) at kernel/qwidget.cpp:5790
#33 0x00007fde209970b5 in QWidgetPrivate::drawWidget (this=0xd3b6a0, pdev=0xf20a40, rgn=..., offset=..., flags=<optimized out>, sharedPainter=0x0, backingStore=0xda1570) at kernel/qwidget.cpp:5647
#34 0x00007fde20b65958 in QWidgetBackingStore::sync (this=0xda1570) at painting/qbackingstore.cpp:1373
#35 0x00007fde2098c7f0 in QWidgetPrivate::syncBackingStore (this=this@entry=0xd3b6a0) at kernel/qwidget.cpp:1892
#36 0x00007fde2099be4c in QWidget::event (this=0xd3b550, event=0x30dbfe0) at kernel/qwidget.cpp:8664
#37 0x00007fde20d641cb in QMainWindow::event (this=0xd3b550, event=0x30dbfe0) at widgets/qmainwindow.cpp:1478
#38 0x00007fde220e1778 in KXmlGuiWindow::event (this=0xd3b550, ev=0x30dbfe0) at ../../kdeui/xmlgui/kxmlguiwindow.cpp:126
#39 0x00007fde2094be9c in QApplicationPrivate::notify_helper (this=this@entry=0xb9f9f0, receiver=receiver@entry=0xd3b550, e=e@entry=0x30dbfe0) at kernel/qapplication.cpp:4562
#40 0x00007fde2095030a in QApplication::notify (this=0x7fffd1887320, receiver=0xd3b550, e=0x30dbfe0) at kernel/qapplication.cpp:4423
#41 0x00007fde21ff01d6 in KApplication::notify (this=0x7fffd1887320, receiver=0xd3b550, event=0x30dbfe0) at ../../kdeui/kernel/kapplication.cpp:311
#42 0x00007fde215a856e in QCoreApplication::notifyInternal (this=0x7fffd1887320, receiver=receiver@entry=0xd3b550, event=event@entry=0x30dbfe0) at kernel/qcoreapplication.cpp:915
#43 0x00007fde215ac3f1 in sendEvent (event=0x30dbfe0, receiver=0xd3b550) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#44 QCoreApplicationPrivate::sendPostedEvents (receiver=0xd3b550, event_type=77, data=0xb68ff0) at kernel/qcoreapplication.cpp:1539
#45 0x00007fde20f33ef2 in dispatchPendingUpdateRequests (this=0xd68b00) at ../../include/QtGui/private/../../../src/gui/graphicsview/qgraphicsview_p.h:200
#46 QGraphicsScenePrivate::_q_emitUpdated (this=0x11b4010) at graphicsview/qgraphicsscene.cpp:390
#47 0x00007fde20f3e6c9 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at .moc/release-shared/moc_qgraphicsscene.cpp:105
#48 QGraphicsScene::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qgraphicsscene.cpp:86
#49 0x00007fde215bd43e in QObject::event (this=0x30c49b0, e=<optimized out>) at kernel/qobject.cpp:1195
#50 0x00007fde20f48f54 in QGraphicsScene::event (this=0x30c49b0, event=0x11a7100) at graphicsview/qgraphicsscene.cpp:3565
#51 0x00007fde2094be9c in QApplicationPrivate::notify_helper (this=this@entry=0xb9f9f0, receiver=receiver@entry=0x30c49b0, e=e@entry=0x11a7100) at kernel/qapplication.cpp:4562
#52 0x00007fde2095030a in QApplication::notify (this=0x7fffd1887320, receiver=0x30c49b0, e=0x11a7100) at kernel/qapplication.cpp:4423
#53 0x00007fde21ff01d6 in KApplication::notify (this=0x7fffd1887320, receiver=0x30c49b0, event=0x11a7100) at ../../kdeui/kernel/kapplication.cpp:311
#54 0x00007fde215a856e in QCoreApplication::notifyInternal (this=0x7fffd1887320, receiver=receiver@entry=0x30c49b0, event=event@entry=0x11a7100) at kernel/qcoreapplication.cpp:915
#55 0x00007fde215ac3f1 in sendEvent (event=0x11a7100, receiver=0x30c49b0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#56 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xb68ff0) at kernel/qcoreapplication.cpp:1539
#57 0x00007fde215d6a63 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#58 postEventSourceDispatch (s=0xba1f80) at kernel/qeventdispatcher_glib.cpp:279
#59 0x00007fde1bdf7ab5 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#60 0x00007fde1bdf7de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#61 0x00007fde1bdf7ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#62 0x00007fde215d6bf6 in QEventDispatcherGlib::processEvents (this=0xb6a4b0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#63 0x00007fde209f0c1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#64 0x00007fde215a72bf in QEventLoop::processEvents (this=this@entry=0x7fffd1887090, flags=...) at kernel/qeventloop.cpp:149
#65 0x00007fde215a7548 in QEventLoop::exec (this=0x7fffd1887090, flags=...) at kernel/qeventloop.cpp:204
#66 0x00007fde215ac708 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#67 0x000000000041827a in ?? ()
#68 0x00007fde1fdd976d in __libc_start_main (main=0x4168e0, argc=3, ubp_av=0x7fffd18874d8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffd18874c8) at libc-start.c:226
#69 0x0000000000418ac9 in _start ()

Possible duplicates by query: bug 308099, bug 307328, bug 303310.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-11-07 12:30:51 UTC

*** This bug has been marked as a duplicate of bug 308099 ***