Bug 306400 - Kontact crash every day
Summary: Kontact crash every day
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.4
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-07 14:22 UTC by Tosi Rivella
Modified: 2012-09-07 14:26 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tosi Rivella 2012-09-07 14:22:04 UTC
Application: kontact (4.8.4)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-29-generic-pae i686
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed: No esperé que la barra de progreso se detenga. Desinstalé varias aplicaciones instaladas antes de la falla: System Clock, por ejemplo. La falla continúa

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb21bf980 (LWP 25161))]

Thread 5 (Thread 0xafc2cb40 (LWP 25162)):
#0  0xb39c9c5e in __pthread_mutex_unlock_usercnt () from /lib/i386-linux-gnu/libpthread.so.0
#1  0xb60d2634 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0xb3933410 in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb38f33a7 in g_main_context_release () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb38f4058 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb38f456b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xafc31134 in ?? () from /usr/lib/i386-linux-gnu/gio/modules/libdconfsettings.so
#7  0xb39176b3 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb39c6d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#9  0xb60c4ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 4 (Thread 0xaf2ffb40 (LWP 25163)):
#0  0xb779e424 in __kernel_vsyscall ()
#1  0xb60b417b in read () from /lib/i386-linux-gnu/libc.so.6
#2  0xb39326ae in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb38f3bd2 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb38f4042 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb38f456b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb08281ba in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#7  0xb39176b3 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb39c6d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#9  0xb60c4ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xad048b40 (LWP 25165)):
#0  0xb779e424 in __kernel_vsyscall ()
#1  0xb39ca96b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb60d23dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb5850263 in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#4  0xb585037f in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#5  0xb39c6d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0xb60c4ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xac71fb40 (LWP 25166)):
#0  0xb77b7b9e in ?? () from /lib/ld-linux.so.2
#1  0xb77b0b5c in ?? () from /lib/ld-linux.so.2
#2  0xb77b0eb6 in ___tls_get_addr () from /lib/ld-linux.so.2
#3  0xb62cbd8f in get_thread_data () at thread/qthread_unix.cpp:174
#4  QThreadData::current () at thread/qthread_unix.cpp:200
#5  0xb6414067 in postEventSourcePrepare (s=0x85ee100, timeout=0x0) at kernel/qeventdispatcher_glib.cpp:256
#6  0xb64140c7 in postEventSourceCheck (source=0x85ee100) at kernel/qeventdispatcher_glib.cpp:272
#7  0xb38f3b7b in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb38f4042 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb38f4201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb64148e7 in QEventDispatcherGlib::processEvents (this=0x85ca830, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#11 0xb63e050d in QEventLoop::processEvents (this=0xac71f270, flags=...) at kernel/qeventloop.cpp:149
#12 0xb63e07a9 in QEventLoop::exec (this=0xac71f270, flags=...) at kernel/qeventloop.cpp:204
#13 0xb62c994c in QThread::exec (this=0x85f5858) at thread/qthread.cpp:501
#14 0xb62c9a3b in QThread::run (this=0x85f5858) at thread/qthread.cpp:568
#15 0xb62ccde0 in QThreadPrivate::start (arg=0x85f5858) at thread/qthread_unix.cpp:298
#16 0xb39c6d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0xb60c4ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb21bf980 (LWP 25161)):
[KCrash Handler]
#7  0x04468900 in ?? ()
#8  0xb3b33254 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0xa95d300, hm=..., sc=-1074275448, rp=..., pu=false, db=..., contentLength=-1279454788) at access/qnetworkaccesshttpbackend.cpp:827
#9  0xb3bca37d in QNetworkAccessHttpBackend::qt_static_metacall (_o=0xa95d300, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xadf35fa8) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#10 0xb63f3c01 in QMetaCallEvent::placeMetaCall (this=0xadf35878, object=0xa95d300) at kernel/qobject.cpp:525
#11 0xb63fcc7b in QObject::event (this=0xa95d300, e=0xadf35878) at kernel/qobject.cpp:1195
#12 0xb694eed4 in notify_helper (e=0xadf35878, receiver=0xa95d300, this=0x83e4e30) at kernel/qapplication.cpp:4559
#13 QApplicationPrivate::notify_helper (this=0x83e4e30, receiver=0xa95d300, e=0xadf35878) at kernel/qapplication.cpp:4531
#14 0xb695430d in QApplication::notify (this=0xadf35878, receiver=0xa95d300, e=0xadf35878) at kernel/qapplication.cpp:4288
#15 0xb74d4401 in KApplication::notify (this=0xbff7e404, receiver=0xa95d300, event=0xadf35878) at ../../kdeui/kernel/kapplication.cpp:311
#16 0xb63e197e in QCoreApplication::notifyInternal (this=0xbff7e404, receiver=0xa95d300, event=0xadf35878) at kernel/qcoreapplication.cpp:876
#17 0xb63e5ad8 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#18 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x83baab8) at kernel/qcoreapplication.cpp:1500
#19 0xb63e5e0c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#20 0xb6414494 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#21 postEventSourceDispatch (s=0x83e6c58) at kernel/qeventdispatcher_glib.cpp:279
#22 0xb38f3d86 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#23 0xb38f4125 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#24 0xb38f4201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#25 0xb6414887 in QEventDispatcherGlib::processEvents (this=0x83bb800, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#26 0xb6a07aaa in QGuiEventDispatcherGlib::processEvents (this=0x83bb800, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#27 0xb63e050d in QEventLoop::processEvents (this=0xbff7e364, flags=...) at kernel/qeventloop.cpp:149
#28 0xb63e07a9 in QEventLoop::exec (this=0xbff7e364, flags=...) at kernel/qeventloop.cpp:204
#29 0xb63e5eba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#30 0xb694ca74 in QApplication::exec () at kernel/qapplication.cpp:3820
#31 0x0804ac91 in main (argc=<error reading variable: Cannot access memory at address 0x3>, argv=<error reading variable: Cannot access memory at address 0x7>) at ../../../kontact/src/main.cpp:218

Possible duplicates by query: bug 306298, bug 305532, bug 305201, bug 303896, bug 303882.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-09-07 14:26:39 UTC

*** This bug has been marked as a duplicate of bug 286307 ***