Bug 303032 - Kontact crashes while deleting email form gmail imap account
Summary: Kontact crashes while deleting email form gmail imap account
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.4
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-04 20:26 UTC by Jeff gibbs
Modified: 2012-07-04 20:29 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff gibbs 2012-07-04 20:26:34 UTC
Application: kontact (4.8.4)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-26-generic-pae i686
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed: Was reading email and Kontact crashed several times while I was deleting old emails from a gmail account configured as an Imap account in Kontact.

The crash can be reproduced every time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb216b980 (LWP 2086))]

Thread 4 (Thread 0xafb91b40 (LWP 2087)):
#0  0xb7742424 in __kernel_vsyscall ()
#1  0xb397696b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb607e3dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb57fc263 in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#4  0xb57fc37f in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#5  0xb3972d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0xb6070ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xaf270b40 (LWP 2088)):
#0  0xb36c4dcd in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb62d7315 in do_gettime (frac=0xaf270000, sec=0xaf26fff8) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb63c1226 in QTimerInfoList::updateCurrentTime (this=0xae902074) at kernel/qeventdispatcher_unix.cpp:343
#4  0xb63c157a in QTimerInfoList::timerWait (this=0xae902074, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#5  0xb63bfe23 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xaf2700ec) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb389f872 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb389ffaf in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb38a0201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb63c08e7 in QEventDispatcherGlib::processEvents (this=0xae900468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#10 0xb638c50d in QEventLoop::processEvents (this=0xaf270270, flags=...) at kernel/qeventloop.cpp:149
#11 0xb638c7a9 in QEventLoop::exec (this=0xaf270270, flags=...) at kernel/qeventloop.cpp:204
#12 0xb627594c in QThread::exec (this=0x9014f80) at thread/qthread.cpp:501
#13 0xb6275a3b in QThread::run (this=0x9014f80) at thread/qthread.cpp:568
#14 0xb6278de0 in QThreadPrivate::start (arg=0x9014f80) at thread/qthread_unix.cpp:298
#15 0xb3972d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#16 0xb6070ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xabd74b40 (LWP 2101)):
#0  0xb7742424 in __kernel_vsyscall ()
#1  0xb6062380 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb38ada7b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb38a00ae in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb38a0201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb63c08e7 in QEventDispatcherGlib::processEvents (this=0xab400468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb638c50d in QEventLoop::processEvents (this=0xabd74240, flags=...) at kernel/qeventloop.cpp:149
#7  0xb638c7a9 in QEventLoop::exec (this=0xabd74240, flags=...) at kernel/qeventloop.cpp:204
#8  0xb627594c in QThread::exec (this=0x9815670) at thread/qthread.cpp:501
#9  0xb6369b5d in QInotifyFileSystemWatcherEngine::run (this=0x9815670) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb6278de0 in QThreadPrivate::start (arg=0x9815670) at thread/qthread_unix.cpp:298
#11 0xb3972d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb6070ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb216b980 (LWP 2086)):
[KCrash Handler]
#7  ref (this=0xb63c0c7b) at ../../include/QtCore/../../src/corelib/arch/qatomic_i386.h:120
#8  QSharedDataPointer (o=..., this=0xbf87ecc8) at ../../include/QtCore/../../src/corelib/tools/qshareddata.h:93
#9  QNetworkCacheMetaData::QNetworkCacheMetaData (this=0xbf87ecc8, other=...) at access/qabstractnetworkcache.cpp:137
#10 0xb3adda4f in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0xabba118, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1016
#11 0xb3adf27e in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0xabba118, hm=..., sc=-1237578629, rp=..., pu=255, db=..., contentLength=-5496694211744911343) at access/qnetworkaccesshttpbackend.cpp:828
#12 0xbf87ed28 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 302056, bug 301320, bug 297059, bug 291839.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-07-04 20:29:05 UTC

*** This bug has been marked as a duplicate of bug 286307 ***