Bug 297059 - Kontact crashes by switching between Mails ore moving Mails
Summary: Kontact crashes by switching between Mails ore moving Mails
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-29 17:14 UTC by Jens Mohr
Modified: 2012-03-30 08:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jens Mohr 2012-03-29 17:14:36 UTC
Application: kontact (4.8.0)
KDE Platform Version: 4.8.1 (4.8.1)
Qt Version: 4.8.0
Operating System: Linux 3.0.0-17-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

since kde 4.8.1 Kontact crashes in several Cases by selecting or moving Mail's.

Kind regards

	Jens Mohr

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fd8c7dfc7c0 (LWP 20128))]

Thread 5 (Thread 0x7fd8ac667700 (LWP 20133)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fd8c4635c2c in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007fd8c4635d59 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007fd8bfe02efc in start_thread (arg=0x7fd8ac667700) at pthread_create.c:304
#4  0x00007fd8c534559d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fd8abd4e700 (LWP 20134)):
#0  0x00007fd8c5339473 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fd8bf930f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fd8bf931429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fd8c5ab3c26 in QEventDispatcherGlib::processEvents (this=0x21220e0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fd8c5a83402 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fd8c5a83657 in QEventLoop::exec (this=0x7fd8abd4ddc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fd8c5983067 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fd8c598608b in QThreadPrivate::start (arg=0x2120000) at thread/qthread_unix.cpp:298
#8  0x00007fd8bfe02efc in start_thread (arg=0x7fd8abd4e700) at pthread_create.c:304
#9  0x00007fd8c534559d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fd860de5700 (LWP 20172)):
#0  0x00007fd8bf930dc7 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fd8bf931429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fd8c5ab3c26 in QEventDispatcherGlib::processEvents (this=0x26545d0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#3  0x00007fd8c5a83402 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#4  0x00007fd8c5a83657 in QEventLoop::exec (this=0x7fd860de4d90, flags=...) at kernel/qeventloop.cpp:204
#5  0x00007fd8c5983067 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#6  0x00007fd8c5a6317f in QInotifyFileSystemWatcherEngine::run (this=0x275f290) at io/qfilesystemwatcher_inotify.cpp:248
#7  0x00007fd8c598608b in QThreadPrivate::start (arg=0x275f290) at thread/qthread_unix.cpp:298
#8  0x00007fd8bfe02efc in start_thread (arg=0x7fd860de5700) at pthread_create.c:304
#9  0x00007fd8c534559d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fd85bfff700 (LWP 20457)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
#1  0x00007fd8c59864ff in wait (time=30000, this=0x30b1200) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x30b1938, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fd8c597967f in QThreadPoolThread::run (this=0x30b27b0) at concurrent/qthreadpool.cpp:141
#4  0x00007fd8c598608b in QThreadPrivate::start (arg=0x30b27b0) at thread/qthread_unix.cpp:298
#5  0x00007fd8bfe02efc in start_thread (arg=0x7fd85bfff700) at pthread_create.c:304
#6  0x00007fd8c534559d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fd8c7dfc7c0 (LWP 20128)):
[KCrash Handler]
#6  ref (this=0x32000000000) at ../../include/QtCore/../../src/corelib/arch/qatomic_x86_64.h:121
#7  QSharedDataPointer (o=..., this=0x7fffaa592020) at ../../include/QtCore/../../src/corelib/tools/qshareddata.h:93
#8  QNetworkCacheMetaData::QNetworkCacheMetaData (this=<optimized out>, other=...) at access/qabstractnetworkcache.cpp:137
#9  0x00007fd8c0bd6554 in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0x794d6b0, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1016
#10 0x00007fd8c0bd7d04 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x794d6b0, hm=<optimized out>, sc=<optimized out>, rp=<optimized out>, pu=<optimized out>, db=<optimized out>, contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:828
#11 0x00007fd8c0c63299 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x794d6b0, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#12 0x00007fd8c5a9dbc6 in QObject::event (this=0x794d6b0, e=<optimized out>) at kernel/qobject.cpp:1195
#13 0x00007fd8c6478104 in notify_helper (e=0x7fd854006090, receiver=0x794d6b0, this=0x1f55010) at kernel/qapplication.cpp:4555
#14 QApplicationPrivate::notify_helper (this=0x1f55010, receiver=0x794d6b0, e=0x7fd854006090) at kernel/qapplication.cpp:4527
#15 0x00007fd8c647cf83 in QApplication::notify (this=0x7fffaa592aa0, receiver=0x794d6b0, e=0x7fd854006090) at kernel/qapplication.cpp:4416
#16 0x00007fd8c71aa9a6 in KApplication::notify (this=0x7fffaa592aa0, receiver=0x794d6b0, event=0x7fd854006090) at ../../kdeui/kernel/kapplication.cpp:311
#17 0x00007fd8c5a8461c in QCoreApplication::notifyInternal (this=0x7fffaa592aa0, receiver=0x794d6b0, event=0x7fd854006090) at kernel/qcoreapplication.cpp:876
#18 0x00007fd8c5a883ea in sendEvent (event=0x7fd854006090, receiver=0x794d6b0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1f0b380) at kernel/qcoreapplication.cpp:1500
#20 0x00007fd8c5ab3793 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#21 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#22 0x00007fd8bf930a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007fd8bf931258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fd8bf931429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007fd8c5ab3bbf in QEventDispatcherGlib::processEvents (this=0x1f0cc10, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#26 0x00007fd8c651d28e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007fd8c5a83402 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#28 0x00007fd8c5a83657 in QEventLoop::exec (this=0x7fffaa592a30, flags=...) at kernel/qeventloop.cpp:204
#29 0x00007fd8c5a886e7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#30 0x0000000000403629 in ?? ()
#31 0x00007fd8c528330d in __libc_start_main (main=0x402b40, argc=1, ubp_av=0x7fffaa5930c8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffaa5930b8) at libc-start.c:226
#32 0x0000000000403b71 in _start ()

Possible duplicates by query: bug 291839.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-03-30 08:01:42 UTC

*** This bug has been marked as a duplicate of bug 286307 ***