Bug 291839 - Random crashes of Kontact while browsing through messages in Kmail2
Summary: Random crashes of Kontact while browsing through messages in Kmail2
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-18 09:11 UTC by Mircea Sava
Modified: 2012-05-01 09:06 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (4.23 KB, text/plain)
2012-05-01 09:06 UTC, zoone
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mircea Sava 2012-01-18 09:11:19 UTC
Application: kontact (4.7.4)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.8.0
Operating System: Linux 3.1.9-1.fc16.i686 i686
Distribution: "Fedora release 16 (Verne)"

-- Information about the crash:
- What I was doing when the application crashed:
I was quickly browsing through my emails in Kmail2.
- Unusual behavior I noticed:
Crash!
- Custom settings of the application:
None I could think that has any relevance.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb789b780 (LWP 1288))]

Thread 3 (Thread 0xb6c5cb40 (LWP 1299)):
#0  0x00ee9416 in __kernel_vsyscall ()
#1  0x488aa85c in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:172
#2  0x43c089a3 in WTF::TCMalloc_PageHeap::scavengerThread (this=0x4432dfe0) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:2495
#3  0x43c08ac0 in WTF::TCMalloc_PageHeap::runScavengerThread (context=0x4432dfe0) at ../../../Source/JavaScriptCore/wtf/FastMalloc.cpp:1618
#4  0x488a6cd3 in start_thread (arg=0xb6c5cb40) at pthread_create.c:309
#5  0x487b783e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 2 (Thread 0xb6333b40 (LWP 1301)):
#0  0x00ee9416 in __kernel_vsyscall ()
#1  0x487acfb0 in __GI___poll (fds=0xb5a00de8, nfds=1, timeout=8405) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0x48be87cc in g_poll (fds=0xb5a00de8, nfds=1, timeout=8405) at gpoll.c:132
#3  0x48bd9c06 in g_main_context_poll (n_fds=1, fds=0xb5a00de8, priority=<optimized out>, timeout=<optimized out>, context=0xb5a004e0) at gmain.c:3386
#4  g_main_context_iterate (context=0xb5a004e0, block=1220446112, dispatch=1, self=0xb5a00d70) at gmain.c:3068
#5  0x48bd9faf in g_main_context_iteration (context=0xb5a004e0, may_block=1) at gmain.c:3136
#6  0x495da307 in QEventDispatcherGlib::processEvents (this=0xb5a00468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0x495a64de in QEventLoop::processEvents (this=0xb6333230, flags=...) at kernel/qeventloop.cpp:149
#8  0x495a6789 in QEventLoop::exec (this=0xb6333230, flags=...) at kernel/qeventloop.cpp:204
#9  0x4948eb2c in QThread::exec (this=0x97b07a0) at thread/qthread.cpp:501
#10 0x4948ec1c in QThread::run (this=0x97b07a0) at thread/qthread.cpp:568
#11 0x494920b1 in QThreadPrivate::start (arg=0x97b07a0) at thread/qthread_unix.cpp:298
#12 0x488a6cd3 in start_thread (arg=0xb6333b40) at pthread_create.c:309
#13 0x487b783e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0xb789b780 (LWP 1288)):
[KCrash Handler]
#7  ref (this=0x495bf33b) at ../../src/corelib/arch/qatomic_i386.h:120
#8  QSharedDataPointer (o=..., this=0xbff18038) at ../../src/corelib/tools/qshareddata.h:93
#9  QNetworkCacheMetaData::QNetworkCacheMetaData (this=0xbff18038, other=...) at access/qabstractnetworkcache.cpp:137
#10 0x4dee5450 in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0xd1a3548, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1016
#11 0x4dee6d04 in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0xd1a3548, hm=..., sc=1230762811, rp=..., pu=255, db=..., contentLength=5618242167232266280) at access/qnetworkaccesshttpbackend.cpp:828
#12 0xbff18098 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Reported using DrKonqi
Comment 1 Mircea Sava 2012-01-18 19:42:54 UTC
I just remembered that this strange behavior started after I activated the loading of external references from the Internet.
Maybe this helps identifying the problem.
Comment 2 Christophe Giboudeaux 2012-01-21 11:19:57 UTC

*** This bug has been marked as a duplicate of bug 286307 ***
Comment 3 zoone 2012-05-01 09:06:45 UTC
Created attachment 70786 [details]
New crash information added by DrKonqi

kontact (4.8.2) on KDE Platform 4.8.2 (4.8.2) using Qt 4.8.1

- What I was doing when the application crashed:

When HTML Gmail IMAP KMail spadne.A it still happens. Kubuntu 12.04.

-- Backtrace (Reduced):
#8  QSharedDataPointer (o=..., this=0xbfed6168) at ../../include/QtCore/../../src/corelib/tools/qshareddata.h:93
#9  QNetworkCacheMetaData::QNetworkCacheMetaData (this=0xbfed6168, other=...) at access/qabstractnetworkcache.cpp:137
#10 0xb3a8aa4f in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0x8f51c80, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1016
#11 0xb3a8c27e in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x8f51c80, hm=..., sc=-1237930885, rp=..., pu=255, db=..., contentLength=-5498154363186950127) at access/qnetworkaccesshttpbackend.cpp:828
[...]