Bug 301320 - Kontact-kmail crashed again
Summary: Kontact-kmail crashed again
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.8.2
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-07 05:17 UTC by Pieyre Philippe
Modified: 2012-06-07 06:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pieyre Philippe 2012-06-07 05:17:27 UTC
Application: kontact (4.8.2)
KDE Platform Version: 4.8.2 (4.8.2) (Compiled from sources)
Qt Version: 4.8.1
Operating System: Linux 3.3.6-desktop-2.mga2 i686
Distribution: "Mageia 2"

-- Information about the crash:
- What I was doing when the application crashed: This time the crash appear when i clic on a mail to read it.
These crashs appear three or four time by day, and disappear without knowing how.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/i686/libthread_db.so.1".
[Current thread is 1 (Thread 0xb2179710 (LWP 2964))]

Thread 3 (Thread 0xb0f38b70 (LWP 2965)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb3c1c25b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i686/libpthread.so.0
#2  0xb613a93c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i686/libc.so.6
#3  0xb58b88cb in ?? () from /usr/lib/libQtWebKit.so.4
#4  0xb58b89ef in ?? () from /usr/lib/libQtWebKit.so.4
#5  0xb3c18a37 in start_thread () from /lib/i686/libpthread.so.0
#6  0xb612c98e in clone () from /lib/i686/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xb060fb70 (LWP 2966)):
#0  0xb3c1a85f in pthread_mutex_lock () from /lib/i686/libpthread.so.0
#1  0xb613ab54 in pthread_mutex_lock () from /lib/i686/libc.so.6
#2  0xb3b75200 in g_mutex_lock () from /lib/libglib-2.0.so.0
#3  0xb3b34e69 in g_main_context_acquire () from /lib/libglib-2.0.so.0
#4  0xb3b35cd8 in ?? () from /lib/libglib-2.0.so.0
#5  0xb3b35f81 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#6  0xb6469207 in QEventDispatcherGlib::processEvents (this=0xafd00468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0xb643540d in QEventLoop::processEvents (this=0xb060f2d0, flags=...) at kernel/qeventloop.cpp:149
#8  0xb64356a9 in QEventLoop::exec (this=0xb060f2d0, flags=...) at kernel/qeventloop.cpp:204
#9  0xb631f67c in QThread::exec (this=0x9570838) at thread/qthread.cpp:501
#10 0xb631f76b in QThread::run (this=0x9570838) at thread/qthread.cpp:568
#11 0xb6322b60 in QThreadPrivate::start (arg=0x9570838) at thread/qthread_unix.cpp:298
#12 0xb3c18a37 in start_thread () from /lib/i686/libpthread.so.0
#13 0xb612c98e in clone () from /lib/i686/libc.so.6
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb2179710 (LWP 2964)):
[KCrash Handler]
#7  ref (this=0xb646959b) at ../../src/corelib/arch/qatomic_i386.h:120
#8  QSharedDataPointer (o=..., this=0xbfaa1e38) at ../../src/corelib/tools/qshareddata.h:93
#9  QNetworkCacheMetaData::QNetworkCacheMetaData (this=0xbfaa1e38, other=...) at access/qabstractnetworkcache.cpp:137
#10 0xb3d3d17f in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0xa8622d8, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1016
#11 0xb3d3e9ae in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0xa8622d8, hm=..., sc=-1236888165, rp=..., pu=255, db=..., contentLength=-5486089834405998604) at access/qnetworkaccesshttpbackend.cpp:828
#12 0xbfaa1e98 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Possible duplicates by query: bug 297059, bug 291839.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-06-07 06:02:10 UTC

*** This bug has been marked as a duplicate of bug 286307 ***