Bug 302056 - The program crash frequently, just selecting the input folder
Summary: The program crash frequently, just selecting the input folder
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kontact
Classification: Applications
Component: mail (show other bugs)
Version: 4.8.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-17 13:18 UTC by Richard
Modified: 2012-06-17 21:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
File containing infos from the trace program (3.58 KB, application/octet-stream)
2012-06-17 13:18 UTC, Richard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Richard 2012-06-17 13:18:38 UTC
Created attachment 71887 [details]
File containing infos from the trace program

I had just selected the inbox folder and the program krash.  My config for Kontact imply to follow 6 mail accounts.
My computer config is base on Kubuntu  with KDE 4.8.3.

Thanks in advance if you can correct this bug.

Richard Goulet
Comment 1 Jekyll Wu 2012-06-17 21:32:28 UTC
Please always paste the bactrace inline when you report crash manually instead of using Dr.Konqi. That helps searching for duplicates.

Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb21ef980 (LWP 1954))]

Thread 4 (Thread 0xafadeb40 (LWP 1956)):
#0  0xb77c0424 in __kernel_vsyscall ()
#1  0xb39fa96b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb61003dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb587e263 in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#4  0xb587e37f in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#5  0xb39f6d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0xb60f2ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xaf1b5b40 (LWP 1957)):
#0  0xb39630a7 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb3963388 in g_mutex_lock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb3924020 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb39241c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb64428e7 in QEventDispatcherGlib::processEvents (this=0xae800468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0xb640e50d in QEventLoop::processEvents (this=0xaf1b5270, flags=...) at kernel/qeventloop.cpp:149
#6  0xb640e7a9 in QEventLoop::exec (this=0xaf1b5270, flags=...) at kernel/qeventloop.cpp:204
#7  0xb62f794c in QThread::exec (this=0x997bdd8) at thread/qthread.cpp:501
#8  0xb62f7a3b in QThread::run (this=0x997bdd8) at thread/qthread.cpp:568
#9  0xb62fade0 in QThreadPrivate::start (arg=0x997bdd8) at thread/qthread_unix.cpp:298
#10 0xb39f6d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0xb60f2ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xab3ffb40 (LWP 2882)):
#0  0xb77c0424 in __kernel_vsyscall ()
#1  0xb60e4380 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb3931a3b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb392406e in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb39241c1 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb64428e7 in QEventDispatcherGlib::processEvents (this=0xac16438, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb640e50d in QEventLoop::processEvents (this=0xab3ff240, flags=...) at kernel/qeventloop.cpp:149
#7  0xb640e7a9 in QEventLoop::exec (this=0xab3ff240, flags=...) at kernel/qeventloop.cpp:204
#8  0xb62f794c in QThread::exec (this=0xac42340) at thread/qthread.cpp:501
#9  0xb63ebb5d in QInotifyFileSystemWatcherEngine::run (this=0xac42340) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb62fade0 in QThreadPrivate::start (arg=0xac42340) at thread/qthread_unix.cpp:298
#11 0xb39f6d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb60f2ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb21ef980 (LWP 1954)):
[KCrash Handler]
#7  ref (this=0xb607c549) at ../../include/QtCore/../../src/corelib/arch/qatomic_i386.h:120
#8  QSharedDataPointer (o=..., this=0xbfe2b8a8) at ../../include/QtCore/../../src/corelib/tools/qshareddata.h:93
#9  QNetworkCacheMetaData::QNetworkCacheMetaData (this=0xbfe2b8a8, other=...) at access/qabstractnetworkcache.cpp:137
#10 0xb3b61a4f in QNetworkAccessHttpBackend::fetchCacheMetaData (this=0xab9a200, oldMetaData=...) at access/qnetworkaccesshttpbackend.cpp:1016
#11 0xb3b6327e in QNetworkAccessHttpBackend::replyDownloadMetaData (this=0xab9a200, hm=..., sc=-1241004727, rp=..., pu=255, db=..., contentLength=-5494372043178401804) at access/qnetworkaccesshttpbackend.cpp:828
#12 0xbfe2b908 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

*** This bug has been marked as a duplicate of bug 286307 ***