Bug 300110 - Crash on almost evry shutdown
Summary: Crash on almost evry shutdown
Status: RESOLVED DUPLICATE of bug 292950
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: storage (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-16 04:57 UTC by Martin Oberzalek
Modified: 2012-05-26 02:15 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Oberzalek 2012-05-16 04:57:56 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.7.2 (4.7.2) "release 5"
Qt Version: 4.7.4
Operating System: Linux 3.1.10-1.9-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
Just shutting down KDE
OpenSUSE 12.1 with all patches.
I think this is happening when Neopmuk is collecting some data.

The crash can be reproduced some of the time.

-- Backtrace:
Application: Nepomuk-Dienst (nepomukservicestub), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f1302c99760 (LWP 4601))]

Thread 8 (Thread 0x7f12edfd5700 (LWP 4864)):
#0  0x00007f130240a014 in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00007f12ff550a5f in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f12ff550f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f13027a9586 in QEventDispatcherGlib::processEvents (this=0x7f12e40008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f130277da32 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f130277dc2f in QEventLoop::exec (this=0x7f12edfd4df0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f13026955df in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f1302760aff in QInotifyFileSystemWatcherEngine::run (this=0x88fd90) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f1302698025 in QThreadPrivate::start (arg=0x88fd90) at thread/qthread_unix.cpp:331
#9  0x00007f1302407f05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f130010510d in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7f12d4ff9700 (LWP 4885)):
[KCrash Handler]
#6  end (this=) at ../../src/corelib/tools/qlist.h:98
#7  constEnd (this=) at ../../src/corelib/tools/qlist.h:259
#8  QCoreApplication::translate (context=0x7f12fe9d21c0 "QLocalSocket", sourceText=0x7f12fe9d277b "%1: Remote closed", disambiguation=0x0, encoding=QCoreApplication::CodecForTr, n=-1) at kernel/qcoreapplication.cpp:1821
#9  0x00007f130277f25f in QCoreApplication::translate (context=<optimized out>, sourceText=<optimized out>, disambiguation=<optimized out>, encoding=<optimized out>) at kernel/qcoreapplication.cpp:1738
#10 0x00007f1302784330 in QMetaObject::tr (this=<optimized out>, s=<optimized out>, c=<optimized out>) at kernel/qmetaobject.cpp:281
#11 0x00007f12fe99de8c in tr (s=0x7f12fe9d277b "%1: Remote closed", c=<optimized out>) at socket/qlocalsocket.h:60
#12 QLocalSocketPrivate::generateErrorString (this=<optimized out>, error=<optimized out>, function=...) at socket/qlocalsocket_unix.cpp:142
#13 0x00007f12fe99e603 in QLocalSocketPrivate::_q_error (this=<optimized out>, socketError=QAbstractSocket::RemoteHostClosedError) at socket/qlocalsocket_unix.cpp:100
#14 0x00007f12fe99afac in QLocalSocket::qt_metacall (this=0x7f12ac0013c0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7f12d4ff8620) at .moc/release-shared/moc_qlocalsocket.cpp:91
#15 0x00007f13027915aa in QMetaObject::activate (sender=0x7f12ac002080, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7f12d4ff8620) at kernel/qobject.cpp:3287
#16 0x00007f12fe992ca1 in QAbstractSocket::error (this=<optimized out>, _t1=QAbstractSocket::RemoteHostClosedError) at .moc/release-shared/moc_qabstractsocket.cpp:156
#17 0x00007f12fe994a51 in QAbstractSocketPrivate::readFromSocket (this=0x7f12ac0020e0) at socket/qabstractsocket.cpp:1178
#18 0x00007f12fe994d73 in QAbstractSocketPrivate::canReadNotification (this=0x7f12ac0020e0) at socket/qabstractsocket.cpp:618
#19 0x00007f12fe983b71 in event (this=<optimized out>, e=<optimized out>) at socket/qnativesocketengine.cpp:1103
#20 QReadNotifier::event (this=<optimized out>, e=<optimized out>) at socket/qnativesocketengine.cpp:1100
#21 0x00007f1300894c34 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#22 0x00007f1300899ac1 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#23 0x00007f130277e82c in QCoreApplication::notifyInternal (this=0x7fff3284efa0, receiver=0x7f12ac002b30, event=0x7f12d4ff8b70) at kernel/qcoreapplication.cpp:787
#24 0x00007f13027a8c37 in sendEvent (event=0x7f12d4ff8b70, receiver=<optimized out>) at kernel/qcoreapplication.h:215
#25 socketNotifierSourceDispatch (source=0x7f12ac001e00) at kernel/qeventdispatcher_glib.cpp:110
#26 0x00007f12ff55058d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#27 0x00007f12ff550d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#28 0x00007f12ff550f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#29 0x00007f13027a951f in QEventDispatcherGlib::processEvents (this=0x7f12ac0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#30 0x00007f130277da32 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#31 0x00007f130277dc2f in QEventLoop::exec (this=0x7f12d4ff8d80, flags=...) at kernel/qeventloop.cpp:201
#32 0x00007f13026955df in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#33 0x00007f12f3b6e4d8 in Soprano::Server::ServerConnection::run (this=0x8cb4e0) at /usr/src/debug/soprano-2.7.2/server/serverconnection.cpp:151
#34 0x00007f1302698025 in QThreadPrivate::start (arg=0x8cb4e0) at thread/qthread_unix.cpp:331
#35 0x00007f1302407f05 in start_thread () from /lib64/libpthread.so.0
#36 0x00007f130010510d in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f12bf7fe700 (LWP 4888)):
#0  0x00007f12ff54fbc3 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f12ff55092d in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f12ff550f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f13027a9586 in QEventDispatcherGlib::processEvents (this=0x7f12b00008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f130277da32 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f130277dc2f in QEventLoop::exec (this=0x7f12bf7fdd80, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f13026955df in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f12f3b6e4d8 in Soprano::Server::ServerConnection::run (this=0xdfcb30) at /usr/src/debug/soprano-2.7.2/server/serverconnection.cpp:151
#8  0x00007f1302698025 in QThreadPrivate::start (arg=0xdfcb30) at thread/qthread_unix.cpp:331
#9  0x00007f1302407f05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f130010510d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f12ed7d4700 (LWP 4896)):
#0  0x00007f130240b11f in __pthread_mutex_unlock_usercnt () from /lib64/libpthread.so.0
#1  0x00007f12ff54f1b7 in g_main_context_acquire () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f12ff5508b1 in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f12ff550f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f13027a9586 in QEventDispatcherGlib::processEvents (this=0x7f12d80008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f130277da32 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f130277dc2f in QEventLoop::exec (this=0x7f12ed7d3d80, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f13026955df in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#8  0x00007f12f3b6e4d8 in Soprano::Server::ServerConnection::run (this=0x827b80) at /usr/src/debug/soprano-2.7.2/server/serverconnection.cpp:151
#9  0x00007f1302698025 in QThreadPrivate::start (arg=0x827b80) at thread/qthread_unix.cpp:331
#10 0x00007f1302407f05 in start_thread () from /lib64/libpthread.so.0
#11 0x00007f130010510d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f12ee7d6700 (LWP 4899)):
#0  0x00007f130240be6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f13026984bb in wait (time=18446744073709551615, this=0x9343f0) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x934320, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f130268ce9f in QThreadPoolThread::run (this=0x8ba1a0) at concurrent/qthreadpool.cpp:140
#4  0x00007f1302698025 in QThreadPrivate::start (arg=0x8ba1a0) at thread/qthread_unix.cpp:331
#5  0x00007f1302407f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f130010510d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f12be7fc700 (LWP 4901)):
#0  0x00007f130240be6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f13026984bb in wait (time=18446744073709551615, this=0x9343f0) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x934320, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f130268ce9f in QThreadPoolThread::run (this=0x857dc0) at concurrent/qthreadpool.cpp:140
#4  0x00007f1302698025 in QThreadPrivate::start (arg=0x857dc0) at thread/qthread_unix.cpp:331
#5  0x00007f1302407f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f130010510d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f12bd7fa700 (LWP 4952)):
#0  0x00007f13000fbff3 in poll () from /lib64/libc.so.6
#1  0x00007f12ff550a98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f12ff550f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f13027a9586 in QEventDispatcherGlib::processEvents (this=0x7f12a00008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f130277da32 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f130277dc2f in QEventLoop::exec (this=0x7f12bd7f9d80, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f13026955df in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f12f3b6e4d8 in Soprano::Server::ServerConnection::run (this=0x8b4300) at /usr/src/debug/soprano-2.7.2/server/serverconnection.cpp:151
#8  0x00007f1302698025 in QThreadPrivate::start (arg=0x8b4300) at thread/qthread_unix.cpp:331
#9  0x00007f1302407f05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f130010510d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f1302c99760 (LWP 4601)):
#0  0x00007f130240be6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f13026984bb in wait (time=18446744073709551615, this=0x8506e0) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x8a2b50, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f1302697d6c in QThread::wait (this=<optimized out>, time=18446744073709551615) at thread/qthread_unix.cpp:745
#4  0x00007f12f3b6e1e8 in Soprano::Server::ServerConnection::~ServerConnection (this=0x8cb4e0, __in_chrg=<optimized out>) at /usr/src/debug/soprano-2.7.2/server/serverconnection.cpp:124
#5  0x00007f12f3b756b3 in ~LocalServerConnection (this=0x8cb4e0, __in_chrg=<optimized out>) at /usr/src/debug/soprano-2.7.2/server/localserver.cpp:30
#6  (anonymous namespace)::LocalServerConnection::~LocalServerConnection (this=<optimized out>, __in_chrg=<optimized out>) at /usr/src/debug/soprano-2.7.2/server/localserver.cpp:30
#7  0x00007f12f3b6884e in qDeleteAll<QList<Soprano::Server::ServerConnection*>::const_iterator> (end=<optimized out>, begin=<optimized out>) at /usr/include/QtCore/qalgorithms.h:322
#8  qDeleteAll<QList<Soprano::Server::ServerConnection*> > (c=...) at /usr/include/QtCore/qalgorithms.h:330
#9  Soprano::Server::ServerCore::~ServerCore (this=0x746dd0, __in_chrg=<optimized out>) at /usr/src/debug/soprano-2.7.2/server/servercore.cpp:76
#10 0x00007f12f3da4dfc in ?? () from /usr/lib64/kde4/nepomukstorage.so
#11 0x00007f12f3da4ea9 in ?? () from /usr/lib64/kde4/nepomukstorage.so
#12 0x00007f1302790465 in QObjectPrivate::deleteChildren (this=0x7b3ec0) at kernel/qobject.cpp:1964
#13 0x00007f1302795a09 in QObject::~QObject (this=0x7b83e0, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#14 0x00007f12f3da4113 in ?? () from /usr/lib64/kde4/nepomukstorage.so
#15 0x00007f1302790465 in QObjectPrivate::deleteChildren (this=0x744ad0) at kernel/qobject.cpp:1964
#16 0x00007f1302795a09 in QObject::~QObject (this=0x744be0, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#17 0x00000000004047f9 in _start ()

This bug may be a duplicate of or related to bug 295021.

Possible duplicates by query: bug 295021, bug 286059, bug 285259, bug 279622, bug 273675.

Reported using DrKonqi
Comment 1 Vishesh Handa 2012-05-26 02:15:15 UTC

*** This bug has been marked as a duplicate of bug 292950 ***