Bug 285259 - nepomuk stub crashes at shutdown
Summary: nepomuk stub crashes at shutdown
Status: RESOLVED DUPLICATE of bug 257176
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
: 285227 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-29 14:43 UTC by MonkZ
Modified: 2011-11-01 14:19 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MonkZ 2011-10-29 14:43:53 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.7.2 (4.7.2)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-12-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:
nepomuk an plasma-desktop crashed at shutdown after dist-upgrade

-- Backtrace:
Application: Nepomuk-Dienst (nepomukservicestub), signal: Segmentation fault
pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
	in ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S
[Current thread is 1 (Thread 0x7f2f0976b780 (LWP 2060))]

Thread 7 (Thread 0x7f2eefc50700 (LWP 2284)):
#0  0x00007f2f06db1773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f2f05fe4f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2f05fe5429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2f0926ff3e in QEventDispatcherGlib::processEvents (this=0x99ebc0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f2f09243cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f2f09243ef7 in QEventLoop::exec (this=0x7f2eefc4fdd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f2f0915b27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f2f09226cbf in QInotifyFileSystemWatcherEngine::run (this=0x9932c0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f2f0915dd05 in QThreadPrivate::start (arg=0x9932c0) at thread/qthread_unix.cpp:331
#9  0x00007f2f06ac6efc in start_thread (arg=0x7f2eefc50700) at pthread_create.c:304
#10 0x00007f2f06dbd89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f2eecc4a700 (LWP 2312)):
[KCrash Handler]
#6  end (this=) at ../../include/QtCore/../../src/corelib/tools/qlist.h:98
#7  constEnd (this=) at ../../include/QtCore/../../src/corelib/tools/qlist.h:259
#8  QCoreApplication::translate (context=0x7f2f0543e9c0 "QLocalSocket", sourceText=0x7f2f0543ef7b "%1: Remote closed", disambiguation=0x0, encoding=QCoreApplication::CodecForTr, n=-1) at kernel/qcoreapplication.cpp:1821
#9  0x00007f2f0924552f in QCoreApplication::translate (context=<optimized out>, sourceText=<optimized out>, disambiguation=<optimized out>, encoding=<optimized out>) at kernel/qcoreapplication.cpp:1738
#10 0x00007f2f0924acb0 in QMetaObject::tr (this=<optimized out>, s=<optimized out>, c=<optimized out>) at kernel/qmetaobject.cpp:281
#11 0x00007f2f0540a89c in tr (s=0x7f2f0543ef7b "%1: Remote closed", c=<optimized out>) at socket/qlocalsocket.h:60
#12 QLocalSocketPrivate::generateErrorString (this=<optimized out>, error=<optimized out>, function=...) at socket/qlocalsocket_unix.cpp:142
#13 0x00007f2f0540b013 in QLocalSocketPrivate::_q_error (this=0x963530, socketError=QAbstractSocket::RemoteHostClosedError) at socket/qlocalsocket_unix.cpp:100
#14 0x00007f2f0540799c in QLocalSocket::qt_metacall (this=0x9bcca0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7f2eecc49790) at .moc/release-shared/moc_qlocalsocket.cpp:91
#15 0x00007f2f09257eba in QMetaObject::activate (sender=0x963620, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7f2eecc49790) at kernel/qobject.cpp:3278
#16 0x00007f2f053ff681 in QAbstractSocket::error (this=<optimized out>, _t1=QAbstractSocket::RemoteHostClosedError) at .moc/release-shared/moc_qabstractsocket.cpp:156
#17 0x00007f2f05401431 in QAbstractSocketPrivate::readFromSocket (this=0x9d1400) at socket/qabstractsocket.cpp:1178
#18 0x00007f2f05401763 in QAbstractSocketPrivate::canReadNotification (this=0x9d1400) at socket/qabstractsocket.cpp:618
#19 0x00007f2f053f0551 in event (this=<optimized out>, e=<optimized out>) at socket/qnativesocketengine.cpp:1103
#20 QReadNotifier::event (this=<optimized out>, e=<optimized out>) at socket/qnativesocketengine.cpp:1100
#21 0x00007f2f0757e424 in notify_helper (e=0x7f2eecc49b50, receiver=0x98ccf0, this=0x71c440) at kernel/qapplication.cpp:4486
#22 QApplicationPrivate::notify_helper (this=0x71c440, receiver=0x98ccf0, e=0x7f2eecc49b50) at kernel/qapplication.cpp:4458
#23 0x00007f2f07583291 in QApplication::notify (this=0x7fffc64715e0, receiver=0x98ccf0, e=0x7f2eecc49b50) at kernel/qapplication.cpp:4365
#24 0x00007f2f09244afc in QCoreApplication::notifyInternal (this=0x7fffc64715e0, receiver=0x98ccf0, event=0x7f2eecc49b50) at kernel/qcoreapplication.cpp:787
#25 0x00007f2f0926f5b7 in sendEvent (event=0x7f2eecc49b50, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 socketNotifierSourceDispatch (source=0x9a7770) at kernel/qeventdispatcher_glib.cpp:110
#27 0x00007f2f05fe4a5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f2f05fe5258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f2f05fe5429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f2f0926fed6 in QEventDispatcherGlib::processEvents (this=0x998f30, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#31 0x00007f2f09243cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#32 0x00007f2f09243ef7 in QEventLoop::exec (this=0x7f2eecc49d60, flags=...) at kernel/qeventloop.cpp:201
#33 0x00007f2f0915b27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#34 0x00007f2ef9faa0ae in ?? () from /usr/lib/libsopranoserver.so.1
#35 0x00007f2f0915dd05 in QThreadPrivate::start (arg=0x7f2ef00180e0) at thread/qthread_unix.cpp:331
#36 0x00007f2f06ac6efc in start_thread (arg=0x7f2eecc4a700) at pthread_create.c:304
#37 0x00007f2f06dbd89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#38 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f2eedc4c700 (LWP 2315)):
#0  0x00007f2f06db1773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f2f05fe4f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2f05fe5429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2f0926ff3e in QEventDispatcherGlib::processEvents (this=0x953ba0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f2f09243cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f2f09243ef7 in QEventLoop::exec (this=0x7f2eedc4bd60, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f2f0915b27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f2ef9faa0ae in ?? () from /usr/lib/libsopranoserver.so.1
#8  0x00007f2f0915dd05 in QThreadPrivate::start (arg=0x9949e0) at thread/qthread_unix.cpp:331
#9  0x00007f2f06ac6efc in start_thread (arg=0x7f2eedc4c700) at pthread_create.c:304
#10 0x00007f2f06dbd89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f2eec449700 (LWP 2325)):
#0  0x00007f2f06db1773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f2f05fe4f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2f05fe5429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2f0926ff3e in QEventDispatcherGlib::processEvents (this=0x9bbf10, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f2f09243cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f2f09243ef7 in QEventLoop::exec (this=0x7f2eec448d60, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f2f0915b27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f2ef9faa0ae in ?? () from /usr/lib/libsopranoserver.so.1
#8  0x00007f2f0915dd05 in QThreadPrivate::start (arg=0x988150) at thread/qthread_unix.cpp:331
#9  0x00007f2f06ac6efc in start_thread (arg=0x7f2eec449700) at pthread_create.c:304
#10 0x00007f2f06dbd89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f2eef44f700 (LWP 6128)):
#0  0x00007f2f06db1773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f2f05fe4f68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2f05fe5429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2f0926ff3e in QEventDispatcherGlib::processEvents (this=0x9a4680, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f2f09243cf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f2f09243ef7 in QEventLoop::exec (this=0x7f2eef44ed60, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f2f0915b27f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f2ef9faa0ae in ?? () from /usr/lib/libsopranoserver.so.1
#8  0x00007f2f0915dd05 in QThreadPrivate::start (arg=0x7f2ef000eb30) at thread/qthread_unix.cpp:331
#9  0x00007f2f06ac6efc in start_thread (arg=0x7f2eef44f700) at pthread_create.c:304
#10 0x00007f2f06dbd89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f2eebc48700 (LWP 6129)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f2f0915e1ab in wait (time=18446744073709551615, this=0xa1f690) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x9ea350, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f2f0915281f in QThreadPoolThread::run (this=0x7f2ef000e5b0) at concurrent/qthreadpool.cpp:140
#4  0x00007f2f0915dd05 in QThreadPrivate::start (arg=0x7f2ef000e5b0) at thread/qthread_unix.cpp:331
#5  0x00007f2f06ac6efc in start_thread (arg=0x7f2eebc48700) at pthread_create.c:304
#6  0x00007f2f06dbd89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f2f0976b780 (LWP 2060)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f2f0915e1ab in wait (time=18446744073709551615, this=0x7f2ef0004b40) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f2ef0005210, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f2f0915da4c in QThread::wait (this=<optimized out>, time=18446744073709551615) at thread/qthread_unix.cpp:745
#4  0x00007f2ef9fa9628 in ?? () from /usr/lib/libsopranoserver.so.1
#5  0x00007f2ef9fafc43 in ?? () from /usr/lib/libsopranoserver.so.1
#6  0x00007f2ef9fa5e7e in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#7  0x00007f2efa1dd9fc in Nepomuk::Core::~Core (this=0x8d6d00, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:45
#8  0x00007f2efa1ddaa9 in Nepomuk::Core::~Core (this=0x8d6d00, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:48
#9  0x00007f2f09256d75 in QObjectPrivate::deleteChildren (this=0x8dbda0) at kernel/qobject.cpp:1955
#10 0x00007f2f0925c349 in QObject::~QObject (this=0x8a4c00, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#11 0x00007f2efa1dcc83 in ~Storage (this=0x8a4c00, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/storage.cpp:54
#12 Nepomuk::Storage::~Storage (this=0x8a4c00, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/storage.cpp:56
#13 0x00007f2f09256d75 in QObjectPrivate::deleteChildren (this=0x8d6d70) at kernel/qobject.cpp:1955
#14 0x00007f2f0925c349 in QObject::~QObject (this=0x8d51b0, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#15 0x0000000000404419 in Nepomuk::ServiceControl::~ServiceControl (this=0x8d51b0, __in_chrg=<optimized out>) at ../../../nepomuk/servicestub/servicecontrol.cpp:39
#16 0x00007f2f09256d75 in QObjectPrivate::deleteChildren (this=0x71c440) at kernel/qobject.cpp:1955
#17 0x00007f2f0925c349 in QObject::~QObject (this=0x7fffc64715e0, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#18 0x00007f2f07587f87 in QApplication::~QApplication (this=0x7fffc64715e0, __in_chrg=<optimized out>) at kernel/qapplication.cpp:1093
#19 0x0000000000403a4d in main (argc=2, argv=0x7fffc6471a88) at ../../../nepomuk/servicestub/main.cpp:102

This bug may be a duplicate of or related to bug 257176.

Possible duplicates by query: bug 279622, bug 273675, bug 257176.

Reported using DrKonqi
Comment 1 Sebastian Trueg 2011-11-01 14:15:16 UTC
*** Bug 285227 has been marked as a duplicate of this bug. ***
Comment 2 Sebastian Trueg 2011-11-01 14:19:02 UTC

*** This bug has been marked as a duplicate of bug 257176 ***