Bug 273675 - Nepomuk stub crashed at system shutdown
Summary: Nepomuk stub crashed at system shutdown
Status: RESOLVED DUPLICATE of bug 257176
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-19 22:53 UTC by Heikki Välisuo
Modified: 2011-10-12 08:18 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (15.00 KB, text/plain)
2011-06-16 08:45 UTC, Stewart Watkiss
Details
New crash information added by DrKonqi (13.49 KB, text/plain)
2011-07-04 22:22 UTC, mercatino13
Details
New crash information added by DrKonqi (22.82 KB, text/plain)
2011-08-03 18:12 UTC, Dmitriy
Details
New crash information added by DrKonqi (11.29 KB, text/plain)
2011-10-05 01:36 UTC, Sebastián Ramírez
Details
New crash information added by DrKonqi (5.59 KB, text/plain)
2011-10-11 21:29 UTC, svex87
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heikki Välisuo 2011-05-19 22:53:38 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.6.3 (4.6.3) "release 4"
Qt Version: 4.7.3
Operating System: Linux 2.6.38.6-29-desktop x86_64
Distribution: "openSUSE 11.4 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

I clicked the KDE shutdown command.

I think I got the same error once before. Didn't try to systematically reproduce.

-- Backtrace:
Application: Nepomuk Service Stub (nepomukservicestub), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fc2d942a760 (LWP 4933))]

Thread 9 (Thread 0x7fc2beffd700 (LWP 5029)):
[KCrash Handler]
#6  end (context=0x7fc2d5219460 "QLocalSocket", sourceText=0x7fc2d5219a1b "%1: Remote closed", disambiguation=0x0, encoding=QCoreApplication::CodecForTr, n=-1) at ../../src/corelib/tools/qlist.h:98
#7  constEnd (context=0x7fc2d5219460 "QLocalSocket", sourceText=0x7fc2d5219a1b "%1: Remote closed", disambiguation=0x0, encoding=QCoreApplication::CodecForTr, n=-1) at ../../src/corelib/tools/qlist.h:259
#8  QCoreApplication::translate (context=0x7fc2d5219460 "QLocalSocket", sourceText=0x7fc2d5219a1b "%1: Remote closed", disambiguation=0x0, encoding=QCoreApplication::CodecForTr, n=-1) at kernel/qcoreapplication.cpp:1765
#9  0x00007fc2d8f24edf in QCoreApplication::translate (context=<value optimized out>, sourceText=<value optimized out>, disambiguation=<value optimized out>, encoding=<value optimized out>) at kernel/qcoreapplication.cpp:1682
#10 0x00007fc2d8f2a400 in QMetaObject::tr (this=<value optimized out>, s=<value optimized out>, c=<value optimized out>) at kernel/qmetaobject.cpp:281
#11 0x00007fc2d51e6cf2 in tr (this=<value optimized out>, error=<value optimized out>, function=...) at socket/qlocalsocket.h:60
#12 QLocalSocketPrivate::generateErrorString (this=<value optimized out>, error=<value optimized out>, function=...) at socket/qlocalsocket_unix.cpp:142
#13 0x00007fc2d51e7361 in QLocalSocketPrivate::_q_error (this=<value optimized out>, socketError=QAbstractSocket::RemoteHostClosedError) at socket/qlocalsocket_unix.cpp:100
#14 0x00007fc2d51e3dac in QLocalSocket::qt_metacall (this=0x81c3e0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fc2beffc570) at .moc/release-shared/moc_qlocalsocket.cpp:91
#15 0x00007fc2d8f38a5f in QMetaObject::activate (sender=0x7fef40, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7fc2beffc570) at kernel/qobject.cpp:3278
#16 0x00007fc2d51dc131 in QAbstractSocket::error (this=<value optimized out>, _t1=QAbstractSocket::RemoteHostClosedError) at .moc/release-shared/moc_qabstractsocket.cpp:156
#17 0x00007fc2d51df202 in QAbstractSocketPrivate::readFromSocket (this=0x8d46d0) at socket/qabstractsocket.cpp:1174
#18 0x00007fc2d51df513 in QAbstractSocketPrivate::canReadNotification (this=0x8d46d0) at socket/qabstractsocket.cpp:614
#19 0x00007fc2d51cd2e1 in QReadNotifier::event (this=<value optimized out>, e=<value optimized out>) at socket/qnativesocketengine.cpp:1103
#20 0x00007fc2d70ab144 in QApplicationPrivate::notify_helper (this=0x62b740, receiver=0x834910, e=0x7fc2beffcb50) at kernel/qapplication.cpp:4462
#21 0x00007fc2d70b36fa in QApplication::notify (this=<value optimized out>, receiver=0x834910, e=0x7fc2beffcb50) at kernel/qapplication.cpp:4341
#22 0x00007fc2d7fd7006 in KApplication::notify (this=0x7fff3dbd78a0, receiver=0x834910, event=0x7fc2beffcb50) at /usr/src/debug/kdelibs-4.6.3/kdeui/kernel/kapplication.cpp:311
#23 0x00007fc2d8f2447c in QCoreApplication::notifyInternal (this=0x7fff3dbd78a0, receiver=0x834910, event=0x7fc2beffcb50) at kernel/qcoreapplication.cpp:731
#24 0x00007fc2d8f4ec09 in sendEvent (source=0xa73990) at kernel/qcoreapplication.h:215
#25 socketNotifierSourceDispatch (source=0xa73990) at kernel/qeventdispatcher_glib.cpp:110
#26 0x00007fc2d5d94bd3 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#27 0x00007fc2d5d953b0 in ?? () from /lib64/libglib-2.0.so.0
#28 0x00007fc2d5d95650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#29 0x00007fc2d8f4f22f in QEventDispatcherGlib::processEvents (this=0x8ebf00, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#30 0x00007fc2d8f238d2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#31 0x00007fc2d8f23ae5 in QEventLoop::exec (this=0x7fc2beffcd70, flags=...) at kernel/qeventloop.cpp:201
#32 0x00007fc2d8e387a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#33 0x00007fc2c8e8a40b in ?? () from /usr/lib64/libsopranoserver.so.1
#34 0x00007fc2d8e3b095 in QThreadPrivate::start (arg=0x7fc2c0002b00) at thread/qthread_unix.cpp:320
#35 0x00007fc2d8baaa3f in start_thread () from /lib64/libpthread.so.0
#36 0x00007fc2d693e67d in clone () from /lib64/libc.so.6
#37 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7fc2be7fc700 (LWP 5030)):
#0  0x00007fc2d6935503 in poll () from /lib64/libc.so.6
#1  0x00007fc2d5d95114 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007fc2d5d95650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007fc2d8f4f286 in QEventDispatcherGlib::processEvents (this=0xa81850, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fc2d8f238d2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fc2d8f23ae5 in QEventLoop::exec (this=0x7fc2be7fbd70, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fc2d8e387a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007fc2c8e8a40b in ?? () from /usr/lib64/libsopranoserver.so.1
#8  0x00007fc2d8e3b095 in QThreadPrivate::start (arg=0x7fc2c00048f0) at thread/qthread_unix.cpp:320
#9  0x00007fc2d8baaa3f in start_thread () from /lib64/libpthread.so.0
#10 0x00007fc2d693e67d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7fc2bdffb700 (LWP 5048)):
#0  0x00007fc2d6935503 in poll () from /lib64/libc.so.6
#1  0x00007fc2d5d95114 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007fc2d5d95650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007fc2d8f4f286 in QEventDispatcherGlib::processEvents (this=0x8c5d40, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fc2d8f238d2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fc2d8f23ae5 in QEventLoop::exec (this=0x7fc2bdffad70, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fc2d8e387a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007fc2c8e8a40b in ?? () from /usr/lib64/libsopranoserver.so.1
#8  0x00007fc2d8e3b095 in QThreadPrivate::start (arg=0x7fc2c0004dd0) at thread/qthread_unix.cpp:320
#9  0x00007fc2d8baaa3f in start_thread () from /lib64/libpthread.so.0
#10 0x00007fc2d693e67d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7fc2bd7fa700 (LWP 5051)):
#0  0x00007fc2d6935503 in poll () from /lib64/libc.so.6
#1  0x00007fc2d5d95114 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007fc2d5d95650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007fc2d8f4f286 in QEventDispatcherGlib::processEvents (this=0xa82cf0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fc2d8f238d2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fc2d8f23ae5 in QEventLoop::exec (this=0x7fc2bd7f9d70, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fc2d8e387a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007fc2c8e8a40b in ?? () from /usr/lib64/libsopranoserver.so.1
#8  0x00007fc2d8e3b095 in QThreadPrivate::start (arg=0x7fc2c0004e00) at thread/qthread_unix.cpp:320
#9  0x00007fc2d8baaa3f in start_thread () from /lib64/libpthread.so.0
#10 0x00007fc2d693e67d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fc2bcff9700 (LWP 5071)):
#0  0x00007fc2d6935503 in poll () from /lib64/libc.so.6
#1  0x00007fc2d5d95114 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007fc2d5d95650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007fc2d8f4f286 in QEventDispatcherGlib::processEvents (this=0xa881d0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fc2d8f238d2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fc2d8f23ae5 in QEventLoop::exec (this=0x7fc2bcff8d70, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fc2d8e387a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007fc2c8e8a40b in ?? () from /usr/lib64/libsopranoserver.so.1
#8  0x00007fc2d8e3b095 in QThreadPrivate::start (arg=0x7fc2c0008780) at thread/qthread_unix.cpp:320
#9  0x00007fc2d8baaa3f in start_thread () from /lib64/libpthread.so.0
#10 0x00007fc2d693e67d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fc2c4947700 (LWP 12847)):
#0  0x00007fc2d6935503 in poll () from /lib64/libc.so.6
#1  0x00007fc2d5d95114 in ?? () from /lib64/libglib-2.0.so.0
#2  0x00007fc2d5d95650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#3  0x00007fc2d8f4f286 in QEventDispatcherGlib::processEvents (this=0xa7be40, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007fc2d8f238d2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fc2d8f23ae5 in QEventLoop::exec (this=0x7fc2c4946d70, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007fc2d8e387a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007fc2c8e8a40b in ?? () from /usr/lib64/libsopranoserver.so.1
#8  0x00007fc2d8e3b095 in QThreadPrivate::start (arg=0x7fc2c0009a80) at thread/qthread_unix.cpp:320
#9  0x00007fc2d8baaa3f in start_thread () from /lib64/libpthread.so.0
#10 0x00007fc2d693e67d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fc2b77fe700 (LWP 12852)):
#0  0xffffffffff600108 in ?? ()
#1  0x00007fff3dbff7a1 in ?? ()
#2  0x00007fc2d60452b3 in clock_gettime () from /lib64/librt.so.1
#3  0x00007fc2d8e8c8d2 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#5  0x00007fc2d8f4fc4d in QTimerInfoList::updateCurrentTime (this=0x8c6120) at kernel/qeventdispatcher_unix.cpp:339
#6  0x00007fc2d8f4ffc5 in QTimerInfoList::timerWait (this=0x8c6120, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#7  0x00007fc2d8f4ea8c in timerSourcePrepareHelper (src=<value optimized out>, timeout=0x7fc2b77fdbdc) at kernel/qeventdispatcher_glib.cpp:136
#8  0x00007fc2d8f4eb35 in timerSourcePrepare (source=<value optimized out>, timeout=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#9  0x00007fc2d5d94087 in g_main_context_prepare () from /lib64/libglib-2.0.so.0
#10 0x00007fc2d5d94fa9 in ?? () from /lib64/libglib-2.0.so.0
#11 0x00007fc2d5d95650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#12 0x00007fc2d8f4f286 in QEventDispatcherGlib::processEvents (this=0x8ce4b0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#13 0x00007fc2d8f238d2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#14 0x00007fc2d8f23ae5 in QEventLoop::exec (this=0x7fc2b77fdd70, flags=...) at kernel/qeventloop.cpp:201
#15 0x00007fc2d8e387a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#16 0x00007fc2c8e8a40b in ?? () from /usr/lib64/libsopranoserver.so.1
#17 0x00007fc2d8e3b095 in QThreadPrivate::start (arg=0x7fc2c0005f20) at thread/qthread_unix.cpp:320
#18 0x00007fc2d8baaa3f in start_thread () from /lib64/libpthread.so.0
#19 0x00007fc2d693e67d in clone () from /lib64/libc.so.6
#20 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fc2b67fc700 (LWP 14619)):
#0  0x00007fc2d8bad0a4 in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00007fc2d5d940b6 in g_main_context_prepare () from /lib64/libglib-2.0.so.0
#2  0x00007fc2d5d94fa9 in ?? () from /lib64/libglib-2.0.so.0
#3  0x00007fc2d5d95650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#4  0x00007fc2d8f4f286 in QEventDispatcherGlib::processEvents (this=0xa855a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fc2d8f238d2 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fc2d8f23ae5 in QEventLoop::exec (this=0x7fc2b67fbd70, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007fc2d8e387a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#8  0x00007fc2c8e8a40b in ?? () from /usr/lib64/libsopranoserver.so.1
#9  0x00007fc2d8e3b095 in QThreadPrivate::start (arg=0x7fc2c0007570) at thread/qthread_unix.cpp:320
#10 0x00007fc2d8baaa3f in start_thread () from /lib64/libpthread.so.0
#11 0x00007fc2d693e67d in clone () from /lib64/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fc2d942a760 (LWP 4933)):
#0  0x00007fc2d8baf38c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fc2d8e3b77b in wait (this=<value optimized out>, mutex=0x7fc2c0004ff0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x7fc2c0004ff0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007fc2d8e3a810 in QThread::wait (this=<value optimized out>, time=18446744073709551615) at thread/qthread_unix.cpp:722
#4  0x00007fc2c8e8a13c in ?? () from /usr/lib64/libsopranoserver.so.1
#5  0x00007fc2c8e912b3 in ?? () from /usr/lib64/libsopranoserver.so.1
#6  0x00007fc2c8e84cfe in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib64/libsopranoserver.so.1
#7  0x00007fc2c90b7945 in ?? () from /usr/lib64/kde4/nepomukstorage.so
#8  0x00007fc2c90b79c9 in ?? () from /usr/lib64/kde4/nepomukstorage.so
#9  0x00007fc2d8f36a34 in QObjectPrivate::deleteChildren (this=0x76fbc0) at kernel/qobject.cpp:1955
#10 0x00007fc2d8f3b782 in QObject::~QObject (this=0x799b80, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#11 0x00007fc2c90b6c03 in ?? () from /usr/lib64/kde4/nepomukstorage.so
#12 0x00007fc2d8f36a34 in QObjectPrivate::deleteChildren (this=0x6eb6b0) at kernel/qobject.cpp:1955
#13 0x00007fc2d8f3b782 in QObject::~QObject (this=0x6e9910, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#14 0x0000000000404749 in _start ()

This bug may be a duplicate of or related to bug 257176.

Possible duplicates by query: bug 257176, bug 254140.

Reported using DrKonqi
Comment 1 Stewart Watkiss 2011-06-16 08:45:17 UTC
Created attachment 61045 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed:

I often get this message when shutting down using the KDE shutdown button from the start menu. On this occassion I had only had the computer on for a short time during which I used Dolphin and GIMP.

-- Backtrace (Reduced):
#6  end (context=0x7fc6301bb240 "QNativeSocketEngine", sourceText=0x7fc6301b1658 "The remote host closed the connection", disambiguation=0x0, encoding=QCoreApplication::CodecForTr, n=-1) at ../../include/QtCore/../../src/corelib/tools/qlist.h:98
#7  constEnd (context=0x7fc6301bb240 "QNativeSocketEngine", sourceText=0x7fc6301b1658 "The remote host closed the connection", disambiguation=0x0, encoding=QCoreApplication::CodecForTr, n=-1) at ../../include/QtCore/../../src/corelib/tools/qlist.h:259
#8  QCoreApplication::translate (context=0x7fc6301bb240 "QNativeSocketEngine", sourceText=0x7fc6301b1658 "The remote host closed the connection", disambiguation=0x0, encoding=QCoreApplication::CodecForTr, n=-1) at kernel/qcoreapplication.cpp:1765
#9  0x00007fc633f4fedf in QCoreApplication::translate (context=<value optimized out>, sourceText=<value optimized out>, disambiguation=<value optimized out>, encoding=<value optimized out>) at kernel/qcoreapplication.cpp:1682
[...]
#11 0x00007fc63016789d in tr (this=0x1275ff0, error=<value optimized out>, errorString=<value optimized out>) at socket/qnativesocketengine_p.h:107
Comment 2 mercatino13 2011-07-04 22:22:51 UTC
Created attachment 61612 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed:

I was closing the system when nepomuka crashed

-- Backtrace (Reduced):
#7  end (context=0x61bb720 "QLocalSocket", sourceText=0x61bbccf "%1: Remote closed", disambiguation=0x0, encoding=QCoreApplication::CodecForTr, n=-1) at ../../include/QtCore/../../src/corelib/tools/qlist.h:98
#8  constEnd (context=0x61bb720 "QLocalSocket", sourceText=0x61bbccf "%1: Remote closed", disambiguation=0x0, encoding=QCoreApplication::CodecForTr, n=-1) at ../../include/QtCore/../../src/corelib/tools/qlist.h:259
#9  QCoreApplication::translate (context=0x61bb720 "QLocalSocket", sourceText=0x61bbccf "%1: Remote closed", disambiguation=0x0, encoding=QCoreApplication::CodecForTr, n=-1) at kernel/qcoreapplication.cpp:1765
#10 0x00265c06 in QCoreApplication::translate (context=0x61bb720 "QLocalSocket", sourceText=0x61bbccf "%1: Remote closed", disambiguation=0x0, encoding=QCoreApplication::CodecForTr) at kernel/qcoreapplication.cpp:1682
[...]
#12 0x06185a95 in tr (this=0x8f2ac90, error=QLocalSocket::PeerClosedError, function=...) at socket/qlocalsocket.h:60
Comment 3 Dmitriy 2011-08-03 18:12:24 UTC
Created attachment 62514 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.6.5 (4.6.5) using Qt 4.7.3

Shuting down computer using shutdown button in KDE. It happens rather often, but not always.

-- Backtrace (Reduced):
#6  end (context=0x7f62addca8a0 "QNativeSocketEngine", sourceText=0x7f62addc0cb8 "The remote host closed the connection", disambiguation=0x0, encoding=QCoreApplication::CodecForTr, n=-1) at ../../include/QtCore/../../src/corelib/tools/qlist.h:98
#7  constEnd (context=0x7f62addca8a0 "QNativeSocketEngine", sourceText=0x7f62addc0cb8 "The remote host closed the connection", disambiguation=0x0, encoding=QCoreApplication::CodecForTr, n=-1) at ../../include/QtCore/../../src/corelib/tools/qlist.h:259
#8  QCoreApplication::translate (context=0x7f62addca8a0 "QNativeSocketEngine", sourceText=0x7f62addc0cb8 "The remote host closed the connection", disambiguation=0x0, encoding=QCoreApplication::CodecForTr, n=-1) at kernel/qcoreapplication.cpp:1765
#9  0x00007f62b1be49ef in QCoreApplication::translate (context=<value optimized out>, sourceText=<value optimized out>, disambiguation=<value optimized out>, encoding=<value optimized out>) at kernel/qcoreapplication.cpp:1682
[...]
#11 0x00007f62add75728 in tr (this=0xf46580, error=<value optimized out>, errorString=<value optimized out>) at socket/qnativesocketengine_p.h:107
Comment 4 Sebastián Ramírez 2011-10-05 01:36:29 UTC
Created attachment 64221 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.6.5 (4.6.5) using Qt 4.7.2

- What I was doing when the application crashed:

I click on the suthdown button.
Clickee en el botón de apagar.

-- Backtrace (Reduced):
#7  end (context=0xbb1ae0 "QLocalSocket", sourceText=0xbb208f "%1: Remote closed", disambiguation=0x0, encoding=QCoreApplication::CodecForTr, n=-1) at ../../include/QtCore/../../src/corelib/tools/qlist.h:98
#8  constEnd (context=0xbb1ae0 "QLocalSocket", sourceText=0xbb208f "%1: Remote closed", disambiguation=0x0, encoding=QCoreApplication::CodecForTr, n=-1) at ../../include/QtCore/../../src/corelib/tools/qlist.h:259
#9  QCoreApplication::translate (context=0xbb1ae0 "QLocalSocket", sourceText=0xbb208f "%1: Remote closed", disambiguation=0x0, encoding=QCoreApplication::CodecForTr, n=-1) at kernel/qcoreapplication.cpp:1765
#10 0x00983c06 in QCoreApplication::translate (context=0xbb1ae0 "QLocalSocket", sourceText=0xbb208f "%1: Remote closed", disambiguation=0x0, encoding=QCoreApplication::CodecForTr) at kernel/qcoreapplication.cpp:1682
[...]
#12 0x00b7bbe5 in tr (this=0x91766f0, error=QLocalSocket::PeerClosedError, function=...) at socket/qlocalsocket.h:60
Comment 5 svex87 2011-10-11 21:29:43 UTC
Created attachment 64441 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.7.2 (4.7.2) "release 9" using Qt 4.7.4

- What I was doing when the application crashed:

Shutting down the system, no programs were opened

-- Backtrace (Reduced):
#6  end (context=0x7f1f76553300 "QLocalSocket", sourceText=0x7f1f765538bb "%1: Remote closed", disambiguation=0x0, encoding=QCoreApplication::CodecForTr, n=-1) at ../../src/corelib/tools/qlist.h:98
#7  constEnd (context=0x7f1f76553300 "QLocalSocket", sourceText=0x7f1f765538bb "%1: Remote closed", disambiguation=0x0, encoding=QCoreApplication::CodecForTr, n=-1) at ../../src/corelib/tools/qlist.h:259
#8  QCoreApplication::translate (context=0x7f1f76553300 "QLocalSocket", sourceText=0x7f1f765538bb "%1: Remote closed", disambiguation=0x0, encoding=QCoreApplication::CodecForTr, n=-1) at kernel/qcoreapplication.cpp:1821
#9  0x00007f1f7a2cc22f in QCoreApplication::translate (context=<value optimized out>, sourceText=<value optimized out>, disambiguation=<value optimized out>, encoding=<value optimized out>) at kernel/qcoreapplication.cpp:1738
[...]
#11 0x00007f1f76520852 in tr (this=<value optimized out>, error=<value optimized out>, function=...) at socket/qlocalsocket.h:60
Comment 6 Sebastian Trueg 2011-10-12 08:18:56 UTC

*** This bug has been marked as a duplicate of bug 257176 ***