Bug 279622 - crash shutdown kde
Summary: crash shutdown kde
Status: RESOLVED DUPLICATE of bug 257372
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-07 23:42 UTC by Kris85
Modified: 2011-09-19 12:14 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kris85 2011-08-07 23:42:48 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-10-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
Erreur à la fermeture de kde

The crash can be reproduced some of the time.

-- Backtrace:
Application: Jeton du service Nepomuk (nepomukservicestub), signal: Segmentation fault
pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
	in ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S
[Current thread is 1 (Thread 0x7ff08eeba780 (LWP 1840))]

Thread 8 (Thread 0x7ff0737fe700 (LWP 1919)):
[KCrash Handler]
#6  end (context=0x7ff08ac02f40 "QLocalSocket", sourceText=0x7ff08ac034fb "%1: Remote closed", disambiguation=0x0, encoding=QCoreApplication::CodecForTr, n=-1) at ../../include/QtCore/../../src/corelib/tools/qlist.h:98
#7  constEnd (context=0x7ff08ac02f40 "QLocalSocket", sourceText=0x7ff08ac034fb "%1: Remote closed", disambiguation=0x0, encoding=QCoreApplication::CodecForTr, n=-1) at ../../include/QtCore/../../src/corelib/tools/qlist.h:259
#8  QCoreApplication::translate (context=0x7ff08ac02f40 "QLocalSocket", sourceText=0x7ff08ac034fb "%1: Remote closed", disambiguation=0x0, encoding=QCoreApplication::CodecForTr, n=-1) at kernel/qcoreapplication.cpp:1765
#9  0x00007ff08e9a2edf in QCoreApplication::translate (context=<value optimized out>, sourceText=<value optimized out>, disambiguation=<value optimized out>, encoding=<value optimized out>) at kernel/qcoreapplication.cpp:1682
#10 0x00007ff08e9a82d0 in QMetaObject::tr (this=<value optimized out>, s=<value optimized out>, c=<value optimized out>) at kernel/qmetaobject.cpp:281
#11 0x00007ff08abd01a7 in tr (this=<value optimized out>, error=<value optimized out>, function=...) at socket/qlocalsocket.h:60
#12 QLocalSocketPrivate::generateErrorString (this=<value optimized out>, error=<value optimized out>, function=...) at socket/qlocalsocket_unix.cpp:142
#13 0x00007ff08abd0914 in QLocalSocketPrivate::_q_error (this=<value optimized out>, socketError=QAbstractSocket::RemoteHostClosedError) at socket/qlocalsocket_unix.cpp:100
#14 0x00007ff08abcd2dc in QLocalSocket::qt_metacall (this=0x263ad80, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ff0737fd5e0) at .moc/release-shared/moc_qlocalsocket.cpp:91
#15 0x00007ff08e9b75f8 in QMetaObject::activate (sender=0x27c86f0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x7ff0737fd5e0) at kernel/qobject.cpp:3287
#16 0x00007ff08abc5651 in QAbstractSocket::error (this=<value optimized out>, _t1=QAbstractSocket::RemoteHostClosedError) at .moc/release-shared/moc_qabstractsocket.cpp:156
#17 0x00007ff08abc86d9 in QAbstractSocketPrivate::readFromSocket (this=0x26013f0) at socket/qabstractsocket.cpp:1174
#18 0x00007ff08abc89e3 in QAbstractSocketPrivate::canReadNotification (this=0x26013f0) at socket/qabstractsocket.cpp:614
#19 0x00007ff08abb6581 in QReadNotifier::event (this=<value optimized out>, e=<value optimized out>) at socket/qnativesocketengine.cpp:1103
#20 0x00007ff08ccee9f4 in QApplicationPrivate::notify_helper (this=0x237bef0, receiver=0x25f2240, e=0x7ff0737fdb50) at kernel/qapplication.cpp:4462
#21 0x00007ff08ccf33ba in QApplication::notify (this=<value optimized out>, receiver=0x25f2240, e=0x7ff0737fdb50) at kernel/qapplication.cpp:4341
#22 0x00007ff08e9a249c in QCoreApplication::notifyInternal (this=0x7fff098c6350, receiver=0x25f2240, event=0x7ff0737fdb50) at kernel/qcoreapplication.cpp:731
#23 0x00007ff08e9ccda9 in sendEvent (source=0x2648690) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#24 socketNotifierSourceDispatch (source=0x2648690) at kernel/qeventdispatcher_glib.cpp:110
#25 0x00007ff08b7a7bcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007ff08b7a83a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007ff08b7a8639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007ff08e9cd3ef in QEventDispatcherGlib::processEvents (this=0x2649fc0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#29 0x00007ff08e9a1882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#30 0x00007ff08e9a1abc in QEventLoop::exec (this=0x7ff0737fdd50, flags=...) at kernel/qeventloop.cpp:201
#31 0x00007ff08e8b8924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#32 0x00007ff07e308641 in ?? () from /usr/lib/libsopranoserver.so.1
#33 0x00007ff08e8bb175 in QThreadPrivate::start (arg=0x7ff06c017600) at thread/qthread_unix.cpp:320
#34 0x00007ff08c283d8c in start_thread (arg=0x7ff0737fe700) at pthread_create.c:304
#35 0x00007ff08c58104d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#36 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7ff072ffd700 (LWP 1923)):
#0  0x00007ff08c2863c4 in __pthread_mutex_lock (mutex=0x25efdc8) at pthread_mutex_lock.c:61
#1  0x00007ff08b7a81e4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff08b7a8639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff08e9cd446 in QEventDispatcherGlib::processEvents (this=0x261dcf0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007ff08e9a1882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff08e9a1abc in QEventLoop::exec (this=0x7ff072ffcd50, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007ff08e8b8924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007ff07e308641 in ?? () from /usr/lib/libsopranoserver.so.1
#8  0x00007ff08e8bb175 in QThreadPrivate::start (arg=0x7ff06c003e10) at thread/qthread_unix.cpp:320
#9  0x00007ff08c283d8c in start_thread (arg=0x7ff072ffd700) at pthread_create.c:304
#10 0x00007ff08c58104d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7ff0727fc700 (LWP 1925)):
#0  0x00007ff08c573f03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007ff08b7a8104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff08b7a8639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff08e9cd446 in QEventDispatcherGlib::processEvents (this=0x27e4090, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007ff08e9a1882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff08e9a1abc in QEventLoop::exec (this=0x7ff0727fbd50, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007ff08e8b8924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007ff07e308641 in ?? () from /usr/lib/libsopranoserver.so.1
#8  0x00007ff08e8bb175 in QThreadPrivate::start (arg=0x7ff06c0169a0) at thread/qthread_unix.cpp:320
#9  0x00007ff08c283d8c in start_thread (arg=0x7ff0727fc700) at pthread_create.c:304
#10 0x00007ff08c58104d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7ff071ffb700 (LWP 1930)):
#0  0x00007ff08bc5d370 in pthread_getspecific@plt () from /usr/lib/x86_64-linux-gnu/libgthread-2.0.so.0
#1  0x00007ff08b7d05e9 in g_thread_self () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff08b7a8629 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff08e9cd446 in QEventDispatcherGlib::processEvents (this=0x2655980, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007ff08e9a1882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff08e9a1abc in QEventLoop::exec (this=0x7ff071ffad50, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007ff08e8b8924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007ff07e308641 in ?? () from /usr/lib/libsopranoserver.so.1
#8  0x00007ff08e8bb175 in QThreadPrivate::start (arg=0x7ff06c003e60) at thread/qthread_unix.cpp:320
#9  0x00007ff08c283d8c in start_thread (arg=0x7ff071ffb700) at pthread_create.c:304
#10 0x00007ff08c58104d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7ff0717fa700 (LWP 2073)):
#0  __pthread_getspecific (key=<value optimized out>) at pthread_getspecific.c:67
#1  0x00007ff08e8bb241 in get_thread_data () at thread/qthread_unix.cpp:161
#2  QThreadData::current () at thread/qthread_unix.cpp:199
#3  0x00007ff08e9cce99 in postEventSourcePrepare (s=0x25dc5d0, timeout=0x7ff0717f9bcc) at kernel/qeventdispatcher_glib.cpp:254
#4  0x00007ff08b7a70a2 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007ff08b7a7f9d in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007ff08b7a8639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007ff08e9cd446 in QEventDispatcherGlib::processEvents (this=0x266df90, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#8  0x00007ff08e9a1882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#9  0x00007ff08e9a1abc in QEventLoop::exec (this=0x7ff0717f9d50, flags=...) at kernel/qeventloop.cpp:201
#10 0x00007ff08e8b8924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#11 0x00007ff07e308641 in ?? () from /usr/lib/libsopranoserver.so.1
#12 0x00007ff08e8bb175 in QThreadPrivate::start (arg=0x7ff06c004100) at thread/qthread_unix.cpp:320
#13 0x00007ff08c283d8c in start_thread (arg=0x7ff0717fa700) at pthread_create.c:304
#14 0x00007ff08c58104d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#15 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7ff06affd700 (LWP 2089)):
#0  0x00007ff08c573f03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007ff08b7a8104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff08b7a8639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff08e9cd446 in QEventDispatcherGlib::processEvents (this=0x2646320, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007ff08e9a1882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff08e9a1abc in QEventLoop::exec (this=0x7ff06affcd50, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007ff08e8b8924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007ff07e308641 in ?? () from /usr/lib/libsopranoserver.so.1
#8  0x00007ff08e8bb175 in QThreadPrivate::start (arg=0x7ff06c0195d0) at thread/qthread_unix.cpp:320
#9  0x00007ff08c283d8c in start_thread (arg=0x7ff06affd700) at pthread_create.c:304
#10 0x00007ff08c58104d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7ff0697fa700 (LWP 2250)):
#0  0x00007ff08c2863c4 in __pthread_mutex_lock (mutex=0x2660058) at pthread_mutex_lock.c:61
#1  0x00007ff08b7a8624 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff08e9cd446 in QEventDispatcherGlib::processEvents (this=0x2621de0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#3  0x00007ff08e9a1882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#4  0x00007ff08e9a1abc in QEventLoop::exec (this=0x7ff0697f9d50, flags=...) at kernel/qeventloop.cpp:201
#5  0x00007ff08e8b8924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#6  0x00007ff07e308641 in ?? () from /usr/lib/libsopranoserver.so.1
#7  0x00007ff08e8bb175 in QThreadPrivate::start (arg=0x7ff074000ef0) at thread/qthread_unix.cpp:320
#8  0x00007ff08c283d8c in start_thread (arg=0x7ff0697fa700) at pthread_create.c:304
#9  0x00007ff08c58104d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ff08eeba780 (LWP 1840)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007ff08e8bb82b in wait (this=<value optimized out>, mutex=0x7ff06c017bc0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x7ff06c017bc0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007ff08e8ba910 in QThread::wait (this=<value optimized out>, time=18446744073709551615) at thread/qthread_unix.cpp:722
#4  0x00007ff07e307c48 in ?? () from /usr/lib/libsopranoserver.so.1
#5  0x00007ff07e30de93 in ?? () from /usr/lib/libsopranoserver.so.1
#6  0x00007ff07e304556 in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#7  0x00007ff07e559ecb in Nepomuk::Core::~Core (this=0x24a6d60, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:45
#8  0x00007ff07e559f49 in Nepomuk::Core::~Core (this=0x24a6d60, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:48
#9  0x00007ff08e9b4c14 in QObjectPrivate::deleteChildren (this=0x24a6580) at kernel/qobject.cpp:1964
#10 0x00007ff08e9b95f4 in QObject::~QObject (this=0x24a5720, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#11 0x00007ff07e559173 in ~Storage (this=<value optimized out>, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/storage.cpp:50
#12 Nepomuk::Storage::~Storage (this=<value optimized out>, __in_chrg=<value optimized out>) at ../../../../nepomuk/services/storage/storage.cpp:52
#13 0x00007ff08e9b4c14 in QObjectPrivate::deleteChildren (this=0x24d62e0) at kernel/qobject.cpp:1964
#14 0x00007ff08e9b95f4 in QObject::~QObject (this=0x24d5f00, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#15 0x00000000004043e9 in Nepomuk::ServiceControl::~ServiceControl (this=0x24d5f00, __in_chrg=<value optimized out>) at ../../../nepomuk/servicestub/servicecontrol.cpp:39
#16 0x00007ff08e9b4c14 in QObjectPrivate::deleteChildren (this=0x237bef0) at kernel/qobject.cpp:1964
#17 0x00007ff08e9b95f4 in QObject::~QObject (this=0x7fff098c6350, __in_chrg=<value optimized out>) at kernel/qobject.cpp:946
#18 0x00007ff08ccf8122 in QApplication::~QApplication (this=0x7fff098c6350, __in_chrg=<value optimized out>) at kernel/qapplication.cpp:1080
#19 0x0000000000403cd1 in main (argc=2, argv=<value optimized out>) at ../../../nepomuk/servicestub/main.cpp:101

This bug may be a duplicate of or related to bug 254140.

Possible duplicates by query: bug 273675, bug 257176, bug 254140.

Reported using DrKonqi
Comment 1 Sebastian Trueg 2011-09-19 12:14:45 UTC

*** This bug has been marked as a duplicate of bug 257372 ***