Bug 295021 - Crash on shutdown
Summary: Crash on shutdown
Status: RESOLVED DUPLICATE of bug 292950
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-28 20:19 UTC by nakki
Modified: 2012-05-26 02:08 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (19.08 KB, text/plain)
2012-03-21 15:49 UTC, Lans
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nakki 2012-02-28 20:19:39 UTC
Application: nepomukservicestub (0.2)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

I surfed on the web a bit, then i closed chromium and i pushed the shutdown button, but a bug segnalation appeared to me.
In this moment I'm writing on that segnalation with no desktop (only black screen + bug window).

-- Backtrace:
Application: Programma stub per servizio di Nepomuk (nepomukservicestub), signal: Segmentation fault
pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
	in ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S
[Current thread is 1 (Thread 0x7f72a457a780 (LWP 1729))]

Thread 6 (Thread 0x7f728ee34700 (LWP 1883)):
#0  0x00007f72a18df034 in __pthread_mutex_lock (mutex=0x1862138) at pthread_mutex_lock.c:61
#1  0x00007f72a0dfa361 in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f72a0dfae6a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f72a0dfb429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f72a4086f3e in QEventDispatcherGlib::processEvents (this=0x1860610, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f72a405acf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f72a405aef7 in QEventLoop::exec (this=0x7f728ee33dd0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f72a3f7227f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#8  0x00007f72a403dcbf in QInotifyFileSystemWatcherEngine::run (this=0x18aeb90) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f72a3f74d05 in QThreadPrivate::start (arg=0x18aeb90) at thread/qthread_unix.cpp:331
#10 0x00007f72a18dcefc in start_thread (arg=0x7f728ee34700) at pthread_create.c:304
#11 0x00007f72a1bd389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f7287fff700 (LWP 2011)):
[KCrash Handler]
#6  end (this=) at ../../include/QtCore/../../src/corelib/tools/qlist.h:98
#7  constEnd (this=) at ../../include/QtCore/../../src/corelib/tools/qlist.h:259
#8  QCoreApplication::translate (context=0x7f72a02549c0 "QLocalSocket", sourceText=0x7f72a0254f7b "%1: Remote closed", disambiguation=0x0, encoding=QCoreApplication::CodecForTr, n=-1) at kernel/qcoreapplication.cpp:1821
#9  0x00007f72a405c52f in QCoreApplication::translate (context=<optimized out>, sourceText=<optimized out>, disambiguation=<optimized out>, encoding=<optimized out>) at kernel/qcoreapplication.cpp:1738
#10 0x00007f72a4061cb0 in QMetaObject::tr (this=<optimized out>, s=<optimized out>, c=<optimized out>) at kernel/qmetaobject.cpp:281
#11 0x00007f72a022089c in tr (s=0x7f72a0254f7b "%1: Remote closed", c=<optimized out>) at socket/qlocalsocket.h:60
#12 QLocalSocketPrivate::generateErrorString (this=<optimized out>, error=<optimized out>, function=...) at socket/qlocalsocket_unix.cpp:142
#13 0x00007f72a0221013 in QLocalSocketPrivate::_q_error (this=<optimized out>, socketError=QAbstractSocket::RemoteHostClosedError) at socket/qlocalsocket_unix.cpp:100
#14 0x00007f72a021d99c in QLocalSocket::qt_metacall (this=0x18caf50, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7f7287ffe740) at .moc/release-shared/moc_qlocalsocket.cpp:91
#15 0x00007f72a406eeba in QMetaObject::activate (sender=0x18d82d0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7f7287ffe740) at kernel/qobject.cpp:3278
#16 0x00007f72a0215681 in QAbstractSocket::error (this=<optimized out>, _t1=QAbstractSocket::RemoteHostClosedError) at .moc/release-shared/moc_qabstractsocket.cpp:156
#17 0x00007f72a0217431 in QAbstractSocketPrivate::readFromSocket (this=0x186c4c0) at socket/qabstractsocket.cpp:1178
#18 0x00007f72a0217763 in QAbstractSocketPrivate::canReadNotification (this=0x186c4c0) at socket/qabstractsocket.cpp:618
#19 0x00007f72a0206551 in event (this=<optimized out>, e=<optimized out>) at socket/qnativesocketengine.cpp:1103
#20 QReadNotifier::event (this=<optimized out>, e=<optimized out>) at socket/qnativesocketengine.cpp:1100
#21 0x00007f72a2394474 in notify_helper (e=0x7f7287ffeb50, receiver=0x18c3740, this=0x1619570) at kernel/qapplication.cpp:4486
#22 QApplicationPrivate::notify_helper (this=0x1619570, receiver=0x18c3740, e=0x7f7287ffeb50) at kernel/qapplication.cpp:4458
#23 0x00007f72a23992e1 in QApplication::notify (this=0x7fff28bb4700, receiver=0x18c3740, e=0x7f7287ffeb50) at kernel/qapplication.cpp:4365
#24 0x00007f72a3375466 in KApplication::notify (this=0x7fff28bb4700, receiver=0x18c3740, event=0x7f7287ffeb50) at ../../kdeui/kernel/kapplication.cpp:311
#25 0x00007f72a405bafc in QCoreApplication::notifyInternal (this=0x7fff28bb4700, receiver=0x18c3740, event=0x7f7287ffeb50) at kernel/qcoreapplication.cpp:787
#26 0x00007f72a40865b7 in sendEvent (event=0x7f7287ffeb50, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#27 socketNotifierSourceDispatch (source=0x18645e0) at kernel/qeventdispatcher_glib.cpp:110
#28 0x00007f72a0dfaa5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f72a0dfb258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f72a0dfb429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f72a4086ed6 in QEventDispatcherGlib::processEvents (this=0x1854660, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#32 0x00007f72a405acf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#33 0x00007f72a405aef7 in QEventLoop::exec (this=0x7f7287ffed60, flags=...) at kernel/qeventloop.cpp:201
#34 0x00007f72a3f7227f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#35 0x00007f7294fab0ae in ?? () from /usr/lib/libsopranoserver.so.1
#36 0x00007f72a3f74d05 in QThreadPrivate::start (arg=0x1c35fe0) at thread/qthread_unix.cpp:331
#37 0x00007f72a18dcefc in start_thread (arg=0x7f7287fff700) at pthread_create.c:304
#38 0x00007f72a1bd389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#39 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f72877fe700 (LWP 2012)):
#0  0x00007f72a18e01fd in __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x18c5198) at pthread_mutex_unlock.c:290
#2  0x00007f72a0df9fe4 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f72a0dfadfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f72a0dfb429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f72a4086f3e in QEventDispatcherGlib::processEvents (this=0x185fd00, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00007f72a405acf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f72a405aef7 in QEventLoop::exec (this=0x7f72877fdd60, flags=...) at kernel/qeventloop.cpp:201
#8  0x00007f72a3f7227f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#9  0x00007f7294fab0ae in ?? () from /usr/lib/libsopranoserver.so.1
#10 0x00007f72a3f74d05 in QThreadPrivate::start (arg=0x18903b0) at thread/qthread_unix.cpp:331
#11 0x00007f72a18dcefc in start_thread (arg=0x7f72877fe700) at pthread_create.c:304
#12 0x00007f72a1bd389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f72867fc700 (LWP 2015)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f72867fba80 in ?? ()
#2  0x00007fff28bff7e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 2 (Thread 0x7f7285ffb700 (LWP 2017)):
#0  0x00007f72a40876ed in QTimerInfoList::updateCurrentTime (this=0x18abb10) at kernel/qeventdispatcher_unix.cpp:339
#1  0x00007f72a4087a33 in QTimerInfoList::timerWait (this=0x18abb10, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#2  0x00007f72a408644c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f7285ffabcc) at kernel/qeventdispatcher_glib.cpp:136
#3  0x00007f72a40864f5 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#4  0x00007f72a0df9ff2 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f72a0dfadfd in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f72a0dfb429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007f72a4086f3e in QEventDispatcherGlib::processEvents (this=0x1c7c8f0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#8  0x00007f72a405acf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#9  0x00007f72a405aef7 in QEventLoop::exec (this=0x7f7285ffad60, flags=...) at kernel/qeventloop.cpp:201
#10 0x00007f72a3f7227f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#11 0x00007f7294fab0ae in ?? () from /usr/lib/libsopranoserver.so.1
#12 0x00007f72a3f74d05 in QThreadPrivate::start (arg=0x7f728819e420) at thread/qthread_unix.cpp:331
#13 0x00007f72a18dcefc in start_thread (arg=0x7f7285ffb700) at pthread_create.c:304
#14 0x00007f72a1bd389d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#15 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f72a457a780 (LWP 1729)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f72a3f751ab in wait (time=18446744073709551615, this=0x185a5d0) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x18c0f40, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f72a3f74a4c in QThread::wait (this=<optimized out>, time=18446744073709551615) at thread/qthread_unix.cpp:745
#4  0x00007f7294faa628 in ?? () from /usr/lib/libsopranoserver.so.1
#5  0x00007f7294fb0c43 in ?? () from /usr/lib/libsopranoserver.so.1
#6  0x00007f7294fa6e7e in Soprano::Server::ServerCore::~ServerCore() () from /usr/lib/libsopranoserver.so.1
#7  0x00007f72951dec8c in Nepomuk::Core::~Core (this=0x17ac630, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:46
#8  0x00007f72951ded39 in Nepomuk::Core::~Core (this=0x17ac630, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/nepomukcore.cpp:49
#9  0x00007f72a406dd75 in QObjectPrivate::deleteChildren (this=0x17ac6f0) at kernel/qobject.cpp:1955
#10 0x00007f72a4073349 in QObject::~QObject (this=0x17b0010, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#11 0x00007f72951ddef3 in ~Storage (this=0x17b0010, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/storage.cpp:54
#12 Nepomuk::Storage::~Storage (this=0x17b0010, __in_chrg=<optimized out>) at ../../../../nepomuk/services/storage/storage.cpp:56
#13 0x00007f72a406dd75 in QObjectPrivate::deleteChildren (this=0x178c600) at kernel/qobject.cpp:1955
#14 0x00007f72a4073349 in QObject::~QObject (this=0x178a7b0, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#15 0x0000000000404439 in Nepomuk::ServiceControl::~ServiceControl (this=0x178a7b0, __in_chrg=<optimized out>) at ../../../nepomuk/servicestub/servicecontrol.cpp:39
#16 0x00007f72a406dd75 in QObjectPrivate::deleteChildren (this=0x1619570) at kernel/qobject.cpp:1955
#17 0x00007f72a4073349 in QObject::~QObject (this=0x7fff28bb4700, __in_chrg=<optimized out>) at kernel/qobject.cpp:946
#18 0x00007f72a239dfd7 in QApplication::~QApplication (this=0x7fff28bb4700, __in_chrg=<optimized out>) at kernel/qapplication.cpp:1093
#19 0x0000000000403a54 in main (argc=2, argv=0x7fff28bb4ba8) at ../../../nepomuk/servicestub/main.cpp:105

This bug may be a duplicate of or related to bug 285259.

Possible duplicates by query: bug 286059, bug 285259, bug 279622, bug 273675.

Reported using DrKonqi
Comment 1 Lans 2012-03-21 15:49:42 UTC
Created attachment 69789 [details]
New crash information added by DrKonqi

nepomukservicestub (0.2) on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:

I just try shutdown my system. Then error screen appears

-- Backtrace (Reduced):
#6  end (this=) at ../../include/QtCore/../../src/corelib/tools/qlist.h:98
#7  constEnd (this=) at ../../include/QtCore/../../src/corelib/tools/qlist.h:259
#8  QCoreApplication::translate (context=0x7ff8bc2689c0 "QLocalSocket", sourceText=0x7ff8bc268f7b "%1: Remote closed", disambiguation=0x0, encoding=QCoreApplication::CodecForTr, n=-1) at kernel/qcoreapplication.cpp:1821
#9  0x00007ff8c007252f in QCoreApplication::translate (context=<optimized out>, sourceText=<optimized out>, disambiguation=<optimized out>, encoding=<optimized out>) at kernel/qcoreapplication.cpp:1738
[...]
#11 0x00007ff8bc23489c in tr (s=0x7ff8bc268f7b "%1: Remote closed", c=<optimized out>) at socket/qlocalsocket.h:60
Comment 2 Vishesh Handa 2012-05-26 02:08:52 UTC

*** This bug has been marked as a duplicate of bug 292950 ***