Bug 299446 - Kmail crashes when checking servers(email and internet)
Summary: Kmail crashes when checking servers(email and internet)
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.8.2
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-05 14:40 UTC by John
Modified: 2012-05-09 12:59 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John 2012-05-05 14:40:10 UTC
Application: kmail (4.8.2)
KDE Platform Version: 4.8.2 (4.8.2) (Compiled from sources)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed: Kmail loads emails fine. When it rechecks all servers, then it crashes.

The crash can be reproduced every time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f51528e97c0 (LWP 3019))]

Thread 4 (Thread 0x7f5130501700 (LWP 3024)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f5144be1dec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f5144be1f19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f514d713e9a in start_thread (arg=0x7f5130501700) at pthread_create.c:308
#4  0x00007f514fc444bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f512fc00700 (LWP 3025)):
#0  0x00007f51485295ac in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f51484ed89b in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f51484edf6a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f51484ee124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f51505cf426 in QEventDispatcherGlib::processEvents (this=0x7f51280008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f515059ec82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f515059eed7 in QEventLoop::exec (this=0x7f512fbffdc0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f515049dfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f51504a0fcb in QThreadPrivate::start (arg=0x22d0090) at thread/qthread_unix.cpp:298
#9  0x00007f514d713e9a in start_thread (arg=0x7f512fc00700) at pthread_create.c:308
#10 0x00007f514fc444bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f512cc20700 (LWP 3030)):
#0  0x00007f514fc38b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f51484edff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f51484ee124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f51505cf426 in QEventDispatcherGlib::processEvents (this=0x7f50dc0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f515059ec82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f515059eed7 in QEventLoop::exec (this=0x7f512cc1fd90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f515049dfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f515057e9ff in QInotifyFileSystemWatcherEngine::run (this=0x2751bd0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f51504a0fcb in QThreadPrivate::start (arg=0x2751bd0) at thread/qthread_unix.cpp:298
#9  0x00007f514d713e9a in start_thread (arg=0x7f512cc20700) at pthread_create.c:308
#10 0x00007f514fc444bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f51528e97c0 (LWP 3019)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x3628d20, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f514ec79709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x3628d20, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f51505b9446 in QObject::event (this=0x3628d20, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007f5150ac2894 in notify_helper (e=0x7f50bc00ade0, receiver=0x3628d20, this=0x1d3e820) at kernel/qapplication.cpp:4559
#10 QApplicationPrivate::notify_helper (this=0x1d3e820, receiver=0x3628d20, e=0x7f50bc00ade0) at kernel/qapplication.cpp:4531
#11 0x00007f5150ac7713 in QApplication::notify (this=0x7fff02842e80, receiver=0x3628d20, e=0x7f50bc00ade0) at kernel/qapplication.cpp:4420
#12 0x00007f51522fbb46 in KApplication::notify (this=0x7fff02842e80, receiver=0x3628d20, event=0x7f50bc00ade0) at ../../kdeui/kernel/kapplication.cpp:311
#13 0x00007f515059fe9c in QCoreApplication::notifyInternal (this=0x7fff02842e80, receiver=0x3628d20, event=0x7f50bc00ade0) at kernel/qcoreapplication.cpp:876
#14 0x00007f51505a3c6a in sendEvent (event=0x7f50bc00ade0, receiver=0x3628d20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1cf2220) at kernel/qcoreapplication.cpp:1500
#16 0x00007f51505cef93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f51484edc9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f51484ee060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f51484ee124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f51505cf3bf in QEventDispatcherGlib::processEvents (this=0x1cf3b00, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f5150b6ad5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f515059ec82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f515059eed7 in QEventLoop::exec (this=0x7fff02842d60, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f51505a3f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000402bd3 in ?? ()
#27 0x00007f514fb7376d in __libc_start_main (main=0x4021a0, argc=3, ubp_av=0x7fff028432d8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff028432c8) at libc-start.c:226
#28 0x0000000000403095 in _start ()

Possible duplicates by query: bug 299040, bug 298890, bug 298869, bug 298363, bug 298322.

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-05-09 12:59:03 UTC

*** This bug has been marked as a duplicate of bug 286307 ***