Bug 298869 - kmail segfaults
Summary: kmail segfaults
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.8.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-26 18:27 UTC by BluesKaj
Modified: 2012-04-27 06:14 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description BluesKaj 2012-04-26 18:27:46 UTC
Application: kmail (4.8.2)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
segfaults when opening email or transferring to a folder

The crash can be reproduced every time.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f79d8df37c0 (LWP 2907))]

Thread 4 (Thread 0x7f79b6d94700 (LWP 2911)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f79cb0e0dec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f79cb0e0f19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f79d3c12e9a in start_thread (arg=0x7f79b6d94700) at pthread_create.c:308
#4  0x00007f79d61434bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f79b6493700 (LWP 2912)):
#0  0x00007fff6d49d8de in ?? ()
#1  0x00007f79cda6a15d in __GI_clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:116
#2  0x00007f79d69f6bb4 in do_gettime (frac=0x7f79b6492ba8, sec=0x7f79b6492ba0) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f79d6aceb8d in QTimerInfoList::updateCurrentTime (this=0x7f79b0002860) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007f79d6aceec3 in QTimerInfoList::timerWait (this=0x7f79b0002860, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x00007f79d6acd97c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f79b6492c5c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007f79ce9ec71e in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007f79ce9ecf1b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f79ce9ed124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f79d6ace426 in QEventDispatcherGlib::processEvents (this=0x7f79b00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#11 0x00007f79d6a9dc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#12 0x00007f79d6a9ded7 in QEventLoop::exec (this=0x7f79b6492dc0, flags=...) at kernel/qeventloop.cpp:204
#13 0x00007f79d699cfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#14 0x00007f79d699ffcb in QThreadPrivate::start (arg=0xcd83b0) at thread/qthread_unix.cpp:298
#15 0x00007f79d3c12e9a in start_thread (arg=0x7f79b6493700) at pthread_create.c:308
#16 0x00007f79d61434bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#17 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f796f1d3700 (LWP 2917)):
#0  0x00007f79d6137b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f79ce9ecff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f79ce9ed124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f79d6ace426 in QEventDispatcherGlib::processEvents (this=0x7f79640008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f79d6a9dc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f79d6a9ded7 in QEventLoop::exec (this=0x7f796f1d2d90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f79d699cfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f79d6a7d9ff in QInotifyFileSystemWatcherEngine::run (this=0xed5340) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f79d699ffcb in QThreadPrivate::start (arg=0xed5340) at thread/qthread_unix.cpp:298
#9  0x00007f79d3c12e9a in start_thread (arg=0x7f796f1d3700) at pthread_create.c:308
#10 0x00007f79d61434bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f79d8df37c0 (LWP 2907)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x272af20, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f79d5178709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x272af20, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f79d6ab8446 in QObject::event (this=0x272af20, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007f79d6fc1894 in notify_helper (e=0x7f79600102c0, receiver=0x272af20, this=0x88a920) at kernel/qapplication.cpp:4559
#10 QApplicationPrivate::notify_helper (this=0x88a920, receiver=0x272af20, e=0x7f79600102c0) at kernel/qapplication.cpp:4531
#11 0x00007f79d6fc6713 in QApplication::notify (this=0x7fff6d452be0, receiver=0x272af20, e=0x7f79600102c0) at kernel/qapplication.cpp:4420
#12 0x00007f79d87fab46 in KApplication::notify (this=0x7fff6d452be0, receiver=0x272af20, event=0x7f79600102c0) at ../../kdeui/kernel/kapplication.cpp:311
#13 0x00007f79d6a9ee9c in QCoreApplication::notifyInternal (this=0x7fff6d452be0, receiver=0x272af20, event=0x7f79600102c0) at kernel/qcoreapplication.cpp:876
#14 0x00007f79d6aa2c6a in sendEvent (event=0x7f79600102c0, receiver=0x272af20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x826220) at kernel/qcoreapplication.cpp:1500
#16 0x00007f79d6acdf93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f79ce9ecc9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f79ce9ed060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f79ce9ed124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f79d6ace3bf in QEventDispatcherGlib::processEvents (this=0x827b00, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f79d7069d6e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f79d6a9dc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f79d6a9ded7 in QEventLoop::exec (this=0x7fff6d451010, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f79d7410141 in QMenu::exec (this=<optimized out>, p=..., action=0x0) at widgets/qmenu.cpp:2113
#26 0x00007f79d226ab8c in MessageList::Widget::viewMessageListContextPopupRequest (this=<optimized out>, selectedItems=..., globalPos=...) at ../../messagelist/widget.cpp:281
#27 0x00007f79d224a6d3 in MessageList::Core::View::mousePressEvent (this=0xc24a60, e=0x7fff6d451e50) at ../../messagelist/core/view.cpp:2192
#28 0x00007f79d7012429 in QWidget::event (this=0xc24a60, event=0x7fff6d451e50) at kernel/qwidget.cpp:8358
#29 0x00007f79d73d23c6 in QFrame::event (this=0xc24a60, e=0x7fff6d451e50) at widgets/qframe.cpp:557
#30 0x00007f79d74e68ab in QAbstractItemView::viewportEvent (this=0xc24a60, event=0x7fff6d451e50) at itemviews/qabstractitemview.cpp:1644
#31 0x00007f79d752e4c5 in QTreeView::viewportEvent (this=0xc24a60, event=0x7fff6d451e50) at itemviews/qtreeview.cpp:1257
#32 0x00007f79d6a9f028 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0xc40950, event=0x7fff6d451e50) at kernel/qcoreapplication.cpp:986
#33 0x00007f79d6fc185f in notify_helper (e=0x7fff6d451e50, receiver=0xc40950, this=0x88a920) at kernel/qapplication.cpp:4555
#34 QApplicationPrivate::notify_helper (this=0x88a920, receiver=0xc40950, e=0x7fff6d451e50) at kernel/qapplication.cpp:4531
#35 0x00007f79d6fc70bf in QApplication::notify (this=<optimized out>, receiver=0xc40950, e=0x7fff6d451e50) at kernel/qapplication.cpp:4102
#36 0x00007f79d87fab46 in KApplication::notify (this=0x7fff6d452be0, receiver=0xc40950, event=0x7fff6d451e50) at ../../kdeui/kernel/kapplication.cpp:311
#37 0x00007f79d6a9ee9c in QCoreApplication::notifyInternal (this=0x7fff6d452be0, receiver=0xc40950, event=0x7fff6d451e50) at kernel/qcoreapplication.cpp:876
#38 0x00007f79d6fc2862 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#39 QApplicationPrivate::sendMouseEvent (receiver=0xc40950, event=0x7fff6d451e50, alienWidget=0xc40950, nativeWidget=0xbdcf00, buttonDown=0xc40950, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3170
#40 0x00007f79d7041bf5 in QETWidget::translateMouseEvent (this=0xbdcf00, event=<optimized out>) at kernel/qapplication_x11.cpp:4617
#41 0x00007f79d7040bae in QApplication::x11ProcessEvent (this=0x7fff6d452be0, event=0x7fff6d452720) at kernel/qapplication_x11.cpp:3732
#42 0x00007f79d706a0e2 in x11EventSourceDispatch (s=0x88f970, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#43 0x00007f79ce9ecc9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#44 0x00007f79ce9ed060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#45 0x00007f79ce9ed124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#46 0x00007f79d6ace3bf in QEventDispatcherGlib::processEvents (this=0x827b00, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#47 0x00007f79d7069d6e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#48 0x00007f79d6a9dc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#49 0x00007f79d6a9ded7 in QEventLoop::exec (this=0x7fff6d452ac0, flags=...) at kernel/qeventloop.cpp:204
#50 0x00007f79d6aa2f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#51 0x0000000000402bd3 in main (argc=<optimized out>, argv=<optimized out>) at ../../kmail/main.cpp:145

Possible duplicates by query: bug 298363, bug 298322, bug 296440, bug 296145, bug 295746.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-04-27 06:14:20 UTC

*** This bug has been marked as a duplicate of bug 286307 ***