Bug 299040 - Crash
Summary: Crash
Status: RESOLVED DUPLICATE of bug 286307
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.8.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-29 15:43 UTC by Sandro Steger
Modified: 2012-05-01 10:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sandro Steger 2012-04-29 15:43:00 UTC
Application: kmail (4.8.2)
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

I double clicked on a new email. It crashed before it appeared.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f62abeaa7c0 (LWP 8906))]

Thread 6 (Thread 0x7f6289715700 (LWP 8911)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:215
#1  0x00007f62a9a6143f in wait (time=30000, this=0x2681bd0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2681b48, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f62a9a545bf in QThreadPoolThread::run (this=0x2695890) at concurrent/qthreadpool.cpp:141
#4  0x00007f62a9a60fcb in QThreadPrivate::start (arg=0x2695890) at thread/qthread_unix.cpp:298
#5  0x00007f62a6cd3e9a in start_thread (arg=0x7f6289715700) at pthread_create.c:308
#6  0x00007f62a92044bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f6281d1d700 (LWP 8913)):
#0  0x00007f62a6cd705d in __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x7f6274000a60) at pthread_mutex_unlock.c:290
#2  0x00007f62a1ae9591 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f62a1aada09 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f62a1aadf96 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f62a1aae124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f62a9b8f426 in QEventDispatcherGlib::processEvents (this=0x7f62740008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0x00007f62a9b5ec82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#8  0x00007f62a9b5eed7 in QEventLoop::exec (this=0x7f6281d1cd90, flags=...) at kernel/qeventloop.cpp:204
#9  0x00007f62a9a5dfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#10 0x00007f62a9b3e9ff in QInotifyFileSystemWatcherEngine::run (this=0x2ac36a0) at io/qfilesystemwatcher_inotify.cpp:248
#11 0x00007f62a9a60fcb in QThreadPrivate::start (arg=0x2ac36a0) at thread/qthread_unix.cpp:298
#12 0x00007f62a6cd3e9a in start_thread (arg=0x7f6281d1d700) at pthread_create.c:308
#13 0x00007f62a92044bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#14 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f6271aed700 (LWP 8915)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f629e1a1dec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f629e1a1f19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f62a6cd3e9a in start_thread (arg=0x7f6271aed700) at pthread_create.c:308
#4  0x00007f62a92044bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f62711d4700 (LWP 8916)):
#0  __libc_enable_asynccancel () at ../nptl/sysdeps/unix/sysv/linux/x86_64/cancellation.S:66
#1  0x00007f62a91f8ae8 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:85
#2  0x00007f62a1aadff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f62a1aae124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f62a9b8f426 in QEventDispatcherGlib::processEvents (this=0x7f626c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f62a9b5ec82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f62a9b5eed7 in QEventLoop::exec (this=0x7f62711d3dc0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f62a9a5dfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f62a9a60fcb in QThreadPrivate::start (arg=0x4226c40) at thread/qthread_unix.cpp:298
#9  0x00007f62a6cd3e9a in start_thread (arg=0x7f62711d4700) at pthread_create.c:308
#10 0x00007f62a92044bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f6229604700 (LWP 8946)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:215
#1  0x00007f62a9a6143f in wait (time=30000, this=0x2245200) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x447f8a8, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f62a9a545bf in QThreadPoolThread::run (this=0x4347f10) at concurrent/qthreadpool.cpp:141
#4  0x00007f62a9a60fcb in QThreadPrivate::start (arg=0x4347f10) at thread/qthread_unix.cpp:298
#5  0x00007f62a6cd3e9a in start_thread (arg=0x7f6229604700) at pthread_create.c:308
#6  0x00007f62a92044bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f62abeaa7c0 (LWP 8906)):
[KCrash Handler]
#6  QNetworkAccessHttpBackend::replyDownloadMetaData (this=0x45d8d20, hm=..., sc=<optimized out>, rp=..., pu=<optimized out>, db=..., contentLength=-1) at access/qnetworkaccesshttpbackend.cpp:827
#7  0x00007f62a8239709 in QNetworkAccessHttpBackend::qt_static_metacall (_o=0x45d8d20, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at .moc/release-shared/moc_qnetworkaccesshttpbackend_p.cpp:91
#8  0x00007f62a9b79446 in QObject::event (this=0x45d8d20, e=<optimized out>) at kernel/qobject.cpp:1195
#9  0x00007f62aa082894 in notify_helper (e=0x7f622400c1c0, receiver=0x45d8d20, this=0x20b7050) at kernel/qapplication.cpp:4559
#10 QApplicationPrivate::notify_helper (this=0x20b7050, receiver=0x45d8d20, e=0x7f622400c1c0) at kernel/qapplication.cpp:4531
#11 0x00007f62aa087713 in QApplication::notify (this=0x7fff41912210, receiver=0x45d8d20, e=0x7f622400c1c0) at kernel/qapplication.cpp:4420
#12 0x00007f62ab8bbb46 in KApplication::notify (this=0x7fff41912210, receiver=0x45d8d20, event=0x7f622400c1c0) at ../../kdeui/kernel/kapplication.cpp:311
#13 0x00007f62a9b5fe9c in QCoreApplication::notifyInternal (this=0x7fff41912210, receiver=0x45d8d20, event=0x7f622400c1c0) at kernel/qcoreapplication.cpp:876
#14 0x00007f62a9b63c6a in sendEvent (event=0x7f622400c1c0, receiver=0x45d8d20) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#15 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1fa3220) at kernel/qcoreapplication.cpp:1500
#16 0x00007f62a9b8ef93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#17 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#18 0x00007f62a1aadc9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f62a1aae060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f62a1aae124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f62a9b8f3bf in QEventDispatcherGlib::processEvents (this=0x1fa4b00, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0x00007f62aa12ad6e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0x00007f62a9b5ec82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#24 0x00007f62a9b5eed7 in QEventLoop::exec (this=0x7fff419120f0, flags=...) at kernel/qeventloop.cpp:204
#25 0x00007f62a9b63f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#26 0x0000000000402bd3 in ?? ()
#27 0x00007f62a913376d in __libc_start_main (main=0x4021a0, argc=1, ubp_av=0x7fff41912668, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff41912658) at libc-start.c:226
#28 0x0000000000403095 in _start ()

This bug may be a duplicate of or related to bug 286307.

Possible duplicates by query: bug 298890, bug 298869, bug 298363, bug 298322, bug 296440.

Reported using DrKonqi
Comment 1 Laurent Montel 2012-05-01 10:07:38 UTC

*** This bug has been marked as a duplicate of bug 286307 ***